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Welcome to 
AXEL V2
AXEL V2 builds upon AXEL’s formula of easy-to-
create, intuitive Web 3D content creation, and shake-
and-bakes in new 2D, 3D and other import/export 
and publishing possibilities.

AXEL V2 remains totally cross-platform, and its 
new Standalone players for Windows and Macintosh 
open CD-ROM content creation for AXEL authors.

AXEL V2, with its new wider variety of formats, 
where Flash, VRML, QuickTime, MPEG-4 are 
tightly integrated—and for AXELedge LightWave 
and 3ds max—pushes Web 3D to where it should be, 
understood by all.

AXEL V2 continues to let you model, animate, 
texture, light, preview, integrate and publish 
interactive content directly to the Web, or for CD-
ROM.

Use this manual to learn how to use AXEL 2.

In this chapter:

Documentation conventions ... 4

AXEL system 
requirements ............................ 9

Installing AXEL V2 on Windows 
6

Installing AXEL V2 on 

Macintosh ..................7
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Documentation conventions
The AXEL User Guide uses the following conventions:

Menu commands
The forward arrow indicates menu selections. For example, choose File > Save means click the 
File menu, then choose the Save command from the menu.

Keyboard shortcuts
Keyboard shortcuts appear in bold and small caps type. For example, press T; press SHIFT+Q; 
hold L.

Press T means press and release the T key. 

Press SHIFT+Q means hold down the Shift key, press and release the Q key, then release the 
Shift key.

Hold L means press and hold down the L key. When you release the key, AXEL returns to its 
previous state.

For a complete list of available keyboard shortcuts, refer to the AXEL Keyboard Shortcuts card. 

Instructions for Macintosh and Windows
This User Guide is designed for Macintosh® and Windows® users. When a step varies 
depending on the platform, both instructions are provided. For example: “To multi-select objects 
in the Project Manager, CTRL-click (Windows) or OPTION-click (Macintosh) each object.”

Instructions for AXELcore and AXELedge
This training is both for users of AXELcore and AXELedge. Several of the lessons and 
functions are solely for AXELedge users and are indicated as such, with either the “(!AXELedge 
only)” designtion, or the following icon: .
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AXEL system requirements
AXEL runs on Windows and Macintosh (Mac OS 9 and Mac OS X) platforms.

These are the minimum system requirements for AXEL v1.5 Windows and Macintosh:

Windows
• Intel® Pentium® II processor (350 MHz or faster)

• Microsoft® Windows® 98, Windows 98 Second Edition, Windows Millennium Edition, Windows 
2000, Windows NT® 4.0 with Service Pack 3, or higher, or Windows XP 

• 128 MB of RAM 

• 45 MB of available hard-disk space 

• 16, 24 or 32-bit color display adapter 

• Monitor resolution of 1024x768 or greater

• Apple QuickTime 5 software

• 3-button mouse

Macintosh
• PowerPC® G3 or G4 processor (450 MHz or faster)

• Mac OS 9.2 with OpenGL 1.2, and CarbonLib 1.4, or

• Mac OS X v10.1 

• 128 MB of RAM 

• 45 MB of available hard-disk space

• Monitor resolution of 1024 x 768 or greater 

• Apple QuickTime 5 software
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Installing AXEL V2 on Windows
You must install AXEL onto your hard disk. When you do this, you are prompted to install the 
AXEL Player, which is necessary for previewing your projects in a web browser.

If you have installed previous versions or trial versions of AXEL, it is recommended to remove 
them via the Add/Remove Programs from your control panel before installing AXEL 1.5; all 
project files will be kept. On Windows NT and Windows 2000, you must login as Administrator 
or have administrator privileges to install AXEL. 

To install AXEL 2 on Windows:
1. If the set-up program does not run automatically when you load the CD, double-click the 

setup.exe from the CD. Follow the on-screen instructions.

Click the AXEL desktop icon to launch AXEL.If you had installed AXEL 1.01 
It is recommended that you remove AXEL 1.01 prior to installing AXEL 1.5. However if you 
wish to keep AXEL 1.01 and AXEL 1.5 you need to perform the following when going from 
one version to the other:

To use AXEL 1.01:
Register the player by double-clicking the following DLL file: 
C:/Program Files/MindAvenue/AXEL/AXELAP.dll. 

To use AXELV2:
Register the player by double-clicking the following DLL file:

C:/Program Files/MindAvenue/AXEL/AXELAP.dll

If you have a problem registering the AXELAP.dll:
1. Go to the your MindAvenue folder and select AXELAP.dll file.

2. SHIFT-right click the AXELAP.dll file and select the "Open with" option.

3. A pop-up window "Open With" will appear. Scroll down until you locate Regsvr32. Select it 
and click OK. 

4. If you do not have the option to select Regsvr32 then click "Other". 
The path for Windows 98/Me is C:/Windows/System/regsvr32.exe. The path on Windows 
NT/2000 is C:/WINNT/SYSTEM32/regsvr32.exe. The path on Windows XP is C:/
WINDOWS/SYSTEM32/regsvr32.exe. 

5. Select "Always use this program to open these files" and click OK. 
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6. I

Installing AXEL V2 on Macintosh
You must install AXEL onto your hard disk. On Mac OS 9, you must have CarbonLib1.4 installed 
on your system. As well, to preview your AXEL content in a web browser, you must install the 
AXEL player.

If you have installed previous versions or trial versions of AXEL, it is recommended to remove 
them before installing AXEL 1.5. You can keep your project files.

To install AXEL 1.5 on Macintosh:
1. On Mac OS 9 a Finder window opens automatically when you load the CD.

On Mac OS X, double-click the AXEL1.5 CD icon which appears on your desktop after you 
load the CD. 

2. Follow the Finder window’s instructions to drag the AXEL 1.5 folder onto your desktop or 
hard disk.We recommend placing the AXEL folder in the Applications (Mac OS 9) folder 
under Mac OS 9, or the Applications folder under Mac OS X.

3. Click the AXEL icon in the AXEL 1.5 folder to launch AXEL.
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Installing CarbonLib1.4 on Mac OS 9
If CarbonLib1.4 it is not already installed, it is included in the AXEL 1.5 folder for your 
convenience.

To install CarbonLib1.4:
1. Double-click CarbonLib1.4.smi, then double-click the CarbonLib Installer. Remember to 

choose your Mac OS 9 startup disk to install it on. 
CarbonLib1.4 is installed.

2. Restart your computer.

Installing the AXEL player
In order to preview your content in a web browser, it is necessary to install the AXEL Player on 
your system.

To install the AXEL Player on Mac OS 9:
1. Copy AXEL Player from the AXEL 1.5 folder to the Plug-ins folder of your web browser: for 

example, for Internet Explorer, copy the AXEL Player to Applications (Mac OS 9) / Internet 
Explorer 5 / Plug-ins.

2. If your web browser is open, close and re-open it.
You can now preview your AXEL project in your web browser.

To install the AXEL Player on Mac OS X:
1. Copy AXEL Player for Mac OS X from the AXEL 2 folder to Library / Internet Plug-Ins. If 

you do not have administrator privileges you may copy it to your Home / Library / Internet 
Plug-Ins.

2. If your web browser is open, close and re-open.
You can now preview your AXEL project in your web browser.
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Supported Import File Formats
AXEL supports the following files for import:

Sounds
• MP3

• MPEG

• WAV

• MIDI
For more informations, see “Play Sound reaction” on page 427.

Images
• JPEG

• GIF

• BMP

• PNG
For more informations, see “Adding image textures” on page 316.

Movies
• MPEG

• AVI

• MOV

• SWF
For more informations, see “Adding movie textures” on page 317.

2D Vector Objects and Animation
• SWF

3D Models & Animation
• VRML 97 (version 2)
For more informations, see “Importing VRML files” on page 60.

• LWS and LWO (!AXELedge only)
For more informations, see “Importing LightWave 3D files” on page 62.

• 3DS through AXELpublisher (!AXELedge only)



10 | AXEL V2 | User Guide

For more informations, see “Exporting 3ds max files to AXELedge using AXELpublisher” on 
page 66.

Curves
• EPS
For more informations, see “Importing EPS files” on page 59.

Details: What’s New in AXEL V2
AXEL V2 integrates a plethora of new import/export and publishing possibilities into its 
complete worklow.

New import capabilities:
•  3ds max models and animations import through the AXELpublisher. AXELpublisher is a 

plug-in for 3ds max that allows you to add basic AXEL interaction to your models right while 
working in 3ds max. You also export your files using the same AXELpublisher dialog directly into 
.axs or .axel files—AXEL’s native formats—or into an interactive .mov file that uses the QuickTime 
AXEL component.

• New robust import architecture keeps you informed of incoming data.

• Improved VRML import quality.

New export capabilities:
• Capacity to export content directly to the Flash .swf format with the Flash (SWF) Exporter. You have 

control over how your animations are exported when your 3D content is converted into vector 2D that 
can play with the Flash 5 or 6 player. Add interactivity in the Flash author or other .swf compatible 
authoring programs.

• Capacity to publish still images—JPEGs, GIFs or PNGs—from directly in AXEL, and of any 
viewport.

•  VRML exporter with all of AXEL’s interactivity that is applicable in VRML. Also, VRML 
control of your avatar through export settings.

• New export dialog with information that keeps you aware of what’s being exported i.e. applicable 
parameters/interactions in export type. Includes previewing options.

• Standalone player/projector: The AXELplayer Standalone allows you to play .axs files on either 
Windows or Macintosh machines with no browser or other software. Now you can generate Projector 
files directly from AXEL that bundles the AXELplayer with your AXEL content.

• Integrated QuickTime publishing: Publish your QuickTime AXEL Movies (.mov) files directly from 
AXEL, keep all their interactivity intact, and preview in QuickTime.
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• Export linear movies in either MPEG-4, QuickTime JPEG or PNG, or Animated GIF formats. This 
streamlines workflows so that they can publish and export both interactive content, as well as linear 
content with the same source content.

Other:
• On the Macintosh, you can now multi-select your objects, parameters, animations, etc. and their 

common parameters appear in the Parameter Editor. This makes editing, aligning, coordinating 
animation and reactions, as well as many other functions much more efficient.

• New documentation, tutorials and AXEL Help Online in addition to the regular Help is updated on 
the Web and features a better search engine. Also, interactive AXEL examples throughout Help to 
quickly grasp 3D and AXEL interactive concepts.

AXEL Publish/Export Options Summary
All of the following files are generated using the original source AXEL Author file (.axel), so 
keep this file to regenerate and edit published content. All the following formats are cross-
platform (Windows and Macintosh), with the caveat that you must generate AXEL projector 
files for a specific platform..

Name File Extension Plays With... Interaction in format?
AXEL Stream 
file 

For more infor-
mation, see 
“Publishing” on 
page 555.

.axs AXELplayer, either 
embedded in a webpage 
or with the AXELplayer 
Standalone. Also opens 
in QuickTime with the 
QuickTime AXEL com-
ponent.

All AXEL interaction available.

AXEL Quick-
Time Movie

For more infor-
mation, see 
“Publishing” on 
page 555.

.mov QuickTime Player (ver-
sion 5 or 6) with the 
QuickTime AXEL com-
ponent.

All AXEL interaction available.

Linear movie/
Animated Gifs

.mov, .gif or 

.mp4
QuickTime Player (ver-
sion 5 or 6) or any appli-
cation that supports 
.movs or animated GIFs.

Export linear movies or animated GIFs 
without interaction.

VRML Worlds .wrl VRML browser or 
application (version 97-
2)

Much of AXEL interaction is pre-
served—all that is applicable in VRML.

Flash Movies .swf Flash Player (version 5 
or 6)

Exports linear animation sequences.
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Learning AXEL
This guide covers every feature in AXEL—what the feature is and how to use it. The following 
training material is also provided to help you master AXEL quickly

AXEL projector 
files

.exe (Windows)

Note: No 
extension on the 
Macintosh 
Standalone.

AXELplayer Standal-
one. There are different 
Standalone players for 
Windows and PC, but 
you can generate projec-
tor files for both Win-
dows and Macintosh 
that bundle the appropri-
ate Player in a single 
file. Useful for CD-
ROM authoring.

All AXEL interaction available.

Still images .jpeg, .gif, .png Not applicable-use still 
images as typical digital 
images.

Not applicable.

AXEL Tutorial This tutorial, accessed through the AXEL Help menu, introduces basic 3D concepts 
and gives an overview of the AXEL interface and workflow. This is a good starting 
place to finding your way around AXEL.

AXEL User Guide 
(PDF)

The User Guide (PDF) describes all the features and shows you how to use them 
through step by step procedures and examples. For users who downloaded their pur-
chased copy of AXEL, they have to download the AXEL User Guide PDF from the 
Updates section of the MindAvenue web site at http://www.mindavenue.com/en/
download/updates.asp. For all others, the PDF is installed in the main MindAvenue/
AXEL folder.

AXEL Help AXEL Help contains the same information as the User Guide. In addition, it contains 
many AXEL interactive examples to teach 3D concepts, hyperlinks as well as addi-
tional search features to help you find answers fast.

AXEL Help Online AXEL Help Online is accessed over the Internet and is based on the same informa-
tion and structure as AXEL Help. It has the added advantage of regular updates and 
a more robust search engine.

Support at 
www.MindAvenue.com

Here you’ll find more tutorials, tips and tricks, and the AXEL Support forum. 

AXEL Keyboard 
Shortcuts (PDF)

This PDF lists all the keyboard shortcuts available in AXEL. It is available from the 
AXEL Help menu, under Keyboard Shortcuts
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Chapter 1
QuickStart

What is this guide for?
Quick Start will introduce you to some of the basic 
concepts of AXELcore, the 3D authoring software 
that allows you to create interactive content for the 
Internet. Use this guide to answer basic questions 
regarding AXELcore’s interface, workflow and 
design tools.

When you are finished with this guide, do the 
AXELcore Tutorial in the Help menu. By following 
the step-by-step procedures, you will soon be 
creating, developing and publishing an interactive 
3D sequence yourself. 

After this you can explore AXELcore further by 
using the AXELcore Training documents provided 
with the software. If you have specific questions 
regarding any of AXELcore’s interface, workflow or 
design tools, choose Help > AXELcore Help to look 
up the complete reference information on AXELcore 
features. You can also visit MindAvenue’s Web site, 
at www.mindavenue.com, to get the latest 
information and updates for AXELcore. 

In this guide:

What is 3D modeling & 
animation? ............................. 17

The geometry of 3D objects .. 17

Creating 3D surfaces and objects 
18

Viewing 3D objects ............... 22

What’s in AXEL’s workspace? .
24

How do I work with AXEL? . 25

How do I make and manipulate a 
model? ................................... 25

How do I connect the pieces? 30

How do I add color and light to 
my model? ............................. 33

How do I animate my models? .
35
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Chapter 1

How do I make my models 
interactive? ............................ 38

How do I publish my work to the 

Web? ..................................... 43
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What is 3D modeling & animation?
“3D” refers to three visual dimensions: height, width, and depth. If you are used to working with 
2D animation software, you are used to creating flat artwork that is described in terms of width 
and height and perhaps layer order. In a 2D environment, objects and space are described in 
terms of two axes: the X axis (width), and the Y axis (height). To create the illusion of depth, 
you must use shadows and perspective or overlapping layers.

In a 3D environment, depth is a real coordinate like width and height, and is described by the 
Z axis, while perspective is rendered automatically by the computer. In a 3D environment, any 
point in space can be described by its three coordinates: X, Y, and Z.

With AXEL you create and manipulate 3D objects in 3D space.   While some of the tools in 
AXEL, such as scaling or translating, are similar to those found in 2D animation programs, there 
are also many tools and concepts that are specific to animating in a 3D environment.   If you 
have never worked in a 3D environment before, you might want to familiarize yourself with 
some of these tools and concepts before attempting a new project.

The geometry of 3D objects
Before we look at creating objects, let’s take a look at how they are described by the software.

Y

X

Z

Y

X
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First, let’s start with a point. A point is a location in space, described by the three coordinates X, 
Y, and Z.

Next, if you connect one point to another point, you have a line often referred to as a curve.

If you connect three points, you have created the smallest possible surface: a triangle. These 
triangles are often called polygons (Greek for “many-sided”), although by definition a polygon 
can be any closed shape, such as a four-point square. If a triangle (or any other closed shape) is 
filled, it is called a surface or face. 

In the following example, a large number of adjacent polygons are used to create a 3D object. 

When you surf the Internet and download 3D images, you are downloading large numbers of 
these polygons, each comprised of lines and points, all of which are described by their X, Y and 
Z coordinates. These are the building blocks of any 3D modeling software.

Creating 3D surfaces and objects
To create 3D surfaces in AXEL, you use two main modeling techniques: primitives—also 
referred to as preset surfaces—or revolutions and extrusions.
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Preset surfaces are familiar geometric shapes like cubes and spheres. You can use these simple 
shapes to create more elaborate structures by moving, scaling, and combining them as necessary.
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The other fundamental technique is using a 2D line or curve to create a 3D surface.

Revolution from Curve takes a 2D curve and spins it around an axis to create a 3D surface.

Extrusion from a Curve takes a 2D curve and pushes out a surface, giving it depth.
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Extrusion along a Curve pushes one 2D curve along another 2D curve to create a 3D surface.

You can combine these techniques to create a single object of numerous parts. For example, the 
chair below uses cubes and cylinders for its legs, and extrusions and revolutions for its back.

Once you have familiarized yourself with these basic tools, you will be able to model any object.

For more information, see Adding spheres, cubes, cylinders, cones, planes, Creating a 
revolution surface, and Creating an extrusion surface.

Revolution from a Curve

Extrusion along a Curve

Extrusion from a Curve

Cylinder

Cube
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Viewing 3D objects
One of the obvious difficulties in representing 3D content on a computer is that the computer 
screen itself is 2D—flat. To deal with this, AXEL uses four windows to display any 3D object. 
These windows are called viewports.

By default, three of the viewports display Top, Front and Right-side views of the 3D object you 
are working on. The fourth viewport is called the WebCam, and it represents your object and 
environment in full 3D space, which is how the content will appear when it is published to a Web 
page.

Getting used to working with the viewports is essential because it allows you to manipulate your 
objects in any direction. When you look at the viewports, note that each one has small colored 
arrows in the bottom-left of its screen describing which axes you control with that viewport.

Once you create a 3D surface or object, you can zoom, pan and orbit around the object much as 
you would any object in real life.

On the toolbar (Windows) or in the toolbox (Macintosh), click Zoom ( ) or Pan ( ) then 
drag the cursor in any of the viewports. You can also click Orbit ( ) and drag in the WebCam 



 Chapter 1 |  | 15

viewport. These camera controls are a good way to see your objects and environments from 
every perspective.

Because it is important to be able to focus on your objects quickly while working, AXEL’s View 
menu has specific controls for framing objects in the viewports. Use the View menu to focus 
viewports on selected objects by choosing View > All Viewports > Frame Selection, or on all 
objects simultaneously by choosing View > All Viewports > Frame All. 

Experiment with the View menu to get familiar with the tools that will enable you to view your 
3D objects in any way you like.

Orbit
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What’s in AXEL’s workspace?
AXEL’s workspace is designed to allow you immediate access to, and control of, all the tools 
necessary to create, manipulate and publish your 3D content.

Note: The above illustration is of the AXEL workspace in Windows. Macinsotsh users will notice 
some differences in layout, but AXEL’s features and functionality are mostly the same between the 
two platforms. Differences, mostly to do with the user interface, are elaborated on in the appropriate 
areas of the documentation.

Parameter Editor — See 
“How do I make and 
manipulate a model?” on 
page 16

Interaction Editor — See “How do I make 
my models interactive?” on page 29

Sequencer — See “How do I animate 
my models?” on page 26

Viewports — See “Viewing 
3D objects” on page 13

Project Manager — See “How do I make and 
manipulate a model?” on page 16.

Top toolbar (Windows). 
below.
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You can access everything you need through the menu bar at the top of the work area, and in the 
top toolbar (Windows) or toolbox (Macintosh).

There are also toolbars in the other windows that provide easier access to tools useful for 
particular stages of the AXEL workflow. 

How do I work with AXEL?
When you work on a project in AXEL, the typical workflow will be similar to the steps in the 
following few sections, which describe the production of a typical project:

• Model:see “How do I make and manipulate a model?” on page 16

• Relate: see “How do I connect the pieces?” on page 21

• Visualize: see “How do I add color and light to my model?” on page 24

• Animate: see “How do I animate my models?” on page 26

• Interact: see “How do I make my models interactive?” on page 29

• Publish: see “How do I get my work on the Web?” on page 34
If you look at the menu bar at the top of the work area, you will see this same workflow 
represented as the central menu items. In the following sections we will follow that layout to 
describe a typical project creation.

How do I make and manipulate a model?
You use the Model menu to create 3D objects, and the toolbar (Windows) or the toolbox 
(Macintosh) to manipulate them.

For example, in the following project we created a TV set. We began by choosing 
Model > Add Surface > Cube to create the surface.

Menu bar for AXEL on Mac OS X

Window’s top toolbar
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Once you create a model, you can manipulate it using the Select and Manipulation tools. First, 
you have to select the object you want to manipulate by turning on the Select tool ( ) and 
then selecting it in either the viewports or the Project Manager. You will know an object is 
selected if it is highlighted in orange in the viewports, and its name is highlighted in the Project 
Manager.

You can also select an object’s points or its center by turning on the Point or Center tools. 
Depending on which mode you select, the entire object, the object’s points, or the object’s 
center, will be highlighted.

After you have made a selection, you can scale, rotate, or move it (called “translation” in AXEL) 
with the manipulation tools. You can also choose to manipulate objects along particular axes. 

After you make a selection, you can turn on off the Select tool off to lock the selection as active, 
then proceed to manipulate it.

For our project we wanted to make the cube more rectangular. We achieved this by selecting the 

cube, turning on the Scale ( ) and X axis ( ) tools, and dragging the cube in the Top viewport 
to widen it. Notice in the Parameter Editor below, how one of the Scale fields changed to 1.50 

Selection 
highlight

Object
Point

Center

Manipulation tools
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as a result of our scaling along the X axis. Every parameter adjustment you make to an object 
has a corresponding value change in the Parameter Editor. 

Along with the menus and viewports, you use both the Project Manager and the Parameter 
Editor to select and manipulate your objects. The Project Manager keeps track of every item 
contained within your 3D environment (objects, groups, animation sequences, etc.), while the 
Parameter Editor gives you complete control over those items’ various parameters. 

When you need to make specific adjustments to an item’s parameters, use the fields, sliders, and 
lists in the Parameter Editor to edit the selected item. For example, we could have created a 
rectangle from the cube by using the Parameter Editor instead of the Scale tool. We would have 
selected the cube in the Project Manager, then entered a new scale value directly in the 
Parameter Editor.
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For the next surface in our project—which will form one of four support ornaments at the 
corners of the television base—we began by choosing Model > Draw Curve, then drew the 
curve (below left) in the Front viewport.

To go from the curve on the left to the rounded surface on the right, we chose 
Model > Create Surface > Revolution from Curve. AXEL created the surface based only on 
the 2D curve we drew. With this tool you can create any number of rounded surfaces based on 
a simple 2D curve.

For the next object of the project—which will connect the four support ornaments of the 
television base—we drew another curve, this time in the Top viewport. Then we chose Model 
> Create Surface > Extrusion from Curve to create the surface from the 2D curve. With this 
tool, you can create any number of objects with depth based on a simple 2D line. To make the 
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base of the TV set, we added duplicates of the Revolution surface to this new Extrusion surface 
through the use of grouping, which we’ll explore a bit later.

Finally, to create the television’s screen we chose Model > Add Surface > Vertical Plane. But 
for our project we needed to blunt the edges of the plane as most TV screens do not have 
perfectly sharp corners. We selected the surface, and turned on Point mode ( ) and Translate 

( ). Then we dragged each of the corner points inwards to soften the edges. 

You can manipulate any point on a surface when you select it in Point mode ( ).
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Now take a look at the rest of the varied surfaces and objects we created using the tools we just 
described.

Experiment with these tools to familiarize yourself with creating and manipulating your 3D 
objects. You should also choose Help > AXEL Tutorial and try the Modeling lesson to create 
and manipulate 3D objects yourself.

How do I connect the pieces?
You use the Relate menu to connect multiple 3D objects to each other. You can make either a 
group, which provides a way to organize objects and manipulate them as one, or you can make 
a constraint, which provides a number of ways to connect objects together in defined, dynamic 
ways. Both are similar, but typically you will use constraints to set up particular interactions 
between specific separate objects, and you will use grouping mainly to facilitate the 
organization and moving of intricate creations. 

Cylinder

Vertical 
Plane

Extrusion 
along a Curve

Horizontal 
Plane

Revolution 
from a Curve

Extrusion 
from a Curve

Sphere
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For example, the picture below shows the television we created in AXEL, comprised of multiple 
3D objects. To group these individual objects, we selected the Main Box, Legs and Antenna 
entries in the Project Manager, then chose Relate > Group. The entire television was then 
grouped, making it easy to move it from one place to another within the 3D environment. All 
we have to do is select the TV group in the Project Manager, and then in the viewport drag the 
selection where we want. We can also select any of the separate components of the TV group 
(such as the Legs or Antenna) individually in the Project Manager.
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At the same time, there are objects in our example project that interact with one another based 
on specific constraints.   For example, the TV remote below is constrained to the TV Group in 
two ways. We created a bounding box around the remote to keep it within a particular area by 
choosing Relate > Constrain to Bounding Box. This will ensure that the remote stays in this 
space when we make it interactive later.

We also created a direction constraint between the remote and the TV by choosing 
Relate > Constrain Direction. This will ensure that the remote is always pointing towards the 
TV no matter which way it moves.

When you want to constrain two or more objects, you have to set one as a follower and one as a 
leader. To do this you select the follower(s) first, and the leader last. Once they are constrained, 
followers exist and act in relation to their leaders. In the above example, the remote is the 
follower, and the TV is the leader, which is why the Direction constraint arrow is pointing 
towards the TV.

Experiment with the various groupings and constraints available in the Relate menu to 
familiarize yourself with creating specific relationships between objects. You should also 
choose Help > AXEL Tutorial and do the Relate lesson to create groupings and set constraints 
for 3D objects yourself.

Direction constraint 

Bounding Box
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How do I add color and light to my model?
You use the Visualize menu to add color, textures, movies and light sources to your 3D model. 
You use materials to define a model’s color, shininess, glow and transparency, and you use 
texture materials to map an image or a movie onto an object.

For example, to add a color material to the remote in the illustration below, we selected the 
remote group, chose Visualize > Add Color Material > Shaded, then selected a color from the 
Color dialog.

You can also manipulate the color’s parameters in the Parameter Editor, changing the color, 
glow, shininess and transparency. You can do the same thing for any material and texture.

To create a texture for the floor, we selected the floor, chose Visualize > Add Image Texture, 
then selected a saved image file for the texture.

Point light

Movie texture

Color material

Image texture
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You add movies as textures in the same way. For example, to create a TV screen that actually 
plays a TV program we selected the screen, chose Visualize > Add Movie Texture, then 
selected a saved movie file for the texture.

Any graphic or movie file that can be converted into a supported format can be used as a texture. 
For example, you can use image files, scanned artwork, video grabs, QuickTime®, M-PEG or 
Flash movies as textures for your model. You can also link any material (including a texture) to 
multiple 3D objects, allowing them to all share the same look and to download more efficiently.

You also use the Visualize menu and tools to create light sources for your objects and 
environment. When you create a new project, a default directional light source is created for the 
environment, but you can add and manipulate other kinds of light sources at any time. 

For example, to create a Point light source for the TV, we chose Visualize > Add Light > Point. 
The new Point light appeared, and we moved it using the same Translate tool we used to move 
our surfaces, objects and groups. 

You can also choose a flat 2D look for your 3D object to create a more cartoon-like image. For 
example, to make the TV look more cartoony we selected the TV group and chose Visualize > 
Add Color Material > Cartoon, then selected a color.

You can also choose to display your objects in colored wireframe.
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Experiment with the Visualize menu to get familiar with the various ways you can change the 
look of your 3D models and environments. You should also choose Help > AXEL Tutorial and 
do the Visualize lesson to add materials, textures and lights to 3D objects yourself.

How do I animate my models?
You use the Animate menu to create and design animation sequences for your 3D models. You 
can animate almost anything in AXEL: an object’s scale, rotation and position values, as well as 
almost any other parameter. 

Along with the Animate menu, you use the Sequencer as your main animation tool.   The 
Sequencer displays your animation sequences on a timeline. You can navigate the Sequencer by 
dragging the Playhead to any spot on the timeline.

To animate your models, you record keys in the Sequencer.   Keys are like snapshots of particular 
objects’ attributes and positions at specific times in the Sequencer. You can record keys either 
interactively or by saving specific keys at specific times. AXEL then interpolates the difference 
between the keys automatically, creating the animated movement or other change. 

For example, we created two animations using keys. In the first case, we wanted to create an 
animation of the TV’s antenna moving from one spot to another, as if tuning itself. To do this, 

Playhead

Keys
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we started by selecting the antenna, turning on Rotate, and then choosing 
Animate > Add Animation Sequence. A key appeared on the Sequencer for the starting 
position of the antenna.

Then, in the Sequencer we dragged the Playhead to 3 seconds on the timeline. Finally, we 
selected the antenna and dragged it to the second position. The new key was created at 3 seconds 
on the timeline. 

To play back the animation, we clicked Play on the Sequencer, and the antenna moved from the 
first to second position over a period of 3 seconds. 

You can also animate any parameter change you make in AXEL, such as scaling and position, 
as well as many others. We used the Parameter Editor to create our next animation: animating a 
light’s intensity parameter to create a fade-up of the scene’s light. To begin, we selected the Point 
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light in the Project Manager, then in the Parameter Editor we selected the Intensity parameter 
and changed the Intensity value to 0.00. Next we chose Animate > Add Animation Sequence. 
A new animation sequence and key appeared in the Sequencer.

Next we dragged the Playhead to 2 seconds on the timeline, then in the Parameter Editor 
changed the Intensity value to 100.00. The second key appeared in the Sequencer at 2 seconds.
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Finally, we previewed the animation by pressing Play on the Sequencer, and the two animations 
played together. The antenna “tuned” itself while the Point light faded up in on the TV.

You can also create keys automatically by using the Sequencer to Record any actions and 
changes you make; you can animate your objects on a defined path using a curve; and you can 
add waves to objects. You can also use particles to simulate many small or fragmented objects 
such as snow flakes or sparks. You can then combine these and other various animation 
techniques to make complex animation sequences.

You should also note that any animation you create will automatically appear in the Interaction 
Editor as a reaction. Reactions have to be triggered by something in order to play, whether a user 
action, or some internal trigger like a mark in time. For now, our animations appear in the 
Interaction Editor as Play Animation reactions simply reacting to linear time like traditional 
animation. We will discuss how to make these reactions interactive in the next section.

Experiment with the Animate menu and Sequencer to familiarize yourself with creating and 
designing the animation sequences you want to put on the Web. You should also choose 
Help > AXEL Tutorial and do the Animate lesson to animate 3D objects yourself.

How do I make my models interactive?
You use the Interact menu to let your Web audience play with the 3D environments and objects 
you’ve created. There are a variety of ways to do this. You can create sensors, which will trigger 
reactions at particular times or when a Web Surfer performs a particular task (like clicking a 
mouse). You can add handles to let surfaces intuitively control certain aspects of the scene, such 
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as dragging particular objects or zooming with a WebCam. You can also link any animation 
you’ve created to a trigger so that it starts only after the surfer performs a particular task.

Along with the Interact menu, you use the Interaction Editor as your main tool for designing the 
interactive components of your 3D environment. The Interaction Editor displays a list of all the 
animations and reactions in your 3D environment, along with the triggers and sensors connected 
to them, making it easy to link, unlink, and organize your sensors, triggers, and reactions.

For example, the movie texture we added to the TV, along with the animation sequences we 
created in the last section, appear in the Interaction Editor as reactions linked to a Time Sensor. 
This simply means that the reactions will only play according to the timeline in the Sequencer—
in this case when the time is at 0.00.



32 | AXEL V2 | User Guide

To make the Twist Antenna and PlayMovie reactions interactive, we first selected the red button 
on the remote in our 3D environment, then chose Interact > Add Sensor > Mouse. A Mouse 
Sensor for the red button was created and appeared in the Interaction Editor.

Next we dragged the Twist Antenna and Play Movie links from the Time sensor down to the 
OnLeftClick trigger. This means that the reactions will play now only when the surfer clicks the 
Red Button on the remote.

Once you create an interaction in AXEL it’s a good idea to preview it to see how it will look to 
a surfer. You can use the Preview in AXEL button ( ) to switch out of Author mode and into 
Preview mode where you can view a simulation of your project as it will appear on the Web. 
You can then use the Author button ( ) to switch back to Author mode to continue working on 
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your project. It’s a good idea to switch back and forth regularly to see how your interactions are 
working.

In Preview mode, clicking the red button on the remote makes the antenna twirl and the movie 
play. Remember, any animation you create, no matter how complex, can be attached to a sensor. 
This means any animation can be an interactive component of your 3D environment. 

Another important interactive tool is a handle, which gives surfers some control over the 3D 
environment in ways you—the author—defines.

For example, to let the surfer control the movement of the remote, we selected the remote, then 
chose Interact > Add Handle > Translate. In the Interaction Editor, both a Mouse Sensor and 

Movie plays

Antenna twirls

Red button 
Mouse Sensor is 
clicked
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Translate reaction appeared. When you add a handle, AXEL automatically creates a Mouse 
Sensor that the surfer will use, and the reaction you chose from the Add Handle menu.

Then we switched back to Preview mode and dragged the remote. Remember that we put the 
remote in a bounding box and gave it a direction constraint earlier. This means that even though 
the surfer can move the remote, it can’t be dragged outside of the bounding box or made to face 
away from the TV.

You can also use handles to let the surfer rotate, scale, bend and push any object within the 
environment. You can create as many interactions for the surfer to play with as you want. You 
can also group reactions so that a single interaction by the surfer will set off multiple reactions 
in the 3D environment.
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Experiment with the Interact menu and Interaction Editor to get familiar with the various 
reactions, sensors and handles you can set for a surfer to interact with. You should also choose 
Help > AXEL Tutorial and do the Interact lesson to make interactive animations and reactions 
yourself.

How do I get my work on the Web?
Once you have completed your 3D environment in AXEL, you use the Publish menu to embed 
your 3D environment in a Web page or publish to the QuickTime player. A surfer visiting the 
page can then view, play, or interact with it.

When you work on a project in AXEL, the file is saved as a .axel project file. When you generate 
an AXEL stream, AXEL converts the .axel file to a .axs file and creates an HTML file, leaving 
you with three files: .axel, .axs , and .htm.

The .axel file is the original project file, and you use it to edit your AXEL content. The .axs file 
is the stream file that contains your published AXEL content optimized for the Web. The .htm 
file is the host Web page file into which the .axs file is embedded. The HTML code in this 
generated .htm file invokes the AXEL Player to playback your AXEL content.

Publishing to QuickTime is similar, only you select the Generate AXEL QuickTime Movie from 
the Publish menu, publishing a .mov file. AXEL content plays exactly the same in QuickTime 
as in the AXELplayer with all its interactivity, while opening up other options like using 
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QuickTime effects, multi-tracking interactive AXEL content with other QuickTime media 
types, etc.

You can also export your AXEL content to a variety of formats which will include a greater or 
lesser amount of any interactivity you built into your AXEL content. The export formats are 
accessible through the file menu:

• You can create AXEL Projector files for either Windows or Macintosh platforms, which are 
executable files that bundle the AXELplayer with your AXEL content so it plays 
independently without the need for a browser or other software.

• For exporting to Flash, AXEL generates a .swf Flash movie. You can use these linear Flash 
movies for playback in the Flash Player or import them into the Flash author to add your 
interactivity there.

• You can also generate still images of your AXEL projects in JPEG, GIF or PNG formats. 
Try using these images as thumbnails in a Web page to introduce your 3D interactive AXEL 
content!

• Lastly, you have the option of exporting your .axel files to VRML (Virtual Reality 
Modeling Language) to either post to the web or open in other applications for further work.

You select Publish or Export Settings in the Project Manager to set the properties for either 
AXEL, QuickTime, Flash, Image, AXEL Projector Exporter or VRML. Set the names of your 
files, choose 3D window sizes, and select other important publishing and exporting attributes.

When you are ready to publish your project to the AXEL or QuickTime players, you have a 
number of options for previewing, setting publishing parameters, and saving your project. You 
can preview your project in a host Web page by choosing Publish > Preview in Netscape. You 
can also preview your project in another browser or HTML editor of your choice. 

To create the Web page for our project, we entered the necessary publish settings for AXEL in 
the Parameter Editor, then we chose Publish > Generate AXEL Stream. We viewed the final 
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Web page by navigating to the folder where the original .axel file was saved and opening the 
new .htm file.

When generating Web content, the .axs file is embedded in the HTML code, so you can cut and 
paste the 3D content from one Web page to another like any embedded image. You can view the 
HTML code generated by AXEL by choosing View > Source in the Web browser window. This 
code always begins with the line “<!-- Beginning of AXEL content -->” and ends with the line 
“<!-- End of AXEL content -->” The following is the code that is generated to invoke the 
AXELplayer for playback of our television project called Television.axs:

<! -- Beginning of AXEL content -- >

<object id=”Television” classid=“CLSID:68A2C3BD-7809-1ID3-8ACF-0050046F2F9A”
 codebase=”http://www.mindavenue.com/Downloads/AXELPlayerAX_Win32.cab#cab#version=1,5,100,0”

 width=”400” height=”300”>
<param name=”Src” values “Television.axs”>
<param name=”Windowless” value=”0”>

 <embed src=”Television.axs” name=”Television”
plug-inspage=”http://www.mindavenue.com/Downloads/AXELPlayerNPInstall.html”
type=”application/x-MindAvenueAXELStream”
width=400 height=300 Windowless=false>
</embed>
</object>

<! -- End of AXEL content -->

Similar code is used to invoke the QuickTime player for playback of your AXEL QuickTime 
Movies (.mov files).

You can also use similar code in the HTML of your Web page to embed Flash files generated 
from AXEL. For more information see Publishing 3D content.

You can also extend the surfer’s interactivity by creating buttons outside the Web page’s 3D 
window. Use the Publish > Export Parameter and Publish > Export Reaction Trigger 
commands to create standalone buttons on the Web page for more interactive possibilities. For 
more information, see “Exporting parameters” on page 578 and “Exporting reaction triggers” 
on page 581.

Experiment with the publish and export commands and settings to get familiar with the various 
ways you can get your 3D content onto the Web, onto a CD-ROM, or simply onto your 
audience’s computer screens. You should also choose Help > AXEL Tutorial and do the Publish 
lesson to publish a completed AXEL project yourself.
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Where do I go from here?
Now that you have finished reading through Quick Start and become familiar with some basic 
tools and concepts, use the Help menu to access the AXELcore Tutorial, On-Line Help 
documents, and to visit MindAvenue’s AXEL Support Web page. 

First choose Help > AXEL Tutorial to access the AXELcore Tutorial and use some of the basic 
tools and concepts you learned about in Quick Start. This is an excellent way for you to become 
familiar with the AXELcore workspace, workflow, and tools.

After you do the tutorial, and if you are interested in learning about more complex tools and 
techniques, do the AXELcore Training provided in PDF format on the AXELcore CD.

If you have a specific question regarding any aspect of AXELcore, choose Help > On-Line Help 
to access the complete reference manual for AXELcore. 

You can also visit the MindAvenue Support page by choosing Help > MindAvenue Support. 

Visit the site regularly to get up-to-date information on AXELcore, as well as tips and tricks 

from professional AXELcore users.



 Chapter 2 | User Interface | 37

Chapter 2
User Interface

Quickly come to grips with AXEL’s viewports, 
editors, and tools—where they are, and what they do.

See how to zero-in on the information you need, edit 
it, then move on.

Customize the UI for your particular style of 
working.

In this chapter:

The Work Area ...................... 38

Viewports .............................. 46

Editors ................................... 60

Customizing on the Macintosh .
68

Menus .................................... 73

Help menu ...............83
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The Work Area
The work area, its Editors and Viewports, are customizable to fit your work style.

The default AXEL work area contains all the tools needed to model, animate, add interaction, 
and publish 3D content. You can show, hide, and resize different components according to your 
personal preferences.

On the Macintosh, you can also customize what tools appear in the toolbars.

When you first launch AXEL, the following work area appears:
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Customizing windows
The windows in AXEL can be rearranged, resized and hidden.

To show or hide a window:
In Windows, choose View > Editors, then turn on/off the relevant window. To hide a window 
you click the x on one of the top corners of a window.

On the Macintosh, choose Window, then choose Show/Hide for the relevant window, or click 
the close box.

Note: On the Macintosh, clicking the close box at the upper left of the viewports closes the project. 
You cannot hide the toolbox.
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To move a window:
Drag the window’s handle bar (Windows) or title bar (Macintosh).

Note: On the Macintosh, if your windows are not dragging smoothly, turn on Solid window 
dragging in Preferences. For more information, see “Changing Preferences on the Macintosh” on 
page 72.

To float a docked window:
In Windows, drag the window’s handle bar into the viewports, or drag the window outside of 
the project.

Note: If you drag the window border instead of the handle, you will resize the window.

On the Macintosh, drag the window’s title bar so the edge of the window is no longer close to 
the edge of the desktop. 

To dock a floating window:
Drag the handle bar (Windows) or the title bar (Macintosh) to the approximate docking position 
and the window snaps into place.

Drag here
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To resize windows:
In Windows, drag a window’s border, or the border between windows.

On the Macintosh, do one of the following:

• Drag the size box.

• To minimize or maximize a window, click the zoom box.

• To collapse or expand a window, click the collapse box.

To show or hide a window’s toolbar:
In Windows, right-click in an editor that has a toolbar and turn the toolbar on or off. 

On the Macintosh, click a window that has a toolbar. Choose View, then turn the toolbar on or 
off, or press COMMAND+B. You can also CONTROL-click a window that has a toolbar, and in 
the context menu that appears, turn the toolbar on or off.

Zoom Box Collapse Box

Borders Size Box Size Box

Close Box Zoom Box

M
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Tools
The AXEL tools are accessed through icons located in the toolbars, and also in a toolbox on the 
Macintosh. 

Interaction Editor Toolbar

Macintosh Toolbox Macintosh Playback Floating Toolbar

Window’s Top Toolbar
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Author/Preview tools 

Navigation tools

Playback tools

Switches to Author mode, where you create your content, edit values, create relations, anima-
tions and set interactions. 
Switches to Preview in AXEL mode, where you preview the World as it will appear on the 
Internet. In Preview mode, you can interact with the World in the WebCam viewport, but you 
cannot modify it.

Zooms in and out of the World.

Pans left, right, up and down.

Orbits around the interest of the active WebCam—that is, the 
point that the WebCam focuses on. You can set the distance of a 
WebCam’s interest to change how it orbits. 

Go to start time.

Rewind.

Start playback.

Stop playback

Loop playback.

Fast forward.

Go to end time.
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Selection and manipulation tools

Switches to Object mode, where you manipulate surfaces, curves and other objects.

Switches to Point mode, where you manipulate points on a surface or curve.

Switches to Center mode, where you manipulate an object’s center.

Toggles X axis on or off for your manipulation. With this button on, the manipulation 
is limited to the objects local X axis.

Toggles Y axis on or off for your manipulation. With this button on, the manipulation 
is limited to the objects local Y axis.

Toggles Z axis on or off for your manipulation. With this button on, the manipulation 
is limited to the objects local Z axis.

Selects objects in the viewports. Can also be used in combination with the Scale, 
Rotate and Translate tools.

Scales the object(s). When Select tool is turned on, this tool simultaneously selects 
and scales the object.

Rotates the object(s). When Select tool is turned on, this tool simultaneously selects 
and rotates the object.

Translates the object(s). When Select tool is turned on, this tool simultaneously 
selects and translates the object.

Draws a curve.

Sketches a curve.

Draws a surface.

Pushes on a surface.

Locks all the constraints.

Unlocks all the constraints.
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Animation tools

Standard toolbar in Windows

Setting up toolbars
In Windows, you can show or hide the tools in the toolbars.

On the Macintosh, you can show or hide all the toolbars as well as change their displays. 

To show or hide a toolbar:
In Windows, right-click in an editor that has a toolbar and turn the toolbar on or off. To turn all 
the top toolbars on or off, press ALT+2.

On the Macintosh, click a window that has a toolbar. Choose View, then turn the toolbar on or 
off, or press COMMAND+B. For floating toolbars, choose View > Floating Toolbars, then turn 
the toolbar on or off. You can also CONTROL-click a window that has a toolbar, and in the 
context menu that appears, turn the toolbar on or off.

Record key.

Add Animation.

Add key.

Previous key.

Next key.

Opens an existing AXEL 3D project.

Saves the current project.

Copies the selected key(s) or parameter(s).

Pastes the last key(s) or parameter (s) you copied.
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To change a toolbar’s display on the Macintosh:
CONTROL-click a toolbar, then choose a display option:

• Show icon and text

• Show icon only

• Show text only

Viewports
A viewport is the space where you draw, model, and manipulate your objects. By default, there 
are four viewports: Top, Front, Right, and WebCam.
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The Front, Right, and Top viewports display construction views, also known as orthogonal 
views. Because there is no perspective in constructions views you can precisely manipulate 
objects. The WebCam viewport displays objects as seen through a WebCam, which is how they 
will appear once they are published in a web page.

You can see the orientation of a viewport by looking at the XYZ axis bars at the lower left of 
each viewport.

The viewport in which you are working is the active viewport. You can distinguish an active 
viewport by its highlighted outline. 

If you have a good graphic card on your system, you can speed up the display of AXEL content 
through the WebCams by turning on Hardware Acceleration in Author settings / Visualize. For 
more information, see “Hardware acceleration” on page 594.

To make a viewport active:
Click in the viewport.

To make a viewport active without selecting anything in the viewport:
SHIFT-click the viewport.

Usually you create objects in the construction views and then use WebCam view to look at them 
from different angles. This is similar to a movie set: when all the props are in place, you can 
move the camera into position and choose the best angle.

You can change the view in the viewports to display different parts of the World, as well as to 
display different types of information. The view can be changed in an individual active 
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viewport, or in all the viewports simultaneously. All four viewports can display construction 
views or WebCam views.

Zooming, Panning and Orbiting
Use navigation buttons and keyboard shortcuts to navigate in your 3D World. You can pan to 
move around or zoom in to inspect details in the Front, Top, Right and WebCam viewports. In 
the WebCam viewport, you can also orbit the camera around the center of the World.

Navigating in the construction viewports does not affect the WebCam or what appears in 
WebCam view.

Note: You can also use the WebCam parameters to control what is displayed in the WebCam 
viewport and in the published content. For example, you can make the WebCam follow an object, 
adjust its viewing frustum, or animate any of its parameters. For more information, see “WebCams” 
on page 340.

To navigate in a 3D World:
Click a navigation button, or hold the keyboard shortcut, and drag the mouse in the viewport.
In Windows, the navigation buttons appear in the camera toolbar.
On the Macintosh, the navigation buttons appear in the toolbox.

To show the camera toolbar in Windows:
Choose View > Toolbars > Camera Toolbar. 

Navigation Tools

Z Zooms in and out of the World.

Orthogonal view WebCam view
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X Pans left, right, up and down.

C Orbits around the current WebCam’s interest.
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Changing the view in a viewport
You can change what part of the 3D World is framed in a viewport, as well as what kind of 
information is displayed. 

You can change the view of a single viewport, or change the view for all viewports 
simultaneously. You can also toggle your display between all four viewports and a single 
enlarged viewport. 

As well, you can change each of the four viewports to display the Top, Front, Right or WebCam 
views.

Construction viewports are independent, so you can have 2 or more of the Top viewport, for 
example, and change their views separately. WebCams are dependent however, so you have to 
add new WebCams in order to change the view in a WebCam viewport from another WebCam 
viewport.

You can clip the display of AXEL content through a WebCam by using a Clip box. For more 
information, see “Clipping” on page 596.

To change the view in one viewport:
Do one of the following:

• Right-click (Windows) or CONTROL-click (Macintosh) the viewport and use the context menu that 
appears to select a viewport option. 

2 Top viewports and 2 Front viewports in the four 
viewport split all with independent views.

2 WebCams in diagonally opposite viewports with 
only 2 independent views possible.
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• Click a viewport. Choose View > Active Viewport, then select a viewport option.

To change the view for all viewports:
Choose View > All Viewports, then select a viewport option.

To toggle between a single viewport and four viewports:
Do one of the following:

• Select the viewport, then choose View > Switch to Single/Four Viewport(s).

• In Windows, select the viewport, then press ALT+1 or right-click the viewport, then choose Switch 
to Single/Four Viewport(s) from the context menu.

• On the Macintosh, click the zoom box at the upper right corner of a viewport.
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To set a viewport to display the Top, Front, Right or a WebCam view:
In Windows, right-click a viewport and choose Set Camera, then select choose a view. 
On the Macintosh, click the viewport label at the lower left corner of a viewport, then select a 
view.

Viewport Options

Frame Selection F (one viewport)
SHIFT+F (all viewports)

Frames the selected object(s) in the view-
port(s) as well as setting the WebCam’s inter-
est to the center of the selected object(s).
If the selection includes a WebCam, and the 
WebCam’s visibility is on, the WebCam is 
also framed in the construction views.

Tip: If you want to select an object in one 
viewport and frame it in another, select it in the 
first, then SHIFT-select the second viewport and 
press F.

Frame All A (one viewport)
SHIFT+A (all viewports)

Frames all objects in the viewport(s).

Reset Viewpoint Q (one viewport)
SHIFT + Q (all viewports)

Resets the viewport(s) to their default views. 
Resetting the viewpoint in the WebCam view-
port resets the WebCam parameters to their 
default values.

Show/Hide Con-
straints

Shows turquoise lines between objects that 
have relations.

Show/Hide Stats 
(Windows)

I (one viewport)
SHIFT + I (all viewports)

Indicates time and refresh rate.

Show/Hide Grid G (one viewport)
SHIFT + G (all viewports)

Shows the grid.
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Authoring and previewing in AXEL
When you create a 3D World, you are in Author mode. You can switch to Preview in AXEL to 
preview your World and test the interaction as if you were viewing the content via the Internet. 
To modify the World, switch back to Author mode.

When previewing in AXEL, you can perform a download simulation by setting a connection 
speed beforehand, and turning on Simulation in Download Estimates. For a preview that does 
not take into account any connection time, which is the quickest, make sure Simulation is off. 
For more information, see “To simulate the download with different connections:” on page 592.

To switch between Preview and Author modes:
Do one of the following:

• Click the Preview in AXEL button ( ) or the Author ( ) button. 

• Choose Publish > Preview in AXEL/Return to Author Mode.

• Press B.
In WebCam view, the World appears as if it were published. The Project Manager, Sequencer 
and toolbox are dimmed to indicate you are in Preview mode. All the elements in your World 
are frozen at the values you set in Author mode, but you can still expand items in the editors 
to gauge their values as your project plays. You can also toggle on/off Wireframe mode as 

Enable Snap to Grid Turns on snap to grid so that actions such as 
adding or modifying objects only take place at 
the intersection of grid lines. For more infor-
mation, see “Using a reference grid” on page 
55.

Set Grid Size Sets the ratio of the grid spacing.
Show/Hide Clipbox Shows the clip box. This option is only avail-

able if you add a clip box. For more informa-
tion, see “Clipping” on page 238.

Enable Clipping Turns on clipping so that only the portion of 
your World that is within the clip box is visi-
ble.

Enable Wireframe W (one viewport)
SHIFT + W (all viewports)

Toggles Wireframe mode on and off.

Enable Selection Fil-
ter

Hides everything but the selected object. To 
show all objects, choose this option again to 
turn it off. 

Edit Background 
Color

Sets the background color of the viewport(s).
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well as the reference grid, and control a few other viewport options, which are available in 
the context menu of a WebCam viewport that is in Preview in AXEL mode.

To control viewport options in Preview in AXEL mode:
Do one of the following:

• When in Preview in AXEL mode, use the View menu or shortcut keys to change one, or all 
viewport displays. For example, in the active viewport, press I to toggle on/off the stats, or 
press SHIFT+I to toggle on/off the stats for all the viewports. Viewport options that are not 
available in Preview in AXEL mode are ghosted.

• Use the context menu in a viewport by right-clicking (Windows) or CTRL-clicking 
(Macintosh) that viewport, then selecting a viewport option from the context menu. Like 

Most tools are greyed out in Preview in AXEL mode. The AXEL content becomes 
active, but you can still change some viewport options in the context menu.
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the View menu, viewport options not available in Preview in AXEL mode, are either 
ghosted (Windows), or are not displayed (Macintosh).

Note: On the Macintosh, even in Preview in AXEL mode, you can still switch between WebCam’s 
and construction views from the viewport label at the lower left corner of a viewport.

Using a reference grid
By default, a grid is displayed as a guide to help position and align objects. The center of the 
grid passes through the origin of the World.

For more precision as you create and manipulate objects, you can enable Snap to Grid, which 
limits your actions to the intersection of grid lines. You can show or hide the grid, and change 
the grid spacing. 

You can adjust the grid in all viewports or change the grid in only one viewport.

To show or hide the grid in one viewport:
Do one of the following:

• Click the viewport and choose View > Active Viewport > Show/Hide Grid.

• Click the viewport and press G.

• Right-click (Windows) or CONTROL-click (Macintosh) the viewport and choose Show/Hide Grid 
from the context menu.

Context menu in Preview in 
AXEL mode in Windows

Context menu in Preview in 
AXEL mode on the Macintosh
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To show or hide the grid in all the viewports:
Choose View > All Viewports > Show/Hide Grid or press SHIFT+G.

To change the grid spacing:
1. For one viewport, click the viewport and choose View > Active Viewport > Set Grid Size, 

or right-click the viewport (Windows) or CONTROL-click the viewport (Macintosh) and 
choose Edit Grid Size. 

2. For all viewports, choose View > All Viewports > Set Grid Size. 

3. Choose the grid line/units ratio: 2:1 means there are two grid lines every unit; 1:1 means there 
is one grid line every unit; 1:2 means there is one grid line every two units, and so on.

To turn on Snap to Grid:
Do one of the following:

• For one viewport, click the viewport and choose View > Active Viewport > Enable Snap to Grid. 

• For all viewports, choose View > All Viewports > Enable Snap to Grid or press SHIFT+H.
When you translate objects or draw curves, they snap to the intersection of grid lines. 
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Choosing Wireframe display for viewports
You can represent objects in Wireframe in each viewport overriding rendering styles to show the 
objects as a wireframe mesh. The wireframe mesh allows you to accurately view the edges of 
objects for precise construction or animation. For more information, see “Rendering styles” on 
page 306.

You can change modes for an individual viewport, or for all viewports simultaneously. 

Switching between Wireframe and a rendering style in the construction viewports simply 
changes how your information is presented for construction purposes. However, in WebCam 
view, these modes change how objects are rendered through the WebCam for both construction 
and publishing purposes.

Note: You can also set a specific WebCam to render the World in a rendering style, or in Wireframe 
mode. For more information, see “WebCams” on page 340.

To set one viewport to Wireframe mode:
Do one of the following:

• Right-click (Windows) or CONTROL-click (Macintosh) the viewport and choose Enable 
Wireframe from the context menu.

• Click a viewport and press W.

• Click a viewport and Choose > Active Viewport > Enable/Disable Wireframe.

To set all viewports to Wireframe mode:
Choose View > All Viewports > Enable/Disable Wireframe, or press SHIFT+W.
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Setting the viewport background color
You can set the background color for the World. In the construction views, the background color 
affects your work area. In WebCam view, the background color also affects the published 
content.

You select background colors for individual viewports or for all viewports from the View menu 
or a context menu.

Of course, you can create your own background in AXEL using textures applied on planes. 
Also, try using gradients by editing point colors. For more information, see “Color per point, per 
face” on page 314.

You can also publish your World without a background. For more information, see “Windowless 
content (AXELplayer)” on page 580.

Tip: Besides using AXEL’s windowless publishing feature, you might try just using the same 
WebCam background color as the Web page the AXEL content will be embedded in, therefore 
giving the illusion that there is no surrounding window.

To change the background color in one viewport:
1. Click the viewport and choose View > Active Viewport > Edit Background Color, or right-

click (Windows) or CONTROL-click (Macintosh) a viewport and choose Edit Background 
Color. 

2. Select a color from the Color dialog that appears.

To change the background color in all the viewports:
1. Choose View > All Viewports > Edit Background Color. 

2. Select a color from the Color dialog that appears.
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To change the background color for a WebCam:
1. In the Project Manager, select the WebCam. 

2. Set its background color in the Parameter Editor. To set the color, enter an RGB color value, 
or click the color chip and select a color from the Color dialog that appears. 
In Windows, you can enter a color value in decimal or HTML format. For example, to set the 
color to red, enter 255 0 0 or FF0000; for cyan, enter 0 V255 255 or 00FFFF. 
On the Macintosh, you can enter a color value in decimal format in the Parameter Editor, but 
you have to use the HTML option in the Color Picker to specify an HTML color value.

Displaying the host web page in Windows
In Windows, the WebCam view can also display the host web page. The host web page is the 
web page that contains your AXEL project. For more information, see “Previewing in a host 
web page (Windows)” on page 567.

To show/hide the host web page:
Right-click the WebCam viewport and toggle on/off Host Web Page, or click the WebCam 
viewport and choose View > Active Viewport > Enable/Disable Host Web Page.
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Editors
You can show or hide the Editors. 

On Windows, choose View > Editors, then select an Editor to show/hide.

On the Macintosh, choose Window, then select an Editor to show/hide.

Project Manager
Use the Project Manager to select any object, resource, or setting in your project. All items 
appear in the World, Resource bank, or Settings bank of the Project Manager: 

• The World lists objects with their materials, sensors, reactions, constraints, animation and 
corresponding parameters. It includes a setting to control streaming for the whole project, and 
displays the total number of points in the World which is important for Download time and 
Performance.

• The Resources bank lists all the effects associated with the objects in your World, listed by item type. 

The context menu and the Host Web Page

When you right-click a 
WebCam viewport with a Host 
Web Page, the context menu 
that appears has a few extra 
options that are specifically to 
control the Host Web Page. 

The Back and Forward items 
will cycle through the links of 
the page, because hyperlinks 
remain active in the Host Web 
Page. While Refresh will 
reload the page.
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• The Settings bank lists values and attributes that are defined for the entire project. For example, in the 
Edit settings, when you set a value for Duplicate offset, each time you create a duplicate of an object 
it is offset from the original by this value. 

Use the Project Manager to organize a project’s elements, and to select elements in order to edit 
their parameters in the Parameter Editor. The icons in the Project Manager make it easy to 
identify the different types of elements. For example, a green circle ( ) next to a parameter 
indicates that it can be edited or animated; a green circle with a line in it ( ) indicates that it 
can be edited but not animated; and an orange circle ( ) indicates that it can be neither edited 
nor animated. 

Tip: Most items in the Project Manager can be renamed. Be sure to name your items clearly as 
you work; otherwise, your project can become difficult to work with.

To expand or collapse items in the Project Manager:

Click the plus sign ( + ) (Windows) or the right arrow ( ) (Macintosh) next to an item to expand 

it; click the minus sign ( - ) (Windows) or down arrow ( ) (Macintosh) next to an item to 
collapse it. You can also double-click an icon to expand or collapse it.

To rename an object in the Project Manager:
1. Click the object’s name twice (Windows) or click the text of the name of the object 

(Macintosh). 

2. Type a new name and press ENTER.
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Tip: In Windows, you can also edit parameters and settings in the Project Manager by double-
clicking them and entering new values. In general, it is easier to use the Parameter Editor for 
changing parameters and settings.

To select an item in the Project Manager:
Click the item. 

Parameter Editor
When you select an object, an animation sequence, or any other item in the project, its 
parameters appear in the Parameter Editor. Use the fields, sliders, and lists in the Parameter 
Editor to edit the selected item. 

Some parameters are grouped into categories, which are located at the lower left of the 
Parameter Editor.

The pin at the upper left corner of the Parameter Editor is useful for locking the display of a 
particular set of parameters while you work on another object, so that you can compare and 
contrast.

You can also multi-select items in your project to display and edit their common parameters in 
the Parameter Editor.

To expand a category in the Parameter Editor:
Click the category.

Categories

Pop-up menu Pin
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To view a higher level category:
Click the pop-up menu and choose a higher level. 

To rename an object in the Parameter Editor:
1. Select the object.

2. Type a new name in the Name field.

To lock the Parameter Editor on a particular item:

Click the Pin icon. ( ). It switches to ( ).

This prevents the Parameter Editor from changing when you select another object or parameter.

Higher levels are displayed here
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To display an object’s parameters in the Parameter Editor:
Select the object.

Note: You can select objects or constraints in the viewports; sensors, reactions, or triggers in the 
Interaction Editor; animation sequences or keys in the Sequencer; or any element in the Project 
Manager. The corresponding parameters appear in the Parameter Editor.

To display common parameters shared between items:
Multi-select the items. For example, you can select any combination of objects and groups, or 
multiple animation sequences, or reactions from the Interaction Editor, etc.

Parameters that are common to the items are displayed in the Parameter Editor. If the parameter 
values are not the same for the selected objects, the fields appear empty. Entering a new 
parameter makes this value common for all selected items, overriding any individual item’s 
value for this parameter—a useful method, for example, to align objects.

To select a parameter:
Do one of the following:

• In the Project Manager, expand the object, then click the parameter.

• Select the object, then select the parameter in the Parameter Editor.

Two WebCam handles are multi-selected in the Interaction Editor 
with their common parameters showing up in the Parameter Editor.
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Copying parameters in Windows
You can copy similar parameters from one item to another. For example, copy the position 
parameters of a surface and paste them in the position parameters of another, or copy a parameter 
of a constraint and paste it onto similar constraints.

You can paste animation keys from one animation key to another, in which case you will be 
pasting only the key value information and not the time field.

You can paste any relevant value onto another as long as their number of fields match, as well 
as value type. For example, the number of steps on a curve can be pasted onto the number of 
subdivisions of a surface, because they have both the same number of fields and the same value 
type, that is, a positive integer.

To copy parameters:
1. In the Project Manager, select the parameter that you want to copy then click it again or press 

F2.
The parameter value is highlighted.

2. To copy the values, choose Edit > Copy, press CTRL+C, or click the Copy icon ( ) in the 
Standard toolbar.

3. Select the parameter to which you want to paste the values. Click it again or press F2 to edit 
the parameters.
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4. To paste the values, choose Edit > Paste, press CTRL+V, or click the Paste icon in the 
Standard toolbar ( ), then press ENTER.
The parameter is set to the value that you copied.

Sequencer
The Sequencer displays a graphical view of the animation, interaction, and streaming in your 
World. You can view and edit animation sequences, keys, and animation curves. You can drag 

Example: Copying an Animation Key

When you use the steps above on an animation key, 
you copy just the animated parameters and not the 
time field, which remains constant—unchanged by 
the pasted values.
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the playhead to change the current time, or drag single keys or entire animation sequences to 
change their times. You can also arrange and edit your reactions in the Sequencer. 

You can display a graphical representation of the streaming within your project, that is, the order 
and time it will take for each item that comprises your project to download onto a surfer’s 
computer.

Interaction Editor
The Interaction Editor provides a schematic view of interactions. Use it to link triggers and 
reactions in order to make your World interactive. 

Zoom Scroll bar

Playhead

KeysAnimation curves

Animation 
sequences

Displays Interaction

Sequence 
start time 
bar

Displays Streaming

Streaming 
priority
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You can filter the information that is displayed in the Interaction Editor. For more information, 
see “Interaction” on page 415

To filter information in the Interaction Editor:
Right-click (Windows) or CONTROL-click (Macintosh) the Interaction Editor and select a 
filtering option from the context menu.

Customizing on the Macintosh
AXEL on the Macintosh includes some additional ways to customize the user interface, as well 
as some other customization options.

Customizing toolbars on the Macintosh
On the Macintosh, you can customize the toolbars. You can also create new floating toolbars and 
add tools. This can help you create the most intuitive user interface for your style of working.
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To customize toolbars:
1. Choose View > Customize Toolbars.

A list of icons, with their names, replaces the viewports.

Note: You can change the display of the icons using the Show list in the lower left of the window. 

2. Drag and drop desired icons into the toolbars. 

3. Rearrange the order of the icons in your toolbar by dragging an icon into a new position.

4. Delete an icon by dragging it outside of the toolbar.

Tip: Drop in separators appropriately to better organize your toolbars.

5. Click Done.
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To create floating toolbars:
1. Choose View > Floating Toolbars > Create New. 

A dialog appears.

2. Type a name for the new toolbar, then click Create.
An empty toolbar is created.

3. Customize the new toolbar.

4. Afterwards, you can change the display of your floating toolbars, between Icon and Text, 
Icon Only and Text Only, by choosing View > Floating Toolbars > Edit, then changing the 
Show setting for each of your toolbars.

Tip: You can create as many toolbars as you want with as many icons as you want, including 
multiple copies of the same icon within a toolbar. Use this function sparingly, as your work area 
can quickly become crowded.

Default floating toolbars on the Macintosh
On the Macintosh, Playback and Animation tools are available both within default Playback and 
Animation floating toolbars, as well as within the Sequencer.

These toolbars are customizable.

Editing keyboard shortcuts on the Macintosh
AXEL has default keyboard shortcuts for many menu items. You can edit or add keyboard 
shortcuts, all of which must include the COMMAND key in addition to one or more other keys. 
Shortcuts appear to the right of the item in the menus. They also appear in the Keyboard 

Playback Toolbar Animation Toolbar
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Shortcuts Editor when you highlight a menu item. You can export and import your shortcuts to 
share them between projects.

To edit keyboard shortcuts:
1. On Mac OS 9, choose Edit > Keyboard Shortcuts.

On Mac OS X, choose AXELcore/edge > Keyboard Shortcuts.

2. Find a menu item by clicking the right arrow ( ) next to a menu heading to expand it. Click 
the down arrow ( ) next to a menu heading to collapse it.

3. Highlight a menu item by clicking it.
If there is a shortcut assigned to this item, it appears in the field.

4. Enter a new button combination, including the COMMAND button, in the field. You must 
press all the buttons at the same time.

Note: If you enter keys already assigned to another item, you are prompted to either Cancel or 
to Replace. Replacing will reassign these keys to the new menu item only.

5. Click OK.
The new shortcut now functions as a menu item, appearing next to the item in the menus.

After highlighting a menu item, type a key 
combination into the field
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To export keyboard shortcuts:
1. In the Keyboard Shortcuts Editor, click Export.

2. Choose a location to save the shortcuts. 

3. Type a name in the Name field, then click Save.
Your keyboard shortcuts are saved to the specified location as an AXEL Author document 
and can be opened in any AXEL project.

To import keyboard shortcuts:
1. In the Keyboard Shortcuts Editor, click Import.

2. Select the file that contains your keyboard shortcuts. 

3. Click Open. You can only import keyboard shortcuts that were previously exported from 
AXEL as an AXEL Author document.

Changing Preferences on the Macintosh
Preferences allows you to change several default settings within AXEL. 

There are four categories of preferences: 

• General: This category includes Menu settings and Window settings.

• Periodic Tasks: This category includes MindAvenue Web Customer Services and Auto Save 
Settings.

• Web Browsers: This category includes functions to edit the web browsers you use to preview your 
AXEL content.

• Text Editor: This category includes adjustable settings for the text editor that you use to edit your 
host web page’s source HTML code.

To change preferences:
1. On Mac OS 9, choose Edit > Preferences.

On Mac OS X, choose AXELedge/core > Preferences

2. Click a category, then adjust your preferences.

3. Click OK.
Your changes take affect immediately.
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Menus
The menus correspond to a typical AXEL workflow, and each menu contains the commands you 
need in that stage of the workflow.

AXELcore/edge menu (Mac OS X)
The AXEL menu is only for Mac OS X, and it groups specific tools for customizing your AXEL 
sessions, as well as identification information.

About AXEL Displays a window with information about the version of AXEL you 
are running.

MindAvenue Support Brings you to the Support section of the MindAvenue web page.
Keyboard Shortcuts Opens the Keyboard Shortcuts Editor where you set keyboard shortcuts 

for menu items.
Preferences Opens the dialog where you set preferences for the organization of the 

AXEL windows.
Quit AXEL Closes all the open projects and exits AXEL.
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File menu
The File menu contains standard file management commands.

Note: In Windows, recent projects are listed. Choose a project to open it.

New Starts a new World.
Open Opens an existing World.
Open Recent 
(Macintosh)

Opens one of the projects you worked on recently.

Close (Macintosh) Closes the current project file.
Save Saves the current project in an .axel project file.
Save As Saves the current project with a new name.
Revert to Saved (Macintosh) Opens the saved version of the current project. Changes since the last 

time you saved are lost.
Import AXEL Project Imports an AXEL project into the current World. 

AXELedge users can also use this command to import .axel projects 
created with AXELpublisher from 3ds max content.

Import Imports VRML objects or EPS curves  into the current project, as Light-
Wave object and scene files into AXELedge.

Export Selects a file type to export to the project folder:

• Flash (.swf)

• Image: PEG, GIF or PNG

• Movie: Linear Movie, animated GIF (. mp4, .mov, or .gif)

• VRML97 (.wrl)
Export As Selects a file type to export to and offers a dialog for the save path:

• Flash (.swf)

• Image: PEG, GIF or PNG

• Movie: Linear Movie, animated GIF (. mp4, .mov, or .gif)

• VRML97 (.wrl)
Exit (Windows) /
Quit (Mac OS 9)

Closes the current project and exits AXEL.
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Edit menu
The Edit menu contains standard editing commands.

Undo Undoes the last action. You can undo up to 50 actions.
Redo Redoes the last action you undid. You can redo up to 50 actions.
Cut Cuts the selected parameter or key (Macintosh).
Copy Copies the selected parameter or key to the clipboard.
Paste Pastes the value on the clipboard into the selected parameter or 

key. 
Delete Deletes the selected item(s).
Duplicate Creates a copy of the selected object(s). The duplicate is offset 

from the original object. You can change the offset in the Edit set-
tings in the Project Manager.

Instance Creates a clone of the selected object(s). If you change the geom-
etry parameters of either the original or the instance, both objects 
change. The instance is offset from the original object. You can 
change the offset in the Edit settings in the Project Manager.

Select All Selects all visible objects in the World.
Unselect All Unselects all objects.
Manipulation Options Selects the axis the manipulation uses.
Unhide All Makes all objects and groups visible.
Keyboard Shortcuts (Mac OS 9) Opens the Keyboard Shortcuts Editor where you set keyboard 

shortcuts for menu items.
Preferences
(Mac OS 9)

Opens the dialog where you set preferences for the organization of 
the AXEL windows.

Edit Custom Script (Windows)
Custom Script (Macintosh)
(!AXELedge only)

Opens an editor where you can edit the script of a selected Custom 
relation, Custom sensor, or Custom reaction.
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View menu 
Use the View menu to control what appears the viewports. For more information, see 
“Viewports” on page 46.

Note: The same commands appear when you right-click (Windows) or COMMAND-click 
(Macintosh) a viewport but they only affect that viewport.

.

Active Viewport Displays viewport options for the active viewport.
All Viewports Displays viewport options for all viewports.
Sequencer Displays view options for the Sequencer.
Interaction Editor Displays view options for the Interaction Editor.
Switch to Single/Four View-
port(s)

Toggles the work area between one viewport (Single Viewport) and 
four viewports.

Floating Toolbars (Macin-
tosh)

Shows/hides floating toolbars or creates new toolbars.

Show/Hide Toolbar Shows/hides the toolbars or the status bar in the active window.
Editors
(Windows)

Shows/hides a selected editor.

Toolbars
(Windows)

Shows/hides a selected toolbar.

Customize Toolbars (Macin-
tosh)

Adds or removes icons from toolbars.
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Model menu
The Model menu contains commands for creating and modifying 3D objects. For more 
information, see “Modeling” on page 151

Add Curve Creates preset 2D shapes. 
Draw Curve Switches to Draw Curve mode so you can draw a curve in the viewport.
Sketch Curve Switches to Sketch Curve mode so you sketch a curve as you drag in a 

viewport.
Modify Curve Edits a curve. 
Add Surface Creates preset 3D shapes. 
Create Surface Creates a 3D shape from a curve. 
Draw Surface Switches to Draw Surface mode so you can draw a surface in the view-

port.
Modify Surface Edits a 3D shape. 
Push Surface Switches to Push mode so you can deform a surface in a viewport. 
Bend Surface Deforms the selected surface. 
Add Text Creates 3D text surfaces. 
Add Text Layer Creates a 2D layer of text in front of, or within the 3D World.
Convert Text to Curve Converts text to a curve so it can be manipulated as a curve.
Add Limbs(!AXELedge 
only)

Creates 1-bone and 2-bone limbs. 

Modify Limbs (!AXELedge 
only)

Resets or goes to limb’s home state.

Apply Skin (!AXELedge 
only)

Attaches surfaces to other surfaces or limbs so that they can be 
deformed by these objects.

Mix Shapes Modifies an object’s shape with selected shape modifiers.
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Relate menu
Use the Relate menu to group objects and attach them together with constraints. For more 
information, see “Relations” on page 255

Visualize menu
Use the Visualize menu to add materials, textures, and lights. For more information, see 
“Visualization” on page 301

Constrain Pose Ties the position, orientation, and scale of an object or group to 
another object’s position, orientation, and scale.

Constrain Distance Makes an object or group stay at a certain distance from another 
object.

Constrain Direction Makes one object or group point at another object.
Constrain to Curve Attaches an object or group to a curve.
Constrain to Bounding Box Constrains an object or group to stay inside or outside a selected box.
Constrain to Bounding Sphere Constrains an object or group to stay inside or outside a selected 

sphere.
Add Spring Attaches an object or group to another object so that when you pull 

them apart, they bounce back toward each other as if attached by a 
spring. 

Add Snap Makes an object or group snap to one or more objects’ positions.
Add Pin Joint (!AXELedge 
only)

Attaches an object or group to another object using a pin joint, for 
example like a door on a hinge.

Add Ball Joint (!AXELedge 
only)

Attaches an object or group to another object using a ball joint, for 
example a shoulder, or the new imac on its base.

Add Slider Joint (!AXELedge 
only)

Attaches an object or group to another object using a slider joint, for 
example sliding windows or the side door of a van.

Add Custom Relation 
(!AXELedge only)

Allows you to define a constraint on an object or group according to 
the script that you enter.

Group Groups selected objects or groups.
Ungroup Removes objects or sub-groups from a group and deletes the group. 

This does not delete the actual objects that together comprise the 
group.

Add to Group Adds an object or group to another group.
Remove from Group Removes an object or group from another group.

Add Color Material Adds a color material to the project and applies it to the selected sur-
faces and/or curves. If no surface is selected, the material is added only 
to Resources and is listed in Project Manager / Resources / Materials.
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Link Material Links the selected material to the selected surfaces.
Unlink Material Unlinks the selected material and surfaces.
Edit Point Color Changes the color of a surface at selected points.
Add Image Texture Adds an image texture to the project and applies it to the selected sur-

face(s). If no surface is selected, the texture is added only to Resources 
and is listed in Project Manager / Resources / Images. 

Add Movie Texture Adds a movie texture to the World and applies it to the selected sur-
face(s). A Play Movie reaction must be triggered to play, and comes 
into the project linked to the TimeSensor at the current time. If no sur-
face is selected, the texture is added only to Resources and is listed in 
Project Manager / Resources / Movies. 

Texture Projection Adds a planar or cylindrical texture projector to the selected textured 
surface. Texture projectors allow you to more correctly map textures 
onto surfaces in the way you define.

Link Texture Links the selected texture to selected materials or surfaces.
Unlink Texture Unlinks the selected texture and materials or surfaces.
Add Light Adds a point, spot, or directional light to the World. 
Add WebCam Adds a WebCam to the World.
Add ClipBox Adds a clip box to limit what is visible when the World is published.
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Animate menu
Use the Animate menu to create and modify animation. For more information, see “Animation” 
on page 363

Interact menu
Use the Interact menu to create interactions. For more information, see “Interaction” on page 
415

Add Animation Sequence Creates an animation sequence for the selected parameter(s). 
Add Key Adds a key at the current time, on the selected animation sequence(s). 
Animate on Path Animates an object along a curve. 
Apply Wave Adds a wave deformation to the selected object. 
Add Particles Adds particles which are small or fragmented objects that you can con-

trol together to mimic snowflakes, sparks, or smoke for example.
Link Particle Obstacle Makes an object an obstacle to the flow of particles. 
Unlink Particle Obstacle Makes the particles ignore the selected object. 
Playback Controls Controls playback.
Animation Controls Turns recording on or off, and navigates between keys.

Add Sensor Creates a sensor.
Add Reaction Creates a reaction.
Add Handle In one action, creates and links predefined sensors and reactions which 

together form handles. There are manipulation handles, deformation 
handles and WebCam handles.

Add Rollover Creates a Rollover group reaction linked to a selected object. The Roll-
over group reaction includes a Set Glow Parameter reaction, a Tooltip 
Text reaction and a Play Sound reaction—which all can be edited.

Link Reaction Links the selected reaction(s) to the selected sensor.
Unlink Reaction Unlinks selected reactions and sensors.
Unlink Reaction from All Unlinks the selected reaction(s) from any sensor to which it is linked.
Group Reactions Groups the selected reactions to make it easier to link them to the same 

sensor.
Ungroup Reactions Ungroups the selected reactions.
Add Reaction to Group Adds a reaction to an existing group of reactions. 
Remove Reaction from 
Group

Removes a reaction from a group of reactions. 
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Publish menu
Use the Publish menu to publish your work. For more information, see “Publishing” on page 447

Generate AXEL Stream Generates the AXEL stream file (.axs) and the HTML code in a host 
web page for AXELplayer playback. 
You also open up the .axs file generated by this command in the AXEL-
player Standalone, or when you invoke the QuickTime player for play-
back.

Generate AXEL QuickTime 
Movie

Generates an AXEL QuickTime movie which plays directly in Quick-
Time with the QuickTime AXEL component. All AXEL interactivity is 
intact.

Generate AXELprojector Generates an AXELprojector with the current content, so no other soft-
ware is needed to play your project.

View Source Host Web Page In Windows, displays the source code of the host web page in a text edi-
tor. On Mac OS 9, displays the source code in a dialog, and on Mac OS 
X, displays the source code on a sheet.

Enable/Disable Host Web 
Page (Windows only)

Displays or hides the host web page in the WebCam viewport.

Export Parameter Exports the selected parameters so surfers can modify the parameter in 
the published web page. The next time you Generate AXEL Stream or 
AXEL QuickTime Movie, the parameter controls appear on the host 
web page. You can replace the sample controls with your own JavaS-
cript (or appropriate script language) to control the parameters. 

Export Reaction Trigger Exports a trigger for the selected reaction so surfers can launch the reac-
tion by clicking a button in the published web page. The next time you 
Generate AXEL Stream, the reaction controls appear on the host web 
page. You can replace the sample controls with your own JavaScript to 
control the reaction.

Preview in AXEL/Return to 
Author Mode

Toggles between Preview in AXEL and Author Mode. Previewing in 
AXEL with simulation turned in Download Estimates on performs a 
download simulation.

Preview in IE (Windows) Opens the current host web page in Internet Explorer® with the current 
AXEL 3D content playing in the AXELplayer.

Preview in Netscape (Win-
dows)

Opens the current host web page in Netscape® with the current AXEL 
3D content playing in the AXELplayer.

Preview in QuickTime Opens the QuickTime Standalone player with the current AXEL con-
tent as an interactive AXEL QuickTime Movie.

Preview in... (Windows) Opens the current host web page in a browser or an HTML editor.
Preview in (Macintosh) Opens the current host web page in a browser you choose from the list 

of available browsers.
Batch Publish (Windows) Publishes a batch of stream files. This is useful, for example, for 

upgrading a series of projects to a new version AXEL. 



82 | AXEL V2 | User Guide

Window menu on the Macintosh
Use the Window menu on the Macintosh to display and organize AXEL windows and editors.

Note: Open projects are listed at the bottom of the Window menu. Choose a project to make it 
active.

AppleScript menu on the Macintosh
Use this menu to open AppleScripts.

To show/hide the AppleScript menu icon:
1. On Mac OS 9, choose Edit > Preferences.

On Mac OS X, choose AXELcore/edge > Preferences.

2. Under Menu Settings, turn off Show AppleScript menu.
The scripts remain available from the finder but the AppleScript icon no longer appears in 
the AXEL menu bar.

Help menu
Use the Help menu to learn AXEL and to find answers to your questions.

Stack Windows Stacks the active viewports over the other viewports.
Collapse Window/Uncol-
lapse Window (Mac OS 9)
Minimize Window/Uncol-
lapse (Mac OS X)

Collapses/expands selected window. Hold the OPTION key to col-
lapse/expand all.

Zoom Window Resizes the viewports to take up the entire desktop. Select Zoom Win-
dow again to toggle the viewports back to their previous size.

Reset Windows Resets windows to their default sizes and positions.
Show/Hide Project Manager Shows/hides the Project Manager.
Show/Hide Sequencer Shows/hides the Sequencer.
Show/Hide Interaction Editor Shows/hides the Interaction Editor.
Show/Hide Parameter Editor Shows/hides the Parameter Editor.
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Settings 
Settings are editable values and attributes that are consistent throughout the current AXEL 
project. Settings are grouped into three: Author settings, Publish settings, Import settings and 
Download estimates.

Author settings

Publish settings

Download estimates

Import settings

Export settings
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Author settings
Author settings define how manipulations act on the objects as your create your project, as well 
as whether Hardware acceleration is enabled to speed up your work. Author settings are 
accessed from the Project Manager.

Edit settings

Model settings

Push surface settings

Note: The Push surface settings do not apply to the Push handle, which is an interactive push that 
Web Surfers perform on your objects. For more information, see “Push handle” on page 491.

Simplify curve settings

Simplify surface settings

Delete confirmation Prompts you to confirm each time you delete an item.
Duplicate offset Determines the distance the duplicate is positioned from the original 

when created. 
Instance offset Determines the distance the instance is positioned from the original 

when created. 

Contact radius Determines how close the cursor has to be to the surface before the push 
takes effect.

Deform radius Determines how much the surface is pushed in.
Deform depth Determines the distance around the contact point of the surface affected 

by the deformation. 

Angle threshold Sets the angle under which points are removed.

Angle threshold Sets the angle under which points are removed.
Percentage Determines the percentage of points, within the angle threshold, that are 

removed.
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Sketch curve settings

Distance sampling Determines the spacing of points as you sketch a curve.
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Visualize settings

Publish settings

Publish settings affect how your project is published and placed on a web page when you 
generate stream files and movies for the AXELplayer or QuickTime. Publish settings are 
accessed from the Project Manager and edited through the Parameter Editor.

For more information, see:

See:
“Publish settings/AXEL Stream” on page 560

“Publish Settings/AXEL QuickTime Movie” on page 565

Export settings
Export settings affect how your project is exported to create AXEL Projectors, Flash .swf 
movies, images, linear movies including QuickTime and MPEG-4, as well as VRML 97 files. 
Export settings are accessed from the Project Manager and edited in the Parameter Editor.

For more information, see:

See:
“Export settings/Flash (SWF)” on page 123

“Export settings/Image” on page 129

“Export settings/Movie” on page 131

“Export settings/VRML 97” on page 146

Hardware acceleration Turns on/off hardware acceleration during the authoring of AXEL 
projects—speeding up your machine as you work. For systems without 
a graphic card, using Hardware acceleration can negatively affect per-
formance. This does not affect the published content.
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Import settings
Import settings affect how some file types are imported into AXEL. Import settings are accessed 
from the Project Manager.

See:
“Importing EPS files” on page 102

“Importing VRML files” on page 103

“Importing LightWave 3D files” on page 104

“3ds max files through AXELpublisher” on page 109
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Download estimates
Use download estimates to gauge the time it will take for your project to download to surfers’ 
computers.

Download Estimates settings

Note: Download estimates are tied to AXEL Stream file (.axs) generation for the AXELplayer, but 
published QuickTime .mov files should be very close to this. Other publishing formats, like VRML 
or Flash .swf movies vary. For more information, see “Optimizing” on page 586.

Download Speed Sets the download speed used for download simulations when preview-
ing in AXEL. It is as if AXEL content was transferred to a host com-
puter via the Internet at this speed. Also controls the connection speed 
used in the Sequencer’s streaming view representation of the down-
load.

Simulation Turns on a download simulation that will run when previewing in 
AXEL.

Autorefresh Estimates Automatically refreshes download estimates as you transform your 
World.

Time to initial display The time it takes for the first elements of your AXEL project to appear 
on the surfer’s computer.

Total download time The time it takes for all the elements of your AXEL project to transfer 
to the surfer’s computer.

Total size The size of the AXEL stream file (.axs) in bytes.
Show details The file size, in bytes, of items in your AXEL project listed by stream-

ing priority and item type.
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Chapter 3
Projects & Im-
port/Export
Understand AXEL’s file structure, including the file 
formats that can be imported and exported, the types 
of which have been augmented in AXEL V2.

For import and export formats, get a head’s-up on 
what information from each type comes into AXEL, 
as well as what goes out of AXEL, improving how 
you use AXEL to leverage and combine these 
formats in new ways.

In this chapter:

Project Files .......................... 96

Importing AXEL projects ... 100

Importing EPS files ............. 102

Importing VRML files ........ 103

Importing LightWave 3D files ..
104

Exporting 3ds max files to 
AXELedge using 
AXELpublisher ..................... 59

Exporting AXEL Projector files 
131

Exporting Flash Movies .......115

Exporting Images ................ 128

Exporting VRML Worlds ... 133

Previewing exported files ....114
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Project Files
You can start building a 3D World as soon as you launch AXEL. You can also open existing 
projects, and save projects to continue working on them later. You can merge AXEL projects to 
reuse models, and import VRML files created in other 3D modeling packages.

The File menu contains the commands you need to manage your project files. 

Opening and saving projects
Note: You can also publish your work so that others can interact with your 3D World on the web. 
For more information, see “Publishing” on page 447.

3D Worlds are saved in AXEL project files (.axel) that store all the information required to 
recreate the objects, animation, interaction, and settings in your project, and from which you can 
publish and export content.The folder in which you save your project becomes the Project 
folder. 

When you add image and movie textures to your project, they are copied to the Textures folder 
which is located in your Project folder, and when you add sounds, they are copied to the Sounds 
folder. Textures and sounds are linked to the project using relative paths, so you can move the 
Project folder without breaking the links. 

If you have several projects in the same folder, the Textures and Sounds folders contains the files 
used by all the projects. If you want to move one project, use the Save As command. When you 
save a project in a different location, AXEL automatically creates Textures and Sound folders 
in the new location and copies the relevant texture, sound and movie files into those folders.

If you publish a movie texture as a URL, it hyper-linked to the AXEL project. It will not be 
located within your Textures folder. See “Adding movie textures” on page 317.

You can open an AXEL project created in Windows on the Macintosh (although it will not show 
the correct icon). You can open an AXEL project created on the Macintosh in Windows if you 
manually add the extension .axel to the file.

Note: When you publish your work, a stream file and an HTML file are created. These files are 
also stored in the Project folder. For more information, see “Publishing” on page 447.

To start a new project:
Launch AXEL or, if AXEL is running, choose File > New, or press CTRL+N (Windows) or 
COMMAND+N (Macintosh).
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To save your work:
Choose File > Save, or press CTRL+S (Windows) or COMMAND+S (Macintosh). In Windows, 
you can also click the Save button ( ) on the standard toolbar.

Note: In Windows, the standard toolbar may be hidden, depending on your screen resolution. To 
show the standard toolbar, choose View > Toolbars > Standard Toolbar. 

Note: On the Macintosh, your work is automatically saved by default every 30 minutes. See 
“Automatic file saving on the Macintosh” on page 99.

To save a project under another name:
Choose File > Save As, then enter a new name.

To move a project file:
1. Open the file in AXEL, then choose File > Save As.

2. Navigate to the location where you want to save the file, and click Save.
The following files and folders are copied to the new location:

• Project file (.axel)

• Textures folder containing the image and movie textures in the saved project

• Sounds folder containing the sounds used in the saved project

• A default host web page (projectname.htm) required for web publishing

To open an existing project:
Choose File > Open, or press CTRL+O (Windows) or COMMAND+O (Macintosh). In Windows, 
you can also press the Open button ( ) on the standard toolbar. 
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To open multiple projects:
In Windows, since you can only open one project at a time in AXEL, you must open another 
copy of the AXEL application on your computer in order to open another project file (.axel). 

On the Macintosh. you can open up many projects in a single opened AXEL session. With a 
project open, choose File > Open.

The newly opened project’s viewports overlap other opened projects. Its properties are loaded 
into all the Editors. When you click the viewports of another open project, that project becomes 
active and its properties, in turn, are loaded into all of the Editors.

To revert to the saved version of the current project on the Macintosh:
Choose File > Revert to Saved.

Note: Any changes made since the last time you saved are lost. Revert to saved is not available in 
Windows.

To exit AXEL:
Choose File > Exit (Windows), or File > Quit (Mac OS 9) or AXELcore/edge > Quit (Mac OS 
X).

Automatic backups in Windows
When you work on an existing project, AXEL makes a backup of the project file the first time 
you save it in a working session. That way, you can always revert to the project as it was when 
you started working on it in that session.

When you first create a file and save it, AXEL does not make a backup. When you re-open an 
existing project, AXEL creates a backup the first time you save your changes. If you continue 
to work on the file, the backup is not updated each time you save it. The backup is only updated 
after you close the project, re-open it, and save it for the first time in the next working session.

Note: On the Macintosh, AXEL does not create backup files. However, you can choose 
File > Revert to Saved to open your project with the changes you made up to the point you last 
saved.

Example: Using backups on Windows
1. Create a project, save it as My_Project.axel, then save it several times as you work.

Your Project folder contains the file My_Project.axel. There is no backup.

2. To close MyProject, exit AXEL, or open another project.
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3. Re-open MyProject, modify the objects, and save the file.
AXEL creates a backup of the project that you opened, without the most recent changes. It 
then saves My_Project.axel with the changes. Your Project folder now contains the files 
My_Project_backup.axel, and My_Project.axel.

4. Continue working on My_Project.axel, and save the project frequently. 
Saving the project does not overwrite the backup. To revert to the project as it was when you 
first opened it, you can open the backup.

5. Close MyProject.

6. Re-open MyProject, modify the objects, and save the file.
AXEL updates My_Project_backup.axel. The backup is now a copy of the project you just 
opened, without the most recent changes. It then saves My_Project.axel with the changes.

Automatic file saving on the Macintosh
On the Macintosh, your file is automatically saved by default every 30 minutes. This way you 
do not have to save your work periodically; the computer does it for you. You can disable this 
behavior or change its frequency.

To set up automatic saving of your work:
On Mac OS 9, choose Edit > Preferences, then click Periodic Tasks.
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On Mac OS X, choose AXELcore/edge > Preferences, then click Periodic Tasks.

To return to the last saved version:
Choose File > Revert to Saved.
You current project is replaced with the last saved version.

Importing AXEL projects
Import AXEL projects into your current session when you want to reuse objects created in other 
AXEL sessions. This creates copies of your AXEL models complete with animations and 
constraints. All the resources, included unused resources, are also imported. Settings, 
preferences and other author-related options remain at the state set for your current authoring 
session and project.

AXEL’s actual duplicate and instance commands only duplicate the objects themselves, so this 
function is very useful for efficiently creating copies of objects complete with their animations, 
constraints, interactions, etc.

You can import projects from AXEL version 1.01 through 2.0.

Set frequency Turn on/off automatic file saving
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You can import AXELedge projects into AXELedge, and AXELcore projects into AXELcore. 
As well, you can import AXELcore projects into AXELedge. 

You cannot import AXELedge projects into AXELcore.

AXELedge users can also import .axel projects created from AXELpublisher (3ds max content). 
For more information, see “3ds max files through AXELpublisher” on page 109.

When you import AXEL projects, objects that have the same name are given a number to 
differentiate them. For example, if you already have Sphere1 in your project, and import a 
project that had an object also called Sphere1, this second sphere is now called Sphere2. Global 
objects such as the default material and time triggers, as well as the default WebCam and 
Directional light, are not merged.

To import AXEL projects:
Choose File > Import AXEL Project, then select the file whose objects you want to use.
The objects from the imported project are added to the current project.

Note: Since lights, WebCams and materials are imported, you may need to clean up your project 
by deleting unnecessary items after importing a project.

Importing non-native files
You can import EPS and VRML97  directly into AXELcore and AXELedge, as well as 
LightWave scene and object files and 3ds max files (through a 3ds max exporter called 
AXELpublisher) directly into AXELedge.

For all formats except for 3ds max files, you do this through the AXEL interface. For 3ds max 
files, there is a separate plug-in that you use to export your files from 3ds max as .axel files, 
which then can be opened in AXEL.

When importing files in AXEL, a dialog opens and gives you the status of your imported file. 
For example, when importing a VRML file (.wrl), the dialog may inform you of several models 
that AXEL successfully imports, and perhaps certain proto information or events that it does not 
recognize and so skips.

Importers are individual files that are installed in the MindAvenue/AXEL folder, which can be 
updated. MindAvenue posts updates on their Web site so you can import files from the latest 
versions of these programs.

Sounds are imported though the Play Sound Reaction. For more information, see “Play Sound 
reaction” on page 427.
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Images are imported by adding Image textures. For more information, see “Adding image 
textures” on page 316.

Movies (including Flash .swf ) are imported by adding Movies. For more information, see 
“Adding movie textures” on page 317.

Importing EPS files
Importing files in the EPS (Encapsulated PostScript) format allows you to bring 2D curves from 
Adobe ® Illustrator ® into AXEL.

You can control how detailed the curves are on import by setting the Curve precision setting in 
the EPS import settings.

To import EPS files into AXEL:
1. Optionally, set the detail of imported curves by selecting EPS import settings in the Project 

Manager, then setting the Curve precision in the Parameter Editor.

2. Choose File > Import > Import EPS.

3. Navigate to an EPS file then click Open.

Note: When trying to create surfaces from certain EPS curves—for example from some irregular 
kinds of fonts—you may encounter inconsistent results. Try inverting your imported EPS curve, 
then creating the surface from the inverted curve. For more information, see “Inverting a curve” on 
page 189.
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Importing VRML files
Importing VRML (Virtual Reality Modeling Language) models allows you to create 3D models 
and animation in another application and bring them into AXEL to add interactivity or simply 
publish the models for the Web.

The models must be polygonal and imported as VRML 97. 

VRML1/94 files do not import and will cause errors, even though they have the same .wrl file 
extension. Therefore, you must convert your VRML 94 files to VRML 97 before import.

To import VRML files into AXEL:
1. Choose File > Import > Import VRML.

2. Navigate to a VRML file then click Open.

Imported elements through VRML
• Geometries, including the position, orientation and scale of objects. Some surfaces may be inverted 

on import, so either turn off the Single sided parameter for this surface’s geometry, of use the Model 
> Modify Surface > Invert command. For more information, see “Inverting surfaces” on page 
207.

• Textures: like all image textures in AXEL, are limited to 512 by 512 pixels, so if your VRML models 
have larger texture images they are simply skipped. Because VRML does not support texture per face, 
some 3D programs split objects with mutiple textures into separate objects when they export to 
VRML, one for each texture, then offset these slightly to give the illusion that the object is properly 
textured per face. These constructs are properly imported into AXEL, so if texture per face is crucial 
to your work, you might use this method.

• Color including materials, color, color per face, and color per point.

• Animation: Translation (Position) and Rotation animations of objects are imported. Their precise 
keys will appear in the Sequencer, and their animations will be separated to the corresponding 
categories in AXEL, and linked to the time sensor in the Interaction Editor. WebCams are imported 
with their animations intact.

• VRML lighting, including animation of lights.

• Groups.

Not imported:
• Events. 

• PROTO definitions.
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Importing LightWave 3D files 
You can import your LightWave object and scene files directly into AXELedge using the AXEL 
importer.

Since AXELedge is built to take advantage of the internet—its distribution method, capacity for 
interaction, and the continued reality of its limited bandwidth—AXELedge's priorities are 
different from LightWave, which is a dedicated 3D modeler/animator.

In general, this means that models imported into AXELedge should be simplified first within 
LightWave. This makes them much lighter for diffusion on the Web. You can add the rich 
interaction that AXELedge provides once objects are imported.

Typically, when a LightWave parameter does not exist in AXELedge, the parameter is ignored. 
For example, for color materials, the luminosity and reflection parameters from LightWave are 
discarded when a LightWave file is imported into AXELedge. 

Note: Because paths to texture files and Object files may be broken, you will be prompted to 
specify a new path for each of these files when AXELedge cannot locate them on import. 

To import LightWave Object files into AXEL:
In AXELedge, choose File > Import > Import LightWave, then select a LightWave object file 
(.lwo). 
The LightWave object is imported into AXEL and can be manipulated and animated using all 
the AXELedge tools. Its center is at the World origin.

To import LightWave Scene files into AXEL:
1. In AXELedge, choose File > Import > Import LightWave, then select a LightWave scene 

file (.lws). 

2. Clean up the elements in the imported scene. This could include deleting unnecessary lights, 
adjusting keys, and resetting objects’ centers.
You are now able to manipulate your imported models using all the AXELedge tools. 

Imported elements:
• Geometries: Object geometries are imported up to 256 points per polygon. Their position reference 

is imported as their center, where the first key for Scale, Rotation and Translation (SRT) for the object 
in LightWave defines the center’s SRT in AXELedge. Certain objects may be inverted when imported 
into AXELedge. You can either turn on double-sided for the object, which should fix the problem, or 
select the object and choose Model > Modify Surface > Invert. The second method may not work 
because only some of the object faces may be inverted, and AXELedge can only invert all the faces 
of an object simultaneously.

• Position, Orientation, Scale and Animations of objects, lights and cameras are imported.
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• Lights are imported from LightWave as follows:

Lights: 

• Precise keys for simple animation is imported. If keys from LightWave animations are less that 0.1 
seconds apart, they may be skipped in AXELedge, as AXELedge’s limit for recording keys is 
intervals of 0.1 seconds. Animations appear separately in the Sequencer and Interaction Editor, just 
like animations created within AXELedge. For example, if you animated a camera moving, rotating 
and zooming within LightWave, in AXELedge you would have three separate animations: a 
PlayAnim reaction translating the camera, a PlayAnim reaction rotating the camera, and a PlayAnim 
reaction decreasing the Vertical FOV angle, all linked to the Time sensor. 

• Motion Curves, Pre and Post behavior, behavior applied to incoming curves: AXELedge maps motion 
curve behavior from LightWave into the Interpolation and Extrapolation types that it uses as follows: 

Interpolation: 

LightWave max AXELedge 

Spot Spot

Point Point

Distant Directional

Linear Directional

Area Directional

LightWave AXELedge 

TCB Smooth 

Hermite "

Bezier 1 "

Bezier 2 "

Linear Linear 

Step Constant
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Extrapolation: 

• Path Animation: AXELedge imports Path Animation, plotting the path for the animated object as a 
curve in the viewports, along with tangency support. In AXEL, you can then manipulate the curve in 
order to adjust the animation, along with any of the other AXEL parameters that apply. 

• Basic Material information, including colors per face.

• Textures: AXELedge supports one texture per object, while LightWave supports textures per face. On 
import, then, AXELedge imports the texture if it is used in 50 % or more of the polygons of an object, 
then uses the most common texture on the object and applies it to the whole object. A work-around 
for objects that use multiple textures could be to divide this object in LightWave into multiple objects 
so you can apply one texture to each object before import into AXEL. AXELedge will not import 
image textures in formats not supported by AXELedge—a warning is given.

• Transparency: LightWave supports separate transparency values per face. AXELedge will apply the 
first transparency it finds on an object’s face uniformly for the whole object imported from 
LightWave. Unlike Texture conversion, then, even if just one face of an object from LightWave has 
transparency, on import the whole object uses this transparency value. 

• Rendering Modes: Quickshade and Realistic are imported to AXELedge as Shaded, and LightWave’s 
Wireframe rendering mode is imported to AXELedge in the Wireframe rendering style. 

• Target: In LightWave you can target an object with the Camera or lights. This in effect constrains its 
position and orientation to the object, but in LightWave you can still tilt—or in LightWave terms 
bank—the camera independently. In AXELedge, this bank is removed as the camera is direction 
constrained to the object. This is the same with lights. And as a result, some animations may need 
some tweaking once imported into AXELedge. 

• Groups: In LightWave, hierarchies are created using parents and children. AXELedge converts a 
parent and its children into a group, where the parent’s Position, Orientation and Scale parameters, as 
well as its animations, are applied to the group. The parent object becomes one of, and identical to, 
the objects of the group, along with what had formerly been its children. 

• Layers: Objects that are created from Layers are imported into AXELedge as separate objects. 
Objects that are created on the same layer in the LightWave Modeler are imported as one object into 
AXELedge; in other words, one geometry per layer is recognized as LightWave objects come into 

LightWave AXELedge 

Constant Constant 

Offset "

Linear "

Oscillate "

Reset "

Repeat Cycle
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AXELedge. For example, if you have a cube and a cone that are a few units from one another, and 
are on the same layer, they are imported as one object with a single center and geometry. Also, objects 
that are created by combining layers in LightWave using the Flatten Layers command, will be 
imported properly into AXELedge also as a single object. 

• Texture Projection is imported in AXELedge as follows: 

Texture projection

• LightWave primitives: Some of the more complex LightWave primitives, such as gears, may have to 
be switched to double-sided, and/or their coloring switched to Per surface, in order to appear properly. 

Not imported: 
• Shape animation 

• IK, skinning 

• Envelopes 

• Particles 

• Front texture projection 

• Polygons with more than 256 points 

• Textures and transparency per face, and material parameters besides basic color and texture formation

• Pivot feature

LightWave AXELedge 

Cylindrical Cylindrical 

Planar Planar

Spherical Cylindrical

Cubic Planar

UV UV projection is 
imported but with-
out a projector, so 
you cannot edit the 
projection within 
AXELedge.
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3ds max files through AXELpublisher
You can export your 3ds max content to the .axel format using AXELpublisher, a plug-in for 3ds 
Max. AXELpublisher is a separate plug-in located in your install directory. You can see its own 
internal help for instructions on how to use it, so here we just expand upon how 3ds models and 
animations exported with AXELpublisher will come into AXELedge.

Your exported .axel can then be opened and edited in AXELedge identical to other AXEL author 
files.

Since AXELedge is built to take advantage of the internet—its distribution method, capacity for 
interaction, and the continued reality of its limited bandwidth—AXELedge's priorities are 
different from 3ds max, which is a dedicated 3D modeler/animator.

In general, this means that models imported into AXELedge should be simplified first within 
3ds max. This makes them much lighter for diffusion on the Web. You can add the rich 
interaction that AXELedge provides once objects are imported.

Typically, when a 3ds max parameter does not exist in AXELedge, the parameter is ignored. For 
example, if you set a type of animation interpolation that doesn’t exist in AXEL, such as Noise 
or Bounce, the animation will not export to the AXEL file, although everything else that is 
applicable in AXEL imports. 

All of AXELpublisher’s features: navigation control and interaction, are imported into 
AXELedge—as these are all native AXEL behaviors.
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Note: AXELpublisher is just for the Windows versions of 3ds max, versions 3-5, as 3ds max is not 
available for the Macintosh. Files exported from 3ds max on PC, however, open on a Macintosh 
version of AXEL. 

Imported elements:
• Geometries, including Patches as Nurbs, are imported as meshes. Geometries are imported, with their 

modifiers, but modifier animations do not import; nor do spline geometry: see “Not imported and 
known limitations” on page 110 below. Number of polygons and points per polygon are at the AXEL 
limits, but importing very complex geometry is not recommended for Internet distribution anyhow.

You export your 3ds max files to the .axel format directly in 3ds max from this dialog.
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• Basic animation of Position, Rotation and Scale. These come in as the appropriate AXELedge 
animations into the Sequencer and the Interaction Editor linked to the Time sensor at the time 
referenced from the beginning of the Max scene.

• Basic color information, where the Diffuse color defines the object, along with some other basic 
material parameters. Color per vertex/point. 

• Only one texture per object will import, this being the most prominent texture of the object. You have 
to manually copy the texture into your AXELedge project folder’s Texture folder. 

• Groups and Hierarchies, including basic animation (Position, Rotation, Scale) are applied on the 
grouped/linked objects. Complex hierarchies import as nested groups—that is groups within 
groups—to mimic the original hierarchy.

• Lights, light colors and an approximation of fall-offs are imported. Target lights, which in AXELedge 
are essentially lights with direction constraints will come in but without the appropriate constraint. 
Therefore, you can just add a direction constraint between the light and object once inside AXEL. 
Lights are imported from 3ds max as follows:

Lights: 

Interpolation: 

Not imported and known limitations 
• Geometry created from splines

• Complex material and texture information except the basic Diffuse color and color per point and a 
single texture per object.

3ds max AXELedge 

Omni Point

Free Spotlight Spotlight

Target Spotlight “

Target Direction Directional

Direction Directional

3ds max AXELedge 

Bezier Smooth 

Linear Linear 
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• Point animation, so therefore any animated modifiers (freeform deformations that are animated) are 
not imported.

• Complex interpolation such as Noise or Spring

• IK and envelopes

• Constraints

• Particles

• Some geometrical primitives may cause your file to give an error message when exporting from 3ds 
max. In most cases, however, the file in question does export properly and can be opened in 
AXELedge.

Exporting
Export settings determine how your project appears as a Flash SWF Movie or linear Movie, is 
captured in still images, or is exported as a VRML97 World (.wrl).

You might use exported content because you wanted to combine your 3D AXEL work with other 
content in the Flash author or a VRML editor, or to use as linear movies—in the QuickTime, 
Animated GIF, or MPEG-4 format—that can then be composited or streamed over the Internet. 
Also, exported still images are static so you might use them for 3D backgrounds for your Web 
pages, to illustrate technical documentation or as thumbnails to introduce your 3D AXEL 
content. 

There are a couple of central differences between exporting and publishing: 

• Exported content is primarily a way to use and combine your AXEL content with other media 
formats, web-based or otherwise.

• Publishing can automatically embed the content in a web page.

• Generally, 3D content published to the AXELplayer and QuickTime includes all of AXEL’s 
interactive capabilities, while content exported as a VRML world is more limited in its interactivity, 
for example, or has none at all in the case of Flash, linear movies and images. 

For more information on publishing AXEL Stream files (.axs), AXEL projectors (.exe in 
Windows) and AXEL QuickTime Movies (.mov), see “Publishing” on page 555.
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All exporters have 2 common settings which can be toggled on/off: Confirm overwrite, which 
gives a warning dialog when exporting a file with a name that already exists; and Use default 
filename, which names all exported files with the name of the AXEL project filename, with the 
proper file extension added at the end.

In addition, when exporting Flash files, Images, and linear Movies, you can interactively control 
the time period or the individual frames that are exported in the Sequencer, by keying in times 
for the corresponding sequences under Export time control.

To display the Export settings in the Parameter Editor:
In the Project Manager, click Export Settings, then in the Parameter Editor choose Flash (SWF), 
Image, Movie or VRML 97.

To use/disable the default filename:
1. In the Project Manager, click Export settings.

2. In the Parameter Editor, toggle on/off Use default filename.
With this setting enabled, the name of your AXEL project—that is, the .axel file—is used for 
all export formats. It will be inputted to the name field of each format’s export settings, with 
the corresponding file extension. It also cannot be edited. Toggle it off again if you want to 
give different names to your exported files.

To show/hide the Export time control in the Sequencer:
1. Click the Display options button ( ) in the Sequencer.

2. Turn on/off Display Export track.
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When you turn on Display Export track, it is displayed as a sequence in the Sequencer. 
Expand it to see its three comprising sequences: Flash (SWF), Image and Movie.

To set export times interactively using the Export time control:
1. For Flash (SWF) or Movie, drag the first and last keys on their Export time control sequences 

to set beginning and end times. For Image, drag its key.
The times you set in Sequencer are inputted into the corresponding time fields in their Export 
settings.

2. For Movies, whether QuickTime, MPEG-4 or Animated GIF, you can add keys directly to 
the Movie sequence in order to export only specific frames. 
If you key in specific frames, the Frame rate setting is diasabled. To revert to exporting the 
whole time period, delete all the keys between the first and last key.
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AXEL Export Options Summary
All of the following files are generated using the original source AXEL Author file (.axel), so 
keep this file to regenerate and edit published content. All the following formats are cross-
platform.

Previewing exported files
When you export your AXEL content into different file formats, an Export dialog appears giving 
you the status of your files, including information about what was successfully exported. In this 
dialog, you have the option of previewing the file once it has been exported.

By default, the Preview button opens the exported file in QuickTime, but you can click the 

Preview In.. button ( ) and change the application used for previewing that particular 
file type.

To preview exported files:
1. Export your AXEL content to a file format using the File > Export command.

2. From the Export dialog, click Preview.
By default, your file opens in QuickTime with the settings you entered in the corresponding 
export settings. 

Name File Extension Plays With... Interaction in format?
Flash Movies .swf Flash Player (version 5 

or 6)
Exports linear Flash animation 
sequences.

Linear movie/
Animated Gaffs

.mov, .gif or 

.mp4
QuickTime Player (ver-
sion 5 or 6) or any appli-
cation that supports 
.mov or animated GIFs. 
Or any application that 
plays .mp4

Exports linear movies or animated GIFs 
without interaction.

Still images .jpeg, .gif, .png Not applicable-use still 
images as typical digital 
images.

Exports static images.

VRML Worlds .wrl VRML browser or 
application (version 97-
2)

Much of AXEL interaction is pre-
served—all that is applicable in VRML. 
Read the following section for deatils: 
“Features and current limitations of 
exported VRML content” on page 134
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3. You can then choose to preview your file in a different application, by clicking the Preview 
In... button ( ) then choosing an appropriate application.

Exporting Flash Movies
You can export your AXEL content as linear Flash .swf movies that will play directly in the 
Flash Player. 

The interactivity and rendering style will be limited. 

AXEL is a powerful tool for creating interactive vector 3D content. Some of these strengths can 
be applied to rendering linear vector 2D Flash animations (.swf) to post directly on web pages, 
or combine with other content and add interactivity in any Flash compatible authoring software.

Because AXEL’s Flash exporter flattens AXEL 3D vector objects into 2D vector Flash objects, 
creating many individual frames for animation and not taking advantage of the power of 
interpolation or tweening, you must use different strategies for the best results: a balance 
between visual complexity and keeping file size low. 

Combine AXEL’s rendering styles with settings for the Flash exporter that effect how color and 
polygons are treated on export, with organizing your content into separately exportable pieces, 
to composite into layers in the 2D world of Flash. For more information, see “AXEL content in 
Flash” on page 117.

Details of 
exported file.

Preview options
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To export a Flash .swf movie:
1. In the Project Manager, click Export Settings / Flash (SWF).

2. In the Parameter Editor, adjust the Export settings.

Note: If Use default filename is toggled on for Export settings, the exported .swf file uses the 
AXEL project name. If you want to use another name, moving up a level and toggle this setting off 
for the exporters. Also, do not use spaces in your .swf file name as it will not be recognized by 
JavaScript. You can use underscores instead.

3. Adjust your project to make it ready for exporting. This may include selecting certain lights, 
disabling textures, or making sure reactions are rendered by the Flash Exporter—removing 
reactions that are triggered by outside input from the web surfer. You may also want to toggle 
on/off the visibility of certain objects or groups to prepare for multiple layers in Flash. For 
more information, see “AXEL content in Flash” on page 117.

4. You have the option of setting the Start time and End time of the exported Flash movie 
interactively in the Sequencer. With Start to End selected for the Export mode in the Flash 

Name of the output .swf file. 
If Use default filename has 
been checked, the project’s 
name is used.

Frames per second of 
Flash content to 
export.

Dimensions of the 
Flash content to 
export.

Start/End time of your Flash 
content to export.

Disable ability to import 
movie into an authoring 
software.

Optimize exported 
.swf file. Takes longer 
to publish.

Exports only selected 
items and groups.

Sets how shaded objects are 
treated on export.

Sets how Wireframe objects 
are treated on export.

Limits colors in exported 
content.

Sets how the export 
time period is 
measured.
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export settings, drag the first and last key for the Flash seqence under Export time control in 
the Sequencer. 

If the Export time control is hidden, click the Display button in the Sequencer ( ), then 
choose Show Export time control.
The start and end time are reflected in the Flash export settings.

5. Choose File > Export > Flash (SWF).
The Flash Export dialog opens and tracks the conversion process frame by frame as your 
Flash content is generated. You can watch each frame being generated in the WebCam 
viewport.

A .swf Flash movie is created and saved to your project directory. To save to another location, 
use choose File > Export As > Flash (SWF).

Tip: Remember to save the project. If you want to edit the 3D content later on, you will need the 
AXEL project file (.axel) that was used to create it.

AXEL content in Flash
When you export Flash files from AXEL you create .swf files. 

Like other 3rd party software programs that export to Flash, the exported .swf file contains one 
layer with separate vector images for keyframe animation.
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A basic concern is file size. Because you are exporting vector images, it is not so much the 
dimensions (width & height) of the individual frames that affect file size, but more relevant is 
the number of frames exported, the quality and quantity of color and textures used, as well as 
the complexity of the geometry. For example, one setting in AXEL’s Flash Exporter affecting 
how shaded objects are exported, set to either Flat per face, Gradient per object or Gradient per 
face, either returns a smoother result in the case of the gradient choices, or creates a very faceted 
look with a smaller file size, in the case of Flat per face.

Visual considerations
Many properties and parameters within AXEL affect how exported Flash content looks and 
weighs, and these sometimes differ from how these same elements impact 3D AXEL content 
published to the AXELplayer or QuickTime. Lighting, complexity of geometry, and animation 
may significantly increase the exported Flash file size and download time, where in AXEL they 
had little effect. 

For example, a simple sphere, highly subdivided but still drawn from its geometry (for more 
information see “Example: How sphere geometry affects download time and performance” on 
page 590), moving across the screen due to two keys on a Position animation is extremely light 
when publishing AXEL 3D content. However in the case of the Flash content, each frame of the 
animation, with all the points and polygons, and how the light breaks upon the sphere, must be 
calculated.

Here, AXEL’s rendering styles, in combination with its Flash export settings, can help or hinder 
your exported content. The general rule is that for very curvaceous objects you can use AXEL’s 
Cartoon rendering style for your objects, which will result in a smaller file, while some 
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perception of depth is lost. You might accentuate the 3D look of the final result by animating the 
lighting as you would see the light break between the gradation of color.

The Shaded objects setting in the Flash Export settings defines how object’s using AXEL’s 
Shaded rendering style are treated on export. 

Depending on the complexity and nature of the geometry, different settings should be used for 
best results. As explained above, you probably would want to render characters and very 
curvaceous objects in Cartoon, where this settings is not used. If you wanted increased detail, 
you might choose Gradient per object for Shaded objects, which would apply a gradient to an 
entire object as if it were one single face. For more information, see “Shaded objects” on page 
125.

AXEL’s Cartoon rendering style, with its 
clear breaks between highlight, color, and 
ambient color, works well with characters 
exported to Flash.

SWF output.
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Another Shaded object export setting is Flat per face. This setting is inappropriate for a 
character, as every face on its body will be visible, the edges between the faces sharply defined. 
On the other hand, for architectural objects or machinery, a good result can be achieved.

You can use any combination of AXEL’s rendering styles, Shaded, Cartoon and Wireframe/
Custom Wireframe in the same exported Flash file, and the Flash export settings are applied to 
the objects accordingly. Although if you want to vary the Flash export settings for different 
objects in your project, for example, using different options for the Shaded objects setting, you 
can export multiple Flash animation sequences for each variation to combine later in Flash.

Textures in Flash
Textures applied onto objects in AXEL will be rendered to exported Flash content, including 
image and movie textures. However, the method AXEL uses, which is to color the actual points 
of the models according to their textures, means that objects have to be subdivided significantly 
for an accurate representation of the texture. 

This, coupled with the weight of actually coloring each point, means that the size of your Flash 
file could get too large to be useful. You may try using textures for patterns, using images or 
movies that can sustain a significant drop in detail and still add visually to the content. 3D 

© Copyright skidoo.com 2002

Although the faces are visible in the exported skidoo .swf file, the result 
remains appealing and realistic because of its initial geometrical composition.
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mapped textures and texture projection, used correctly, can add never before seen effects to 
Flash.

AXEL interactivity and animation applied to Flash:
None of AXEL’s native interaction is exported to the Flash (SWF) format, however many of 
AXEL’s relations, animations, and even interactive functions can be used to author your content, 
and then rendered into animated Flash files. There are many different strategies you could use:

• You could create an animated 3D button in AXEL. Then by setting the Flash export setting Export 
mode to Current time, export 4 single Flash frames, finally importing these into different states of 
your Flash button.

• AXELedge users can take advantage of Inverse Kinematics and bones (for more information, see 
“Modeling characters, and other uses of limbs” on page 213) to animate their characters, then export 
these characters to Flash. 

• Any animation or reaction that might have been triggered by a Web Surfer’s actions, like a Mouse 
click, can, for example, be switched to the TimeSensor and then will also be rendered. Any sensor 
that is triggered in the AXEL content itself, for example, a Proximity sensor that is triggered when 
two spheres are close enough to each other, would also be rendered, as long as these spheres move 
close enough on their own accord, for example by a PlayAnim linked to the TimeSensor. 

Subdivide the sphere for a clearer texture 
in the exported Flash content. Your file 
size will get significantly larger, 
however.
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In this way, you can repurpose content that you had previously built and published to the 
AXELplayer or QuickTime, by setting all the reactions to internal AXEL triggers.

Exporting mutiple .swf files for different Flash layers:
In Flash, when shapes overlap on the same layer they are cut. This makes it very hard to work. 
Therefore, a good strategy is to export individual AXEL linear animations as multiple .swf files, 
one file destined for each layer and/or different times in an interactive Flash movie. This process 
is similar to compositing many layers in film work, and has similarities to working with layers 
in photo retouching programs. The complexity—and interest—comes in translating 3D 
principles to the world of 2D layers. 

Because there is no real depth in the 2D Flash world, it has to be faked. 2D programs use layers 
for this, and using multi-frame animated AXEL 3D content organized into layers, even more 
compelling effects can be achieved, with some forethought. 

For example, say in your AXEL content you have the moon rotating around the earth, you could 
export this as a single Flash .swf movie, but this may limit you. The moon would literally cut 
into the earth as it orbits in front of it, and wouldn’t be rendered at all when it orbits in back of 
the earth. A more useful process, allowing you the most control to add interactivity in a Flash 
authoring environment, in this case, would be to export three Flash animations:

• The half orbit where the moon is in front of the earth.

• The half orbit where the moon is in back of the earth.

• The earth, where the light changes as the moon orbits around it.

Then, by layering these 3 animations in Flash, and making sure the keys for the second half of 
the orbit follow those for the first half, your animation would be totally accessible in Flash. You 
could then add interactivity using all of Flash’s tools.

A typical workflow for outputting AXEL content to different layers in Flash, follows.

To export AXEL content to different Flash layers:
1. Do one, or some combination, of the following to organize your content into separate 

portions ready to be rendered individually:
a) Group your content according to what will be imported to separate layers in Flash. This 

way, you can easily use the Export Selection only setting or toggle on/off the visibility of 
different groups as you export each portion destined for different layers.
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b) Organize your content successively, one animation after another, along the timeline. This 
way, you can set only a particular time period to export.

2. Depending on your strategy, multi-select the elements you want to export to a Flash layer. 
For groups, you only have to select the whole group—for example by clicking the group’s 
icon the Project Manager—not each individual member of the group.

3. Adjust other Flash Export settings. It may be a good idea to name your exported files 
sequentially, for example, to represent layer order.

4. Enable the export setting Export selection only.

5. Choose File > Export > Flash (SWF). 

6. You can preview your content by pressing the Preview button in the Export dialog. You may 
want to choose a browser, or the standalone Flash player for previewing, which you do by 
using the Preview In... button ( ), then selecting the application.

7. Repeat the process for each group or time period.

8. In Flash, create layers for each Flash .swf movie generated in AXEL and then use Flash’s File 
> Import command to drop an exported .swf file to each layer.
Now you can use all of Flash functions on your AXEL 3D content.

Export settings/Flash (SWF)
For the procedure to publish to Flash, see “Exporting Flash Movies” on page 115.

Output file Name of the output .swf file. Toggle off Use default filename for the Export settings 
if you want to use different names. By default, the file is exported to the current 
project folder. Use the Export As > Flash (SWF) command to choose a different 
location.

Width Width of the flash content to generate, in pixels.
Height Height of the flash content to generate, in pixels.

The Flash export time control sequence 
matches the animation to be exported.



124 | AXEL V2 | User Guide

Export mode Sets what time period will be used as the measure of exported frames:

• Current time: Exports a single Flash frame at the current time of your project.

• Start to End: Exports a Flash file for the time between Start time and End time of 
your AXEL project. These can be set interactively in the Sequencer in the Export 
time control.

Start time The beginning time of the generated content according to the AXEL timeline. For 
example, if the Frame rate is 20, and you set Start to 0 and End to 100 then your con-
tent will be a 5 seconds Flash animation file. This corresponds to the first key on the 
Flash (SWF) sequence for the Export time control in the Sequencer.

End time The ending time of the generated content corresponding to the AXEL timeline. This 
corresponds to the last key on the Flash (SWF) sequence for the Export time control 
in the Sequencer.

Frame rate Display rate of the Flash content to generate. In frames per second.
Number of 
frames

This non-editable setting indicates the number of frames that will be exported.

Enable selection 
only

Exports only the items, whether objects or groups, that are selected.
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Shaded objects • Flat per face: Uses flat rendering to achieve a faceted look. This produces the 
smallest file size, and is fine for geometrical objects like boxes. Although with 
curved objects, their individual faces will be apparent.

• Gradient per object: Creates a gradient on the whole object (merging its individual 
faces into one), so that a 3D look can be approximated in the Flash 2D 
environment. Produces a larger file size than Flat per face.

• Gradient per face: Creates a gradient on each face of the objects so that a 3D look 
can be approximated in the Flash 2D environment. Produces an even larger file 
size then Gradient per object.
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Colors per 
object

Sets the amount or value used to measure the amount of color to draw your AXEL 
objects in Flash. 

• All: Uses every color in the current AXEL content.

• Limited number: Uses a number value to set the maximum number of colors from 
the AXEL content generated to the .swf file.

• Limited percentage: uses a percentage of colors in the current AXEL content to 
output to the generated .swf file.

Color limit Depending on whether Limit number or Limit percentage is selected in the Color 
usage parameter, sets the maximum number of colors exported to the .swf file in 
number of colors or percentage of colors.
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Wireframe 
objects

Sets which lines of the wireframe mesh are rendered for objects in your project that 
use the Custom Wireframe rendering style.

• All lines

• No hidden lines

• Outline

Optimize file 
size

When this option is on, the exporter will do its best to reduce the file size of the Flash 
content. Using this option may take more time to render, so it is probably better to 
turn it on only when you are ready to generate your final content.
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Exporting Images
AXEL uses the QuickTime compressor to generate JPG, GIF or PNG images from the active 
viewport.You may be prompted to do a full install of QuickTime. Make sure you select 
"Recommended" for installation type so that you get the QuickTime compressor.

To export an image: 
1. In AXEL, go to the point in time of your animation that you want to publish, and click a 

viewport to make it active.

2. In the Project Manager, expand Export Settings/Image, and adjust the settings in the 
Parameter Editor:

3. You have the option of interactively setting the time when the image will be generated by 
dragging the Image key under the Export time control bar in the Sequencer.

4. Choose File > Export > Image.
The image file is created from either the current time or a specific time in the Export settings 
and reflected on the Image sequence in the Export time control in the Sequencer. By default 

Protect from 
import

Allows the user to protect their Flash content either using a password, or with no 
password at all (in which case no one will be able to import the Flash file into an 
authoring software, not even the Author).

File name of the image. 
Uses the project name 
unless you toggle off Use 
default filename. Dimensions 

in pixels of 
the image. 

JPEG compression quality. Image format: 
JPEG, GIF or 
PNG.

Exports at either the 
current time, or a a 
specific Export time that 
can be set in the 
Sequencer.

Export time can 
also be set 
interactively in 
sequencer.

Note: The GIF format also includes an Interlacing setting. For 
more information, see “Interlacing (GIF)” on page 130.
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the file is saved in the current project folder. To choose a different location, use the File > 
Export As > Image command.

Tip: You can create your own 3D textures right in AXEL by exporting images, then applying 
them as Image textures using the Visualize > Add Image Texture command.

Export settings/Image
For the procedure to publish still images from your AXEL content, see “Exporting Images” on 
page 128.

Image file File name of the image file. It uses the project filename by default, which you can 
change by toggling off the Use default filename for the Export settings. By default, 
the file is exported to the current project folder. Use the Export As > Image com-
mand to choose a different location.

Width Width in pixels of the image.
Height Height in pixels of the image.
Export mode Sets what time period will be used as the measure of exported frames:

• Current time: Exports a still at the current time of your project.

• Specific time: Exports a still at the specified time in Export time.
Export time When choosing Specific time for Export mode, this is the point on the AXEL time-

line when the exported still is generated. 
You can interactively set the time of the exported still by dragging the Image key 
under the Export time control bar in the Sequencer.

Format Image file type: JPEG, GIF, or PNG.
Quality (JPEG) JPEG compression quality.

A 3D image created and exported from AXEL 
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Exporting linear Movies
Besides publishing AXEL QuickTime Movies that avail themselves of all of AXEL’s interactive 
capabilities (see “Publishing AXEL QuickTime Movies” on page 563), you can also export 
regular QuickTime movies, MPEG-4 movies, or Animated GIFs that includes all of AXEL’s 
linear animation—that is, animation triggered by the TimeSensor, Proximity, Parameter 
Change/Range, Custom or other sensors not reliant on any outside input from the Web Surfer. 

These movies play like traditional linear movies, and need no other software besides a 
QuickTime, MPEG-4 or GIF compatible application to play. For example, you can make 3D 
Animated GIFs to use as buttons on web pages with no plug-in required.

You can also use these movies as movie textures within AXEL, to create such interesting effects 
as reflections, or 3D galleries of your projects that you can navigate through, perhaps with a 
virtual character.

To export a movie: 
1. In the Project Manager, expand Export Settings/Movie, and adjust the settings in the 

Parameter Editor.

Interlacing 
(GIF)

For GIF export, makes the image interlaced, which is a method for encoding the 
image so that it loads on-screen line by line, and so slightly faster. Non-interlaced 
pictures load by color.

Name of the output movie 
file. If Use default filename 
has been checked, the 
project’s name is used.

Frames per second of 
the Movie to export.

Dimensions of the 
Movie to export, in 
pixels.

Start/End time of your 
Movie to export.

Sets how the export 
time period is 
measured.

Note: Other movie formats, Animated GIF and MPEG-4, include other export 
settings. For more information, see “Export settings/Movie” on page 131.

QuickTime JPEG 
compression quality.

Movie format: 
QuickTime JPEG 
or PNG, MPEG-4 
or Animated GIF.
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2. You can do one of the following: 

• Interactively set the in and out points for the generated movie by dragging the Movie arrows 
under the Export time control bar in the Sequencer. 

• You can also manually key in specific points on the Movie export sequence by selecting the 
Movie sequence in the Sequencer, moving the playhead to the desired time, then add keys 
( ). Only these keyed-in frames, then, are exported, and are reflected in the Number of 
frames setting in the Movie export settings. 
The Frame rate setting is no longer used when you key in individual frames. 

3. Choose File > Export > Movie.
The Movie is saved to your project directory by default. Use the File > Export As > Movie 
command to choose a different location.

Export settings/Movie
For the procedure to export (linear) Movies see “Exporting linear Movies” on page 130.

MPEG-4 Movies have an extra set of settings that pop-up in a separate dialog when you choose 
MPEG-4 for the Movie format. These settings help you to take advantage of the powerful 
compression and streaming functions of MPEG-4.

Export settings/Movie

Movie file The name of the movie to be exported. By default, the file is exported to the current 
project folder. Use the Export As > Movie command to choose a different loca-
tion.

Expand the drop-down to see the 5 
sets of MPEG-4 export settings: 

• General

• Video

• Audio

• Steaming

• Compatibility
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Exporting VRML Worlds
Use the VRML Exporter to create VRML2/97 files from your AXEL content. VRML has certain 
benefits, including built in collision detection between the web surfer—called an Avatar in 
VRML—as well as a default navigation system. These aspects make it a useful format, for 
example, for creating walk-throughs. 

Some of AXEL’s unique functions, including some sensors, reactions and constraints, are 
exported to VRML, boosting VRML as a medium for interaction. Is is recommended to got 
through the following section to see how AXEL content is treated when exported as a VRML 
World: “Features and current limitations of exported VRML content” on page 134.

Width The width of the exported movie, in pixels.
Height The height of the exported movie, in pixels.
Export mode Sets what time period will be used as the measure of exported frames:

• Current time: Exports a still at the current time of your project.

• Start to End: Exports frames from the Start time to the End time at the Frame rate 
specified.

Start time The in point of the exported movie.
End time The out point of the exported movie.
Frame rate Frames per second to export.
Number of 
frames

Total number of frames to export; A multiple of the frame rate by the time period 
between the start time and end time.

Format Format to export to. Either QuickTime JPEG (.mov), QuickTime PNG (.mov), 
MPEG-4 (.mp4) or Animated GIF (.gif).

Quality (JPEG) For the QuickTime JPEG format, sets the quality of the exported movie. In descend-
ing order of quality: Lossless, High, Medium, Low. The lower the quality of movie 
the smaller the file.

Animation 
cycling (GIF)

Sets what happens to the Animated GIF once it is played through:

• Off: There is no cycling so the Animated GIF plays through once and then stops.

• On: Cycling is enabled, so the Animated GIF plays through from beginning to end 
the number of times specified in the Number of cycles setting.

• Infinite: The Animated GIF plays from beginning to end continuously.
Number of 
cycles (GIF)

When On is selected for the Animation cycling setting, this sets the number of times 
that the Animated GIF plays through from beginning to end.
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To create VRML Worlds:
1. Adjust your VRML export settings.

2. Choose File > Export > VRML 97.
A VRML2/97 file is created from your AXEL content with the file extension .wrl. Because 
the Virtual Reality Modeling Language differs from the AXEL authoring environment, your 
generated VRML content is subject to the features and limitations outlined below.

Features and current limitations of exported VRML content

MODELING
• Curves are exported as if the Steps parameter was set to 0.

• Surfaces and 3D Text: geometries are exported as IndexedFaceSet. Surface parameters are not 
exported therefore they cannot be animated in the interactive content.

• Geometric deformations: bend, push, skin, wave, shape mixing can be used for authoring the 
geometry, but they cannot be used in the interactive content. 

• The following modeling features are not supported:

• Visible: all your models will be visible in your VRML file, regardless of the state of their 
visible parameter in AXEL. You can turn off the Export invisible objects parameter in 
the VRML97 Export settings and your invisible objects simply won’t be exported.

Include interaction in 
exported file.

VRML file to export. Toggle 
off Use default filename in 
Export settings to set a 
different name.

The radius around 
sounds are heard, as 
measured from 0 0 0.

Include objects that have their 
visibility parameter toggled off.
Radius of the avatar, the 
representation of the Web 
Surfer. Height of the avatar, 

the representation of 
the Web Surfer.

Knee height of avatar.

Includes a headlight to 
light the of the avatar.

Include these navigation 
possibilities. Similar to AXEL’s Far 

plane distance on 
WebCams, limits how 
far the avatar sees.

Speed the Avatar travels 
through the scene.
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• Antialiasing 

• 2D Text 

• Limbs/bones/IK 

RELATIONS
• Only the following constraints are supported:

• Pose constraint

• Distance constraint

• Direction constraint

• Constraint mixing is not supported.

• Groups are supported. Groups are implemented as a hierarchy of Transform nodes. Both animation 
and supported constraints work on grouped objects, including groups within groups.

VISUALISATION
• Shaded materials are supported but not all of the advanced color model parameters will be exported 

to VRML. Coloring per point and coloring per face are supported.

• Toon and Wireframe materials are not supported.

• Textures are supported with the following exceptions:

• Environment mapping is not supported. 

• Not all texture blending methods are supported by VRML. 

• Not all image formats are supported by VRML (depend on browser). 

• Not all movie formats are supported by VRML (may depend on browser). 

• Lights are supported with the following exceptions:

• Not all light colors can be exported to VRML.

• Animation of directional lights’ orientation is not supported. 

• Cameras are supported with the following exceptions:

• Orthogonal projection is not supported. 

• Near and far clipping planes are automatically adjusted by VRML. 

• AXEL vertical FOV is not correctly translated to VRML FOV. 

• Cartoon and Custom Wireframe Rendering styles (all objects rendered in Shaded) are 
not supported.
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• Antialiasing is not supported.

• Clipbox is not supported.

ANIMATION
• Shape animation.

• Key-framed animation of Position, Orientation and Scale is supported with the following exceptions: 

• Interpolation is always linear. 

• Additive mode not supported. 

• Animation mixing (e.g. two animations on the position of one object ) is not supported. 

• Orientation interpolation with very few keys is not always exported correctly to VRML. 
The work around is to make angular distance between keys less that 180 degrees.

• Animation of directional lights orientation is not supported. 

• The following animations are not supported:

• Key-framed animation of any parameter besides Position, Orientation and Scale.

• Path animation.

• Particles and obstacles.

SENSORS
• Time Sensors are supported

• Time Pulse Sensors are supported

• Proximity Sensor are supported

• Mouse Sensors are supported with the following exceptions: 

• Only left mouse button is supported. 

• The following sensors are not supported:

• Position/Orientation Sensors

• Parameter change/range Sensors

• Download Sensor 

• Refresh Rate Sensor 

• Keyboard Sensors 

• Custom Sensors 
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REACTIONS
• Play Animation, Play Sound and Play Movie reactions are supported with the following exceptions: 

• Volume not supported for Play Movie reaction.

• See the limitations for ANIMATION which will affect the PlayAnim reactions.

• Switch WebCam, Switch Material, and Switch Geometry Reactions are exported.

• Set Position/Orientation/Scale are exported

• Reaction Groups are exported.

• The following reactions are not supported:

• Set/Toggle Parameter Reactions 

• Tooltip text 

• Hyperlink/Download/Call JavaScript Reactions 

• Control/Goto Time Reactions 

• Custom Reactions 

• Roll-Over Reaction 

HANDLES
• Handles are not supported.

Links
• Links are supported in the following way:

• All trigger modes are exported (Start, Stop, Activate, and Deactivate).

• Expiry Count, Time delay, and Repeat Delay are exported.

• Modifier keys, Start Mode and Stop Mode are not exported.

WEB INTEGRATION
• The following is not supported:

• Exporting web parameters

• Exporting reaction triggers

• Streaming control of geometry, sounds and textures
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VRML Examples
Exporting VRML provides many new ways and directions your AXEL projects can take. There 
is a wide installed user base of VRML browers and players. You can even embed VRML files 
generated by AXEL in some spreadsheets, presentations, and other programs that accept VRML 
objects.

Refer to the “Features and current limitations of exported VRML content” on page 134 to see 
how to properly construct content for VRML playback. Here are two examples showcasing how 
to use some unique AXEL and VRML features. 

The third example shows you a little bit about how VRML files (.wrl) are accessible as text files 
that can be edited by advanced users.

Example: Setting precise viewpoints for a VRML Church
In VRML, you have numerous controls and settings that control how your scene is negotiated 
by Web Surfers on the Internet. Essentially, VRML scenes are constructed to be Worlds, that is, 
to mimic physical places that can be explored. 

For this, you need to have control over how your “Avatar”—the virtual representation of the 
Web Surfer—moves about in the scene. For the following example, the Avatar knee height is set 
to .75, its height to 1.60 and radius to 0.25, so that the Avatar negotiates the Church correctly, 
especially as it travels in between the Church’s pews.
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Also, 3 WebCams were added and positioned into 3 specific locations: View from a pew, Aisle 
View, and Second Floor View. In VRML browsers you can cycle through these views by 
pressing on buttons, which may be called view or viewpoint depending on the browser. 

Set specific views for different WebCams, and the Web Surfer can cycle through them in a VRML browser. 
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Example: Automatic collision detection, animation/reactions and movie textures in 
VRML
The following theatre, including interaction, is totally constructed within AXEL, then exported 
to VRML. Notice the following:

VRML97 Export 
settings control 
what navigation 
types are enabled, 
and how your 
Avatar negotiates 
the scene.

WebCams are directly converted into Viewpoints, as seen here in Cortona 
4.0, a free VRML browser from Parrallel Graphics. Web Surfers can then 
cycle through these precise views that you had set first in AXEL.

AXS/Church.wrl
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• WebCam’s are converted to Viewpoints.

When you select a viewpoint, you always start at 
the initial position as set by the WebCam in AXEL, 
even if you had previously navigated around from 
that viewpoint. So the viewpoints are static, 
making them very useful for controlling how a 
Web Surfer encounters the space you set up.
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• The avatar settings are set in AXEL’s VRML export settings to properly negotiate the stairs, and walk 
through (and over) the isles of theatre seats.

• The reactions on the remote control that open the theatre’s curtains (Shape animation), and plays the 
movie of the surgeons (PlayMovie), are properly converted to the VRML file (.wrl). In the VRML 
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file you click the remote to interact just as you would within an AXEL Stream file (.axs) or AXEL 
QuickTime movie (.mov).

• Image and Movie textures, and sounds, are copied accordingly to textures and sounds folders relative 
to where the VRML file (.wrl) is exported to. Remember to keep these files in the same relative 
position to the VRML file on your server, as their relative location is written to the file. For more 
information, see the next section.

• The .wrl file that AXEL generates is written as a text file that can be opened in a text editor 
and edited like any other VRML file. This can be useful for advanced users. the next 
section.

Example: VRML files in a text editor, Proto information and paths
You can open up your exported VRML Worlds in any text editor. Advanced users can edit the 
text file directly. 

The interactive AXEL content 
in a VRML browser.

Interaction that is properly exported 
to VRML. Make sure you check with 
“Features and current limitations of 
exported VRML content” on page 
134 to verify that your interaction 
works in VRML.
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Textures and sounds are linked to the VRML file using relative paths to Textures and Sounds in 
the Project directory. You can edit these paths in the VRML text file, for example, to give 
absolute paths so your textures and sounds can reside anywhere on the Internet and be 
dynamically updated.

Depending on whether the Export interaction setting is enabled in the VRML export settings, 
your exported file is written in a different way. With this setting enabled, the interaction is 
written to the .wrl file as Proto definitions at the beginning of the file. Otherwise, any animation 

Relative path to a texture used 
in the VRML file.

VRML file exported from AXEL in a text editor.
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(PlayAnim reactions) is written within the body of the file and must be hooked up 
independently.

Two VRML theatres, one with 
Export interaction enabled, the 
other without it.

With Export interaction enabled, 
the interaction is written as Proto 
definitions at the beginning of the 
.wrl file, and the actual scene 
information starts later on.
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Export settings/VRML 97
For the procedure to create VRML files, see “Exporting VRML Worlds” on page 133.

VRML file The name of the VRML file that is exported. By default, the file is exported to the 
current project folder. Use the Export As > VRML97 command to choose a dif-
ferent location.

With Export interaction disabled, 
the scene information starts at the 
beginning of the .wrl file, while 
animations are not connected, and 
are written within the body of the 
file.
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Export interac-
tion

Use Export interaction to include all of the AXEL interaction that can be exported to 
VRML. 
For more information, see “Example: VRML files in a text editor, Proto information 
and paths” on page 143.
Toggle this setting off to only export static geometry and textures and linear anima-
tions (which have to be manually connected), for example, in order to work on your 
AXEL models in a dedicated modeling software that can use VRML as an import 
format.

Export invisible 
objects

Include objects that are invisible in your exported project—that is, that have their 
visibility parameter turned off.

Sound radius Sets the radius around the content where sounds will be heard. All sounds are 
exported to VRML worlds at 0 0 0.

Avatar radius Sets the radius around your Avatar that is imported for collision detection as you 
roam around the exported VRML World.

Avatar height Sets the height of your Avatar that is imported for collision detection as you roam 
around the exported VRML World.

Avatar knee 
height

Sets the knee height of your Avatar that is imported for collision detection as you 
roam around the exported VRML World.

Avatar speed Sets the speed the Avatar moves as it roam around the exported VRML World.
Headlight The Headlight aims a directional light in the direction the Avatar is looking. 
Walk Turns on the VRML walk function so users can simulate walking through the 

exported VRML World.
Fly Turns on the VRML fly function so users can simulate flying through the exported 

VRML World.
Examine Turns on the VRML examine function so users can quickly zoom in and examine a 

detail of the exported VRML World.
Visibility limit Acts similar to AXEL’s Far plane distance parameter on a WebCam, in that, this is 

the distance that your objects disappear from view as your Avatar moves away.



 Chapter 3 | Projects & Import/Export | 147



148 | AXEL V2 | User Guide



 Chapter 4 | Modeling | 151

Chapter 4
Modeling

Learn the techniques of modeling 3D objects in 
AXEL.

Start with a brief overview of 3D space and how it is 
handled in AXEL.

Then progress to drawing and modifying curves, 
then using these curves to create 3D surfaces with 
extrusions and revolutions, or creating your 3D 
objects by combining and modifying pre-set 3D 
surfaces.

For AXELedge users, see how to create characters 
using limbs and skin.

Finally, see how text can be pushed into the 3D 
world in AXEL.

In this chapter:

About 3D space ................... 152

Selection .............................. 156

Manipulation ....................... 164

Instancing and duplicating 
objects ................................. 176

Creating curves ................... 178

Modifying curves ................ 185

Creating surfaces ................. 190

Modifying surfaces ............. 204

Modeling characters, and other 
uses of limbs ........ 213 

Text ....................227
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About 3D space
Virtual 3D space simulates real life. Just as a contractor’s plans contain the spatial information 
needed to build a house, AXEL 3D projects contains the information needed to correctly display 
your objects in 3D space.

3D software is based on a cartesian coordinate system, named after the French mathematician 
and philosopher, Descartes. He devised a numerical system to quantify the position of objects 
in 3D space, using the X, Y, and Z axes.

Whereas a 2D image uses width (X) and height (Y), 3D adds a third axis, depth (Z). So any 
location can be described by a series of three numbers (X, Y, Z). If you instruct movers to put 
your couch on the west side of your house, on the second floor and in the back, you have 
described 3D coordinates. 

At the World origin, the coordinates are (0,0,0). As you move away from the center, the X, Y, 
and Z values vary as follows:

• X increases toward the right.

• Y increases toward the top.

• Z increases toward the front.
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Global and Local Coordinates, Centers
Red, green, and blue axes appear on each object you create in AXEL. The axes originate at the 
center of the object, and so are referred to collectively as the center of the object. The direction 
of the axes indicates the orientation of the object, while the point where the three axis converge 
indicates the position of the object.

Global coordinates refer to the AXEL World view, which is the center of the World. That is, the 
X Y Z axes are always identical references for all objects in the World.

Local coordinates refer to an object's center. They are identical when you create an object, but 
if you rotate it, the local axes change to reflect the new orientation. You can also manipulate the 
axes of an object—its center—independently of the object itself, changing the orientation of an 
object vis-à-vis its own local axes.

As well, you can change the position of the object vis-à-vis its own center, in which case the 
object’s XYZ numeric coordinates are actually that of the center. People from a 2D background, 
then, might think of an object’s center as the equivalent of its registration point.

X=Red 
Y=Green 
Z=Blue

The house’s center has been translated to position 4 3 0, so 
AXEL considers this XYZ value the house’s position.
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In the following illustrations, the global axes appear in the lower left of each image. The axes 
on the Eiffel tower represent its local axes.

Global axes Local axes Object scaled along its local Y axis

Global axes Local axes rotated 
90 degrees clockwise

Object scaled along its local Y axis
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About objects
AXEL uses points to define the geometry of an object. Points that form a closed plane become 
a face. The number of points is also an indicator of the weight of an object, that is, the amount 
of data required to define it.

Every point has a position defined by three values (X Y Z). The first value is the distance from 
the point to the object’s center—its local origin. The second value is the distance from the point 
to the object’s center along the Y axis. The third is the distance along the Z axis to the object’s 
center.

In the following illustration, the center of the shape is in the center of the World, so the XYZ 
values of each of the points correspond to their respective distances from the World origin. If 
you were to move the center of the object, therefore, the coordinates of the points would change 

FacePoint Centers
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while the object remains stationary vis-à-vis the grid (which is referenced from the World 
origin).

Selection
Any object that appears in your World can be selected with the Select tool. Selecting highlights 
an object so that it can be manipulated in order to change its position, orientation or size. 

You select a tool mode to specify what type of data you want to manipulate. You can select 
objects as a whole, the individual points which define the object, or the object’s center. There 
are visual cues in the viewports to help you with your selections, for example, points on curves 
and surfaces appear as different colors depending on several factors. For more information, see 
“Point colors for visual cues in viewports” on page 162.

You can use the Translate, Rotate and Scale tools with the Select tool turned on. Do this when 
you are working with many objects. If you want to work only with one object and not select 
another by mistake, turn off the Select tool. This locks that object as selected. You can then click 
and drag anywhere to manipulate the object, or change between these three tools without having 
to re-select the object. 

Selecting a tool mode
To work with an object, its points or its center, you first select a tool mode. You then manipulate 
it in the viewports.

In the second picture, the center of the object is translated to its top corner, so the position of this top point 
becomes 0, 0, 0. All other point positions are similarly updated, referenced from the new position of the center.
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In the following illustration, six points are translated in Point mode to change the shape of the 
vase. 

Selected points
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To select a tool mode:
Do one of the following:

• Press one of the following keyboard shortcuts:

• To toggle between Object mode and Point mode, double-click an object.

• In Windows, select a mode from the top toolbar.

• On the Macintosh, select a mode from the toolbox.

Each tool mode is reflected in the top right corner of the cursor.

Selecting objects, points and centers
You can select objects in the viewports or the Project Manager. Selected objects are highlighted 
in the viewports and the Project Manager. When you select a single object, its parameters appear 

O Object mode

P Point mode

J Center mode

The Selection tool cursor when you are in Point mode.

The Translate tool cursor in all three modes.

The Rotate tool cursor when you are in Center mode.
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in the Parameter Editor. When you select multiple objects, their common parameters appear in 
the Parameter Editor.

Parameters can only be selected in the Project Manager or Parameter Editor.

To select objects in the viewports:
1. Select Object ( ) from the top toolbar (Windows) or the toolbox (Macintosh).

2. Turn on the Select tool ( ). A manipulation tool ( ) may also be on as long as 
the Select tool is on. 

3. To select a single object, click it or drag a rectangular marquee around it. 

4. To multi-select objects, SHIFT-click each one or drag a rectangular marquee around them.
As long as part of the object is inside the marquee, the object is selected.

5. To add objects to the selection, hold SHIFT and drag a rectangular marquee around the object 
that you want to add.

6. To remove objects from the selection, hold CTRL (Windows) or COMMAND (Macintosh) and 
drag a rectangular marquee around the objects that you want to remove from the selection. 
The CTRL (Windows) and COMMAND (Macintosh) keys toggle the selection.

To select objects using the Project Manager:
1. Click an object to select it.

2. SHIFT-click an object to add it to your selection. CTRL-click (Windows) or COMMAND-click 
(Macintosh) objects to toggle them between selected and not selected.

3. On the Macintosh, you can select a range of objects in the Project Manager by clicking the 
first one, then SHIFT-clicking the last. You can also rectangle select a range in the Project 
Manager.
Selected objects are highlighted in the viewports and in the Project Manager.

To select nothing:
Do one of the following:

Selecting the cup Selecting the cup 
and saucer



160 | AXEL V2 | User Guide

• Turn on the Select tool (with or without the Translate, Scale or Rotate tool) and click an empty part 
of a viewport.

• Hold S and click an empty part of a viewport.

• Choose Edit > Unselect All.
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To select all the objects in the World:
Do one of the following:

• Choose Edit > Select All.

• In Windows, press CTRL+A

• On the Macintosh, press COMMAND+A.

To select points on an object:
1. Select the object in Object mode.

2. Switch to Point mode ( ).

3. Turn on the Select tool (with or without the Translate, Scale or Rotate tool) or press S. 

4. Select points by doing one of the following:

• SHIFT-click a point to add it to your selection. CTRL-click (Windows) or COMMAND-click 
(Macintosh) points to toggle them between selected and not selected.

The selected points are highlighted.

• Drag a rectangular marquee around the point(s) you want to select. 
The selected points are highlighted. To select more points, hold SHIFT and drag a rectangular 
marquee around the points you want to add to the selection.

5. To remove points from the selection, hold CTRL (Windows) or COMMAND (Macintosh) and 
drag a rectangular marquee around the points that you want to remove. You can also CTRL-
click (Windows) or COMMAND-click (Macintosh) individual points to toggle them off.

To select a group:
Do one of the following:

• In the Project Manager, select the group.

• In a viewport, select an object in the group, then hold ALT (Windows) or OPTION (Macintosh) and 
click the object again.
The group is selected. If the group is nested in another group, hold ALT (Windows) or 
OPTION (Macintosh) and click the object again to select the larger group, and so on. 

For more information, see “Using groups” on page 257.

For more information on groups, see “Using groups” on page 257.
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To select an object’s or a group’s center:
1. Select the object or the group in Object mode.

2. Switch to Center mode ( ).
The axes that are visible in the viewports are the object’s or group’s center. An object’s center 
is usually at the center of the object until it is manipulated. Objects created from revolutions 
and extrusions as well as groups’ centers are at the World origin until these objects’ or 
groups’ centers are manipulated. Similarly, imported objects’ centers can be at the World 
origin when they first come into AXEL, depending on what format they are imported from.

Point colors for visual cues in viewports
In Point mode, you see the points for curves and surfaces of selected objects in the viewports. 
The points are different colors to signify different meanings as follows:

• Blue: regular points for an object in Point mode. The points that appear in blue are not themselves 
selected.

• Orange: points that are selected on an object. This signifies they are selected and active for 
manipulations.

• Red: when a curve or object is instanced, the instances’ points are red instead of orange when selected. 
The original instance’s points remain orange when selected.

• Green: only for curves, this connotes the starting point, or first point of a curve. This is especially 
important, for example, for Path Animation, to see where the object will start moving on the path, or 
for curve constraints that reference the point number or percentage along the curve starting from the 
first point.

• Magenta: only for curves, this connotes the end point, or last point of a curve. This is especially 
important, for example, for Path Animation, to see when the object ends its movement along the path, 
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or for curve constraints that reference the point number or percentage along the curve ending at the 
last point.

• White: only for curves, this connotes the first (and last) point of a curve when the curve is closed. This 
is especially important, for example, for Path Animation, to see when the object begins and ends its 
movement along the path, or for curve constraints that reference the point number or percentage along 
the curve beginning and ending at this joining point.

First and last points on a curve. Points are red on the instance of the original 
and all subsequent instances.

The white points are where the curves are closed—both the 
first and last point for each object.
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• Yellow: points that are selected individually in the Project Manager or Parameter Editor. You can edit 
the values of these points in the editors, but you will have to actually select them in the viewports (so 
that they are orange) in order to manipulate them directly there.

Manipulation
Manipulations, also known as transforms, are the three common operations used to modify 
objects:

• Use Translation to change position. 

• Use Rotation to change orientation.

• Use Scale to change size. 
The following tools and shortcuts make it easy to manipulate objects, points and centers:

Manipulation keyboard shortcuts

Tip: After pressing one of these keyboard shortcuts, you can then toggle the Select tool on/off by 
pressing S so your object is locked for manipulation.

E Scale

R Rotate

T Translate
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Manipulating along local axes
You can manipulate an object along one of its local axes by pressing an X, Y or Z axis button, 
or by choosing an axis from the Edit menu. You can also use mouse and keyboard buttons in 
combination with the SHIFT key.
Using the SHIFT key always overrides your axis choice in the Edit menu and the toolbar 
(Windows) or toolbox (Macintosh).
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To select local axes for a manipulation:
Click the X, Y or Z button, or choose Edit > Manipulation Options, then choose an axis. 

In Windows, you can also manipulate an object along its local axes by holding SHIFT and using 
one of the mouse buttons:

On the Macintosh, you can also manipulate an object along its local axes by holding SHIFT and 
using the following buttons:

Manipulating along global axes
You can use the construction viewports to manipulate objects along the global axis. For more 
information, see “Translating objects” on page 168 and “Rotating objects” on page 169.

Note: You can only scale objects along their local axis.

Nudge arrows
With an object selected and the Translate tool turned on, press an ARROW key to nudge the 
object four pixels in the direction of the arrow. To nudge in smaller increments, zoom in. To 
nudge in larger increments, zoom out.

Snap to grid
When translating, enable Snap to Grid to make it easier to align objects.

To snap to grid:
For one viewport, click on the viewport and choose View > Active Viewport > Enable Snap 
to Grid. For all viewports, choose View > All Viewports > Enable Snap to Grid or press 
SHIFT+H.
For more information, see “Using a reference grid” on page 55.”

SHIFT + left mouse button Manipulates along the object’s X axis
SHIFT + middle mouse button Manipulates along the object’s Y axis
SHIFT + right mouse button Manipulates along the object’s Z axis

SHIFT + mouse button Manipulates along the object’s X axis
SHIFT+OPTION+mouse button Manipulates along the object’s Y axis
SHIFT+CONTROL+mouse button Manipulates along the object’s Z axis
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Manipulation cursors
To manipulate objects, the edge of the object must be inside the square next to the cursor. To 
manipulate points, one of the points must be inside the square next to the cursor. 

Showing or hiding objects
It is often useful to hide objects while working on other objects. 

To show (or hide) an object in the viewports:
Select the object, then turn on (or off) Visible in the Parameter Editor. 
You can also hide many objects at once by multi-selecting them and then turning off Visible in 
the Parameter Editor or by turning off a group’s Visible parameter.

To show all the objects in your World:
Choose Edit > Unhide All.

Turn off Visible 
to hide objects
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Translating objects
Use the Translate tool to move an object, point, or center. You can also move an item by 
changing its position coordinates in the Parameter Editor. Number values are in grid units.

By default, translation is viewport-based, that is, objects move in the plane of the viewport in 
which you drag them. You can translate objects along their local axes holding the SHIFT key, by 
turning on a manipulation axis from the Edit menu, or by pressing an X, Y or Z button on the 
toolbar (Windows) or in the toolbox (Macintosh).

If there are several objects next to each other, it can be difficult to select and translate the correct 
one. In this case, select the object in the Project Manager and turn on the Translate tool, then 
toggle off the Select tool to lock the selection.

To translate objects using the mouse:
1. Switch to Object mode (press O).
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2. Turn on the Translate tool ( ) or press T, and select the object(s) you want to modify.

3. Drag the object(s) in a viewport. To lock the selection, turn off the Select tool, or hold T while 
translating the object. 

4. To nudge the object, press the ARROW key. The object moves in 4-pixel increments.

5. To translate an object along its local axes, choose Edit > Manipulation Options, then 
choose an axis, or press an axis button. You can also hold SHIFT along with the appropriate 
buttons:

To translate an object using precise position coordinates:
1. In the Project Manager, select the object.

2. In the Parameter Editor, enter new X Y Z values in the Position fields.
The object moves to its new position in the viewports.

Note: In Windows, you can also change the Position parameters in the Project Manager.

Rotating objects
Use the Rotate tool to turn an object around its center. You can also rotate an object by changing 
its Orientation parameters. Orientation values are in degrees.

SHIFT + left mouse button (Windows) or 
SHIFT+mouse button (Macintosh)

Translates the object on its X axis

SHIFT + middle mouse button (Windows) or 
SHIFT+OPTION+mouse button (Macintosh)

Translates the object on its Y axis

SHIFT + right mouse button (Windows) or 
SHIFT+CONTROL+mouse button (Macintosh)

Translates the object on its Z axis
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By default, rotation is viewport-based, that is, objects rotate in the plane of the viewport in which 
you drag them. You can rotate objects along their local axes by holding the SHIFT key, by turning 
on a manipulation axis from the Edit menu, or by pressing an X, Y or Z button on the toolbar 
(Windows) or in the toolbox (Macintosh), 

If there are several objects next to each other, it can be difficult to select and rotate the correct 
one. In this case, select the object in the Project Manager and turn on the Rotate tool, then toggle 
off the Select tool to lock the selection.

To rotate an object in a viewport:
1. Turn on the Rotate tool ( ) or press R.

2. Drag the object in a viewport. To lock the selection, turn off the Select tool, or hold R while 
rotating the object.
It turns around its center, rotating in the plane of the viewport. 

In Windows, you can also rotate into the viewport by dragging the object up or down with the 
middle mouse button. Similarly, you can rotate along the horizontal axis of a viewport by 
dragging the object with the middle mouse button from side to side.

On the Macintosh, you can also rotate into the viewport by OPTION-dragging the object up or 
down. Similarly, you can rotate along the horizontal axis of a viewport by OPTION-dragging the 
object from side to side.

Rotating a cone in 
Front view

Rotating a cone around its local 
Y axis in WebCam view
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To rotate an object around its local X, Y, or Z axes:
1. Turn on the Rotate button or press R.

2. To rotate an object along its local axes, choose Edit > Manipulation Options, then choose 
an axis, or press an axis button. You can also hold SHIFT with the appropriate buttons:

To rotate an object around its own X, Y, or Z axis using precise orientation coordinates:
In the Project Manager, select the object and then in the Parameter Editor, enter new X Y Z 
values in the Orientation fields.
The object turns to its new orientation in the viewports.

Note: In Windows, you can also change the Orientation parameters in the Project Manager.

To change an object’s center of rotation:
1. Select the object, then switch to Center mode ( ).

2. Turn on Translate, and then drag the object’s center in a viewport. 
The object’s center moves. 

3. Switch back to Object mode and rotate the object.
It turns around its new center.

To change the orientation of an object’s X, Y, and Z axis:
1. Select the object, then switch to Center mode ( ).

2. Turn on Rotate, then drag the center in a viewport.
The object’s axes rotate.

3. Switch back to Object mode and rotate the object. 
In Windows, use the SHIFT key and the left, middle, and right mouse buttons. 
On the Macintosh, use the SHIFT key and either the mouse button alone, or use the mouse 
button and the CONTROL and OPTION keys.
The object turns around its new axes.

SHIFT + left mouse button (Windows) or 
SHIFT+mouse button (Macintosh)

Rotates the object around its X axis

SHIFT + middle mouse button (Windows) or 
SHIFT+OPTION+mouse button (Macintosh)

Rotates the object around its Y axis

SHIFT + right mouse button (Windows) or 
SHIFT+CONTROL+mouse button (Macintosh)

Rotates the object around its Z axis
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Scaling objects
Scaling squashes and stretches an object on its own axes. You can scale along all three axes, or 
along one axis at a time. You can scale an object using the Scale tool or by adjusting its Scale 
parameters. Scale values are multiples or fractions of the original size.

Objects are scaled from their centers. Manipulating an object’s or group’s center affects how 
scaling acts on the object.

If there are several objects next to each other, it can be difficult to select and scale the correct 
one. In this case, select the object in the Project Manager and turn on the Scale tool, then toggle 
off the Select tool to lock the selection.

To scale an object:
Turn on the Scale tool ( ) or press E, then with the Select tool on or off, do one of the 
following:

• To scale along three axes, drag the object in a viewport using the left mouse button (Windows) or the 
mouse button (Macintosh). The object is scaled proportionally, that is, it stretches or shrinks along its 
X, Y, and Z axes.

• To scale along two axes non-uniformly, drag the object using the middle mouse button (Windows) or 
drag the object with the mouse button while holding the OPTION key (Macintosh). The object is 
scaled in the plane of the viewport.
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• To scale along one axis, choose Edit > Manipulation Options, then choose an axis, or press an axis 
button. You can also hold SHIFT with the appropriate buttons:

To scale an object using precise values:
Select the object and adjust its Scale parameters in the Parameter Editor. 
The object is scaled along its local axes.

Note: In Windows, you can also change the Scale parameters in the Project Manager.

To change the orientation of the scaling:
1. Select the object.

Switch to Center mode ( ).

2. Turn on Rotate, then drag in a viewport.
The object’s axes rotate.

3. Switch back to Object mode and scale the object. 
In Windows, use the SHIFT key and the left, middle, and right mouse buttons. 
On the Macintosh, use the SHIFT key and either the mouse button alone, or the mouse button 
and the CONTROL or OPTION keys. The object scales along its new X, Y and/or Z axes.

Example: Setting an object’s center
An object’s position is the position of its center. When you rotate an object, it pivots around its 
center. By moving the center, you can change the pivot point.

SHIFT + left mouse button (Windows) or 
SHIFT+mouse button (Macintosh)

Scales the object on its X axis

SHIFT + middle mouse button (Windows) or 
SHIFT+OPTION+mouse button (Macintosh)

Scales the object on its Y axis

SHIFT + right mouse button (Windows) or 
SHIFT+CONTROL+mouse button (Macintosh)

Scales the object on its Z axis

A top pivoting around
its geometric center

A top pivoting 
around its base
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To move the center of the spinning top:
1. Press J to switch to Center mode.

2. Turn on Translate ( ) or press T and drag the center to the base of the spinning top.

Example: Translating in different tool modes
In this example, create a stem for the cherry using different manipulation tools and modes.

1. Choose Model > Add Surface > Cylinder.

2. Scale the cylinder to make it long and thin. 

3. Switch to Object mode (O), then turn on the Translate button ( ) and drag the cylinder over 
the cherry.

4. To tilt the stem, switch to Center mode (J) and drag the center to the base of the stem. Then 
switch to Object mode (O), turn on Rotate and drag the stem.
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The stem rotates around its new center.

5. To give the stem a more natural shape, switch to Point mode (P), select the points at the top 
of the stem, scale them, and then rotate them to make the cut more natural. Select points in 
the middle and translate them to the right to bend the stem.
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Instancing and duplicating objects
There are two ways to create copies of an object: duplicating and instancing.

Duplication makes a copy of the original object. It creates an entirely new object, copying 
materials and textures (not relations, animation, or interactions). You then edit the duplicates’ 
geometry, materials and position/rotation/scaling parameters completely independently of one 
another.

Instancing clones the original object, and the instance remains faithful to it. Any changes to an 
instance’s geometry and materials are immediately reflected on all instances and the original. 
This includes changing the object center’s position, orientation or scale in Center mode ( ). 

Manipulations (position, rotation and scaling) of the objects —when you are in Object mode 
( )—are independent.

Instancing makes AXEL files lighter and quicker to download since a file only stores one 
object's geometry. Display speed does not improve since the computer still must calculate all 
objects on screen.

Duplicates have the same icon as other objects ( ), while instances have a double cone icon 

( ).
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An example of instancing is creating seats in a theater, where one can be instanced into many 
copies, each a clone of another. When you change the shape of one seat, all the others are also 
updated.

To duplicate an object:
Select the object, then choose Edit > Duplicate, or press CTRL+D (Windows) or COMMAND+D 
(Macintosh). 
A duplicate appears in the Project Manager and in the viewports, where it is offset from the 
original. You can adjust how much a duplicate is offset by expanding Author Settings / Edit in 
the Project Manager, then typing a new value for Duplicate offset in the Parameter Editor.

To create an instance of an object:
Select the object, then choose Edit > Instance or press CTRL+I (Windows) or 
COMMAND+CONTROL+D (Macintosh). 
An instance appears in the Project Manager and in the viewports, where it is offset from the 
original. You can adjust the instance’s offset in the Edit settings in the Project Manager.
In the Project Manager, expand the instance. Notice it uses the geometry of the first object.

Original Seat Instances of the seat translated 
to different positions.

Changing points on one seat changes the shape of all the seats. 
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Tip: When you instance an object, the instances share the same material, however, you can then 
add a new material to any instance and it’s added to just that instance. This single instance would 
then have an independent material, although geometries remain connected.

Creating curves
Use curves as motion paths or to create surfaces.

You can choose a preset curve or draw a curve of any shape. The curves in AXEL are 
subdivision curves which make it easy to create a smooth curve with very few points.

Curves can be:

• Basic geometric shapes. See “Creating a square or rectangle” on page 180 and “Creating an arc or a 
circle” on page 182.

• Freeform curves. See “Drawing a curve” on page 183 and “Sketching a curve” on page 184.

Curve parameters
Some parameters are common to all curves, and others are specific to each type of curve.

Common curve parameters

Position Object location in X Y Z coordinates.
Orientation Object rotation values in X Y Z degrees.
Scale Object scaling values in X Y Z multiplication factors.
Visible Toggles the visibility of the curve on or off.
Antialiasing Turns on antialiasing to remove the “jaggies” on diagonal lines by blurring the curve. 

To see the antialiasing, it must be on for the object and the WebCam. Antialiasing 
slows down the refresh rate. For more information, see “About antialiasing” on page 
594.

Motion 
path

Curve for 
extrusion

Curves for 
revolutions
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Rectangle- and Square-specific parameters

Number of 
Points

The number of points that define the curve. When the curve is published in a web 
page, the points are downloaded and the AXEL player redraws the curve on the 
surfer’s web page. Increasing the number of points increases download time.

Steps Adds steps between points to make the curve smoother without adding points. See 
“Modifying curves” on page 185.

Point positions The X, Y, Z coordinates of each point. Point positions are not displayed for objects 
that have more than 200 points.

Frozen Hides the curve geometry parameters.
A curve freezes if you add, move, or delete points, or subdivide it.
When the curve is frozen, AXEL draws the curve based on its points, not its width 
and height parameters. If you turn off Frozen, the curve is redrawn based on its width 
and height, and any points you modified move back to their original position.

Width Size in units along its local X axis.
Height Size in units along its local Y axis.
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Circle- and Arc-specific parameters

Draw Curve- and Sketch Curve- specific parameter

Creating a square or rectangle
Since a square is a rectangle with equal sides, you can create either one and adjust its size to 
make it into a square or a rectangle.

To draw a rectangle:
1. Choose Model > Add Curve > Rectangle, or choose Rectangle from a Shape menu.

A rectangle appears in the center of the viewports and its parameters appear in the Parameter 
Editor.

Closed Draws a segment between the end points to join them together.
Frozen Hides the curve geometry parameters.

A curve freezes if you add, move, or delete points, subdivide or simplify it.
When the curve is frozen, AXEL draws the curve based on its points, not its radius 
parameter. If you turn off Frozen, the curve is redrawn based on its radius, and any 
points you modified move back to their original position.

Radius Size in units.
Subdivisions Adds points to the circle.
Angle Determines the angle of the arc. A circle has an angle of 360 degrees.

Closed Joins the first and last point in a curve to create a closed shape.
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2. You can translate, rotate, and scale the curve using the Manipulation tools or by adjusting its 
position, orientation, and scale parameters. For example, to make the rectangle smaller in X, 
change the Scale to 0.5, 1, 1. It would then be a square.

3. Expand the Geometry parameters. You can also change the curve using its geometry 
parameters, for example, to adjust the height of the rectangle. For more information, see 
“Modifying curves” on page 185.

Click to expand (Windows) 

Double-click to expand (Macintosh)
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Creating an arc or a circle
Since a circle is a 360-degree arc, you can create either one and adjust its angle to make it into 
an arc or a circle.

To create an arc or circle:
1. Choose Model > Add Curve, then choose Circle or Arc, or choose Circle or Arc from a 

Geometry menu.
The curve appears in the center of the World and the curve parameters appear in the 
Parameter Editor.

2. Expand the Geometry parameters.
A circle is closed and its angle is 360. An arc is open and its angle is less than 360. By 
adjusting the Closed and Angle parameters, you can change a circle into an arc and vice-
versa.

Click to expand (Windows)

Double-click to expand (Macintosh)
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Drawing a curve
You can draw a curve of any shape using points in the viewport. The first point on a curve is 
green and the last point is magenta. If you close a curve, the joining point is white.

To draw a curve:
1. Choose Model > Draw Curve, turn on ( ) or press L.

2. Click in a viewport to draw the first point in the curve. Click again to add a second point and 
so on until you have drawn the approximate shape of your curve.

Tip: To draw straight lines, choose View > Active/All Viewports > Snap to Grid.

3. To draw an open curve, press ESC. To close the curve, click the curve’s first point or press 
END (Windows) or COMMAND+END (Macintosh). Press ESC once to continue drawing 
another curve. Press ESC twice to exit drawing mode.
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4. To create a smoother curve, click CurveGeometry in the Parameter Editor, and increase the 
Steps. Steps is an integer from 0 to 10.

Increasing Steps adds points that are not editable and do not increase the weight of the object. 
In the Geometry parameters, notice that the number of points does not increase when you 
increase Steps.The following illustration shows the original curve with various increments of 
Steps.

Tip: When drawing paths, you should draw curves with as few points as possible. By limiting the 
number of points, you obtain a smoother curve that is easy to edit and animate. Somewhat 
differently, when drawing a curve to create a polygon, revolution, or extrusion surface, you should 
draw as many points as needed to obtain the contour you want because the curve steps are not taken 
into account when the surface is generated from the curve.

Sketching a curve
Sketching curves, like drawing curves, creates subdivided curves defined by points. Instead of 
adding individual points, however, you turn on Sketch Curve and drag in the viewports to sketch 
the curve. 

You can quickly draw many curves in succession this way by simply dragging from one place 
to another, then moving to a new position and dragging again.
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To sketch a curve:
1. Choose Model > Sketch Curve or turn on the Sketch curve tool ( ).

2. Drag in a viewport. 
A curve is created following the path of the cursor. 

3. To draw more curves, release the mouse button then drag from a new position.

4. To close the curve, press END (Windows) or COMMAND+END (Macintosh), or turn on 
Closed in CurveGeometry in the Parameter Editor.

5. To exit Sketch curve mode, either turn it off from the Model menu, press ESC, or by selecting 
another manipulation tool.

6. To create a smoother curve, click CurveGeometry in the Parameter Editor, and increase the 
Steps. Steps is an integer from 1 to 10.

To adjust the spacing of points as you sketch curves:
In the Project Manager, select Author Settings / Model / Sketch curve, and adjust the Distance 
Sampling.

Sketch curve settings

Modifying curves
After you create a curve, you can modify it in several ways. You can edit the points on the curve, 
open or close it, make it smoother, change its direction, or rationalize its position and scaling 
values. You can also scale, rotate, and translate the curve. 

Distance sam-
pling

Determines the spacing of points as you sketch a curve.
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About smoothness
There are several ways to make a curve smoother: increasing steps, adding points, or 
subdividing the curve. 

Increasing steps divides the segments between points making the curve look smoother without 
increasing its weight. 

Adding points is an easy way to refine the shape of the curve. You can add more points where 
you want the curve to be round, and have fewer points where the curve is straight. Remember, 
the more points, the longer it takes to download. You add points by inserting new points on the 
curve. 

Subdividing a curve adds a point between every two points. It makes the curve rounder from 
start to finish but significantly increases the number of points on the curve. 

Editing points on a curve
You can add, delete, move, rotate and scale points on a curve.

To add points to a curve:
1. Select the curve in Object mode.

2. Choose Model > Modify Curve > Add Point or press INSERT (Windows).

Steps = 0 Steps = 1 Steps = 2

Two points 
added

Five points 
added

Original curve

Subdivided once Subdivided twiceOriginal curve
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3. In the viewport, click where you want to add a point.
A point is added to the closest segment of the selected curve.

4. Drag to add a point and adjust its location.

5. To add another point, click again.

6. To stop adding points, press ESC.

To delete points from a curve:
1. Select the curve in Object mode.

2. Switch to Point mode (P), select the points you want to delete, and press DELETE.
The curve is redrawn based on the remaining points.

To move points on a curve:
1. Select the curve in Object mode.

2. Switch to Point mode (P).

3. Select the points you want to move.

4. Turn on the Translate button (T), place your cursor over one of the selected points, then drag 
the point. 

Tip: To make sure the points remain selected when you translate them, select the points then turn 
off the Select tool, or press and hold the Translate keyboard shortcut (T) while you drag the points 
in the viewport.

Increasing steps
Steps make a curve smoother without adding points. They are especially useful to smooth out 
an animation path.

Steps are not taken into account, however, when you create surfaces from a curve.

To increase or decrease the steps of a curve:
1. Select the curve.

2. In the Project Manager or Parameter Editor, set the Steps to a value between 0 and 10.

Subdividing a curve
Subdividing adds a point between each point on a curve. 
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To subdivide a curve:
Select the curve and choose Model > Modify Curve > Subdivide.
This creates one additional point between every two existing points on the curve.

Note: You cannot subdivide only selected points on a curve. Instead, use the Model > Modify 
Curve > Add Point command to add points at specific locations on a curve.

Simplifying a curve 
Simplify a curve to remove points.

To simplify a curve:
Select the curve and choose Model > Modify Curve > Simplify.

To simplify selected points on a curve:
Select points along a curve and choose Model > Modify Curve > Simplify.
You can control the level of simplification via the Simplify curve settings. They are in the 
Project Manager, under Author Settings / Model / Simplify curve.

Simplify curve settings

In the following example, the curve drawn for the wine glass (left) has some points (middle) that 
fall under the 20-degree threshold and are simplified. The higher the angle threshold, the more 
points are simplified.

Angle threshold Sets the angle under which points are removed.
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In the case of the glass, points on straight or nearly straight lines are simplified, while points on 
the sweeping top part of the curve remain.

Closing a curve
A curve can be open or closed.

To close a curve:
Do one of the following:

• When you are finished drawing the curve, click on the curve’s first point.

• When you are finished drawing the curve, press END (Windows) or COMMAND+END (Macintosh).

• Click a curve and choose Model > Modify Curve > Close.

• In the Project Manager, select the curve’s geometry and then in the Parameter Editor, turn on Closed.
The curve’s start and end points are joined to close the curve.

Inverting a curve
Inverting a curve reverses the beginning and end of a curve. For example, if an object on a path 
animation is going clockwise along a circle, inverting the circle makes the object go counter-
clockwise. 

To invert a curve:
Select the curve and choose Model > Modify Curve > Invert.
If the curve is not closed, its first point, which is green, and its last point, which is magenta, have 
switched places. 
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Rationalizing scale and pose of a curve
To make the current size of a curve the starting point for subsequent scaling operations, you 
rationalize its scaling. This leaves the curve its current size, but replaces its current scale values 
with 1 1 1.

To move an object’s center to the center of the World and make its current position, scale, and 
orientation the starting point for subsequent manipulations, you rationalize its pose. This again 
leaves the curve in the same position, rotated in the same direction and the same size. Because 
the center is rationalized to the World origin, the parameter values for position and orientation 
are all 0, while the scale values are rationalized to 1 1 1.

To rationalize the scale of a curve:
In Object mode, select the curve and choose Model > Modify Curve > Rationalize Scale.
The curve's Scale parameter is reset to 1, 1, 1 but the curve's size does not change.

To rationalize the position of a curve:
In Object mode, select the curve and choose Model > Modify Curve > Rationalize Pose.
The curve's center moves to the center of the World. Its position and orientation values are reset 
to 0,0,0. Its scale is reset to 1,1,1, but the curve’s appearance does not change.

Creating surfaces
In AXEL, you can use preset surfaces or generate 3D surfaces from 2D curves. 

Preset surfaces, also known as primitives, are standard geometric shapes, such as spheres, cubes, 
cones, and cylinders. Many objects can be modeled from preset surfaces. You can resize, move, 
and rotate them, or manipulate points on these surfaces to create different shapes. 

The methods for generating 3D surfaces from curves mimic real-life modeling techniques: 

• Drawing a surface is like weaving, where you make a contour shape, then weave a mesh over the 
contour. 

• Revolving is similar to a woodworker's lathe, where a piece of wood is set spinning around an axis 
and then a sharp cutting surface carves out a shape, such as baseball bat. 

• Extruding is a common industrial process where a mold is created in the shape of the desired part and 
then the material is pushed (or extruded) through. The result is like the original shape with adjustable 
depth. 

When you create a revolution or an extrusion, a relation is maintained between the curve and the 
surface, so that when you edit the curve, the surface is updated to reflect those changes. This 
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holds true as long as you do not independently edit the geometry of the revolution or extrusion, 
like moving a point or rotating its center. In this case, the Frozen parameter under the object’s 
geometry is turned on and the curve(s) used to create the revolution or extrusion lose their 
influence. You can always toggle off the Frozen parameter, your edits are discarded and the 
curve(s) regain their influence.

Unlike revolutions and extrusions, when you create a surface from a curve using the Model > 
Create Surface > Surface from Curve command, it is independent from the original curve.

Surface parameters
All surfaces have the following parameters, which appear in the Project Manager and the 
Parameter Editor when you create the surface. Parameters that apply only to specific surfaces 
are describedin the sections on creating those surfaces. 

Common Surface Parameters

Position Distance from the center of the World in units, along the X, Y, Z axes.
Orientation Orientation in degrees around the X, Y, Z axes.
Scale Scaling values in X, Y, Z. Scale is a multiplication factor.
Visible Toggles surface visibility.
Antialiasing Turns antialiasing on/off for the selected surface. It blurs the edge of the object to 

remove the “jaggies”.
To be visible, antialiasing must be on for the viewport and the WebCam. Antialiasing 
slows down the refresh rate. For more information, see “About antialiasing” on page 
594.

Number of 
points

Number of points that define the surface. 

Point positions The X Y Z coordinates of every point on the surface. Point positions are not dis-
played for objects that have more than 200 points.

Streamable Enables web streaming for the surface after it is published to the web. For more 
information on streaming, see “Estimating download time” on page 592.

Streaming prior-
ity

When Streamable is turned on, determines the streaming priority - Low, Medium and 
High - of the surface. This in turn determines how fast the surface is downloaded to 
a surfer’s computer in relation to the other items in the project.
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Single sided Displays only the outer face of surfaces. To see both faces, turn off Single sided. 
Turning on Single sided increases the display speed since AXEL has to draw only 
one side of the surface. 
With single sided objects, you can switch the side that is displayed by inverting the 
surface. For more information, see “Inverting surfaces” on page 207.

Smoothness Since polygonal surfaces are a collection of flat planes, smoothness creates an illu-
sion of surface roundness. The sphere on the left shows the true appearance of a 
polygonal surface, where all the faces are visible. The same sphere on the right, with 
smoothness enabled, creates the illusion of a round surface.

Crease control Use crease control for surfaces that have both hard edges and round surfaces, for 
example, a table top with smooth corners. If you turn on smoothness without crease 
control, all the angles are rounded. Turn on crease control to disable smoothness for 
sharp angles. 

Crease angle Defines minimum angle for smoothness to take effect. For example, if you use 
a low crease angle threshold such as 10, faces are visible if the angle between 
2 faces is higher than 10 degrees. A higher crease angle threshold such as the 
default 60 degrees smooths all but the sharpest angles.

 Single sided Double sided

Smoothness off

Smoothness on, crease control off

Smoothness and crease control on

AXS/Model_1or2_sided.htm
AXS/Model_CreaseControl.htm
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Coloring Determines how color is applied to a surface. You apply color per point, per face, or 
to the entire surface. For more information, see “Color per point, per face” on page 
314.

Frozen Hides the surface geometry parameters. In addition, if a revolution or extrusion sur-
face is frozen, it is no longer linked to the curve from which it was generated; chang-
ing the curve does not change the surface. 
A surface freezes if you add, move, or delete points, subdivide it, or simplify it. It 
also freezes if you set the coloring to Per point or Per face, or if you edit texture coor-
dinates.
When the surface is frozen, AXEL draws the surface based on its points, not its 
parameters. If you turn off Frozen, the surface is redrawn. Any points you modified 
move back to their original position, and edited point colors revert to the material 
color.
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Adding spheres, cubes, cylinders, cones, planes
Preset surfaces are available for six commonly used shapes: sphere, cube, cylinder, cone, 
vertical plane, and horizontal plane.

To create a sphere, cube, cylinder, cone, or plane:
1. Choose Model > Add Surface, then choose the type of surface you want to create, or click 

the Shape button and choose a surface from the menu.
The surface appears in the center of the World.

2. Translate, scale, or rotate the surface as needed.

3. In the Parameter Editor, adjust its parameters. For information on common parameters, see 
“Surface parameters” on page 191. The following tables describe the parameters that are 
specific to the six preset surfaces.

Sphere geometry parameters

Cube geometry parameters

Radius Determines the size of the sphere.

Subdivisions A low number of subdivisions creates a very boxy shape, and a light model. Con-
versely, high number of subdivisions creates a much smoother model, which can 
slow performance and increase download time, but adds definition and gives it more 
edges for deformations.
The horizontal subdivisions define the number of faces in longitude; the results are 
most apparent in top view.
The vertical subdivisions define the number of faces in latitude; the results are most 
apparent in front or right view.

Width Determines the size of the cube along the X axis.
Height Determines the size of the cube along the Y axis.

Depth Determines the size of the cube along the Z axis.

Radius
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Cone geometry parameters

Plane geometry parameters (horizontal and vertical)

Height Determines the height of the cone.
Width Determines the diameter of the cone at its base.

Subdivisions A low number of subdivisions creates a very boxy shape, and a light model. Con-
versely, high number of subdivisions creates a much smoother model, which can 
slow performance and increase download time, but adds definition and gives it more 
edges for deformations.
The horizontal subdivisions define the number of faces in longitude; the results are 
most apparent in top view.
The vertical subdivisions define the number of faces in latitude; the results are most 
apparent in front or right view.

Subdivisions The number of subdivisions along each axis. Increase the number of subdivisions 
when deforming the plane or improving the lighting on the surface. For more infor-
mation, see “Increasing subdivisions to improve lighting effect” on page 339.

Height

Width
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Cylinder geometry parameters

Tip: Subdivisions are key to 3D modeling. They add edges to objects where deformations can 
occur. Keep this in mind when applying bends, pushes, or any other type of deformation.

Height Determines the height of the cylinder.
Width Determines the diameter of the cylinder.
Top capping Closes the top of the cylinder.
End capping Closes the bottom of the cylinder.
Horizontal sub-
divisions

Number of faces along the cylinder’s circumference. A low number of subdivisions 
creates a boxy shape, whereas a high number of subdivisions creates a smoother 
model.

Vertical 
subdivisions

Number of faces on the cylinder’s Y axis. Increase vertical subdivisions when bend-
ing or otherwise deforming the cylinder. 

Increasing horizontal subdivisions

Increasing vertical subdivisions
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Drawing a surface
You can draw a surface or create one from an existing curve.

To draw a surface:
1. Choose Model > Draw Surface or turn on Draw Surface ( ).

2. In a viewport, click points to define the corners of the surface.

3. Press ESC and continue drawing surfaces, or press ESC twice to exit Draw Surface mode.

4. Adjust the surface’s parameters in the Parameter Editor.

5. To change the shape of the surface, switch to Point mode (P), then manipulate its points.

To create a surface from a curve: 
1. Draw a curve in a viewport, and adjust its shape.

Note: The Steps parameter is not taken into account by the surface conversion. To soften the 
curve, subdivide the curve or add points individually.

2. With the curve selected, choose Model > Create Surface > Surface from Curve.
The curve is filled to create a surface. If you cannot see the surface, press W to toggle 
between Wireframe and Shade mode, orbit in WebCam view, or turn off Single-sided in the 
Surface Geometry parameters.

3. In the Parameter Editor, adjust the surface’s parameters. 

4. To change the shape of the surface, press P to switch to Point mode, then manipulate the 
points on the surface.
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Creating a revolution surface
Revolution spins a curve around an axis to create a 3D surface. 

By default, the curve revolves around a vertical axis that passes through the origin of the World 
(position 0,0,0). The distance between the curve and the origin determines the thickness of the 
revolution. For example, if you draw the outline of a wine glass 5 units from the World origin, 
your result is a large vat, with a wine glass outline.

By default, a revolution is a rounded shape, but you can change it to an angled surface by 
reducing the number of subdivisions. In the following illustration, the block and the picture 
frame are revolutions with Subdivisions set to 4. 

To create a surface by revolution:
1. Draw a curve close to the World origin. See “Drawing a curve” on page 183.

2. Adjust the curve keeping the following in mind:

• AXEL does not use the curve’s Steps parameter when it creates the surface. A smooth 
curve, then, does not necessarily create a smooth revolution—unless the curve’s 
smoothness is due to just having a lot of points.

• You can refine the curve after you create the revolution since the curve remains linked to 
the revolution. This is true as long as the revolution’s geometry is not altered, for example 
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by moving points or manipulating the revolution’s center, in which case the original curve 
loses its influence.

• You can add points to the original curve to make the revolution surface smoother.

3. With the curve selected, choose Model > Create Surface > Revolution from Curve.
A revolution surface appears.

4. Select the revolution and translate, scale, or rotate it as needed.

5. To change its shape, modify its original contour curve. See “Modifying curves” on page 185.

6. In the Parameter Editor, adjust the Revolution parameters. 

Note: For information on common surface parameters, see “Surface parameters” on page 191. 

Revolution parameters 

Origin Position of the center of the revolution. By default the origin of the revolution is the 
origin of the World origin (0, 0, 0). 

Revolution 
around

Axis around which the surface revolves. The default revolution axis depends on 
where you draw the curve, and whether the curve is drawn from top to bottom. For 
example, if you draw a curve in the front or right view with the points descending 
from the top of the screen, the curve revolves around the + Y axis (0 1 0). After the 
revolution is created, you can change its revolution axis to one of the following: +X, 
+Y, +Z, -X, -Y, -Z or Other axis, for which you can then specify a precise axis value 
in Revolution axis.
If the revolution is inverted, you can either change the +/- value of the Revolution 
around axis, or select the revolution and choose Model > Modify Surface > Invert. 
For more information, see “Inverting surfaces” on page 207.

Revolution axis When you choose Other axis for the Revolution around parameter, this is the axis 
that the curve revolves around to create a surface.

Subdivisions Number of faces of the revolved surface. Increasing subdivisions increases the 
smoothness of the surface as well as its weight, and adds edges where deformations 
can occur.

Angle The number of degrees of revolution. 

Top capping Closes the top of the surface.
End capping Closes the bottom of the surface.

Angle=360 Angle=240



200 | AXEL V2 | User Guide

Surface 
closing

If the angle is less than 360, turning on Surface closing connects the edges of the rev-
olution.
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Creating an extrusion surface
Extrusion pushes a 2D curve along an axis to create a 3D surface. 

The axis is a line coming out of the viewport in which you draw the curve. For example, if you 
draw a curve in top view and extrude it, it is extruded along the Y axis. 

To create a surface by extrusion:
1. Draw a curve. See “Drawing a curve” on page 183.

2. Adjust the curve keeping the following in mind:

• AXEL does not use the curve’s Steps parameter when it creates the surface, so a smooth 
curve does not create a smooth extrusion. A smooth curve, then, does not necessarily create 
a smooth extrusion—unless the curve’s smoothness is due to just having a lot of points.

• You can refine the curve after you create the extrusion since the curve remains linked to the 
extrusion.

• You can add points to the original curve to make the extrusion surface smoother.

3. With the curve selected, choose Model > Create Surface > Extrusion from Curve.
An extrusion surface appears.

4. Select the extrusion and translate, scale, or rotate it as needed.

5. To change its shape, modify its contour curve. See “Modifying curves” on page 185.

6. In the Parameter Editor, adjust the Extrusion parameters. 

Note: For information on common surface parameters, see “Surface parameters” on page 191.
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Extrusion parameters

Roll angle (start/
end)

Creates a twisting extrusion. The first value is the start angle (in degrees) and the sec-
ond, the end angle. The following illustration has a start of 0 and an end of 90 
degrees. This could be useful for modeling an ice cream cone or a woodscrew.

Scaling 
(start/end)

Tapers or expands the extrusion. The first value is the start scale (ranging from 0 to 
1) and the second the end scale. The following illustration has a start of 0.25 and an 
end of 1.

Subdivisions Number of subdivisions along the length of the extrusion. The default value is 1. 
When you deform a surface, for example, by using a bend or push, increase the num-
ber of subdivisions to give the object more edges where the deformations can occur. 

Length Length of the extrusion. The default length is 1 unit.
Top capping Closes the top of the extrusion.
End capping Closes the bottom of the extrusion. 
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Extrusion along curve
Extrusion along a curve pushes one 2D curve along another 2D curve to create a 3D surface. 

To create a an extrusion along a curve:
1. Choose Model > Draw Curve, or press L, and draw the contour curve. You can click on the 

first point or press END (Windows) or COMMAND+END (Macintosh) to close the curve, 
although it does not need to be closed.

2. Choose Model > Draw Curve, or press L, and draw the path for the extrusion. Click on the 
first point or press END to close the curve, or press ESC twice to end the curve without closing 
it and exit Draw Curve mode.

3. SHIFT-select the contour curve then the path curve, in that order. The order is important. The 
first object is the cross-section contour; the second is the path.

4. Choose Model > Create Surface > Extrusion along Curve.
The extrusion is created.

5. To modify the extrusion, modify the curves used to create it, and/or adjust the Extrusion 
parameters in the Parameter Editor. 

Tip: You can also use the Sketch Curve tool ( ) to sketch the profile to be extruded, as well as 
to sketch the extrusion path. 
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Modifying surfaces
You can change surface parameters or move points on a surface to change its shape. 

By default, the appearance of a surface is based on its surface parameters. By adjusting the 
parameters, you change the surface. However, if you modify points on the surface, the following 
geometric parameters are frozen:

• Number of subdivisions

• Height

• Width

• Radius of presets
For extrusions and revolutions, when the geometry is frozen, the surface is no longer linked to 
the curve or curves from which it was created. Instead, you control the shape of the surface by 
manipulating its points. To enable the parameters and the curves again, you can un-freeze the 
surface by turning off Frozen in the Parameter Editor; the surface is redrawn based on its 
parameters and any new or moved points are ignored. Edited point colors or texture coordinates 
are also ignored.

In Windows, you can also copy multi-valued parameters from one surface to another. For more 
information, see “Copying parameters in Windows” on page 65.

 Manipulating points of a surface
You can add, remove, and move points to reshape a surface.

To delete points from a surface:
1. In Object mode (O), select the surface.

2. Switch to Point mode (P), select the points to delete, and press DELETE.

Tip: You can make holes or gaps in an object by deleting some of its points.

To manipulate points on a surface:
1. In Object mode (O), select the surface.

2. Switch to Point mode (press P), and select the points you want to manipulate. You can select 
individual points, or multi-select many points—even on multiple objects. 

3. Turn on the Translate, Scale, or Rotate tool and drag the points in the viewport. 

Tip: To avoid deselecting the points while you manipulate them, lock the selection. To do so, hold 
the manipulation keyboard shortcuts (E, R, or T) while dragging the points in the viewport.
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Manipulating multiple points 
You can multi-select points on a single object, or on many objects, then manipulate their points 
in tandem. Use this principle, for example, to translate selected points along a single axis, to 
squeeze points together, or to rotate or twist points on one or more objects. 

For Scales and Rotations, AXEL calculates the position of a center between all your selected 
points to rotate or scale from, while it uses the World origin for the orientation of this axis. The 
World origin is also used for translations of multiple-point selections.

You can also record keys for Shape animation on multiple Animation sequences at the same 
time. For more information, see “Shape animation” on page 407.

To manipulate multiple points on multiple objects:
1. In the Project Manager or in the Viewports in Object mode, multi-select several objects.
In Point mode ( ), select some points on different objects. You can then toggle off the Selection 
tool ( ) to lock the points as selected.

2. Manipulate the points using the Translate, Scale, or Rotate tool. 
If your Selection tool ( ) remains on—keeping your selected points unlocked—you can 
instead click directly on one of the selected points and drag, and your manipulations are 
applied on all the selected points.
Your manipulation is applied to all your selected points.

Points from two candles are multi-
selected and translated together.
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Subdividing and simplifying surfaces
Subdividing surfaces is vital for modeling, animation and interaction because it gives you more 
points and faces with which to work with. For example, if you are pushing a surface the surface 
will actually only be deformed along the edges of its faces. More faces means a smoother, less 
jagged push.

Simplifying surfaces is also crucial, as it allows you both cleaner objects from which to work 
with as well as makes the objects lighter to download while improving the performance of the 
scene.

You can add points by subdividing the surface. Subdividing adds geometry to the surface 
without modifying its shape. All surfaces are divided. Subdividing can create a smoother 
deformation or give the surface a more defined appearance under light sources.

To subdivide a surface:
Select the surface and choose Model > Modify Surface > Subdivide.

To subdivide selected faces:
In Point mode, select the points that define the faces you want to subdivide, then choose 
Model > Modify Surface > Subdivide.

To simplify a surface:
In Object mode, select the surface, then choose Model > Modify Surface > Simplify.

Selected points Subdivided faces
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To simplify selected points:
Select the points, and choose Model > Modify Surface > Simplify. 
The percentage of points that respect the angle threshold in the Simply surface settings is 
removed.
You can control the level of simplification via the Simplify surface settings. They are in the 
Project Manager under Author Settings / Model / Simplify surface. 

Simplify surface settings

Inverting surfaces
Surfaces, created or imported, are single-sided and have no thickness. You decide which side of 
the surface is exposed to light. For example, a cube can be used as a box when seen from the 
outside, or as a room when seen from the inside. To create a room with four walls, a ceiling, and 
a floor, you could move the WebCam inside a cube and invert the cube’s surface.

In the following illustration, on the left, you see the inside of the glass. On the right, the glass is 
inverted, so you see the outside of the glass wall. By inverting a surface, you indicate which side 
of the surface you want to be visible.

Tip: When importing surfaces from other software you may get many inverted individual faces. 
You can try inverting the whole surface, but since AXEL cannot invert single faces, you may have 
to turn on Double sided for the surface’s geometry to fill in the wrongly places faces.

Angle threshold Sets the angle under which points are removed.
Percentage Determines the percentage of points, within the angle threshold, that disappear.

Inside faces Outside faces

Table inside of an inverted cube, 
which defines the walls of a room.

AXS/Model_Invert.htm
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To invert a surface:
Select the surface and choose Model > Modify Surface > Invert.
The surface faces are inverted.

Rationalizing a surface’s scale
To make the current shape of a surface the starting point for subsequent scaling operations, you 
rationalize its scaling. To move an object’s center to the center of the World and make its current 
position, scale, and orientation the starting point for subsequent manipulations, you rationalize 
its pose. 

To rationalize the scale of a surface:
In Object mode, select the surface and choose Model > Modify Surface > Rationalize Scale.
The surface’s scale parameter is reset to 1, 1, 1 but the surface size does not change.

Rationalizing a surface’s pose
Rationalize Pose resets the surface’s manipulation values (translation, rotation, scaling) back to 
default values.

This can be useful for certain situations:

• Moving the surface's center to the origin of the World to make it orbit around the origin, instead of 
the object’s geometry

• Resetting the manipulation values before constraining another object’s pose to it. If you have been 
manipulating an object, you might be surprised when using a Pose constraint on it, since AXEL 
considers the object’s position, orientation and scaling values in conjunction with the object’s center.

Example: Rationalizing the pose of a cube
1. Choose Model > Add Surface > Cube.

2. Drag the cube to the right, rotate it and scale it.
In the Parameter Editor, notice its values.
If you rotate it, it turns around its geometric center.
If you pose constrain an object to it, that object is scaled and rotated to match your cube.

3. Choose Model > Modify Surface > Rationalize Pose. 
In the Parameter Editor, all values are reset to their default without affecting the cube’s 
present state.
If you rotate the cube, notice how it turns around the World origin.
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The following illustration depicts the cube being rotated before and after the Rationalize 
Pose.

Shape mixing
Shape mixing makes one object’s shape change as it approaches two other objects, the 
modifiers. This can create interesting interactivity, especially when the two modifiers are not 
visible.

Shape mixing works with three objects: the first and second serve as the shape modifiers. The 
middle cube serves as the mixed object. The closer you move the third object to either modifier, 
the more it resembles that shape. In the following illustration, the shape of the crown changes 
as you move it from the queen’s crown on the left to the king’s crown on the right.

The three objects must have the same number of points to mix well. The easiest way to do this 
is to create two copies of an original, then rework the starting shape (first modifier), then rework 
the ending shape (second modifier).
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The three objects must have the same number of points to mix well. The easiest way to do this 
is to create two copies of an original, then rework the starting shape (first modifier), then rework 
the ending shape (second modifier).

Example: Mixing shapes
1. Create a cube.

2. Duplicate the cube twice and translate the three objects so they are lined up along the X axis.

3. To create two modifier objects, edit some of the points on the left and right cube so that they 
are visually distinct.

4. CTRL-select (Windows) or Command-select (Macintosh) the modifiers and then the third 
(middle) cube, in that order.

5. Choose Model > Mix Shapes.
When you translate the third (middle) cube towards a modifier, its shape changes. 
You can also mix the shape by moving the modifiers.

First modifier Second modifier
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Bending surfaces
You can bend a surface around a specific axis by a certain number of degrees. You can then 
adjust or animate the bend parameters.

Tip: You can also let surfers bend objects interactively. For more information, see “Bend handle” 
on page 492.

To bend an object:
1. Select the object.

2. Choose Model > Bend Surface.
A bend deformation appears under the object in the Project Manager.

3. Adjust the bend parameters.

Tip: To move the origin interactively, select Origin in the Parameter Editor, turn on the Translate 
tool, and drag in a viewport. 

Axis

Angle

Bend range
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Bend parameters
The following parameters define the bend.

Active Turns the bend deformation on or off.
Origin The X Y Z coordinates, in relation to an object’s center, where the object 

bends. 
Bend along Axis that the object bends around. By default, objects bend around the Z axis 

(0, 0, 1). You can select + X, +Y, +Z, -X, -Y, -Z, or select Other axis and 
enter a precise value in Bend axis.

Bend axis In you select Other axis for the Bend along parameter, this determines the 
axis of the bend.

Angle Angle of the bend, in degrees.
Minimum angle Smallest amount you can bend the surface.
Maximum angle Largest amount you can bend the surface. Minimum and maximum angles 

are useful when you add a sensor to the bend parameter.
Bend range The region that bends (in units along the bend axis). For example, if the Bend 

axis is +Z, the Bend range is along the Y axis.
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Pushing surfaces
Push a surface to poke it and model it like clay. The settings of a push effects its radius and depth. 
In the following illustration a sphere is reshaped by pushing in its upper-left area. The more 
subdivisions in the surface, the more smooth it will be pushed.

Tip: You can also try adding a push handle for interactivity. For more information, see “Push 
handle” on page 491.

Note: Push surface is different than the Push handle, which is an interactive push that Web Surfers 
perform on your objects. For more information, see “Push handle” on page 491.

To push a surface:
1. Select the surface.

2. Choose Model > Push Surface, turn on ( ) or press Y, then move your cursor over the 
surface in any viewport and hold the mouse button.

To adjust push settings:
1. In the Project Manager, expand Author Settings / Model / Push surface.

2. Adjust the settings in the Parameter Editor.

Push Surface settings

Modeling characters, and other uses of limbs 
You build a skeleton out of 1-bone and 2-bone limbs, then use surfaces for the outer skin. When 
you animate the limbs, the skin moves and bends with the bones. Limbs can also be used for 

Contact radius Determines how close the cursor has to be to the surface before the push 
takes effect

Deform depth Determines how much the surface is pushed in.
Deform radius Determines the distance around the contact point that defines the portion 

of the surface that is affected by the deformation. 
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other purposes and kinds of movement, for example a desk lamp’s movement can be defined 
using a 2-bone limb, and an insect’s antenna can be made out of 1-bone limbs, or scaled 2-bone 
limbs.

     About inverse and forward kinematics 
When you create limbs, you can use inverse kinematics (IK) and forward kinematics (FK) to 
animate characters.

The lamp’s movement is 
defined by a 2-bone limb.

The outer surfaces are 
skinned onto the limbs.

2-bone limbs

1-bone limb

AXS/Modeling_IK_lamp.htm
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IK allows you to create a simple bone structure, for instance, a leg (with the femur and 
shinbone). AXEL calculates the rotation values of both bones as you translate the shin. This 
means that you can simply select the shin and drag it around and IK updates the position and 
orientation of both bones: the rotation of angles and shape of the limbs is determined in a logical 
way as you manipulate the last bone.

With FK, rotation values of different limbs are keyed, so limbs are animated in a more traditional 
sense, allowing a larger degree of control than IK. You decide the exact rotation of each limb. It 
is therefore a more labor-intensive process, but you can still use the structure and dynamics of 
the bones to deform and animate surfaces.

In some circumstances, FK is more useful because some types of bone structures, like the spine, 
bend in ways that IK does not totally account for.

   1-bone limb 
A 1-bone-limb is a group containing a freely rotating bone constrained to a socket. The bone 
socket is similar to a shoulder or hip joint, but has much more freedom of movement. 
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When you translate the bone, it remains constrained to the socket. You can move the bone 
around in the socket. However, you cannot pull it out of the socket or move the socket by pulling 
on the bone. To move the socket and the bone, you must translate the limb group.

You can animate the bone by saving keys or animating it on a path. You can scale bones with 
the Scaling tool or by editing the bone’s Scale parameter.

The bone uses a Ball Joint constraint. You set rotation limits on the bone by editing the Ball Joint 
constraint parameters. For more information, see “Ball Joint constraint” on page 286.

You can apply constraints to the limb group and to individual bones; you can also add the limb 
group to other groups.

To add a 1-bone limb:
Choose Model > Add Limb > 1 Bone.
For examples of how to use limbs, refer to the “Snowman” and “Mr. Cactus” lessons in the 
AXEL Training or look for new tutorials on the MindAvenue web site.

Limb1 Parameters

BallJoint home angle Angle at which the limb is at rest. This angle is the starting point for limb 
rotation.

Mode Manipulation mode: 
Select IK to animate the character by translating the bone. 
Select FK to animate the character by rotating the bone. 
Select Home state to adjust the joint’s home angle. 
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     2-bone limb 
A 2-bone limb creates a pair of bones that can be used, for example, as a leg, where the socket 
is the hip, the first bone the femur, and the second bone the shin.

The first bone is constrained to the socket with a Ball Joint constraint. Like an arm in a shoulder 
joint, the bone can rotate freely inside the socket.

The second bone is constrained to the first bone with a pin joint constraint. The second bone 
rotates at the end of the first bone as if it were attached by a hinge. Like a shin in a knee joint, 
the bone can bend backwards, but not sideways or forward.

You can move the whole group by selecting the limb, or translate the second bone to take 
advantage of IK. The limb acts as a group so you can select it in the viewports by selecting on 
of its constituent bones, then clicking on this same bone again while holding ALT (Windows) or 
OPTION (Macintosh).

Ball joint 
constraint Bone 1 Pin joint Bone 2
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You can edit the parameters of the first bone, including the Ball Joint constraint parameters, and 
the second bone, including the Pin Joint constraint parameters. Adjust the angle limits on the 
constraints to better approximate realistic motion. For more information, see “Pin Joint 
constraint” on page 283 and “Ball Joint constraint” on page 286.

Note: Pin Joints and Ball Joints used for limbs have fewer parameters than the standard joints 
because some parameters are not applicable.

By default, the limb bends downwards. To make it bend in another direction, you rotate the 
whole limb group. In the following illustration, a limb was rotated 180 degrees on the X axis so 
that it could bend inwards.

To add a 2-bone limb:
Choose Model > Add Limb > 2 Bones.
For examples of how to use limbs, refer to the “Snowman” and “Mr. Cactus” lessons in the 
AXEL Training or look for new tutorials on the MindAvenue web site.

Limb 2 Parameters

      Example: Creating a simple skeleton with IK 
When creating a character, it is advantageous to use the power of inverse kinematics to animate 
it or make it interactive. IK allows you to control a leg for example, by pulling its ankle, while 

BallJoint home 
angles

Angles at which the first bone is at rest. These angles are the starting point for limb 
rotation.

PinJoint home 
angle

Angle at which the second bone is at rest. 

Mode Manipulation mode:
Select IK to animate the character by translating the second bone. 
Select FK to animate the character by rotating with a bone. 
Select Home state to adjust the joints’ home angles. 
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the 2 bones of the leg move and rotate accordingly. It is important to create a logical body 
structure so that the bones are correctly attached to one another. 

To the right, the human leg’s faces should be deformed, so the use of Skin is necessary. For more 
information, see 

A simple human skeletal structure could be constructed from the following: 

• A cube for the pelvis 

• Two 2-bone limbs for the legs 

• Two 2-bone limbs for the arms 

• One 2-bone limb for the back 

Create the Back bone:
1. Choose Model > Add Limb > 2 bones.

2. Rename the limb Back bone.

Robot leg Human leg

AXS/Modeling_Skin.htm


220 | AXEL V2 | User Guide

3. Select bone 2 and translate it up in the Front viewport so that the limb points upwards like in 
the picture above.

4. With only bone 2 of the Back bone still selected, scale it smaller a touch.
You can scale the individual bones of a two bone limb separately, as well as scaling the whole 
limb at once. This is very useful for using limbs with different sizes proportions, not 
necessarily just for the human form.

5. Translate the limb.
Its joint is probably bending and extending to the left of your screen, into the -X axis. You 
can rotate the limb so it bends in the right direction. 

Orienting the limb, and setting its angle limit:
1. To reorient the limb in the proper direction, select the whole limb—Back bone—in the 

Project Manager, then rotate it around its own local Y axis. You can try turning off the Select 
tool ( ) to lock the limb as selected, then toggling on the ( ) axis button to limit your 
rotation. You should rotate the limb in the Front viewport, and make sure constraints are 
displayed (D). 
Notice the small violet line that protrudes from the joint where the two bones meet. This is 
where the joint bends. As you rotate the limb in the Front viewport, this line should point into 
the screen along the -Z axis, because this is the axis into which we want the Back bone to 
bend.

2. To better approximate realistic motion of a character, set angle limits for the joint constraints 
on limbs. For example, for the Back bone, first select the Pin Joint constraint for the limb in 
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the Project Manager, which is assigned to the top bone—by default named Bone2. In the 
Parameter Editor, turn on Enable angle limits, then set Minimum and Maximum values. 

Repeat the process for the Ball Joint constraint. You can test the joints in the viewports and 
watch the yellow lines that define the angle limits.

3. Repeat the above steps for the Right arm, Left arm, Right leg and Left leg, all created from 
2 bone limbs. Be sure to rotate each limb so that it bends in the appropriate direction, using 
the violet line on the joint to guide you. 

4. Create a cube, then translate all the limbs into the position shown in the first picture in this 
section.

Constraining the limbs to form a skeleton:
1. Make sure your constraints are off to preserve offsets.

2. Select the Right leg limb then the pelvis/cube, then choose Relate > Constrain Pose.

3. Repeat for the Left leg.
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4. For both arms, you have to constrain their pose to the top bone (Bone 2), of the back bone. 
This way, when you move this bone the skeleton’s arms move in tandem.

5. Create a group with all these elements and call it Skeleton. 
Using this type of setup enables you to animate the whole character by moving the group, having 
her sway and move up and down by animating the pelvis, and making her walk and gesticulate 
by animating the end bones of her arms and legs. 

Once satisfied with the setup, you can now hook it up to your character! 

Here are all the limbs of the skeleton properly constrained. Notice the violet lines 
defining where the limbs bend, and the pose constraints—the straight turquoise 
lines—attaching all the limbs together.
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If your character has elements that are not going to be deformed, simply pose-constrain them to 
the nearest limb. 
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   Using home state 
Think of the home state as a convenient position from where you can animate your character. 
You can set the home state for one limb at a time, or for the entire character. You can then go to 
the home state to reset the character to this starting point in order to add skin or create further 
animations.

To set the home state for one limb:
1. Select the limb.

2. In the Parameter Editor, set the mode to Home State, then adjust the home angles.

3. To animate the limb, set the mode to IK or FK.

To set the home state for several limbs at once:
1. Manipulate the limbs into the positions that you want to use as the character’s home state.

2. Choose Model > Modify Limb > Reset Home State.
The character’s current position becomes its home state. For each limb, the current angle 
becomes the new home angle.

To move limbs into their home state:
Select the limbs and choose Model > Modify Limb > Go to Home State.
The limbs move into the position you defined as their home state.

The character’s limbs are 
reset in this home state.

The character’s limbs return 
to their home state.

The character is 
animated walking along.
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     Skin 
Use the Skin command to deform a surface or a group of surfaces using other surfaces or limbs. 
For example, you can create a character with various surfaces and then create a group of 
deforming surfaces, which you can animate to make the character walk, talk and smile.

It is often useful to add subdivisions to the object that will act as the skin before you use the skin 
command, to increase the edges where the object can be deformed. For more information, see 
“Subdividing and simplifying surfaces” on page 206.

For other examples of how to use skin, refer to the “Snowman” and “Mr. Cactus” lessons in the 
AXEL Training or look for new tutorials on the MindAvenue web site.

Example: Using skin
1. Create a sphere. Choose Model > Add Surface > Sphere. 

2. Scale the sphere to 5 times its original size on all three axes. 

3. Create a cone, a cube, and a cylinder and place them inside the sphere.

4. In the Project Manager, first Select the sphere, then SHIFT-select the cube, the cone and the 
cylinder.
The first surface selected is the skin and the others will be the deformers. 

Note: To deform several surfaces at the same time, for example, a foot, a sock and a shoe, you 
must group them, then select the group, and then SHIFT-select all the deformers. You can also 
create a second group containing all the deformers.
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5. Choose Model > Apply Skin. 
A Skin deformation appears under the sphere in the Project Manager.

6. Select any of the three deformers and scale, rotate and translate them. 
Notice how the sphere is deformed. Each face of the sphere follows the closest deformers 
according to a weighting proportional to their distance from each deformer. The skin follows 
the center of the deformer objects; the size of the objects is not important. In the following 
illustration, the top part of the sphere is mainly affected by the cone.

Note: To remove the deformation, delete the Skin in the Project Manager, then adjust the sphere 
parameters in the Parameter Editor. The sphere is redrawn based on its geometry parameter 
settings. 
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    Text
You can create three kinds of text:

• Text surfaces, which you can translate, scale, and rotate in 3D space. 

• Text curves, which separate the letters of a text into individual curves that are grouped together. You 
can manipulate the whole text as a group or each letter individually. 

• Text layers, which are like titles placed in front of, or behind, the 3D World. 
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Creating text surfaces
A text surface is like any other 3D surface. You can translate, scale, or rotate a text surface, 
animate its parameters, include it in relations, animations, and interaction. Edit its points or 
change its shape using push or bend tools. You can even add an image or movie texture to the 
text surface.

To create a text surface:
1. Choose Model > Add Text or click ( ).

2. Enter the text and select a font and font style in the Text dialog that appears, then click ADD
The text appears in the center of the World and a text object appears in the Project Manager.

Note: The size of the text is determined by its Scale value; the font size is not important. 

3. Adjust the text parameters in the Parameter Editor. 

To adjust the thickness of a text surface:
1. Select the text surface and expand the TextGeometry parameters.

2. In the Parameter Editor, turn on Extrude.

3. Do one of the following:

• Adjust the Extrusion depth.
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• Scale the text along its Z axis. Press E to turn on the Scale tool, then SHIFT + RIGHT MOUSE 
BUTTON-drag (Windows) or SHIFT+CONTROL-drag (Macintosh) the text using the mouse 
button. 

To manipulate text:
Select the text surface and do one of the following:

• Turn on the Scale, Rotate, or Translate tool or press E, R, or T, then drag the text in the viewports.

• Adjust the Position, Orientation, and Scale values in the Parameter Editor.

Languages and Font Types
You can use any font type in any language that is installed on your system, but it is recommended 
to Publish the text as outline, which is a command only available for 3D text, so that users do 
not need to have the font installed on their system in order to see it.
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Surface text parameters

Position Determines the position of the text in 3D space.The center of a text object is—by 
default—in the lower left corner of the first letter.

Orientation Determines the orientation of the text.
Scale Determines the size of the text. 
Visible Displays/hides the text in the viewports.
Antialiasing Makes the text outlines smoother. For more information, see “About antialiasing” on 

page 594.
Number of 
Points

Number of points that define the text. Increasing the precision of the text increases 
the number of points, which in turn increases the download time of the published 
web page. 

Single sided Displays only one side of the text. Turn off Single sided to see the inside and the out-
side of the text.

Smoothness Since polygonal surfaces are not smooth, but a collection of flat planes, smoothness 
creates an illusion of surface roundness. 

Crease control Use crease control for fonts that have both hard edges and round surfaces. If you turn 
on smoothness without crease control, all the angles are rounded. Turn on crease 
control to disable smoothness for sharp angles. 

Crease angle Defines minimum angle for smoothness to take effect. For example, if you use a low 
crease angle threshold such as 10, faces are visible if the angle between 2 faces is 
higher than 10 degrees. A higher crease angle threshold such as the default 60 
degrees smooths all but the sharpest angles. 

Coloring Determines how color is applied to the text. You apply color per point, per face, or 
to the entire text surface. For more information, see “Color per point, per face” on 
page 314.

Frozen Hides the surface geometry parameters. 
A text surface freezes if you add, move, or delete points, subdivide it, or simplify it. 
It also freezes if you set the coloring to Per point or to Per face, or edit texture coor-
dinates.
When the surface is frozen, AXEL draws the surface based on its points, not its 
parameters. If you turn off Frozen, the surface is redrawn, any points you modified 
move back to their original position, and edited point colors revert to the material 
color.

Text The letters or words that appear in the World.
Font name The font used to create the text.
Font style Sets the text to regular, italic, bold, or bold italic.
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Precision Determines how much the shape of the text can deviate from the original font shape. 
Increasing tolerance reduces the polygon count but it also reduces the quality of the 
text. Adjust the tolerance to get the right balance between quality and performance. 

Extrude Extrudes the text to give it thickness.
Extrusion depth Determines the depth of the text.
Publish outline Saves an outline of the text for the published web page so that the text’s font does 

not have to be installed on the local system to display correctly. If the text’s points 
are modified, you cannot publish the outline of the text.

Streamable Makes the text surface streamable so that a surfer can open a page and view the 
World without this text. The text appears when all its information is downloaded.

Streaming 
priority

Determines the priority in which the text surface is downloaded.

Precision = 100 Precision = 75 Precision = 25
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Creating a text layer
A text layer is a 2D layer of text in front of, or behind, the 3D World. You can animate its 
position, size, and color. You can include it in relations, animation, and interaction, but you 
cannot rotate the text. It is always in front of or behind the 3D World, unless it is projected.

If you want to constrain the text layer to an object, move it on the Z axis, or add a handle. The 
text must be projected so that it is within the 3D World with an X Y Z position.

To create a text layer:
1. Choose Model > Add Text Layer.

2. Enter the text and select a font, font style and size in the Text dialog that appears, then click 
ADD. 
The text appears at the lower left corner of the WebCam viewport. 

3. In the Parameter Editor, expand TextGeometry.

4. Adjust the text geometry parameters. 

To position a text layer relative to the viewport:
1. Select the text layer.

2. In the Parameter Editor, expand TextGeometry.

3. Turn off Projected and set the 2D Position. 
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If you resize the viewport, the text maintains it relative distance from the edge. For example, 
if you set the 2D Position to 50 50, the text always starts in the middle of the viewport, or in 
the middle of the browser window after it is published.
Notice when you orbit or zoom in WebCam view, the text does not move. Its position is 
relative to the viewport; it is independent of the 3D World.

Note: You can only manipulate a text layer in the viewports if it is projected.

To position the text layer in front of a point in the 3D World:
1. Select the text layer.

2. In the Parameter Editor, set the Position field to the X Y Z position above which you want 
the text to appear. 

3. Expand the TextGeometry parameters and turn on Projected.
The text appears in front of the X Y Z position that you specified. When you pan, orbit or 
zoom in WebCam view, the text moves so that it is always in front of or behind the same point 
in the 3D World. 

Tip: If you apply a pose constraint between the overlay text and an object, the text always appears 
in front of that object. 
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2D text layer parameters

Text The letters or words that appear in the World.
2D position / 
Position

Positions the text object relative to the viewport. The first number is the distance 
from the left edge as a percentage of the size of the viewport. The second number is 
the distance from the lower edge as a percentage of the height of the viewport. When 
the content is published, the text will be at the same relative distance from the edges 
of the surfer’s browser window. This option is available only when Projected is 
turned off. 
With projected turned on, a Z axis is added. This parameter now determines the point 
above which the text is projected within the World. The center of a text layer is in 
the lower left corner of the first letter.

Visible Displays/hides the text in the viewports.
Projected Places the text object in front of a specific point in the 3D World. This point is deter-

mined by the text object’s X Y Z position value.
Layering Determines the text position relative to other 3D text objects. With Overlay, the text 

layer is in front of 3D objects, and conversely, with Underlay, the text is behind 3D 
objects.

Font name The font used to create the text.
Font style Sets the text to regular, italic, bold, or bold italic.
Font size Determines the size of the text.
Color Determines the color of the text.
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Converting text to curves
You can convert a text surface into curves. The letters are separated into individual curves that 
are grouped together. You can then manipulate the text’s letters individually or together as a 
group.

To convert text to curve:
1. Click a text surface in the viewports or in the Project Manager.

2. Choose Model > Convert Text to Curve.
The curves appear on the face of the text surface in the viewports and may have to be 
translated to be viewed properly. In the Project Manager, the curves appears as a group, with 
the text in quotes. The group consists of the letters of the text, each now a separate curve. The 
group’s center is at the World Origin, while each letter has its own proximate center.

Note: You cannot convert a text layer to a curve.
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Embedding fonts using Publish as outline
You can create text in any vector font available on your system (TrueType, OpenType, for 
example) but after you publish the content, surfers will only see the font if it is available on their 
system. If the .axs stream uses a font that is not available on the surfer’s system, the font is 
replaced by the surfer’s system’s default font.

For this reason, you can use the Publish as outline parameter, or convert the text to curve, so that 
the fonts you use in your project do not have to be installed on the surfer’s computer.

To publish text as an outline:
1. Select a text surface.

2. In the Parameter Editor, expand TextGeometry, then turn on Publish outline.

Note: If the text’s points are modified you cannot publish the outline of the text. If you turn off 
frozen, the text reverts to its default shape and you can then publish it as an outline. 

Common Fonts
The following fonts are standard with Microsoft Internet Explorer, so they should be available 
on most surfers’ computers, both in Windows and on the Macintosh.

• Arial (normal, bold, italic, bold italic)
• Arial Black (normal)
• Comic Sans MS (normal, bold)
• Courier New (normal, bold, italic, bold italic)
• Georgia (normal, bold, italic, bold italic)
• Impact (normal)
• Times New Roman (normal, bold, italic, bold italic)
• Trebuchet MS (normal, bold, italic, bold italic)
• Verdana (normal, bold, italic, bold italic)
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Chapter 5
Relations

After creating 3D models, you can constrain them to 
each other to affect their behavior. Have them 
behave in a realistic manner, for example by making 
a door rotate around a hinge, or create original 
behavior, such as a basketball that can only follow a 
specified trajectory: into the hoop!

Learn about the different constraints AXEL 
provides. When you lock constraints, your relations 
take effect and your models behave as specified. 
Unlock constraints to adjust this behavior or to 
maintain the differences between objects as you add 
constraints to them.

You can even create complex custom relations with 
scripting.

You can group objects to work with them like they 
are a single object. For example, group the 
components of a robot, then apply a direction 
constraint so the robot group always faces a bottle of 
oil. Otherwise, you would have to apply constraints 
to each component.

In this chapter:

Using groups ....................... 257

Using constraints ................. 261

Pose constraint .................... 271

Distance constraint .............. 272

Direction constraint ............. 273

Curve constraint .................. 274

Snap constraint .................... 277

Spring constraint ................. 279

Bounding box constraint ..... 280

Bounding sphere constraint 
282Pin Joint constraint 283 

Ball Joint constraint ............ 286 

Slider Joint constraint ......... 288 

Custom relations ..290 
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    Using groups
When you group objects, you can manipulate them as a whole. You can add relations and 
interaction to the group as well as to its individual objects. You can animate the whole group, 
for example, a robot, and then animate one of its objects separately, for example, an arm.

You can have a group within a group. For example, the head with its eyes and mouth could be 
a group within the whole robot group.

Animations and constraints applied to sub-objects or sub-groups always override the constraints 
and animations applied to the group. In the case of the robot below, you can first animate the 
whole Robot group moving forward, then its head, which is a sub-group, rotating left and right.

When you create a group, its center is at the World origin (0,0,0).

To create a group:
Multi-select the objects you want, then choose Relate > Group or press CTRL+G (Windows) 
or COMMAND+G (Macintosh).

head 
group

body 
group

Robot 
group
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To select a group:
Do one of the following:

• In the Project Manager, click the group’s icon ( ).

• In the viewport, click once to select the object, then ALT-click the object again to select the group 
(Windows) or OPTION-click the object again to select the group (Macintosh).
If the group is nested within other groups, each time you ALT-click (Windows) or OPTION-
click (Macintosh) a member of the group you move up a level.

To select all the objects in a group:
In Windows, ALT-click the group in the Project Manager.
On the Macintosh, expand the group in the Project Manager, then range-select its objects. To 
range-select, drag a rectangle over the list, or click the first item, then SHIFT-click the last.

To rename a group:
In the Project Manager, click the group, then in the Parameter Editor type a new name in the 
name field. 

Click the object to select it. ALT-click (Win)/OPTION-click 
(Mac) selects the nested group.

Second ALT-click (Win)/
OPTION-click (Mac) 
selects the Big group which 
includes the Little group.
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To add an object to a group:
1. In the Project Manager, select the group.

2. SHIFT-select the object you want to add, then choose Relate > Add to Group.

To remove an object from a group:
1. In the Project Manager, select the group.

2. SHIFT-select the object you want to remove from the group, then choose Relate > Remove 
from Group.

To ungroup objects:
1. In the Project Manager, select the group.

2. Choose Relate > Ungroup.
The objects are removed from the group and the group is deleted.

To show / hide a group:
Select the group, and turn on/off Visible in the Parameter Editor.
All the objects in the group disappear in the viewports. If you turn the group’s visibility back on, 
all the objects reappear.
New objects added to the group later do not inherit the visibility parameter of the group. For 
example, if you add a sphere to a group of invisible cones, the sphere remains visible.

To manipulate a group:
1. Select the group.

2. Lock the selection by turning off the Select tool.

3. Turn on a manipulation tool, then drag the group in the viewport.
All objects in the group follow the group as you move it, except if they are otherwise 
constrained or animated in such a way as to prevent them from following the group.

Note: You can also lock the selection by holding a manipulation keyboard shortcut (E, R, or T), 
then dragging the group in the viewport.

To move the center of a group:
1. Select the group, then switch to Center mode (J).

2. Turn on Translate and drag the center in a viewport.
The center of the group moves without changing the position of the objects in the group. 
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Note: When you create a group, its center is at (0,0,0).

To duplicate a group:
1. In the Project Manager, select all the objects in the group:

• In Windows, ALT-click the group.

• On the Macintosh, range-select the objects in the group by expanding the group, then 
SHIFT-clicking the first and last object in the group.

2. Choose Edit > Duplicate, or press CTRL+D (Windows) or COMMAND+D (Macintosh).
All the objects in the group are duplicated. The duplicated objects appear above the group in 
the Project Manager.

3. With the duplicated objects still selected, choose Relate > Group, or press CTRL+G 
(Windows) or COMMAND+G (Macintosh).
The duplicated objects are grouped. This group is a copy of the group you selected in step 1.

Note: Although you cannot select a group and duplicate it, you can duplicate all the objects in a 
group, then group the duplicates. You also use the Import AXEL Project command to create 
multiples of complex objects or groups that include relations and animation. For more information, 
see “Importing AXEL projects” on page 100.
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To add a constraint to a group:
1. In the Project Manager, first select the follower group, and then SHIFT-select the leader group 

or object.

2. Choose a constraint from the Relate menu.

Using constraints
When two objects are linked by a constraint, one object is the leader and the other is the follower. 
The follower is attached to the leader, and its motion is limited. The leader is free; when you 
move or rotate it, the follower moves along in a defined way, depending on the type of constraint 
that connects them. 

You can unlock constraints to adjust the position, orientation, or scaling of constrained objects. 
You can show or hide constraints in the viewports, including in WebCam viewports.

Objects can have more than one constraint, and you can adjust the importance or weight of each 
constraint. You can create constraints between individual objects, objects and groups, or 
between groups. You can also add constraints to WebCams and the WebCursor.

AXS/Constraints_All.htm
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Constraints and centers
Objects’ centers are crucial to constraints. This is because when you relate two objects, you are 
often usually relating these objects’ centers because their centers serve as their position, 
orientation and scale reference. For example, if you relate one object to another using a 
Direction constraint, by default you will be constraining the first object’s X axis to always be 
aligned with the second object’s center. You can later change precisely which axis lines up.

The satellite is constrained to the center of the rocket.

When you translate the rocket’s center the satellite follows.
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   Adding constraints
The workflow for adding constraints between objects or groups is simple: multi-select the 
follower and the leader in that order, then choose the constraint. 

For example, if you want a cube to stick to a position vis-à-vis a sphere, first you select the cube, 
then you select the sphere, and then you add the constraint.

When creating a relation between two objects, AXEL uses a default value. For example, if you 
constrain an object’s direction, by default, the object’s X axis will point towards the target. If 
you add a pose constraint to an object, by default, the object will be placed over the target object, 
immediately taking its position, orientation and scale values. To get the results in the picture just 
above, where a position offset exists, you simply add the Pose constraint with the constraints 

unlocked ( ) which leaves the space between the two objects as is. For more information, see 

“Unlocking constraints” on page 265.

Example: constraining a cube to a sphere:
1. Select the cube (the follower).

2. SHIFT-select the sphere (the leader).

Note: The order is important: the first object selected is the follower and the second is the leader.

3. Click the Unlock button ( ).
This allows you to adjust freely the offset of constraints. 

Pose constraint
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4. Choose a constraint from the Relate menu. For example, choose Relate > Constrain Pose.
The constraint appears in the Project Manager under the cube.

5. Select the constraint and adjust its parameters. To select the constraint, click the turquoise 
constraint in the viewport or select the constraint in the Project Manager or Parameter Editor.

6. Click the Lock button ( ), and test the constraint. When you drag the sphere, the cube 
follows. You can no longer drag the cube independently because its pose is constrained to the 
sphere.

7. To adjust the offset between the cube and the sphere, click Unlock ( ), then adjust the 
position of the cube. When you are satisfied, click Lock ( ) to enable constraints once 
again. 

Constraint

Pose constraint

Pose constraint parameters
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Showing and hiding constraints
You can show the constraints in the viewports—including WebCam viewports—to see how the 
behavior of objects is constrained and to adjust the constraints. You can also hide the constraints 
in the viewports. 

To show/hide constraints in a single viewport:
1. Click a viewport.

2. Choose View > Active Viewport > Show/Hide Constraints.

To show/hide constraints in all the viewports:
Choose View > All Viewports > Show/Hide Constraints. 

Note: If you publish your content with constraints turned on, they show up in the published 
content.

    Unlocking constraints
By unlocking constraints, you can manipulate objects that are constrained to other objects. In 
other words, you unhinge the follower object from its leader so that you can manipulate it freely. 
By locking constraints once again, the follower is constrained to the leader in this new 
relationship.

Depending on your style of work, as well as the type of constraint to be added, you may want to 

unlock constraints ( ) before adding a new constraint between objects. 

Constraint parameters have default values that determine the offsets between the objects. If the 
Lock button is on, the default offsets are applied to the objects as soon as you add the constraints. 
For example, a spring constraint has a default rest length of 1 unit. If you add a spring constraint 
between a Jack-in-a-Box and the box its springs from, the Jack-in-a-Box bounces around and 
stops 1 unit from the box. If you want the Jack-in-a-Box to end up in its original position, unlock 
constraints before adding the spring. This allows you to adjust the constraint offsets before they 
affect the objects.

To unlock constraints:
Choose Relate > Unlock Constraints or click the Unlock button in the Top toolbar (Windows) 
or the toolbox (Macintosh). 
You can also temporarily unlock constraints by holding the U button as you readjust offsets 
between constrained objects.
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Example: Unlocking a direction constraint
1. Create a cone and a cylinder and move them apart.

2. Click Unlock ( ).
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3. Multi-select the cone and the cylinder, in that order, then choose Relate > Constrain 
Direction.
A constraint is added to the cone. When you move either object, the cone rotates to 
continuously face the cylinder in the same direction.

4. Say you want the cone’s tip to point at the cylinder. You turn on Rotate (R) and drag the cone, 
but the cone rotates only around its X axis. This is the axis that is constrained to point at the 
cylinder because it is the default when you add a direction constraint. You can change this by 
switching the Constrained direction in the Parameter Editor.

5. To unlock the constraint, click Unlock ( ), then drag the cone. You can also hold the U 
button to temporarily unlock the constraint as you readjust the offset.
The cone rotates freely and you can make its tip point at the cylinder. With constraints 
unlocked, you can adjust the offset of the constraint. In the case of a Direction constraint, the 
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offset is the axis of the follower that is constrained to point at the leader. In the picture below 
of a simple cone, this is the cone’s +Y axis.

If you click Lock ( ), the constraints will be active again. When you translate either object, 
the cone rotates so that its tip always points at the cylinder.

   Using weight to control multiple constraints
The concept of weight applies when several constraints affect one object. The weight of a 
constraint determines its strength compared to the other constraints.

For example, if a WebCam has Direction constraints to both a sphere and a cube, they both affect 
its orientation equally and the WebCam points in the middle of two. If you increase the weight 
of the constraint to the sphere, the WebCam favors the sphere. If you increase the weight of the 
constraint to the cube, the WebCam favors the cube.

Note: Weight also applies to the animation of position, orientation and scale. Therefore, weights 
of constraints will affect animation and vice versa. 
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    Constraining objects to the WebCursor
The WebCursor is just like any regular cursor that moves on the screen because of movement 
from an input device—usually the Web Surfer’s mouse. In AXEL, the WebCursor appears in the 
Project Manager.

You multi-select objects with this icon in the Project Manager in order to constrain objects to 
the WebCursor, so that when the cursor moves, then the follower object will transform along 
with it.

Examples could be constraining the pose of an object to the WebCursor so the object follows the 
cursor wherever it is on the screen, or constraining the direction of an object to the WebCursor 
so that the object faces the cursor wherever it is on screen. You can constrain a WebCam to the 
WebCursor, then the view you follow the wherever the mouse rolled. You might carry through 
this principle to create a full navigation system.

You also use the WebCursor icon in the Project Manager for other purposes. For example, you 
can create a Proximity Sensor between the WebCursor and an object. For more information, see 
“Proximity sensor” on page 473.

Example: Constraining the direction of a cone to the WebCursor:
This example shows how to make a cone point at the cursor as the WebCursor rolls over the 
AXEL content.
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To constrain the direction of a cone to the WebCursor:
1. First select the cone, and then the WebCursor in the Project Manager, in that order.

2. Choose Relate > Constrain Distance.

3. Adjust the Direction Constraint’s parameters.
In particular, you probably will want to adjust the Cursor Depth Factor, which, because we 
are dealing with 3D space in AXEL, sets how deep into the screen the cursor is for the 
purpose of this constraint. For more information, see “Cursor depth factor” on page 274.

The Direction Constraint ties the 
cone to the WebCursor, which 
appears in brackets here.
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Pose constraint
This relation constrains an object’s position, orientation, and scaling values (or any combination 
of the three) to another object. In the following illustration, the hammer clings to the magnet. 
When the magnet is moved, rotated and scaled, the hammer matches all these changes.

Example: to constrain the hammer to the magnet:
1. Multi-select the hammer and then the magnet, in that order.

2. Click Unlock to maintain the differences between the two objects. Otherwise, in the next step 
the hammer will immediately conform to the magnet’s position, orientation, and scale values.

3. Choose Relate > Constrain Pose.
When you drag the magnet, the hammer follows. Conversely, you cannot drag the hammer 
away from the magnet. When you translate, scale, and/or rotate the magnet, the hammer’s 
position, orientation, and scale values are updated accordingly.

4. Select the constraint and adjust the constraint parameters in the Parameter Editor.

Pose constraint parameters

Active Toggles the constraint on and off. 
Weight Determines the weight of this constraint in relation to other constraints acting 

on the same object.
Constrain position Toggles the position constraint on and off. 
Constrain orientation Toggles the orientation constraint on and off.
Constrain scale Toggles the scale constraint on and off. 
Position offset Offsets position in units (X,Y,Z). You can set offsets interactively by unlock-

ing constraints then manipulating the follower object.
Orientation offset Offsets orientation in degrees along all three axes (X,Y,Z). 
Scale offset Offsets scaling along all three axes (X,Y,Z). 

AXS/Relations_Pose.htm
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    Distance constraint
This relation forces one object to continually maintain a certain distance from another. The 
distance is measured from the centers of the objects. For example, if the cube has a distance 
constraint of 3 in relation to the sphere, no matter where you move the sphere, the cube is always 
3 units away. 

Note: With a pose constraint, you can make one object rigidly follow another by a certain distance; 
a distance constraint allows the object to be loose while maintaining the specified distance.

Example: to constrain the distance of the cube to the sphere:
1. Multi-select the cube and then the sphere, in that order.

2. Choose Relate > Constrain Distance.
When you translate the sphere, the cube moves around to maintain a specific distance from 
the sphere. You can also translate the cube, but it moves in such a way that it keeps the same 
distance from the sphere.

3. By default the constrained distance is 1 unit. To change this distance, do one of the following:

• In the Project Manager or Parameter Editor, select the constraint under the cube then 
change its Distance parameter.

• Turn off the Lock button to disable constraints, then translate the cube in the viewports. 
When it is at the desired distance from the sphere, turn on the Lock button. Notice the 
Distance parameter is updated in the constraint parameters. 

Distance constraint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to other constraints acting on the 

object.
Distance Determines the distance in units separating the two objects.

AXS/Relations_Distance.htm
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    Direction constraint
This relation forces one object to continually point at another. The follower rotates so that one 
of its axes (by default X for surfaces and curves and - Z for camera and spotlights) is always 
aligned with the position of the leader.

For example, you can add this constraint between a WebCam and an object so that the WebCam 
always points at the object.

Example: to constrain the direction of the camera so that it points at the cone:
1. Multi-select the camera and then the cone, in that order.

2. Choose Relate > Constrain Direction.
When you translate the objects, the camera continually rotates to point at the cone.

AXS/Relations_Direction.htm
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Direction constraint parameters

    Curve constraint
This relation constrains an object to a curve. This can be useful to guide objects through 3D 
space without banging into other objects, for example when a character moves through a 

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to other constraints acting 

on the object.
Constrained direction Determines which of the follower’s axes is aligned with the leader’s center. 

The axis can be +X, +Y, +Z, -X, -Y, -Z or Other Axis where you specify a 
precise axis in Direction. 

Direction This parameter appears when the Constrained direction is Other Axis. It 
determines the orientation of the Other Axis, that is, the direction of the align-
ment between the follower and the leader. It can be set interactively by 
unlocking constraints and rotating the follower, or by entering precise values.

Cursor depth factor When a direction constraint is placed between an object and the web cursor, 
the Cursor depth factor determines the distance, in depth, between the object 
and the cursor relative to the camera. The default value of 95 places the cursor 
slightly in front of the object. At 100 the cursor is at the same depth as the 
object; at 0 the cursor is on the WebCam Near Plane: at 110 the cursor is 
behind the object. If the cursor is close to the object, the object has to turn 
suddenly to follow it.

Cone constrained in its +X 
direction (1 0 0). 

Cone constrained in its +Y 
direction (0 1 0)
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corridor in a 3D game. The distance tolerance allows latitude—allowing the object to move a 
prescribed distance off the curve—and makes the constraint less obvious.

Tangency aligns the object with the curve.

Example: to constrain a tractor to a path:
1. Multi-select the tractor and then the path, in that order.

2. Choose Relate > Constrain to Curve.
When you translate the tractor, it moves along the path.

Tangency Off Tangency On

AXS/Relations_CurveCns.htm
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Curve constraint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to others constraints on the 

same object.
Position type Determines the position parameter type, which measures the location of the 

object along the curve. The value is either a percentage (0% at the beginning and 
100% at the end of the curve) or point number (the point number along a curve).
You can decipher which is first and last point on a curve by its color, when the 
curve is selected. For more information, see “Point colors for visual cues in 
viewports” on page 162.

Position 
parameter

Determines the object’s location along the curve.

Free position Toggles the Free position parameter on and off. When an object has a free posi-
tion on a curve, it is loose along the curve. When turned off, the object is locked 
in position on the curve and cannot be translated. To animate it along the curve, 
you can animate its Position parameter.

Distance 
tolerance

Tolerance value in units by which the object can wander off the curve.

Enable tangency Aligns the object with the curve. 
Tangency axis Determines which axis of the object is tangent to the curve. By default, the +X 

axis (1, 0, 0) lines up with the curve. You can select +X, +Y, +Z, -X, -Y, - Z, or 
Other axis for which you can specify a precise axis value in Constrained axis.

Constrained axis When you choose Other axis for the Tangency axis parameter, this is the axis of 
the object that is tangent to the curve.
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 Snap constraint
This relation creates a position and rotation connection between two or more objects. You can 
interactively manipulate the constrained object. 

When using handles to manipulate an object that has a Snap, the constrained object can either 
move or orient itself to the closest snap target as you are manipulating it, or only reconnect and 
reorient itself to the closest snap target when you release it. This depends on whether the 
Override other parameter is turned on for the handle you are using to manipulate the object. If 
Override other is turned on for the handle, you have control of the object until you release it, 
otherwise the object is attracted to its targets continuously. 

Other handle parameters also effect how your snaps take effect. For more information, see 
“About mixing effects and mixing weight” on page 486 and “Using handles” on page 486.

You can choose how much time the object takes to reconnect.This constraint can be useful if 
you want the surfer to freely move objects, but have them land safely in pre-determined 
positions and orientations.

Example: to apply a snap constraint between the cup and saucers:
1. Multi-select the cup and then the saucers, in that order.

2. Choose Relate > Add Snap.
If play is on and you drag the cup, it snaps onto the closest saucer. 
You can increase the Snap’s transition period to allow the cup to be moved around before it 
snaps back into position when released.

Note: You can repeat the previous step with any number of targets.

AXS/Relations_Snap.htm
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Snap constraint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of the constraint in relation to other constraints acting 

on the same object.
Constrained position Determines the point of the object that will snap to the target. By default the 

constrained position is the center of the object. This allows you to offset that 
point (in X,Y, Z units). For example, if you are snapping a coffee cup to sau-
cers, you can use the bottom of the cup as a constrained position so it does 
not go through the saucer.

Transition period Time in seconds the object takes to snap back into position when released. 
Having a period of 0 forces the object to stay on its target. It only moves if 
the cursor is dragged close enough to another target.

Target Position Determines an offset (in X,Y, Z units) from the actual target for the object to 
snap to.

Target Orientation Allows you to modify the orientation of the object as it hits the target. Keep 
in mind that an object relates to its target’s orientation by both its own cen-
ter’s orientation and the target’s center’s orientation—in essence orienting 
the object the same way as the target via their centers. Target orientation adds 
an offset to this orientation, so for example if you add a snap constraint 
between a cone and a cube, entering values of -90 0 0 points the cone into the 
-Z axis. 

If the center of either object is rotated the snap is effected, preserving the tar-
get orientation offset between the objects as specified in this parameter.
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Spring constraint
This relation creates a spring-like constraint between two or more objects. For example, if a 
sphere has a spring constraint linking it to a cube, and you pull the sphere away from the cube, 
it springs back within a determined distance, bouncing around like a superball.

You can control the length of the spring, its tension, as well as the resistance the follower 
encounters as it springs into place.

Example: to apply a spring constraint between a cube and a sphere:
1. Multi-select the cube and then the sphere, in that order.

2. Choose Relate > Add Spring.

3. Turn on Play (SPACEBAR) to see the effect of the constraint.
When you Translate the cube, it bounces back towards the sphere. When you translate the 
sphere, the cube follows, bouncing around behind it.

Spring constraint parameters

Active Toggles the constraint on and off.
Rest length Determines the distance in units at which the object comes to rest vis-à-vis the leader. 

For example, if the rest length is 0, it comes to rest on upon the leader object. If the 
rest length is 2, it comes to rest 2 units from the leader.

Springiness Determines the strength of the spring. A low value makes the object slowly spring 
back to its original position, whereas a higher value tightens the spring making the 
object bounce quickly into place.

Resistance Attenuates the strength of the bouncing. A higher value makes the constrained object 
or group seem to be moving through molasses!

AXS/Relation_Spring.htm
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Bounding box constraint
This constraint creates an invisible box within which the constrained object must remain. An 
object could therefore be moved by Internet surfers but only within a certain area. For example, 
a bounding box could limit the movement of the object to the viewable screen—without the 
bounding box the object is free to move right off the screen!

This constraint keeps an object either inside or outside a box. In the following illustration, the 
jackhammer is constrained to a cube, which is invisible. The jackhammer can move around 
freely but not outside the boundaries of the cube. An alternative is to make sure that an object 
does not enter a specific box. This might be useful, for example, to keep the jackhammer above 
ground.

As with all constraints, first the constrained object is selected, and then the actual bounding box 
of the geometry of the second object is used as the bounding box of the constraint. This 
bounding box can be translated, scaled, rotated, and animated. The constraining object can be 
any object.

Tip: Another interesting example is to force an object to stay on the ground by constraining it to 
the bounding box of a plane, which is only two dimensions.

Example: to constrain the jackhammer to a bounding box:
1. Add a cube to use as a bounding box.

2. Multi-select the jack-hammer and then the cube, in that order.

3. Choose Relate > Constrain to Bounding Box.

4. Scale the cube to the desired dimension and turn off its visibility.
You can drag the jack-hammer freely inside the cube, but you cannot drag it outside the cube.

AXS/Relations_Bounding_Cube.htm
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Bounding box parameters

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to others constraints acting 

on the same object.
Inside Constrains the object to stay inside the box. When Inside is turned off, the 

object cannot enter the box. Toggling this parameter off can be useful, for 
example, to create rudimentary collision detection forcing objects to avoid 
others as they pass through space.

Geometry 
constrained

Uses the object’s outer geometry when calculating if the object has reached 
the bounding box limits. When this option is on, a sphere appears around the 
constrained object, and it is the outer radius of the sphere that determines 
when the object has reached its limit. When Geometry constrained is off, the 
object’s center serves as the constraining reference.

Geometry constrained Geometry constrained 
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 Bounding sphere constraint
This constraint is identical to the bounding box but uses a sphere, determined by a radius. It 
creates an invisible sphere within which the selected object must remain. An object could 
therefore be moved around by Web Surfers but only within a certain radius.

The constraining object can be any object. The actual bounding sphere of the geometry of the 
constraining object—that is an imaginary sphere defined by the outer limits of the object—is 
used as the bounding sphere of the constraint. As with any object, the constraining object can be 
translated, scaled, rotated and animated.

Example: to constrain the jack-hammer to a bounding sphere: 
1. Create a sphere to use as a bounding sphere.

2. Multi-select the jack-hammer and then the sphere, in that order. 

3. Choose Relate > Constrain to Bounding Sphere.

4. Scale the sphere to the appropriate size and toggle off its visibility.
You can drag the jack-hammer freely inside the sphere, but you cannot drag it outside the 
sphere.

Bounding sphere parameters

Active Toggles the constraint on and off. 
Weight Determines the weight of this constraint in relation to other constraints act-

ing on the same object.
Inside Constrains the object to stay inside the sphere. If Inside is turned off, the 

object cannot enter the sphere. Toggling this parameter off can be useful, for 
example, to create rudimentary collision detection forcing objects to avoid 
others as they pass through space.

AXS/Relations_Bounding_Sphere.htm
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Pin Joint constraint 
This relation creates a position and rotation connection between two objects that allows for 
rotation around a single axis. This type of constraint is similar to a knee joint or the hinge of a 
door.

It allows you to pivot one object around another. The object can pivot all the way around the 
joint or you can limit its freedom by setting angle limits. 

Examples of pin joints, or movements you can simulate with pin joints abound: a movie clapper, 
a wheel moving on its axle, scissors opening and closing on a pin, a canon taking aim, etc.

Geometry constrained Uses the object's outer geometry as limits when calculating the bounding 
sphere. When this option is on, a sphere appears around the constrained 
object, and it is the outer radius of that sphere that determines when the 
object has reached its limit. When Geometry constrained is off, the object's 
center serves as a reference.

Minimum

Maximum

AXS/Relations_PinJoint.htm


 Chapter 5 | Relations | 283

Example: to apply a pin joint constraint:
1. Multi-select the object that will pivot and then the object to which it will be constrained, in 

that order.

2. If the objects are positioned correctly, click Unlock ( ) to keep that offset.

3. Choose Relate > Add Pin Joint.

4. Click Lock ( ). 
When you translate the constrained object, it rotates around the hinge.

5. To change the position and direction of the hinge, translate and rotate the Pin Joint constraint. 
To select the pin constraint, click the turqoise constraint in the viewport, or select the 
constraint under the constrained object in the Project Manager.
When you translate the constrained object, it now rotates around the hinge, in its new position 
and axis.

Pin Joint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to other constraints on the 

same object.
Position Determines the position of the hinge in X, Y, Z (in units).
Constraint axis Determines the orientation of the hinge relative to the absolute X, Y, or Z axes. 

By default the hinge rotates around the leader’s X axis. If the leader’s orienta-
tion is 0 0 0, the pin’s axis is 1 0 0. You can set it to the Y axis (0 1 0) or Z axis 
(0 0 1), or the -X, -Y, or -Z axes. You can also select Other Axis and enter an 
axis in the Axis field or drag the constraint manually in a viewport.

Axis When Other Axis is selected in the Constrained axis field, this determines the 
orientation of the pin joint.

Joint angle Displays the current angle of the follower object.
Free joint angle Toggles free joint angle on and off. When an object has a free joint angle, it is 

loose around the angle. When turned off, the object is locked in position on the 
angle and cannot be rotated or translated.
An example of when this might be useful is when creating interaction on a car’s 
door, when the car is stopped you want to open its door which is on a Pin Joint, 
so you toggle this parameter on (it’s on by default). But when the car starts 
moving you don’t want the door to swing dangerously in the wind, so you tog-
gle this parameter off.

Enable angle limits Sets minimum and maximum angle values, which determine how much the fol-
lower object can rotate.

Minimum Sets the minimum angle in degrees when Enable angle limits is turned on. 
Maximum Sets the maximum angle in degrees when Enable angle limits is turned on. 
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 Ball Joint constraint 
This relation creates a position and rotation connection between two objects that allows for 
rotation around all three axes. This type of constraint is similar to a shoulder joint or a joystick. 
It allows one object to pivot freely around another. You can limit the amount of freedom in the 
constraint by setting angle limits. For example, the joystick can pivot freely but it cannot move 
lower than its base.

Example: to applying a ball joint constraint:
1. Create a sphere.

2. Create a cylinder, and set its height to 4 and width to 1. 

3. Multi-select the cylinder and the sphere, in that order.

4. Choose Relate > Add Ball Joint.

5. Click Unlock ( ). This enables you to offset the cylinder's position. Translate the cylinder 
up the Y axis.
To test the constraint, turn on the Lock button and translate the cylinder in all viewports. It is 
constrained to the sphere and can only rotate around the ball joint that you created. Translate 
the sphere to verify this. You can also select the ball joint and offset it if you want to change 
the actual rotation point.

6. Select the constraint and turn on Enable joint limits in the Parameter Editor. 
This constrains the cylinder to move around a certain opening.

Maximum angle

AXS/Relations_BallJoint.htm


 Chapter 5 | Relations | 285

7. Adjust the maximum limit angle, and notice the opening in the ball joint widening or 
narrowing.

8. By default the X axis of the cylinder is constrained. Change Constrained axis to 
0, 1, 0 (the Y axis). Translate the cylinder and notice how it moves freely in the opening you 
set with the Maximum limit angle.

Ball Joint constraint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of the constraint in relation to other constraints acting 

on the same object.
Position Determines the position in X, Y, Z (in units) of the ball joint, around which 

the object rotates.
Orientation Sets the orientation of the ball joint. You can also rotate the constraint inter-

actively in the viewport.
Joint angles Determines the current angle of the constrained object.
Free joint angles Toggles free joint angles on and off. When an object has free joint angles, it 

is loose around the ball joint. When turned off, the object is locked in position 
on the ball joint and cannot be rotated or translated.

Enable joint limits Sets a maximum angle limit. Turning on this option displays the maximum 
angle value, which determines how much the constrained object can rotate, 
as well as the axis to be limited.

Constrained axis Chooses the axis of the object that the joint limit will affect. By default it is 
the X axis. You can also select Y, Z, or -X, -Y and - Z, or select Other Axis 
and enter an axis in the Axis field or drag the constraint manually in a view-
port.

Axis When Other Axis is selected in the Constrained axis field, this determines the 
axis that will be limited.

Maximum Sets the maximum angle in degrees.



286 | AXEL V2| User Guide

Slider Joint constraint 
This relation creates a connection between two objects. It limits the constrained object to move 
within a certain distance along a single axis.

This relation allows you to create a drawer-like constraint where one object can slide along an 
axis related to another object. For example, the small cylinder of this telescope can translate only 
from left to right by a maximum of 5 units and follows the larger cylinder when it is moved.

To apply a slider joint constraint:
1. Multi-select the follower and then the object to which it will be constrained, in that order. You 

can either click Unlock ( ) to create an offset or correct it later.

2. Choose Relate > Add Slider Joint.
The first object is constrained to slide along the turquoise box attached to the second object. 
By default, it slides 5 units along the X axis. 

3. Change the minimum and maximum position limits with the sliders to allow for greater or 
smaller range of movement.
Move the object by adjusting the Position parameter in the Parameter Editor.

4. Translate and rotate the slider joint, then translate the follower again. 

AXS/Relations_SliderJoint.htm
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Slider Joint constraint parameters

Active Toggles the constraint on and off.
Weight Determines the weight of this constraint in relation to other constraints act-

ing on the same object.
Position Determines the position in X, Y, Z (in units) of the origin of the slider con-

straint box.
Constraint axis Determines the axis of the slider constraint. In addition to +X, +Y, +Z, and 

-X, -Y, -Z, you can select Other Axis then enter an axis with XYZ coordi-
nates or drag the constraint manually in the viewports.

Axis When Other Axis is selected in the Constraint axis field, this determines the 
orientation of the slider axis.

Position on slider Displays the current position of the sliding object.
Free position Toggles the Free position parameter on and off. When an object has a free 

position on a slider, it is loose along the slider. When turned off, the object 
is locked in position on the slider and cannot be translated.

Enable slider limits Sets the limits to which the object can slide.
Minimum Sets the minimum position in units. Enable slider limits must be on for this 

to take effect. For example, if you use the slider constraint on a desk drawer, 
the minimum and maximum limits allow you to make sure the drawer cannot 
slide out of the desk.

Maximum Sets the maximum position in units. 
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Custom relations 
Custom relations allow you to create more complex relations between objects that would not 
necessarily be possible with the standard library of relations that are provided in AXEL.

When you add a custom relation, you write a script that determines the value of a selected 
parameter.

The simplest custom relation you can script is relating two parameters of the same type, for 
example the light intensity of two different lights as shown in the example below.

You can also relate some parameters of different types. For example, you can relate a sphere’s 
number of horizontal subdivisions, which is an integer, to a light’s intensity, which is a decimal 
value.

For more information on scripting Custom relations, see “Scripting” on page 517.

To create a custom relation:
1. Select the parameter on which you want a Custom Relation.

2. Choose Relate > Add Custom Relation. 
The Script dialog appears.

3. Click in the script section and compose a script as follows:

• To enter a parameter name, select the parameter in the Project Manager, then click Insert 
World Selection. If the object name contain spaces, rename it to remove the spaces. See 
“Scripts Syntax” on page 518.

• To enter an operator, click the Operators panel, then double-click the operator, or select the 
Operator and click Insert Operator (Windows). The operator is added to your script at the 
insertion point. When you select an operator an explanation of what it does appears below.

• To enter a function, click the Functions panel, then double-click the function or select the 
function and click Insert Function (Windows). When you select a function an explanation 
of what it does appears below. To add arguments to the function, place the insertion point 
in the script to the left, select a parameter in the Project Manager, then click Insert World 
Selection.

4. Correct any errors in the script. Errors in the script appear in real time in the status box as you 
are typing the script. 

5. Click Apply to assign the value of the script to the parameter selected in step 1. 

6. To test the script, you can modify parameters in your project while the dialog is open and 
check the value in the script dialog. If the value is what you expected, your script works.
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7. Click OK.
In the Project Manager, the Custom Relation appears under the object selected in step 1 and 
under Resources / Effects. 

To edit the script:
1. In the Project Manager, select the script. It appears under Custom relation, under the object 

as well as under Resources / Effects.

2. Choose Edit > Edit Custom Script or double-click the script in the Project Manager.

3. The Script dialog appears. Edit the script, and then click OK.

Custom relations syntax
You can also type a script directly in the script dialog. See “Scripts Syntax” on page 518.

Example: making a spot light brighter when a directional light is dimmed: 
Use a custom relation to make a spot light’s intensity equal to 100 minus the value of the 
directional light’s intensity. For example, when the directional light’s intensity is 90, the spot 
light will be10. When the directional light is 30, the spot light will be 70.

1. In the Project Manager, select the spot light’s Intensity parameter.

2. Choose Relate > Add Custom Relation.
The script editing dialog appears.

3. In the Script dialog, type 100-

4. In the Project Manager, select the directional light’s Intensity parameter then in the Script 
dialog click Insert World Selection. The dialog now contains the following script:
100-DirectionalLight1.Intensity

5. The status indicates that the script is valid. Also notice the value. Click Apply to assign this 
value to the spot light’s intensity.

6. Test the custom relation. Like any other relation, you have to adjust the leader’s value, in this 
case the directional light’s intensity, in order to change the follower’s constrained value, 
which is the spot light’s intensity.

7. Click OK.
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Chapter 6
Visualization

Use the Visualization tools and parameters to refine 
how your project looks through the WebCam. 

You can color your models using different rendering 
styles. Control how movie textures are projected 
onto surfaces. Add WebCams with different 
parameters so your project can be viewed from 
numerous perspectives. You can even color objects 
by their individual points or faces. 

Take advantage of the freedom of 3D lighting in 
AXEL to accentuate detail on you objects, add 
nuance and atmosphere. Even color your lights and 
watch how this color combines with colors already 
present on objects to add realism or fantasy to your 
project—your call!

In this chapter:

Materials ............................. 302

Textures ............................... 316

Lights .................................. 333

WebCams ............................ 340
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Materials
You use materials to define objects’ color, shininess, glow, and transparency. You can choose a 
material’s rendering style to alter how the material appears on an object. You can also use 
separate colors to accentuate the highlight, ambience and glow of an object.

A material can contain a texture, such as a scanned image or artwork, or a movie textured on an 
object that can play even as this object is transformed.

Adding Materials
You can add materials to objects or add them to your resources in the Project Manager, and link 
them to objects later on. Linking is useful when you want to use the same material on more than 
one object. When you modify a linked material, all the objects that use it are updated. Linking 
materials that include textures to multiple objects make downloading more efficient because 
only one copy of the image has to be downloaded instead of many.

Note: When you duplicate an object, you also duplicate its material—creating a second 
independent material. However, when you instance the object, there remains just one material 
shared by each instance. For more information, see “Instancing and duplicating objects” on page 
176.

You can create a bank of materials, then link them to objects as needed.

To add a material to surfaces, curves, or groups:
1. Select the surface, curve, or group.

2. Choose Visualize > Add Color Material, then choose a rendering style. 

3. Select a color, then click OK.
The object changes color in the viewports.

4. In the Parameter Editor, click the new Material, then adjust the Material’s parameters. 

To add a material to the project:
1. Make sure nothing is selected. (Choose Edit > Unselect All, or turn on the Select tool and 

click an empty part of the World.)

2. Choose Visualize > Add Color Material, then choose a rendering style.

Shaded Accentuates 3D characteristics of an object approximating real life.
Cartoon Creates a flat 2D look on a 3D object similar to traditional cell animation. 
Custom Wireframe Displays a wireframe outline to which a material is applied.



 Chapter 6 | Visualization | 303

3. Select a color, then click OK.
The material appears in the Project Manager under Resources / Materials.

To link a material to objects:
1. In the Project Manager, CTRL-select (Windows) or COMMAND-select (Macintosh) the 

objects and the material.

2. Choose Visualize > Link Material or press CTRL+L (Windows) or COMMAND+L 
(Macintosh).
In the viewports, the objects are updated. In the Project Manager, the material appears under 
the objects. When you select a linked material in the Project Manager, every instance of the 
material is highlighted. When you edit the material, all the objects that use it are updated.

To remove a material from an object and the World:
In the Project Manager, select the material and press DELETE. 
Objects linked to that material revert to the default material.

Note: When you delete a material containing a texture, the texture file is not removed from 
Resources.
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To remove a material from an object but keep it in the World:
Select the object and the material, then choose Visualize > Unlink Material or press CTRL+U 
(Windows) or COMMAND+SHIFT+L (Macintosh).
The object reverts to the default material.

Note: If you want to change the color of an object that uses a linked material without changing all 
the other instances of the material, unlink the material then add a new material to the object. To 
unlink a material, SHIFT-select the object and the material, and choose Visualize > Unlink 
Material or press CTRL+U (Windows).

To rename a material:
1. In the Project Manager, expand Resources / Materials, or expand the object to which the 

material is applied.

2. Select the material, click it again and then enter a new name. You can also enter a new name 
in the Name field in the Parameter Editor.

To select a material:
Do one of the following:

• Select an object that uses it, then click Material in the Parameter Editor.

• In the Project Manager, expand Resources / Materials and select the material.
Its parameters appear in the Parameter Editor.
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Rendering styles 
Rendering styles refers to the way in which AXEL represents materials that are applied to 
objects. Each rendering style accentuates different aspects of an object. Materials in a project 
can use any rendering style and so there can be any combination of rendering styles in a project.

Each time you add a material to an object, or to your resources in the Project Manager, you 
choose a rendering style.

For an object to maintain its own rendering style in the WebCam view, and thus for publishing 
purposes, the WebCam has to have its rendering style set to Per Material. Otherwise the active 
WebCam’s rendering style overrides all the individual objects’ rendering styles. For more 
information, see “WebCam Parameters” on page 341.

To change a rendering style for an existing material:
1. Click on a material in the Project Manager, or click on an object in the viewports and expand 

its Material category in the Parameter Editor.

2. Choose a rendering style in the Parameter Editor.

Cartoon ShadedCustom Wireframe
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Shaded
Use this rendering style to accentuates 3D characteristics of an object approximating real life.

Cartoon
Use this rendering style to create a flat 2D look on a 3D object. It is often used to better 
approximate the look of traditional cell animation. 

Turning on smoothness for objects with Cartoon rendering allows for color transitions across 
faces, like the side of the television above. Otherwise each face is defined by a single solid color. 

To turn on smoothness for objects:
Select an object’s geometry and turn on smoothness. For more information, see “Smoothness” 
on page 230.

Notice the gradual color drop-off as the edge is rounded into the distance.

Notice the clear separation of color between a surface’s main color, shadow, and contour line.
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Custom Wireframe
Use this rendering style so only the wireframe outline of an object is rendered. As opposed to 
straight wireframe, this rendering style allows some thickness to the wireframe mesh. In this 
rendering style, lighting has no effect. 

You can adjust the thickness of the wireframe mesh by setting a different line width.
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Material parameters
Depending on which rendering style you choose, one of the following lists of parameters 
appears in the Parameter Editor.

Shaded parameters

Color Sets the material color. The value is an RGB color value ranging from 0 to 
255 for each field: red, green and blue. You can open a color dialog and use 
different color models. In Windows you can also enter an HTML color 
directly in the field. 

Advanced Color Model Adds an advanced color model to a material, replacing the different grada-
tions of a single color with distinct colors. This also adds a distinct Glow 
color that replaces the Glow parameter value that combines with the Color 
to otherwise define the Glow. For more information, see “Advanced Color 
Model” on page 312.

Shininess Determines the intensity of the highlight. A value of 0 produces a flat color, 
like fabric; 100 creates the brightest highlight, similar to chrome.

Glow Creates a self-lit, neon-like effect. By default, glow is 0.

Transparency Makes objects see-through. By default, transparency is 0, making objects 
opaque.

Note: You can select objects even if they are completely transparent and they 
can act in your World, for example as targets in a Direction constraint. This is 
also true is you turn off an object’s Visible parameter.

Texture enabled Appears when you add a texture to the material. Activates/deactivates the 
texture.

 0 50 100

0 100

 0 50 90
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Cartoon parameters

Custom Wireframe parameters

Color Sets the material color. The value is an RGB color value ranging from 0 
to 255 for each field: red, green and blue. You can open a color dialog 
and use different color models. In Windows you can also enter an 
HTML color directly in the field. 

Advanced Color Model Adds an advanced color model to a material, replacing the different grada-
tions of a single color with distinct colors. This also adds a distinct Glow 
color that replaces the Glow parameter value that combines with the Color 
to otherwise define the Glow. For more information, see “Advanced Color 
Model” on page 312.

Shininess Determines the intensity and depth of the highlight. A value of 0 produces a 
wide highlight, with a flat color like fabric; 100 creates a concentrated bright 
highlight, like in chrome.

Glow Creates a self-lit, neon-like effect. By default, glow is 0.
Transparency Makes objects see-through. By default transparency is 0, making objects 

opaque.

Note: You can select objects even if they are completely transparent and they 
can act in your World, for example as targets in a Direction constraint. This is 
also true is you turn off an object’s Visible parameter.

Shadow angle Sets the angle at which light hits the surface, determining the portion of the 
object that is ambient. The value is in degrees to a maximum of 180. At val-
ues approaching 180, the whole object appears in shadow.

Line color Sets the color of the object’s contour line.
Line width Determines the width of the object’s contour line.
Line placement Determines the distance that an object’s contour line is displaced.

Color Sets the color of the wireframe mesh. The value is an RGB color value 
ranging from 0 to 255 for each field: red, green and blue. You can open 
a color dialog and use different color models. In Windows you can 
also enter an HTML color directly in the field. 
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Advanced Color Model
You can use an advanced color model with the Shaded or Cartoon rendering styles to further 
define an object’s look, replacing the gradations of a single color with distinct colors for the 
material’s highlight, ambient, and glow properties. With the Shaded rendering style, the Color, 
Highlight Color and Ambient Color bleed into each other; with Cartoon, these colors are solid 
and separated.

To apply an advanced color model:
1. Click a material in the Project Manager or expand an object’s Material category in the 

Parameter Editor.

2. Turn on Advanced color model in the Parameter Editor, and choose one of the following:

Changing the default material
When you create an object, it is displayed with the default material. This includes curves, and 
the outline of lights and WebCams.

To edit the default material:
1. In the Project Manager, expand Resources / Materials.

2. Select Default Material and edit its parameters in the Parameter Editor.

Changing an object’s color
The object’s material determines its color. To apply color to an object, add a material. 

Transparency Makes wireframe mesh see-through. By default transparency is 0, making 
objects opaque.

Note: You can select objects even if they are completely transparent and they 
can act in your World, for example as targets in a Direction constraint. This is 
also true is you turn off an object’s Visible parameter. 

Line width Determines the width of the wireframe mesh.

Color Color applied to the body, which is the main part of a material.
Highlight Color Color applied to highlighted hot-spot, which is the specular part of a material.
Ambient Color Color applied to the shadowed part of an object.
Glow Color Color applied to the emissive part of a material, emitting light in the chosen 

color.
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Once you add a material, you can edit its color at any time. Colors are described with Red Green 
Blue (RGB) values. Values range from 0 to 255. For example, pure red is 255 0 0, which gives 
the maximum red value, with no green and no blue. Purple is 255 0 255; yellow 255 255 0. You 
can also specify colors for Windows using Hue, Saturation, Luminescence (HSL) in the Color 
dialog, and for Macintosh using Hue Angle, Saturation, Value (HSV) (equivalent values are 
found when switching your AXEL files between Windows and Macintosh). 

You can also enter HTML color values directly in the Parameter Editor in Windows, or in the 
Color Picker on the Macintosh.

To change an object’s color:
Select the object, expand its material and do one of the following:

• In the Parameter Editor, click the material color chip and select a new color using the Color dialog 
that appears. The material changes and all the objects that use it are updated.

• In the Parameter Editor, enter a color value in RGB format (3 numbers 0-255) or, in Windows, in 
HTML format (6 digits 0-F). On the Macintosh, you can enter HTML color formats within the Color 
Picker.

Color value Color chip
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Color per point, per face
You can color individual points, faces, or entire surfaces using the Shaded rendering style. Using 
color per point is useful for creating color gradients. 

When you color an object's points or faces, the color parameter of the object's material becomes 
inactive as you are replacing it with the multiple values of different face or point colors. 
However, you still control the Glow, Shininess, and Transparency parameters for the whole 
object through the object's material. Similarly, if you add an Advanced Color model to this 
object, both its Color and Ambient Color are replaced by face colors or point colors, but you still 
control the object's Highlight, Glow, Shininess and Transparency through the object's material.

If no material is linked to an object when you are coloring points, it remains linked to the default 
material for certain material parameters, and so you can adjust those that are still relevant for the 
whole object, like Shininess and Transparency, by adjusting these on the default material found 
under Resources / Materials in the Project Manager.

Note: Using point or face coloring freezes the surface. When the surface is frozen, AXEL draws 
the surface based on its points, not its parameters. If you turn off Frozen, the surface is redrawn, 
and any edited point colors or face colors revert to the material color. The Frozen parameter appears 
under Surface Geometry.

To color selected points:
1. Select the surface. Verify that its rendering style is Shaded.

2. Switch to Point mode, then select the points you want to color.

3. Choose Visualize > Edit Point Color, select a color and click OK.
The selected points take on the new color creating a color gradient between adjacent points. 
In the Project Manager, notice the surface’s geometry parameters: Coloring is set to Per point.

4. In the Parameter Editor, expand Point color to see the color of each point. Click a color chip 
to edit the color of each point.

The vertical plane and the bear have colored points, and the ball has colored faces.
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Tip: You can create nice backgrounds by creating a large vertical plane, then reducing its 
subdivisions, then varying its point colors. If you position the plane behind your objects, the 
gradient that the varied point colors create can mimic the sky, for example.

To color selected faces:
1. Select the surface. Verify that the object’s rendering style is Shaded. 

2. In the Parameter Editor, expand the surface geometry parameters, and set Coloring to Per 
face.

3. Expand the Face colors.

4. To change the color of a face, click its color chip and select a color.

Tip: If the selected face is hidden in the viewports, orbit in WebCam view.

Example: Building a bank of materials
1. With nothing selected, choose Visualize > Add Color Material > Shaded.

2. Click a green color chip.

3. In the Project Manager, expand Resources / Materials, and change the name of the material 
to green. 

4. Create a sphere and choose Visualize > Add Color Material > Shaded.

5. Click a red color chip.
The sphere is now red and another material appears under Resources / Materials. Rename 
the material red.

6. Create several new objects. CTRL-select (Windows) or COMMAND-select (Macintosh) the 
objects and the green material under Resources / Materials.

7. Choose Visualize > Link Material or press CTRL+L (Windows) or COMMAND+L 
(Macintosh). 
The objects are now green. If you edit the green material, all objects with that material are 
updated.

8. Select one of the objects and choose Visualize > Unlink Material. 
The material is removed from the object.
This process is identical for textures and for linking reactions, sounds, and so on. Using the 
same item enables AXEL to use a minimum amount of information and memory in its files, 
and it reduces download times.
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Textures
With textures you can map an image or a movie onto an object. Any graphic or movie file that 
can be converted into a supported format can be used as a texture. For example, you can use 
scanned artwork, video grabs, Apple® QuickTime® or MPEG movies, or Flash SWF 
movies.For more information, see “Supported texture formats & textures through QuickTime” 
on page 332.

The process of applying textures is like projecting an image onto an object; by default the texture 
is stretched or shrunk to cover the entire object, regardless of size or proportion. You can use 
tiling, texture size and texture projection to adjust how the texture covers the object. You can 
also specify how the texture should blend with the object’s material color. 

A texture is tied to a material. When you add a texture to an object, it appears under the material 
in the Project Manager. If there is no material on the object, a white material is added to the 
object, and the texture is added to that material. When a texture is added to a material, all objects 
linked to that material are also updated.

You must select the Shaded rendering style for the texture to appear. Similarly, textures can only 
be mapped onto text that is a 3D surface. Textures that have transparency will preserve this 
transparency for great effects. Textures can also be mapped onto particles again for all kinds of 
exciting effects! For more information, see “Particles” on page 398.

You cannot apply a texture onto a group. Instead, you can multi-select all the members of the 
group individually then apply the texture.

When you add an image texture or a movie texture, the file is copied to the Textures folder in 
the Project folder. Texture setting are the same for image and movie textures. See “Texture 
settings” on page 323.

Adding image textures
You can add an image to surfaces, including text surfaces, or add it to the Project’s Resources 
and then link it to surfaces later on.

To add an image texture:
1. Do one of the following:

• Select the material or surface to which you want to apply the texture.

• To add the texture to the World without adding it to a surface, make sure nothing is selected. 
(Choose Edit > Unselect All or, with the Select tool, click an empty part of the World.)

2. Choose Visualize > Add Image Texture.
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3. Navigate to the texture file, select it, and click OK.
A new image appears in the Project Manager under Resources / Images. 

4. Select the image texture and adjust its parameters. Select Texture settings to adjust the image 
texture’s settings.

ImageFile parameters

Adding movie textures
You can add movies, such as Macromedia® Flash™ or QuickTime movies, to surfaces, and 
watch them play as the surface is transformed. Movies have the properties of both a texture and 
a reaction. They are like image textures in that they are applied onto surfaces and they also play 
like regular movies, as a Play Movie reaction. For more information about reactions, see 
“Interaction” on page 415.

Movie textures can be mapped onto surfaces with a Shaded rendering style. Formats supported 
by QuickTime, such as .swf, .avi, .mpeg, .mov can be used. Adding a movie automatically links 
it as a Play Movie reaction to a TimeSensor at the current time, and it plays accordingly. You 
you can still change its trigger after it is linked.

Texture settings and Texture projectors are the same for movie textures and image textures.

If a movie has sound, the sound plays as the movie plays. The sound from Play Movie reactions 
can play simultaneously with the sound from Play Sound reactions; and their volumes can all be 
adjusted separately. For more information, see “Play Sound reaction” on page 427.

Movie files can be extremely heavy, so you should try to reduce the frame rate, the image size, 
the movie length and the resolution before importing the movie file into AXEL. Importing 
movies copies them to the Textures folder in the Project folder.

File Displays the image texture file. 
Image width and 
height

This is the pixel size of the texture (all images are stretched or squashed into formats 
that are supported by graphics cards; for optimum image quality they should be sized 
using powers of 2, such as 32, 64, 128 pixels and so on, before being imported to 
AXEL). The maximum size is 512 x 512.

Image format Shows if the texture image contains transparency (alpha) information. Options are: 
RGB or RGBA, where RGBA includes transparency.

Streamable Once the World is published, the texture is downloaded using streaming. For more 
information, see “About antialiasing” on page 594.

Streaming 
priority

Determines if the texture is among the first or the last objects to download.
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A movie can be published as a URL; it is then hyper-linked to a location on the Internet and need 
not be stored in the local directory and so is not compressed into your file .axs stream file when 
publishing. Use Publish as URL to take advantage of different streaming formats so that it starts 
to play as it is downloading to a surfer’s computer. For this, you must save the movie in a 
streaming format. For example, you can save a QuickTime movie using the Fast start option.

Tip: While you can only Publish as URL for Movies, you can in fact save large textures, or 
sounds, or any QuickTime compatible file as a MOV, then use this file as a movie and Publish as 
URL. This way, these other files can also be located remotely on the Internet and stream into your 
AXEL project as if they were Movies. Keep in mind that synching these files in time could be 
challenging and cannot always accurately be tested.

To add a movie:
1. Do one of the following:

• Select the material or object to which you want to apply the movie.

• To add the texture to the Project Manager without adding it to an object, make sure nothing 
is selected. (Choose Edit > Unselect All, or hold S and click an empty part of the World.)

2. Choose Visualize > Add Movie Texture.

3. Navigate to the movie file, select it, and click OK.

The eye is a movie texture that is playing.

AXS/Visualization_movie.htm
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A new movie appears in the Project Manager under Resources / Movies. It also appears in 
the Sequencer, and in the Interaction Editor where it is linked to the TimeSensor to start 
playing at the current time.

4. If you want the movie to play at a different time, drag the movie in the Sequencer, or link it 
to a different trigger in the Interaction Editor.

5. Select the movie texture and adjust its parameters. Select Texture settings to adjust the movie 
texture’s settings.
For more information, see “Working in the Interaction Editor” on page 417 and “Interaction 
in the Sequencer” on page 421.

To use the same movie in another Play Movie reaction:
1. In Project Manager / Resources / Movies, select a movie.

2. Choose Interact > Add Reaction > Play Movie.

3. In the Interaction Editor, link the reaction to a sensor.

To play the movie over and over again:
In the Interaction Editor, select the Play Movie reaction and turn on Loop in the Parameter 
Editor.

The movie in the 
Project Manager

The movie in the Interaction Editor 
Its link was switched from the default 
TimeSensor to a MouseSensor.

The movie in the Sequencer
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To turn the movie on and off by clicking:
1. In the Interaction Editor, select the link.

2. In the Parameter Editor, set the Trigger mode to Toggle Start/Stop. 

To remove a Play Movie reaction:
In the Interaction Editor, select the reaction and press DELETE.

To play a movie from its remote location:
1. Select the movie and turn on Publish as URL in the Parameter Editor.

2. Type the location of the movie in the URL field.
When the movie is triggered in a published AXEL project, it plays from its remote location. 
If the movie was compressed in a streaming format, it is streamed when downloading into 
your AXEL content. 

To stream a movie inside an .axs file:
1. Select the movie in the Project Manager.

2. In the Parameter Editor, turn on Streamable and select a Streaming priority.

Note: If a movie file in your project is not streamed, your World will not start to play on the 
surfer’s computer until the movie file is fully downloaded. When the movie is streamed, the 
World starts to play before the movie is fully downloaded, but if its trigger is too early, the movie 
may miss its mark and play out of sequence. To avoid this, trigger the movie texture to play at 
a later time—ensuring it is fully downloaded before it is triggered—or set it to be triggered only 
when it is completely downloaded, as in the steps following.

3. In the Interaction Editor, unlink the PlayMovie reaction from the Time Sensor.
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4. In the Project Manager, under Resources / Movies, select your MovieFile.

5. Choose Interact > Add Sensor > Download.

6. In the Interaction Editor, link the OnDownloadComplete trigger to the PlayMovie reaction.

When the file is finished streaming in, it will trigger the movie to play.
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Play Movie reaction parameters

MovieFile parameters

Linking textures
Before adding a texture to several objects, decide if you want to adjust the settings separately to 
give each object a different look, or use the same setting for all the objects. If you want to adjust 
the texture settings differently for each object, add the texture to each object. If you want to 
adjust the texture settings for all the objects at once, add the texture to a material, then link that 
material to the objects.

To link a texture to objects or materials:
1. CTRL-select (Windows) or COMMAND-select (Macintosh) the objects or materials and the 

texture. 

2. Choose Visualize > Link Texture or press CTRL+L (Windows) or COMMAND+L 
(Macintosh).

3. Adjust the texture settings for each object. 

Loop Plays the movie over and over again.
Volume Determines the volume of the movie, in percentage. This volume control combines 

with the volume set on the surfer’s computer.

File Displays the movie texture file. 
Duration Displays the duration of the movie in seconds. 
Movie width and 
height

This is the pixel size of the movie texture (all movies are stretched or squashed into 
formats supported by graphics cards; for optimum image quality they should be sized 
using powers of 2, such as 32, 64, 128 pixels and so on, before being imported to 
AXEL).

Publish as URL Allows the movie to be played from a remote location on the Internet.
URL The URL path where the movie file is located. Remember to upload the movie file 

to the location you specify in the URL path. For more information, see “Uploading 
AXEL content to the web” on page 580.

Streamable Once the World is published, the movie texture is downloaded using streaming.
Streaming prior-
ity

Determines if the movie texture is among the first or the last objects to download.
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Texture settings
Texture settings, in addition to texture parameters, add further control to refine textures. They 
are the same for images and movies. Texture settings are under an object’s material in the Project 
Manager. 

Note: You can also control the appearance of a texture by adding texture projection to the object. 
For more information, see “Texture projection” on page 328.

ImageFile parameters
Texture settings
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Texture settings

Horizontal tiling Repeats the texture as many times as necessary to cover the projection surface hori-
zontally. To see the effect, change the texture’s Position or Scale parameters. For 
more information, see “About tiling” on page 327.

Vertical tiling Repeats the texture as many times as necessary to cover the projection surface verti-
cally. 

Texturing mode Determines how the material color and the texture are blended. See “About Textur-
ing Modes” on page 325.

Environment 
mapping

Uses the texture to simulate a reflective surface such as a metallic object. The object 
acts as it was reflecting the texture which surrounds it.

Filtering Softens the texture by blending the pixels together. This is useful for small texture 
images that are enlarged. It is on be default.

Position Offsets the texture over the object. Values range from 0 to 1 in latitude and longitude. 
The default position is 0, 0, which starts the texture in the upper right corner. 0.5, 0.5 
starts the texture in the middle of the object, and 0.9, 0.9 starts it in the lower left cor-
ner.

Orientation Rotates the texture, in degrees.
Scale Changes the size of texture (increase Scale to make texture larger). 

No filtering (left) and filtering enabled (right).
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About Texturing Modes
The texturing mode determines how the material color and the texture are blended. 

Multiply 
Blends the texture over the material by multiplying pixel values. A texture mapped over a white 
material (RGB values 255, 255, 255) leaves the texture unchanged from its original look. When 
mapped over a black material (RGB values 0, 0, 0), it is multiplied by zero and appears black. 

Replace 
Uses the texture values instead of the material values. It ignores lighting, such as the glow 
parameter on the material. This can be useful for neon-like effects, or in conjunction with 
Environment mapping since it faithfully reproduces the texture file as it was originally created.

Decal 
Applies the texture over the material.

Texture modes and lighting
Multiply takes lighting into account, darkening the texture in the ambient area. Replace and 
Decal ignore lighting.

Texture multiplied over white material.

Texture multiplied over 50% grey.

Texture multiplied over dark green.

Multiply mode
 

Replace mode
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Texturing modes and .png images
When applying textures with transparency, such as .png files over semi-transparent materials, 
results differ depending on the texturing mode.

Multiply: with PNG textures, the transparency is also multiplied. Fully transparent pixels in the 
PNG image (RGB=0,0,0) make the underlying material transparent.

Replace: with PNG textures, the transparency in the texture file determines the transparency of 
the object.

Decal: with PNG textures, transparent areas in the texture reveal the underlying material. This 
makes it ideal for applying a logo.

.png texture with Multiply 
texturing mode

.png texture with Replace 
texturing mode

.png texture with Decal 
texturing mode

Vertical plane without 
a texture
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Rationalizing texture pose 
When you rationalize texture pose, the position, orientation, and scale of the texture settings are 
permanently applied to the UV coordinates of the geometry and then the settings are reset to 
their default values (Position = 0,0, Orientation=0, Scale=1,1) without changing the appearance 
of the texture. For instance if you scale a texture and then rationalize it, it remains the same size 
in the viewports but the scale values returns to 1, 1.

About tiling
Use tiling to repeat a texture on a surface. This way you can use a very small texture image or 
movie to cover a large surface. To see the effect, change the texture’s Position or Scale 
parameter.

To use tiling:
1. In the Texture Settings, turn on Vertical and Horizontal tiling.

2. To use smaller tiles, decrease the Scale parameter. To use larger tiles, increase the Scale 
parameter.

With tiling off, the border pixels of the texture are repeated to cover the whole object. To obtain 
a uniform look, set all border pixels to the same color.

Tiling on
Scale = .25 .25

Tiling off
Scale=1 1

Texture image



326 | AXEL V2 | User Guide

Texture projection
Texture projection gives you additional control over how a texture is projected onto an object.By 
manipulating a texture projector, you can adjust the texture projection on an object. There are 
two types of texture projectors: planar and cylindrical. By default, AXEL uses planar projection.

Planar
A wireframe plane appears in the object. You can scale, rotate, and translate the plane to get the 
texture mapping you want.

The color at the edge of the texture image is applied to the sides of the object. In the following 
example, notice how the edge of the texture map determines the color of the cube.
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Cylindrical
A wireframe cylinder appears around the object. You can scale, rotate, and translate it to get the 
texture mapping you want. It is useful for mapping textures on cylinders and spheres.

In the following illustration, a texture is applied on a cylinder with planer projection (left and 
middle). Notice the streaking on the side (middle). Adding a cylindrical texture projector (right) 
wraps it like a label around a can.

To adjust cylindrical projection:
1. Select an object to which you added a texture.

2. Choose Visualize > Texture Projection > Add Planar Projector/Add Cylindrical 
Projector.
A projector appears in the viewport and under the object in the Project Manager.

3. Translate, rotate, and/or scale the projector. In the Parameter Editor, adjust the projector 
parameters.

Planar projection Cylindrical projection
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Texture Projector parameters

Active Turn off Active to freeze the texture coordinates. For example, if you bend a cylinder 
on which you applied a cylindrical projection, turn off the projector’s Active param-
eter to make the texture stick to the surface and bend with the cylinder. Deleting the 
projector has the same effect.

Projection type Sets the type to planar or cylindrical.
Visible Shows/hides the projector definition outlines in the viewports. The projector icon 

does not appear when previewing in AXEL or in the published output even if Visible 
is on.

Position Sets the position of the projector relative to the object. For example, when you first 
apply the texture mapping, the projector is at 0 0 0, which means it has the same posi-
tion as the object. You can also adjust the projector position, orientation, and scale 
interactively by dragging the projector in a viewport.

Orientation Sets the orientation of the projector relative to the object.
Scale Sets the size of the projector. If you increase the size of the projector, the texture is 

stretched over a larger area. If you decrease Scale, the texture is repeated to cover the 
surface. 

Default Scale 
values

Low Scale 
values

High Scale 
values
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Creating environment maps
Use environment mapping to simulate reflective materials such as metal or glass. 

When used as an environment map, the texture is reflected off the object as if it were applied to 
a sphere surrounding the object. 

UV Scale Controls the number of repetitions of the texture around the cylinder. This parameter 
is useful with cylindrical mapping. To repeat the texture around the cylinder, 
increase the first value (U) of the UV Scale. 
Increasing the second value (V) repeats the texture from top to bottom; it has the 
same effect as decreasing the Projector’s Scale value. If the texture is already 
repeated because its Projector’s Scale was decreased, then it is be repeated further.

UV Scale =1, 1 UV Scale =4, 4 

Environment mapping

Texture image
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To create an environment map:
1. Select a material or create a new one. 

Tip: Use transparency to enhance the effect of environment mapping. For metallic surfaces, set 
the transparency to 0; for glass, increase the transparency.

2. To see your changes as you work, link the material to the objects in your World. For more 
information, see “Linking textures” on page 322.

3. Choose Visualize >Add Image Texture or Visualize > Add Movie Texture, and navigate 
to the image/movie file you want to use as an environment and click Open.
The texture is applied to the selected material.

4. In the Texture Settings, turn on Environment mapping.
The texture appears to be reflected off the object. Orbit the WebCam to see the effect.

Supported texture formats & textures through QuickTime
On Windows, Image textures are handled through the AXELplayer, while Movie textures are 
handled through QuickTime even when the content itself is playing in the AXELplayer. So, 
when using Movie textures in Windows run through the AXELplayer, surfers need QuickTime 
on their systems or movies show up simply as white space.

On Macintosh, both Image and Movie textures are run through QuickTime for both within the 
AXELplayer, or when the whole AXEL content is run through QuickTime itself. This should 
generally not be a concern as most Mac users have QuickTime, and on OS X it is a part of the 
core system.

The maximum resolution for images is 512 x 512 pixels and for movies it is unlimited. Large 
texture files, especially movies, slow down the refresh rate. AXEL supports the following file 
formats:

Image textures:
• PNG 

• BMP

• GIF 

• JPEG 

Movie textures:
• MPEG

• AVI
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• MOV

• SFW

Note: When a texture is processed, its dimensions are converted into powers of 2 (2, 4, 8, 16, 32, 
64, 128, or 512). For example, if it is 14 x 32 pixels, it is stretched to 16 x 32 pixels. If it is 100 x 
200 pixels, it becomes 128 x 256. To ensure that a texture is not stretched—which will make it more 
accurate giving a better representation—save it with dimensions that are powers of 2.

Lights
Use lights to brighten your 3D World, or highlight certain objects. By default, new projects 
contain one directional light. 

Light is generated in the scene by the three different kinds of light you can add, directional 
lights, point lights and spot lights, as well as if objects have a glow. In the latter case the objects 
are emitting their own light. 

If you turn off all the lights a glowing object remains visible, and is defined exclusively by the 
level of its glow and its glow color. If you delete the lights, however, all your objects remain 
visible, but are rendered flat, defined only by their main color and texture. Other properties, such 
as ambient color and shininess, are ignored.

Lights can be colored and react to an objects’s material color. Their color values are multiplied 
with the corresponding material color values that they hit: the red value is multiplied with the 
red value, the green with the green and the blue with the blue.

Directional Light
A directional light is like sunlight, where all light rays seem to come from an infinitely distant 
source. Parallel light rays hit the entire World. All objects are lit with equal intensity from the 
same angle, which is determined by the orientation of the directional light. 
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Only the rotation of the light affects the result. A directional light pointing downwards (Rotation 
X= -90) results in a midday-sun result, while Rotation X= -30 simulates late afternoon light.
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Point Light
A point light is similar to a light bulb or candle, sending light rays in all directions. The rays all 
emanate from a single point. 

The light’s position determines the source and the angle at which the light rays hit an object. 
Rotation and scaling do not affect the results of a point light.

Spot Light
A spot light funnels the light from a source through an adjustable opening. It allows you to focus 
the lighting into a beam.Think of a spot light following a performer on stage or a flashlight 
pointing at something in the dark. In either case, position (the light source) and orientation (what 
it is aimed at) are important. 

By adjusting or animating a light’s position and orientation, you can create different lighting 
effects.Use a Pose constraint to attach the light to an object or the cursor, or use a Direction 
constraint to point the light at an object or the cursor. For more information, see “Adding 
constraints” on page 263.



334 | AXEL V2 | User Guide

Adding lights
By default, there is one directional light in the 3D World. 

You can have up to eight active lights in your project. If you add more lights, only the first eight 
in the Project Manager are active. You can turn on the additional lights at a later time.

Keep in mind that lights significantly affect performance, so you should try to use as few as 
possible. 

In some cases, you can consider having no lights in your scene. 

To add a light:
1. Choose Visualize > Add Light, then select the type of light to add.

The light icon appears in the construction views.

Note: If the light icon is out of view, press F to frame the light or A to frame the entire World 
including the light.

2. Translate and rotate the light if needed.

3. Adjust the light parameters in the Parameter Editor.
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Light parameters

About fall-off 
Available for point and spot lights, fall-off simulates the natural fading of light as it travels 
through space. The intensity of the light gradually diminishes as it travels, until its fall-off 
distance is reached and the light loses most of or all of its intensity. Think of walking around a 
dark basement with a candle: you can only see as far as your candle lights, the rest being 

Position Sets the position of the light.
Orientation Points the light.
Scale Has no effect on the light.
Visible Determines whether or not the light icon is visible. It does not affect the lighting 

effect.
Turned on Toggles the light on/off. Functions like a light switch. 
Color Determines the main color of the light. This is the color of the light that shines 

directly on the object. Enter the RGB value or the HTML color code. It is combined 
with main color of materials. 

Highlight Determines the color of specular highlights. This is the color of the light that is 
reflected off shiny materials. Enter the RGB value or the HTML color code. It is 
combined with highlighted portions of materials. 

Ambient color Determines the color of the light that affects the entire object, not only the areas on 
which the light shines. It is combined with ambient portions of materials.
You can use ambient light to simulate light reflected off the walls in your World. 
For example, if you shine a spot light on the front of an object, the ambient light 
color will affect the back of the object, like the light that bounces of the walls in the 
real world. If you do not want to light the back of the object, you can set the ambient 
light to black.

Intensity Sets the brightness of a light. It ranges from 0 to 100, with 0 turning the light off and 
100 being the highest value. By animating Intensity, you simulate a light dimmer.

Fall-off Available for point and spot lights, fall-off simulates the natural attenuation of light 
with distance. 

Fall-off 
distance

The distance at which the light has very little effect. At the fall-off distance, the light 
is at 10% of its original intensity.

Spot angle Describes the opening, in degrees, of the spot light beam. A low spot angle results 
in a very thin cone of light, whereas a high value lights a larger area.

Spot 
concentration

Determines how the intensity of the light beam falls off as it spreads out from the 
center of the cone of light. The default value of 8 produces a subtle edge around the 
spot light's cone. A lower value, such as 1 or 2, produces a stark, contrasted edge 
where the light cone hits an object, and displays the full angle of the spot light's 
cone. A high value such as 100 creates a very small light point quickly fading 
towards black.
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completely dark. On the other hand, a high-powered lamp could probably light every corner of 
the basement. 

You can set fall-off to one of the following types.

None
The default for point and spot lights. No attenuation is used. The light has the same effect on an 
object 3 feet away as an object that is 2 miles further.

Gradual 
This produces an attenuation following a gentle curve. The light intensity gradually diminishes 
until it hits the fall-off distance, at which point it only has 10% of its remaining intensity.
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Rapid
This produces an almost immediate fading of light, similar to a night light.

Increasing subdivisions to improve lighting effect
The effect of a light depends on the surface that is reflecting it. For example, you can create 
different effects by varying the shininess of materials or create more uniform lighting by 
increasing the surface subdivisions.The more subdivisions objects have, the better they convey 
the subtleties of lighting and produce smooth results. 

A horizontal plane with 5 
subdivisions in X and Y

A horizontal plane with 15 
subdivisions in X and Y
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WebCams
In WebCam view and in the published content, you look at your World through a WebCam—
AXEL’s designation for what’s usually called cameras in traditional 3D software. By adjusting 
the WebCam, you control what appears on the screen. WebCam’s are also distinguished from 
their traditional counterparts because like other AXEL objects they are highly interactive and 
animatable. 

Examples of WebCam animation and interaction include: 

• Adding path animation to a WebCam so it negotiates through a scene, perhaps pointing to a particular 
object due to a Direction constraint. For more information see “Path animation” on page 404 and 
“Direction constraint” on page 273.

• Constraining a WebCam to an object using a Pin Joint, and then animating the Pin Joint’s Joint angle 
parameter to swivel the camera. For more information see “Pin Joint constraint” on page 283. 

• Creating a navigation system for a WebCam to act as the point-of-view of your character using a 
combination of Set Position and Set Orientation reactions with transition times, as well as keyboard, 
and or mouse sensors. For more information see “Set Position reaction” on page 434, “Set Orientation 
reaction” on page 437, “Keyboard sensor” on page 483, and “Mouse sensor” on page 469.

Adding WebCams
By default, the World contains one WebCam. You can add any number of WebCams to look at 
the World from different points of view. This view is sometimes called perspective in traditional 
3D software, as the WebCam does indeed offer a 3D-perspective viewpoint of your scene.

You can speed up the display of AXEL content through the WebCams by turning on Hardware 
Acceleration in Author settings / Visualize. For more information, see “Hardware 
acceleration” on page 594.

You can also clip the display of AXEL content through a WebCam by using a Clip box. For more 
information, see “Clipping” on page 596.

To add a WebCam to the World:
1. Choose Visualize > Add WebCam.

2. In Windows, to see the World through the new WebCam, right-click a viewport, choose Set 
Camera, and select the new WebCam. 
On the Macintosh, to see the World through the new WebCam, click the viewport label at the 
lower left of the viewport and select the new WebCam.

3. In the Project Manager, select the WebCam and adjust its parameters.
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4. To see the WebCam icon, turn on Visible, then choose Viewpoint > Frame Selection or press 
F.

WebCam Parameters

Position Sets the WebCam position.
Orientation Sets the WebCam orientation, that is, the direction along which you look at your 

World.
Scale Does not affect the WebCam.
Visible Shows/hides the WebCam icon in construction views.
Antialiasing Turns on/off antialising for all objects. If set to Per object, allows each object to 

retain its own antialiasing setting. For more information, see “About antialiasing” on 
page 594.

Background 
color

Sets the background color in the WebCam viewport. Determines background color 
of published content as well. Enter an RGB or HTML color value or click the color 
chip and use the Color dialog to set the background color. When publishing window-
less content, the WebCam background color becomes transparent. 

Rendering Style Can be set to Shaded, Cartoon, Custom Wireframe or Wireframe, overriding individ-
ual material’s rendering styles. If set to per Material, allows each material to main-
tain its own individual rendering style. 

Orthogonal pro-
jection

Removes the Field of View (FOV) angle, thus creating a non-perspective view.

Interest 
distance

Determines what the WebCam is looking at. Also determines the radius around 
which the WebCam orbits. Choosing Frame Selection moves the current WebCam’s 
interest to the center of the selected object.

Near plane 
distance

Indicates the distance between the WebCam and the beginning of the viewing frus-
tum. Objects between the WebCam and the near plane are not visible. For more 
information on the near plane, far plane, and FOV, see “About the viewing frustum” 
on page 343.

Perspective (left) and orthogonal projection (right).
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Far plane 
distance

Indicates the distance between the WebCam and the end of the viewing frustum. 
Objects beyond the far plane are not visible. 

Near plane 
height

Determines the height of the plane, which in turn determines the vertical FOV angle. 
Changing the Near plane height is the same as changing the FOV. The Near plane 
width is adjusted automatically to maintain the aspect ratio.

Vertical 
FOV angle

Determines the vertical FOV angle, which in turn determines the Near plane height. 
Changing the vertical FOV angle has the effect of zooming in on the objects. The 
horizontal FOV is set automatically to maintain the aspect ratio of the viewer. The 
FOV cannot exceed 170 degrees.
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About the viewing frustum
When you look through a WebCam, your scope of vision is limited by the WebCam’s viewing 
frustum.The viewing frustum determines what the WebCam sees. It is in the surface of a 
truncated pyramid. Only objects inside this pyramid are visible to the WebCam. The viewing 
frustum is defined by the near plane distance, the far plane distance, and the vertical FOV angle.

Adjusting the FOV is similar to changing the lens on the WebCam. In the following illustrations, 
the WebCam and the tower stay put, but the FOV angle is changed.

Note: If you turn on Orthogonal projection for your WebCam in the Parameter Editor, you lose 
perspective because the WebCam’s viewing frustrum becomes a rectangle, stretching out to the 
limit of the WebCam’s Far plane distance. You also can no longer perceive distance.

Viewing frustum

A low FOV value, such as 15 degrees, is like 
a tele-photo lens. It gives a close-up while 
flattening the image.

A value of 45 resembles a 
normal WebCam.

A high value such as 75 produces 
a fish-eye effect like a wide-
angle lens.



342 | AXEL V2 | User Guide

Switching WebCams
In WebCam view, you see the World through the eyes of one WebCam. If the World contains 
several WebCams, you can switch WebCams to look at the World from different vantage points 
and/or display the World using the different rendering styles of each WebCam. The label of the 
WebCam viewport indicates which WebCam is used. 

To switch WebCams:
In Windows, to see the World through the new WebCam, right-click a viewport, choose Set 
Camera, and select the WebCam you want to use. 
On the Macintosh, to see the World through the new WebCam, click the viewport name at the 
lower left of the viewport and select the WebCam you want to use.

Moving WebCams
You can zoom, pan, and orbit the WebCam interactively or point it at selected objects. Like any 
object, you can translate and rotate the WebCam, or adjust its position and orientation 
parameters. You can use constraints to make the WebCam follow an object in the World.

To zoom in or out of the World:
Click the Zoom button ( ) or hold Z, then drag in the WebCam viewport.
The current WebCam moves towards or away from the WebCam’s interest (what it is looking 
at).
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To pan:
Click the Pan button ( ) or hold X and drag in the WebCam viewport.
The current WebCam moves up-down or left-right.

To orbit: 
Click the Orbit button ( ) or hold C and drag in the WebCam viewport. 
The current WebCam moves around its interest on a circular axis, either horizontally (drag from 
left to right) or vertically (drag from top to bottom).
You can adjust the interest distance in a WebCam’s parameters. If you frame an object or objects, 
or a group, the WebCam’s interest is moved to the center of the object(s).

To move the WebCam using specific position and rotation values:
1. In the Project Manager, select the WebCam.

2. In the Parameter Editor, enter values in the Position and Orientation fields.
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To translate a WebCam using the mouse:
1. Select a WebCam.

2. In the Parameter Editor, turn on Visible.
The WebCam icon is visible in the viewports. Press F to bring it into view if needed.

3. Turn on the Translate button (or press T), then drag your cursor in a viewport.
The WebCam moves.

To rotate a WebCam using the mouse:
1. Select a WebCam.

2. In the Parameter Editor, turn on Visible.
The WebCam icon is visible in the viewports. Press F to bring it into view if needed.

3. Turn on the Rotate button (or press R), then drag your cursor in a viewport.
The WebCam turns around its center.

To attach the WebCam to an object:
1. In the Project Manager, multi-select the WebCam and the object, in that order.

2. Choose Relate > Constrain Pose.
The WebCam is attached to the object like a WebCam on a rig.

Pointing WebCams
By pointing the WebCam at different objects, you decide what appears on the screen.

To point the WebCam at an object:
1. Select the object(s). 

2. Click the WebCam viewport to make it active.

3. Choose View > Active Viewpoint > Frame Selection or press SHIFT+F.
The current WebCam points at the object(s) and moves in or out so that the object fills the 
viewport.

To make a WebCam always point at an object:
1. In the Project Manager, multi-select the WebCam and the object, in that order.

2. Choose Relate > Constrain Direction.
The WebCam keeps the object in its view wherever it goes.
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To reset the camera’s parameters to their original values: 
Choose View > All Viewports > Reset Viewpoint, or press Q for the active viewport or 
SHIFT+Q for all viewports.

Showing or hiding WebCam icons
You can show or hide the WebCam definition outlines in the construction views. The WebCam 
icon is useful when you are adjusting or animating the WebCam position and/or viewing 
frustum.

To show the WebCam icon:
In the Project Manager, select the WebCam, then turn on Visible in the Parameter Editor.
The WebCam’s definition outlines appears in the construction viewports. If you cannot see 
them, press F to frame the WebCam.

Creating a User Interface for a WebCam
You can create an interface for your 3D content by creating a group of objects then pose 
constraining this group to the WebCam. Try creating a flat, 2D interface, with a hollow space 
that acts as the area for your 3D content. As the WebCam moves through 3D space, the group 
always stays in the same relative position, acting as an interface.

For more information see “Pose constraint” on page 271, “Using groups” on page 257 and 
“WebCams” on page 340.



346 | AXEL V2 | User Guide

To create a user interface by constraining a group of objects to a WebCam:
1. Create the elements of your user interface and place them in your scene. Position your 

interface elements flat on the grid.

2. Translate the WebCam in the desired position vis-à-vis your user interface elements.

3. Multi-select all the user interface elements then group them by choosing Relate > Group, or 
pressing CTRL+G (Windows) or COMMAND+G (Macintosh).

4. In the Project Manager, multi-select your user interface group, then the WebCam.

5. Unlock your constraints ( ), then choose Relate > Constrain Pose.

6. Lock your constraints ( ).

7. Move the WebCam.
The User Interface group remains stationary vis-à-vis your viewpoint. You can still work on 
the objects of the group—manipulating or animating them—because it is the group, and by 
extension its center, that is constrained to the WebCam. You can always unlock your 

User Interface elements flat on the near 
plane of the WebCam’s viewing frustrum.
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constraints to tweak the position and orientation of the User Interface group in relation to the 
WebCam.

Tip: You are not limited to using only a 2D interface. You can add 3D objects, animate these 
objects, or constrain them to other objects in your scene. As long as they are part of this constrained 
User Interface group, they will move with the WebCam. You can also easily delete and add objects 
to this group.
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Chapter 7
Animation

Almost everything can be animated in AXEL.

You can animate an object’s scale, rotation and 
position values, as well as most other parameters. 
Animate a material’s transparency, a light’s intensity, 
even the resistance of a spring constraint. You can 
use different types of animation: Particles, Path 
animation, Waves and Shape animation.

To animate, you record keys, which are like 
snapshots of the scene in a particular state, at a 
particular point in time. AXEL then interpolates, or 
calculates the in-between frames, to give you full 
motion.

Animations are applied to single parameters. If you 
animate the scale and rotation of a sphere, you create 
two separate animations. Each can be edited 
individually in the Sequencer.

In this chapter:

Animations as reactions ...... 364

Animation tools ................... 364

Using the Sequencer ........... 367

Recording animation keys .. 375

When animating scale, position, 
and rotation, you can record the 
motion interactively, that is, 
AXEL records keys as you drag 
the object in the viewport. 
Animating parameters ...............
375Editing animation parameters 
384

Editing animation keys ....... 390

Editing animation keys ....... 390

Particles ............................... 398

Path animation .................... 404

Waves .................................. 406

Shape animation .................. 407
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Animations as reactions
All animations in AXEL are linked to triggers. You use triggers to add interaction to your World. 

A trigger signals when the animations begin to play. When you add an animation, it appears in 
the World linked to a TimeSensor at the current time. This simply means that the animation plays 
as your project plays. It is like a traditional linear animation in that it is only reacting to time. 
Later, you can change the trigger for the animation, so that it will start at a different time, or as 
a result of a particular action. 

Animation tools
Before you start animating, you should know how to:

• Navigate in time. 

• Preview an animation.  

• Use the Sequencer. 
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Navigating in time
You control time using the toolbars or by dragging the playhead in the Sequencer. 

The playback and animation tools are all available, by default, in the Sequencer.

In Windows, the time toolbar is in the top toolbar.

On the Macintosh, the time toolbar is in the toolbox.

To go to a specific time:
Do one of the following:

• Enter the time in seconds in the Time field.

• Click in the timeline. The playhead moves to that time.

• Drag the playhead. The animation updates in the viewports.

Current 
time Start time End time Play

Loop

 Time toolbar

Rewind
Fast 
forward

Go to End

Previous 
key

Next key

 Playback toolbar Animation toolbar

Go to Start

Stop Record

Add Animation

Add Key

Playhead
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To go to the previous or next key in an animation: 
In the Sequencer, select the animation or select a key, then do one of the following:

• Click the Previous Key button or press CTRL+SHIFT and the LEFT ARROW key (Windows) or 
COMMAND+PAGE UP (Macintosh).

• Click the Next Key button or press CTRL+SHIFT and the RIGHT ARROW key (Windows) or 
COMMAND+PAGE DOWN (Macintosh).
The playhead moves to the previous or next key in the selected animation sequence.

Previewing animation
You can play an animation in the viewports. As well, you can preview it as it will appear in a 
web page by clicking the Preview in AXEL button ( ) or by choosing Publish > Preview in 
AXEL.

To start playback:
Click the Play button ( ) or press the SPACEBAR.

To stop playback:
Click the Stop button ( ) or press the SPACEBAR.

To loop playback:
Turn on the Loop button. ( ).
When loop is on, the entire animation plays over and over again, from the Start time to the End 
time both when you are authoring and for the published content. 
If you want only certain sequences to loop, select Cycle for the Extrapolation parameter for 
those sequences. For more information, see “Editing animation parameters” on page 384. 

Tip: If you want the animations to loop when published, be sure to turn on Loop before you 
publish the World. You should be aware of whether this button is on whenever you are publishing 
your content.

Current timePrevious key Next key 
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To play back a portion of the animation:
1. Use the Start and End fields to define the portion that you want to play back.

2. Turn on Play (SPACEBAR).
The animation plays from the Start time to the End time.

Using the Sequencer
The Sequencer is a graphical representation of animation, interaction and streaming, through 
time. Use it to:

• Navigate through the animation by dragging the playhead.

• Offset animations in time. See “Offsetting animations” on page 372.

• Adjust the timing or the value of different keys. See “Editing key values” on page 390.

• Control the playback and recording of your animation, and synchronize these with other reactions. 

• Synchronize sound and/or movies with animation reactions. For more information, see “Play Sound 
reaction” on page 427 and “Adding movie textures” on page 317.

• Display animation curves that show parameter values over time. See “The Curve Editor” on page 371.

• View the Download Stream of your AXEL project organized by priority and item type. See 
“Streaming in the Sequencer” on page 587.
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The Sequencer provides two views:

• Interaction view shows all sensors and linked reactions. 

Note: Reactions and sensors that are not linked do not appear in the Sequencer.

• Streaming view shows all the geometries, sounds and textures in your project organized according to 
their respective streaming priorities.

Sensors, 
triggers and 
linked 
reactions

Show Interaction

Zoom bar Scroll bar Animation curve Keys

Sound file

Timeline

Show Streaming

Streaming 
priority



 Chapter 7 | Animation | 369

To switch views:
In the Sequencer, click the appropriate view icon.

To zoom in or out of the Sequencer:
Drag the Zoom bar.

To frame a portion of the animation:
Right-click (Windows) or CONTROL-click (Macintosh) the timeline, then choose one of the 
following:

Frame Selection Zooms in on the selected animation sequence.
Frame All Displays all animation sequences.
Frame Start to End Time Displays everything from the Start time to the End time.
Display/Hide Toolbar Displays the Sequencer’s toolbar.

Interaction Streaming
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To scrub the animation:
Drag the playhead.
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The Curve Editor
The curve editor shows the value of keys over time.

You can display curve editors only on Play Animation reactions in the Sequencer.

To display the curve editor for an animation sequence:
Double-click the animation sequence.

Notice the animation keys appear on the animation sequence and on the curves. On the 
animation sequence, you can drag keys left and right to change their timing but you cannot 
change their value. On the curve editor, you can drag keys left and right to change their timing, 
as well as up or down to change their value.

To zoom vertically in the curve editor:
Drag the lower edge of the animation sequence.

Animation sequence Curve editor

 Keys High and low values
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Offsetting animations
You can offset animations in the Sequencer by dragging the sequence left or right. You can also 
drag the first key away from the Sequence start time. In the Sequencer, the Sequence start time 
is represented by a small blue bar, showing the time from start of the sequence to the first key.

Example: Offsetting an animation by 5 seconds
You can offset an animation by dragging the Sequence start time.

1. Create an animation sequence which animates the position of a cube over 10 seconds.

2. In the Sequencer, drag the Sequence start time from 0 to 5 seconds.
A five second time offset is added to the start time of your animation. In the Interaction 
Editor, the AtTime trigger is updated to time 5.00. The key values of the animation are not 
affected.

Example: Using the same animation at different offsets
If you link an animation to different triggers, it can have different time offsets while retaining 
the values of all of its keys.

Sequence start time
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1. Link the PlayAnim from the above example to an OnLeftClick trigger under a MouseSensor. 
The PlayAnim can now be triggered by several sensors. It keeps the same animation values, 
but is located at different offsets in time.

2. In the Interaction Editor, click the link to the MouseSensor, then in the Parameter Editor, 
increase the Time Delay.
In the Sequencer, notice the Sequence start time moves to the right to reflect this new time 
delay.

Tip: When using group reactions that are set to be triggered all at once, you can stagger when the 
individual reactions comprising this group occur. Do this by offsetting the individual reactions’ first 
keys at different times for each reaction in the group reaction. So, despite all the reactions having 
the same trigger, they are each delayed by the different values which you set as offsets. For more 
information, see “Grouping reactions” on page 503.

Example: Dragging the first key in an animation sequence
When selecting and dragging the first key, you are changing its time value away from 0.00. 

1. Create an animation sequence that animates the position of a cube and drag its Sequence start 
time to 5 seconds.
The animation sequence is offset by 5 seconds.

2. In the Sequencer, drag the first key in the animation sequence to 9 seconds.
The time value of the first key is 4 seconds because it is positioned 4 seconds from the 
Sequence start time.

Notice that you cannot drag the first key earlier than the Sequence start time, which marks 
where time 0.00 is and prevents you from setting a negative time value as a start time.
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Tip: If there is an offset between the first key and the Sequence start time, you can add keys 
between the two. When you add a key in this segment it becomes the first key.
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Example: Offsetting and extrapolation
The Sequence start time also serves as a reference when using extrapolation in an animation. If 
there is an offset between the Sequence start time and an animation’s first key, and you 
extrapolate the sequence, it will extend backwards to the Sequence start time just as it extends 
forward in time.

1. Create an animation sequence where a ball bounces up and down, and link it to an 
OnLeftClick trigger. Make the sequence start with the ball on the ground.

2. Drag the Sequence start time to 5 seconds.

3. Drag the first key in the animation sequence to the right.

4. Select the animation sequence, and in the Parameter Editor, set its Extrapolation to Cycle.
The bouncing ball animation will start cycling from where the Sequence start time is located, 
which in this case is at 5 seconds. The sequence is extrapolated backward so that the 
animation’s first key retains its values and the ball starts the bouncing sequence from this 
point. If the segment between the Sequence start time and the first key is shorter than the span 
of the animation sequence, the first cycle starts in mid-sequence with the ball already in the 
midst of its bounce.

Recording animation keys
To record animation, first you create an animation sequence for the parameter you want to 
animate, then you record keys at different times. 

When animating scale, position, and rotation, you can record the motion interactively, that is, 

AXEL records keys as you drag the object in the viewport. Animating parameters 
You can animate most parameters in AXEL, for example, material transparency, color, or the 
angle of an object. To animate a parameter, you record keys for that parameter. 

The ball starts going up 
and down here

The ball hits the 
ground here 
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Recording keys is as simple as taking a picture of an object at different points in time. AXEL 
uses interpolation to determine the state of the object between the recorded keys. When you play 
back the animation, the object changes from one key to the next. Depending on the interpolation 
you select, the object can jump from key to key or change gradually over time.

To animate a parameter:
1. To make sure that your project is not playing, click Stop ( ), then go to the time where you 

want the animation to start.

2. In the Project Manager, select the parameter you want to animate. 

3. Do one of the following:

• Choose Animate > Add Animation Sequence.

• Click the Add Animation button ( ). This automatically turns on Record.
Record is turned on and an animation sequence appears in the Sequencer. Notice the first key.
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4. Go to another time, and adjust the parameter.
This creates another key. 

5. To record additional keys, go to other times and adjust the parameters.

6. Turn off Record.

7. To preview the result, drag the playhead to the start and turn on Play (SPACEBAR). 

To animate position, rotation, or scale:
1. Click Stop and go to the time where you want the animation to start.

2. Turn on Translate ( ), Scale ( ), or Rotate ( ), and select the object you want to 
animate. 

3. Do one of the following:

• Choose Animate > Add Animation Sequence. 

• Click the Add Animation button ( ).
Record is turned on and an animation sequence and a first key appear in the Sequencer. If the 
Translate button is on, a position animation is created. If the Rotate button is on, a rotation 
animation is created; if the Scale button is on, a scale animation is created.

4. To record another key, go to another time, and drag the object in a viewport.

5. To preview the result, drag the playhead to the start and Turn on Play (SPACEBAR). 

Example: Animating the scale of a cube
1. Click Stop and go to time 0.

2. Select the cube.

3. Turn on the Scale button ( ).
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4. Choose Animate > Add Animation Sequence, or click the Add Animation button.
An animation sequence appears in the Sequencer.

5. Go to time 2 and scale the cube. 
A new key appears in the Sequencer.

6. Go to time 4 and scale the cube again to add another key.

7. To preview the animation, scrub the Sequencer or go to time 0 and Turn on Play (SPACEBAR). 

8. Continue adding keys until you are pleased with the animation and then turn off Record to 
avoid adding keys by mistake.

Animation sequence First key
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Animating multiple parameters
You can animate multiple parameters simultaneously. As long as Record ( ) is turned on, and 
the parameters you want to animate have corresponding animation sequences linked to the Time 
Sensor, when you change the state of one of these parameters this change is recorded into a key 
value at the current time on the appropriate animation sequence.

The non-keyable parameter, here, is very useful, because turning it on locks your animation 
sequence making you unable to alter it. This can help you to avoid mistakes as you work 
simultaneously with multiple sequences.

Similarly, if an object has an animated parameter and you try to change the state of the parameter 
with the Record button turned off, you will be unable to. This is again a kind of locking 
mechanism different from the non-keyable parameter in that the non-keyable parameter locks 
the animation sequence even when Record is turned on.
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To animate multiple parameters:
1. Create animation tracks for the parameters you want to animate.

2. Move the playhead to a different time.

When you multi-select parameters then add 
an animation sequence, separate sequences 
are created for each selected parameter.
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3. With the Record button ( ) turned on, change the parameters corresponding to the 
animation tracks you made.

Keys are created at the current time on the appropriate animation sequence in the sequencer 
for each change of state that you cause. 

Recording animation during playback
An intuitive way to create animation is to move an object interactively during playback and 
record the movement.

To animate Scale, Rotation, and Translation, you can record the motion as you drag an object in 
the viewport. AXEL records 10 keys per second as you modify the object.

Note: Keys are saved every 0.1 seconds. If this method creates too many keys, record the keys 
individually. 

Example: Recording the motion of a cube as you translate it during playback
1. If your project is playing click Stop ( ), then go to time 0.

2. Turn on Translate ( ), and select the cube.

3. Choose Animate > Add Animation Sequence or click the Add Animation button ( ).
An animation sequence appears in the Sequencer.

When you change the value for the common parameter, keys are recorded on all the sequences.



382 | AXEL V2 | User Guide

4. Turn on Play (SPACEBAR) and drag the cube in a viewport.
As you move the sphere, AXEL records its position 10 times per second.

5. Click Stop and turn off Record.
AXEL stops recording position information. 

6. To preview the animation, go to time 0 and Turn on Play (SPACEBAR). 

7. In the Sequencer, drag the zoom bar to see all the keys you created.

8. Drag the playhead back and forth to scrub the animation.

Keys
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To select an animation:
Do one of the following:

• In the Sequencer, select the animation.

• Select the object that is animated, then click the animation reaction in the Parameter Editor.

• In the Project Manager, expand the object that is animated, then select the animation.

• In the Project Manager, expand Resources / Reactions, then select the animation reaction.
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Editing animation parameters
You can adjust animations by editing their parameters.

To edit animation parameters:
Select the animation sequence in the Sequencer or the Project Manager and edit its parameters 
in the Parameter Editor.



 Chapter 7 | Animation | 385

Animation Parameters

Non keyable Prevents you from adding keys to an animation sequence. 
Lock the keys of an animation sequence to apply more than one animation of the 
same type to an object. Otherwise, when you add a key, they are added to all of the 
sequences.

Interpolation Determines how the animation progresses between keys:

• Linear makes the parameter change evenly between keys.

• Constant makes the parameter stay constant until it reaches the next key; then it 
jumps to a new value. 

• Smooth creates gradual change before and after the keys. This type of 
interpolation is also known as ease-in and ease-out, or slow-in and slow-out. 
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Extrapolation Determines what happens to the animation once it is played through. The anima-
tion sequence is displayed in a different color after the last key to signal that it is 
extrapolated.

• None ends the animation once it is played, so that the animation has no more 
effect on the object once it is played through. For example, say a position 
animation ends at time 5 at position 0 0 1, then another translation animation 
begins at time 7 at position 1 0 5. At time 5 the object ends animation 1 at 
position 0 0 1, then at time 7, it jumps to position 1 0 5 to begin its new position 
animation, with no relationship between the two animations.

• Cycle makes the animation sequence repeat over and over. 

• Constant, as opposed to None, holds the value of the last key making it relevant 
to any further animations, and mixing with these animations according to their 
Weight. Once a secondary animation is complete, the animation parameter 
returns to the value it was at the end of the original animation.

Tip: Animations can also be extrapolated backwards. For more information, see 
“Example: Offsetting and extrapolation” on page 375.

Additive Adds the parameter’s value to its current value. For example, if one animation 
moves an object along the ground plane, you can create an additive animation to 
make it jump off the ground from time to time.

Time scale Slows down or speeds up the animation by a multiplication factor. Scaling the ani-
mation by 2 doubles the speed of the animation; scaling by 0.50 reduces the speed 
of the animation.

Tip: Try multi-selecting a few animation sequences and editing their 
common Time scale parameter in order to speed up, or slow down, all the 
animations by the same value.

Blue line in track 
indicates 
extrapolated track
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Example: animation cycle and interpolation
In this example, you animate the color of the signal lights at a railway crossing. You create an 
animation cycle where the light changes from dark red to bright red, then back to dark red. You 
use Constant interpolation to make the color change suddenly every 1/5 of a second.

Note: To try this example, open the Railway_start.axel in AXELprojects / Training Projects. 
You can also follow this example using a sphere with a red material.

1. If your project is playing click Stop ( ), then go to time 0.

2. In the Project Manager, select light1.

3. In the Parameter Editor, click on the material Light 1.

Weight Determines the weight of the animation relative to other forces that affect the 
parameter. For example, if an object has a position animation and a pose con-
straint, use Weight to control which affects the object most. 

Relative to group When animating objects in a group, the position, orientation, and scale keys are 
relative to the position, orientation, and scale of the group. For example, if a group 
contains a dancing bear and a train, the bear’s animation should be relative to the 
group so that the bear moves with the train as it dances.

Keys Lists the values of each key in the animation.

AXS/Animation_Railway.htm
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4. In the Parameter Editor, select the Color parameter.

5. Choose Animate > Add Animation Sequence or click the Add Animation button ( ).
An animation sequence appears in the Sequencer.

6. At time 0, set the color to dark red. Click the color chip in the Parameter Editor and select a 
color from the Color dialog that appears.

7. Go to 0.4 seconds and click the Add Key button, or press CTRL+K (Windows) or 
COMMAND+K (Macintosh).
A new key appears at time 0.4 in the Sequencer. The color is still dark red.

8. Go back to time 0.2 seconds, click the Add Key button or press CTRL+K (Windows) or 
COMMAND+K (Macintosh), and set the color to bright red.
Notice the keys in the Sequencer. Double-click the animation sequence to display the curve. 

9. To preview the animation, go to time 0, and turn on Play (SPACEBAR). 
The light gradually changes from dark red to bright red, then back to dark red.

Material color parameter

Bright redDark red Dark red
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10.To make the color change suddenly, select the animation sequence and set the Interpolation 
to Constant in the Parameter Editor. 
Notice the jumps in the animation curve. The color value changes suddenly at each key.

11.To make the animation cycle over and over again, switch the Extrapolation to Cycle.

Extrapolation
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Editing animation keys
You can edit key values, add, remove, or copy keys.

Editing key values
You can edit keys in the Sequencer, in the Parameter Editor, interactively in the viewports, or in 
the Project Manager.

To edit keys in the Sequencer:

• Drag the key left for it to be at an earlier time. Drag the key right for it to be at a later time. 

• Double-click the animation sequence to display the animation curve. Drag the keys left or right to 
change their timing, up to increase their value and down to decrease their value. For example, if you 
drag a key on the blue line, which represents the Z value over time, down and to the right, you are 
both decreasing its value, and having it reach this Z value at a later point in time.

To edit keys in the Parameter Editor:
Do one of the following:

• Select the animation sequence in the Sequencer or Project Manager, then click Keys in the Parameter 
Editor. Enter new values.

• Select a key in the Sequencer.
The keys are listed in the Parameter Editor where you can enter new values.

Drag to edit timing

Drag to edit value and timing
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The first number is the key time in seconds; the other numbers are the key values. For 
example, if you animate position, the first number is the time, and the next three numbers are 
the X, Y, and Z position of the object at that time.

Tip: To prevent the Parameter Editor from changing, click the Pin icon. This way you can fine-
tune the animation in the viewports and the Sequencer while editing key values in the Parameter 
Editor.

To edit manipulation keys interactively:
1. Select the animation sequence you want to edit.

2. Use the Previous and Next Key buttons to navigate to the key you want to edit.

3. Turn on Record and move the object in the viewport.
The current key updates in the Sequencer.

4. To add a key, go to the time where you want the new key, click the Add Key button or press 
CTRL+K (Windows) or COMMAND+K (Macintosh), and move the object in the viewport.

5. To preview the animation, turn on Play (SPACEBAR) or drag the playhead to scrub the 
animation.

Time X Y Z

Pin
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To edit keys in the Project Manager (Windows):
1. In the Project Manager, expand the object and then the animation to display the keys. For 

example, to access the keys for an animated material, expand the material and the animation 
under the material.

2. Click twice on the key that you want to edit, type the new values and press ENTER. The first 
number is the key time in seconds; the other numbers are the key values. For example, if you 
animate a color, the first number is the time, and the next three numbers are the red, green, 
and blue (RGB) values of the color at that time.

Adding, removing and copying keys
You can fine-tune animation by adding, removing, or copying keys. Copying keys is useful 
when you want a parameter’s value to repeat at several points in the animation, especially with 
shape animations where copying a geometry key provides a fast way to reproduce an unusual 
shape.

To add keys to an animation sequence:
1. Go to the time where you want to add a key.

2. Select the animation sequence to which you want to add a key.

3. Click the Add Key button ( ) or press CTRL+K (Windows) or COMMAND+K 
(Macintosh).

4. Adjust the object or parameter.

Color animation keys

Time R G B
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To delete a key:
Select the key, then press DELETE.

To delete an entire animation sequence:
Select the animation sequence and press DELETE.

To copy and paste key values (Windows):
1. In the Sequencer, select a key.

2. Press CTRL+C to copy the key’s values.

3. Select another key, and press CTRL+V.
The second key is set to the copied value.

For more information, see “Copying parameters in Windows” on page 65.

Example: recording and editing animation
In this example, you animate the gate at a railway crossing. The gate’s center was moved near 
the bolt. You can rotate the gate to lift or lower it. Create an animation by recording the motion 
interactively, then adjust the keys in the Sequencer.

Note: To try this example, open the Railway_start.axel in AXELprojects / Training Projects. 
You can also follow the example using a cube that you translate across the viewport.
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Record the animation:
1. Go to time 0, and rotate the gate to a vertical position.

2. Choose Animate > Add Animation Sequence or press the Add Animation button ( ).
A position animation appears in the Sequencer.

3. Turn on Play (SPACEBAR) and rotate the gate up and down a couple of times over the course 
of several seconds.
When you release the mouse, several keys appear in the Sequencer. 

4. To preview the animation, go to time 0 and turn on Play (SPACEBAR) or drag the playhead to 
scrub the animation.

Modify the animation using the Sequencer:
1. Right-click (Windows) or CONTROL-click (Macintosh) the animation sequence and choose 

Frame All.
All the keys appear in the Sequencer.

2. Double-click the animation sequence to display the curve editor, then edit keys on the X and 
Y axis to fine-tune the lowering of the gate.

Example: additive animation
Additive animation allows you to combine two animations. So while in AXEL you animate 
individual parameters on each object, this does not prevent you from having different kinds of 
animation on the same object, or even applying multiple sequences of the same type of 
animation on the same object.

This example uses additive animation to make a ball bounce up and down as it moves along a 
path. In the first animation, the sphere moves along a path on the ground; in the second 
animation, the sphere bounces straight up and down. When the bouncing animation is added to 
the path animation, the sphere bounces up and down as it moves along the path. The bouncing 
animation lets the surfer bounce the sphere as it moves along the path.

In this case it is easier to create first the bouncing animation, and then create the animation along 
the path.
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Create the bouncing animation with 3 position keys (down, up, down):
1. Choose Model > Add Surface > Sphere.

2. Make sure time is not running, then go to time 0.

3. Select the sphere, turn on the Translate tool, and choose Animate > Add Animation 
Sequence or click the Add Animation button ( ).
A position animation appears in the Sequencer, with the first key at time 0. This is the first 
key with the sphere on the ground.

4. Without moving the sphere, go to time 2, and click the Add Key button ( ) or press 
CTRL+K (Windows) or COMMAND+K (Macintosh), which adds a key. This is the third key, 
where the sphere is back on the ground.

5. To create the up position key, go to time 1 and drag the sphere up 2 units in front view. 

6. In the Sequencer, drag the playhead to scrub the animation.

7. Select a key to display the key values in the Parameter Editor, then set the keys to the 
following:

Notice how all other values are at 0. Only the movement along the Y axis is needed.

8. Go to time 0 and turn on Play (SPACEBAR) to preview the bouncing animation.

9. Select the bounce animation, then in the Parameter Editor, set the Interpolation to Smooth, 
and turn on Cycle. 
Now when you play the animation, the sphere bounces more smoothly, over and over again. 

10.In the Sequencer, double-click the animation sequence to display the animation curve. You 
can fine-tune the animation by adding keys and adjusting the shape of the animation curve.

To speed up the bouncing motion, increase the Time scale in the Parameter Editor.
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Create the path and a ground plane:
1. Choose Model > Add Surface > Horizontal Plane. Translate the plane along the Y axis so 

that the sphere is sitting on the ground.

2. Choose Model > Draw Curve or click the Draw Curve button ( ), and draw a curve in the 
Top viewport. In the curve geometry parameters, increase Steps to smoothen the curve.

Animate the sphere along the curve:
1. Make sure time is not running and go to time zero.

2. Multi-select the sphere and the curve, in that order, and choose Animate > Animate on Path. 
For more information, see “Path animation” on page 404.
Notice a Path constraint animation appears in the Sequencer.

3. Go to time 0, and turn on Play (SPACEBAR). 
The two animations are mixed, their pull on the sphere combining to result in an XYZ 
average. 

Make the bounce animation additive:
1. Select the bounce animation and turn on Additive.

Turn on Play to preview the result. The sphere bounces up and down as it moves along the 
path.
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Make the bounce interactive:
Instead of bouncing on its own, make the sphere bounce when the surfer presses the UP ARROW 
key. 

1. Select the bounce animation and turn off Cycle.

2. Choose Interact > Add Sensor > Keyboard - Arrow Keypad.

3. In the Interaction Editor, expand the ArrowKeySensor.

4. Unlink the PlayAnim reaction from the TimeSensor and link it to the OnKeyPress: Up trigger 
under the ArrowKeySensor.

5. Switch to Preview in AXEL to test the interaction. Press the UP ARROW key to make the 
sphere jump up.
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Particles
Use Particles to animate a large quantity of small objects that would be difficult to create 
otherwise. For example, you can use particles to create rain, smoke, snow and bubbles. 

When you create particles, an invisible object is added to the World. This object emits particles 
of varying sizes. You can treat the particle object, in most ways, like any other object, translating 
it, rotating it, adjusting its Scale, even applying a bend. Also like other objects, particles have a 
center. However the particle’s center is the point from which it emits.

Use the Shaded rendering style to color particles. You can also apply image and movie textures 
to particles.You can also constrain particles to another object as if the object was the source of 
the emission.You can place obstacles in the way of the particles and animate the obstacles to 
create believable particle behavior.

Default particles (left), transparent .png file applied on smoke particles (middle), and star-
shaped particles for snow (right).

To create particles:
1. Choose Animate > Add Particles.

A particle surface is added to the world at the World origin.

2. Turn on Play (SPACEBAR).

3. Select the Particles and adjust their parameters in the Parameter Editor. 
The particles update in the viewports as you change parameters.
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To select particles:
Do one of the following:

• In the Project Manager, select the Particles.

• In a viewport, marquee-select one or more of the particles.
The Particles parameters appear in the Parameter Editor.

To constrain particles to another object:
1. Select the particles then the object, in that order, and choose Relate > Constrain Pose.

When you turn on Play, particles emit from the object.

2. Turn on Unlock ( ) if necessary to add an offset.

To add a material to particles:
Select the particles and do one of the following

• Choose Visualize > Add Color Material > Shaded.

• Link the particles to an existing material

Note: Particles use only the color and transparency values of the material you select. They do not 
take lighting into account, similar to a regular object having a glow value of 100%.
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To apply textures to particles:
Select the particles and do one of the following

• Choose Visualize > Add Image Texture.

• Choose Visualize > Add Movie Texture.

• Link the particles to an existing textured material by multi-selecting the particles and the texture in 
the Project Manager, then pressing CTRL+L (Windows) or COMMAND+L (Macintosh).

Note: Performance can be greatly diminished by a large quantity of textured particles spinning 
around.

Particles parameters

Active Indicates whether the particles will be emitted. 
Number of 
points

Number of points that define the particles.

Emission rate Number of particles emitted per second.
Minimum age Minimum number of seconds particles emitted will last before disappearing. You 

can use different Minimum and Maximum age values to make the result look ran-
dom.

Maximum age Maximum number of seconds particles emitted will last before disappearing.
Minimum speed Minimum speed, in units per second, at which particles will travel. Snowflakes, for 

instance, will have a lower value than a hailstorm. Different Minimum and Maxi-
mum speed values ensure that the result looks a little more random.

Maximum speed Maximum speed, in units per second, at which particles will travel.

Sphere-shaped particles with a .png texture applied. 
The .png contains transparency.
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Speed factor Determines how much the particles will follow the source, which is the center of the 
particle surface, if it is moving. A value of 0 leaves the particles floating where they 
were generated, while a value of 100 makes the particles use the momentum of the 
moving surface.

Spread angle Spread of the emission, in degrees. A value of 0 creates a beam of particles. A value 
larger than 0 makes the particles fan out.

Particle1 size Size of the particles.
Spin rate Rate, in degrees per second, at which the particles spin while being emitted.
Gravity Axis (X,Y, or Z) along which gravity applies. The default 0, -1, 0 pulls the particles 

downwards (negative Y). Use X or Z values to simulate wind.

Particle shape Shape of emitted particles. Select Triangle, Star, Square, Disc, Cube, Sphere, or 
Cone.

0 degrees 90 degrees45 degrees

0, -1, 0 1, -1, 0
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Adding obstacles to particle flow
You can place obstacles in the path of particles to divert them.

To add obstacles to particles:
1. Create an object and place it in the path of the particles. 

2. CTRL-select (Windows) or COMMAND-select (Macintosh) the obstacle and the particles, 
then choose Animate > Link Particle Obstacle or press CTLR+L (Windows) or 
COMMAND+L (Macintosh).

Obstacle

Particles

Multi-select obstacle 
and particles
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The particles bounce off the obstacle. Move the obstacle, or add more obstacles to create 
different effects.

3. In the Parameter Editor, under ParticleGeometry, click on Obstacles for the list of objects 
used as obstacles for this particular particle group.

Note: The Obstacles affect only the particle group linked to them, not any other particles in your 
world, unless you add the same obstacles to these other particles.

To unlink obstacles from particles:
1. Multi-select the particles and the obstacle that are linked.

2. Choose Animate > Unlink Particle Obstacle.
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Path animation
You can draw a curve then use path animation to make an object move along the curve. 

This automatically creates a Curve Constraint between the object and the path. For more 
information, see “Curve constraint” on page 273.

To create path animation:
1. Multi-select an object and a curve, in that order. 

2. Choose Animate > Animate on Path.
Turn on Play to see the object move along the curve. By default, it moves from the beginning 
of the path to the end of the path in 10 seconds. 

3. Adjust the constraint parameters and animation parameters.

Upper right and upper left: Balloon animated along 
path.

Right: The curve’s visibility is turned off.
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Modifying a path animation
When you apply a path animation to an object, AXEL automatically adds a path constraint to 
the object to keep the object on the path, and animates the position of the object so that the object 
moves along the path. 

To modify a path animation:
1. In the Project Manager, expand the object to which you added a path animation.

Notice the path constraint. Expand the path constraint to see the position animation.

2. To change the way the object is attached to the curve, adjust the curve constraint parameters. 
For more information, see “Curve constraint” on page 273.

3. To change the object’s speed along the curve, modify the animation sequence. See “Editing 
animation parameters” on page 384.

4. To make the object move in the opposite direction, select the curve, then choose Model > 
Modify Curve > Invert.
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Waves 
You can apply an animated wave deformation to any object, for example, to create a waving flag. 
Make sure the object has enough subdivisions to deform smoothly. 

To apply a wave to an object:
1. Select the object and choose Animate > Apply Wave. 

2. Make sure Play is on to see the result.

Wave Animation Parameters

Active Indicates whether the animation is active.
Height Determines how much each point of the object is deformed. It represents the actual 

height of the wave.
Speed The speed, in units/second, at which the wave is propagating.
Length The distance between 2 consecutive “peaks” of the wave.

Some horizontal subdivisions.
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Shape animation
Shape animation is the animation of an object’s geometry. You create shape animation by 
animating points. Shape animation is affecting an object’s geometry so it is referred to as 
PlayAnim on the object’s geometry in the Sequencer and Interaction Editor.

This is useful for adding secondary movement to characters. For example, to make a character 
breath, you can add realism by animating the points on the character's stomach and nose.

To create shape animation:
1. Turn off Play and go to time 0.

2. Select an object, then switch to Point mode (P).

3. Turn on the Translate tool ( ).

4. Choose Animate > Add Animation Sequence or press the Add Animation button ( ).
An animation sequence appears in the Sequencer.

5. Go to another time and, translate points to modify the object's shape. 
A new key appears on the animation sequence.

6. To preview the result, go to time 0 and Turn on Play (SPACEBAR).

Note: Keep in mind that complex shape animation can significantly slow download time, and if it 
is complex enough, also performance, because every single point’s location over time has to be 
downloaded and calculated for each movement. For more information, see “Download time and 
performance” on page 588.

Example: animating a drop of water using Shape Animation
In this example, you animate the shape of a water drop falling from a tap. You do this by 
selecting and moving points and saving keys of various positions of those points.
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You could also use this method to make a mouth open and close, or any shape changing over 
time.

To animate the drop falling from a tap:
1. Choose Model > Add Surface > Sphere.

2. Click Stop and go to time 0.

3. In the Front viewport, translate the sphere 4 units in Y. 

4. Choose Animate > Add Animation Sequence or press the Add Animation button ( ).
Since the Translate tool was active when you turned on Record, an animation sequence is 
created for the position parameter. In the Sequencer, notice the key at time 0.
Go to time 3 and click the Add Key button, or choose Animate > Add Key or press CTRL+K 
(Windows) or COMMAND+K (Macintosh).
A second key, with the same position value, is added at time 3. 

5. Go to time 4.5, then, in the Front viewport, translate the sphere -8 units in Y, so that it is off 
screen. 
Since Record is turned on, moving the sphere automatically adds a key to the position 
animation sequence.

Create an animation sequence for the shape of the sphere: 
1. Select the sphere, switch to Point mode (P).

2. Return to time 0, then press CTRL+K. 
A geometry animation sequence and one key appear in the Sequencer.

3. Since the drop should return to a spherical shape after it is released from the tap, create a key 
for the spherical shape at time 3.2. Go to time 3.2 and click the Add Key button, or press 
CTRL+K (Windows) or COMMAND+K (Macintosh). 

Stretch the shape of the sphere so that it looks heavy as it leaves the tap:
1. Go to time 3.0 and select the points on the bottom half of the sphere. 

2. Translate them down about 2 units. 
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3. Translate any other points of the sphere until you have a drop that is about to break away from 
the tap.

4. Turn off Record to avoid saving keys by mistake.

5. Go to time 0 and turn on Play (SPACEBAR) to preview the animation.
To preview the result, go to time 0 and Turn on Play (SPACEBAR).
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Chapter 8
Interaction

  When you have modeled your project, added 
relations, materials and textures to it, and finally 
animated it, you can define different ways that web 
surfers can interact with your published content. Do 
this with reactions, sensors and triggers. 

A trigger is an action the surfer must do in order for 
a reaction to occur. For example, click a mouse 
button with the cursor on a particular object to switch 
the object’s material color from red to blue. The 
mouse is the sensor, while the button-click is the 
trigger. The connection from the trigger to the 
Switch Material reaction is called the link.

You can edit links, for example: trigger a reaction 
only once, every time a sensor is triggered, toggle the 
reaction on or off.

You can even create complex custom sensors and 
reactions with scripting. 

To explore the endless role of interaction in AXEL, 
it is best to begin with a short example.

In this chapter:

Example: Click a button to 
trigger an animation ............ 416

Working in the Interaction Editor 
417

Interaction in the Sequencer 421

Creating reactions ............... 424

Creating custom reactions 462 

Creating sensors and triggers ....
463

Creating custom sensors ..... 484 

Using handles ...................... 486

Editing Links ....................... 495

Grouping reactions .............. 503
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Example: Click a button to trigger an animation
In this example, you animate the scale of a cube and then replace its default AtTime trigger with 
another trigger, adding interaction. You then place a sensor on a sphere and link the animation 
reaction to that sensor’s trigger. When a surfer clicks the sphere, the scale animation of the cube 
plays.

Create a reaction:
1. Animate the scaling of a cube growing bigger over a couple of seconds.See “To animate 

position, rotation, or scale:” on page 377.

2. Turn on Play (SPACEBAR). 
The cube grows bigger.
The animation is a reaction triggered at time 0. It appears in the Interaction Editor, linked to 
the Time Sensor at time Zero. 

Link a different trigger to the reaction:
1. Create a sphere and translate it to the side of the cube. 

2. With the sphere selected, choose Interact > Add Sensor > Mouse. 
A mouse sensor is placed on the sphere. The new sensor appears in the Interaction Editor.

3. Unlink the reaction from time zero by dragging it off the PlayAnim reaction.

The mouse sensor is also listed in the Project Manager under the sphere.
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4. Expand the mouse sensor in the Interaction Editor, then drag from the OnLeftClick trigger to 
PlayAnim.

5. Switch to Preview in AXEL to test the interaction. Click the sphere to trigger the scaling 
animation.

Working in the Interaction Editor
The Interaction Editor provides a schematic view of the interaction in your World. It makes it 
easy to link, unlink, and organize sensors, triggers and reactions. 

You link a sensor’s trigger to a reaction so that an action causes a particular reaction. The link 
defines exactly what happens when a sensor triggers a reaction. For more information, see 
“Editing Links” on page 495.

The Interaction Editor includes a toolbar with the most relevant tools for creating interaction. 

Sensors

Triggers

Reaction

Link
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You can bring up the Interaction Editor’s context menu by right-clicking (Windows) or 
CONTROL-clicking (Macintosh) the Interaction Editor. You can also group reactions. For more 
information, see “Grouping reactions” on page 503.

To display reaction, group, or sensor parameters:
Click the box representing the reaction, group, or sensor.
Its parameters appear in the Parameter Editor.

To rearrange the order in which sensors are listed:
Drag the sensor to a new location in the list of sensors.
Other sensors move down to accommodate the reposition.

To remove a reaction, sensor, link or any item in the Interaction Editor:
In the Interaction Editor, select the item then press DELETE.

The PlaySound and 
PlayAnim reactions 
are grouped.

Context menu
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To display link parameters:
Click the line that links a reaction to a sensor or trigger.
The link parameters appear in the Parameter Editor.

To link reactions and triggers:
1. In the Interaction Editor, expand the sensor from its collapsed state to display its triggers.

2. Drag from the lower left corner of a trigger to a reaction. 

You can also SHIFT-click the trigger and reaction and choose Interact > Link Reaction, or 
press CTRL+L (Windows) or COMMAND+L (Macintosh).

Dragging from a collapsed sensor to a reaction links the reaction to the sensor’s first trigger. 

To link several reactions and triggers:
1. In the Interaction Editor, CTRL-click (Windows) or COMMAND-click (Macintosh) the 

trigger(s) and reaction(s) that you want to link.

Click to expand
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2. Choose Interact > Link Reaction, or press CTRL+L (Windows) or COMMAND+L 
(Macintosh).

Note: You can also drag from one trigger to several reactions and vice-versa.

To change a link from one reaction or trigger to another:
Drag the link away from a reaction or trigger box, then hinge it to another.

To unlink reactions and triggers:
Drag the link away from either box.

You can also SHIFT-click the trigger or the sensor, and its reaction, and choose Interact > 
Unlink Reaction or press CTRL+U (Windows) or COMMAND+SHIFT+L (Macintosh).

Note: Dragging a link away from a collapsed sensor unlinks all its triggers from their 
corresponding reactions. If the link from a collapsed sensor represents more that one linked trigger, 
it is black and thick.

To filter the display in the Interaction Editor:
Right-click (Windows) or CONTROL-click (Macintosh) the Interaction Editor, then choose an 
option from the menu:

Display all Displays all sensors and reactions.
Display selection Displays only selected sensors and reaction.
Include unlinked reactions Displays reactions that are not linked to a sensor.
Include linked sensors and reac-
tions

Displays reactions and sensors that are linked.

Displayed unlinked triggers Displays unlinked triggers.
Display compact names Displays a shortened name of the reactions and sensor.
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Interaction in the Sequencer
The Sequencer displays all sensors, with their triggers, that are linked to reactions. You can use 
it to test and edit the timing of various reactions.

The following Sequencer correlates to the Rocket project that is pictured. When you click the 
red button, four reactions occur: the rocket takes off, the red button is depressed, the rocket emits 
particles, and a clicking sound plays. 

By dragging the reactions left or right in the sequencer, you adjust the timing of each one. 

1 second later, rocket takes off

0 second later, button goes down and click sound plays

0.5 seconds later, particles starts

Surfer clicks big red button

Show 
Interaction

AXS/Interaction_RedButton.htm
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To display reactions in the Sequencer:
Expand the sensor and trigger that is linked to the reaction.

To edit a Play Animation reaction:
1. To edit the timing of keys, drag them in the Sequencer. The edit the timing and value of keys, 

drag them in the Sequencer’s Curve Editor. For more information, see “The Curve Editor” 
on page 371.

2. To add keys, select the animation sequence, move the playhead to the desired time, then 
choose Animate > Add Key, or press CTRL+K (Windows) or COMMAND+K (Macintosh).

3. To offset an animation in time, drag the track left or right by clicking and dragging inside the 
track, or by its Sequence start time bar. For more information, see “Offsetting animations” on 
page 372.

4. To preview the animation drag the playhead or turn on Play. If you want to preview a reaction 
that is triggered by a sensor other than the TimeSensor, you can add a second temporary link 
in the Interaction Editor from the reaction to an AtTime trigger, and then drag or turn on Play 
(SPACEBAR). Remove the link once you are satisfied.

Sensor

Reaction
Trigger
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5. To display the animation curve, double-click the animation track or click on the expand icon 
on the left of its name box. To hide the animation curve, double-click it again.

To preview a Play sound reaction:
1. To display the sound waveform, double-click the Play Sound reaction or click on the expand 

icon on the left of its name box.

2. To listen to the sound do one of the following:

• To preview sounds that are linked to the TimeSensor, drag the playhead or turn on Play 
(SPACEBAR). 

• For sounds that are nor linked to the TimeSensor, in the Interaction Editor, add a second 
temporary link from the reaction to an AtTime trigger, and then drag the playhead or turn 
on Play. If there are no triggers on the TimeSensor, choose Interact > Add Sensor > Time. 
Remove additional links once you are satisfied.

Waveform
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To preview reactions:
Do one of the following:

• To preview reactions that are linked to the TimeSensor, drag the playhead or turn on Play 
(SPACEBAR).

• For reactions that are not linked to the TimeSensor, in the Interaction Editor, add a second 
temporary link from the reaction to an AtTime trigger, then drag or turn on Play . If there 
are no triggers on the TimeSensor, choose Interact > Add Sensor > Time. Remove the 
additional links once you are satisfied.

To adjust the timing of reactions:
Drag the reactions in the timeline. 
The link’s time delay is updated. For more information, see “Editing animation keys” on page 
390.

Creating reactions
A reaction is an action that only occurs when it is triggered. Reactions can be animations, sounds 
and color changes, for example. They can be triggered by such actions as mouseovers, time 
marks, and key strokes.

Available reactions are listed in the Interact menu. The following sections describe the different 
reactions available and how to create them.
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Play Animation reaction
This reaction creates an animation linked to the TimeSensor at the current time. It is the same as 
adding an animation sequence. 

You can then link the reaction to any trigger. For more information, see “Animation” on page 
363 and “Animation Parameters” on page 385.

Play Animation Plays an Animation reaction. All animations are Play Animation reactions when 
they are created. See “Play Animation reaction” on page 425.

Play Sound Plays a Sound reaction. See “Play Sound reaction” on page 427.
Play Movie Plays a Movie reaction. See “Play Movie reaction” on page 429.
Switch WebCam Switches to a different WebCam. See “Switch WebCam reaction” on page 430.
Switch Material Swaps one material for another. See “Switch Material reaction” on page 430
Switch Geometry Swaps the geometry of one object for another. See “Switch Geometry reaction” 

on page 433.
Set Position Translates an object directly to a set position or in increments. See “Set Position 

reaction” on page 434.
Set Orientation Rotates an object directly to a set orientation or in increments. See “Set Orienta-

tion reaction” on page 437.
Set Scale Scales an object directly to a set size or in increments. See “Set Scale reaction” 

on page 441.
Set Pose Translates, rotates and scales an object to set values. See “Set Pose reaction” on 

page 444.
Set Parameter Changes the value of a parameter to a set value. See “Set Parameter reaction” on 

page 446.
Toggle Parameter Toggles a parameter between two values. See “Toggle Parameter reaction” on 

page 448.
Tootip Text Creates a text box over an object. You can then enter text and it appears on a 

MouseOver. See “Tooltip Text reaction” on page 451.
Hyperlink Places a hyperlink on an object. See “Hyperlink reaction” on page 452.
Download AXEL 
Stream

Downloads an AXEL stream file (.axs). See “Download AXEL Stream reaction” 
on page 454.

Call JavaScript Calls a JavaScript. See “Call JavaScript reaction” on page 458.
Goto Time Moves the animation to a specified time. See “Goto Time reaction” on page 459.
Control Time Starts or stops the World’s time. See “Control Time reaction” on page 461.
Custom 
(!AXELedge only)

Triggers a reaction according to the script that you enter. For more information, 
see “Creating custom reactions” on page 462.
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Play Sound reaction
This reaction plays a sound file. 

Multiple sound files can play simultaneously. Each Play Sound reaction can have different 
volumes, pan values and triggers. Also, Play Sound reactions can play at the same time as the 
sound from movies.

Keep in mind that sound files can be very heavy in terms of download time, so you should try 
to limit their size as well as improve their compression. Certain file formats, such as MIDI, are 
very light, yet sacrifice some quality. For more information, see “Estimating download time” on 
page 592.

You can import .wav, .mpeg/.mpg, .mp3 and .midi sound files.

Note: You may have to change the .mpeg file extension to .mpg before opening the sound file for 
AXEL to read the file properly.

To add a Play Sound reaction to an object:
1. Select the object. 

2. Choose Interact > Add Reaction > Play Sound.

3. In the Open dialog, select a sound file and click OK.
Switch to Preview in AXEL to test the interaction. When you click the object, the sound 
plays.
In the Interaction Editor, notice the Play Sound reaction is linked to a mouse sensor on the 
object.

Note: The sound file is copied to the Sound folder in the Project folder. If you select a sound file 
that is already used in the project, you are prompted to overwrite the existing file. Click No to 
use the existing sound file. Click Yes to update the existing sound file.
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To use a Play Sound reaction with any sensor:
1. With nothing selected, choose Interact > Add Reaction > Play Sound, then select a sound 

file.

2. In the Interaction Editor, link the reaction to a trigger.

To use the same sound in another Play Sound reaction:
The advantage of this approach is that you download the sound only once and can create 
multiple reactions with it.

1. In Project Manager / Resources / Sounds, select a sound.

2. Choose Interact > Add Reaction > Play Sound.

3. In the Interaction Editor, link the reaction to a trigger.

To play the sound over and over again:
In the Interaction Editor, select the Play Sound reaction and turn on Loop in the Parameter 
Editor.

To turn the sound on and off by clicking:
1. In the Interaction Editor, select the link.

2. In the Parameter Editor, set the Trigger mode to Toggle Start/Stop. 
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To view the sound waveform:
1. In the Sequencer, expand the sensor and trigger that is linked to the Play Sound reaction.

2. Double-click the Play Sound reaction or click the expand icon to the left of its name box.

3. To listen to the sound, ensure that the reaction is linked to a TimeSensor or add a second 
temporary link from the reaction to an AtTime trigger, then turn on Play or drag the playhead.

Play Sound reaction parameters

Play Movie reaction
This reaction plays a movie.

Movie files must be textured to an object to be played. They are imported as a movie texture, 
either linked to an object, or put it directly into Resources / Movies in the Project Manager to 
be applied on an object at a later time.

Adding a Play Movie reaction, which is identical to adding a movie texture from the Visualize 
menu, automatically creates a Play Movie reaction linked to the AtTime trigger at the current 
time. Its trigger can be changed and its link edited, like any reaction.

See “Adding movie textures” on page 317. 

Loop Plays the sound over and over again.
Volume Determines the volume of the sound, in percentage. The volume control combines 

with the volume set on the surfer’s computer.
Pan Determines left-right balance of the sound on a surfer’s computer. The value is from 

-100 to 100. At the default value, 0, the volume is balanced with both left and right 
sound channels at full volume. A negative number attenuates the right sound chan-
nel, keeping the left at full volume. A positive number attenuates the left sound chan-
nel, keeping the right sound channel at full volume. For example, a Pan value of -50 
keeps the left speaker at 100%, but attenuates the right speaker to 50%. The result of 
the pan is combined with the Volume parameter.

Waveform

Interaction icon
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Switch WebCam reaction
This reaction switches to a different WebCam.

By switching to a WebCam with different parameters, you can change the point of view, the 
background color, or any other WebCam parameter.

To create a switch WebCam reaction:
1. If necessary, add a second WebCam by choosing Visualize > Add WebCam.

2. In the Project Manager, select the WebCam to which you want to switch.

3. Choose Interact > Add Reaction > Switch WebCam.

4. Link the reaction to a trigger. 
When the reaction is triggered, the WebCam switches to the one you selected in step 1.

Switch Material reaction
This reaction swaps one material for another. 

For example, switch from one color, or material parameters (glow, transparency) to another. As 
well, you can use this reaction to swap textures, since a material supports a texture.

Pressing A switches the view between the two WebCams which both look 
out on the same scene, though from different angles.

AXS/Interaction_SwitchWebCam.htm


430 | AXEL V2 | User Guide

In the following illustration, the original material contains the texture with “ON” and the second 
material contains the texture with “OFF”.

To create a Switch Material reaction:
1. Make sure you have at least one object with a material applied, and a second material, either 

on another object or under Resources / Materials in the Project Manager.

2. Multi-select the object and the material it should switch to.

3. Choose Interact > Add Reaction > Switch Material.

4. Link the reaction to a sensor.
When the reaction is triggered, the object’s material is set to the material you selected in step 
2.
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Note: If you want to swap textures, both the initial and target material should have textures 
(textures appear under the Material).

The texture follows 
the material.
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Switch Geometry reaction
This reaction swaps the geometry of one object for another.

For example, swap the geometry of an ant for that of an elephant. The two objects do not have 
to have the same number of points.When the reaction is triggered, the first object takes the shape 
of the second object. 

In many cases, you hide the second object because it only serves to define the reaction result of 
the first object.

Note: This reaction is different from a Shape animation, where a shape changes over time, or Mix 
Shape, where a shape changes as you move the object (and all objects should have the same amount 
of points).

Example: Changing a cube into a sphere:
1. In the Project Manager, expand the cube and the sphere.

2. First select the object whose shape will change (Cube), then multi-select the geometry of the 
second object (SphereGeometry).

3. Choose Interact > Add Reaction > Switch Geometry.

4. Link the reaction to a trigger.
When the reaction is triggered, the cube becomes a sphere.



 Chapter 8 | Interaction | 433

Set Position reaction
This reaction translates an object to a saved position, or translates an object by increments each 
time the reaction is triggered.

To create a Set Position reaction:
1. Select an object.

2. Choose Interact > Add Reaction > Set Position.

3. Adjust the reaction’s parameters in the Parameter Editor.

4. Link the reaction to a sensor. 
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Set Position reaction parameters

Example: Moving a character forward
You can use the Set Position reaction to easily control the movement of a character. In this 
example, every time the UP ARROW is pressed a robot moves towards a rocket in the distance.

Target position Determines the X Y Z position the object goes to when the reaction is triggered, or, 
when Additive is turned on, it determines the values added to an object’s position 
parameters.

Transition time Determines the time the reaction takes (in seconds). Allows a smooth transition from 
one value to another. 
Not available for on/off parameters such as Visibility.

Additive If Additive is turned off, the target position parameters replace the position param-
eters when the reaction is triggered. If Additive is turned on, the target position val-
ues will instead be added to the current X Y Z position parameters of the object each 
time the reaction is triggered.

Local If Local is turned off, the reaction uses the global axes. If it is turned on, the reaction 
uses the object’s local axes. When Local is turned on, Additive is always turned on.

AXS/Interaction_SetPosition.htm
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To apply a Set Position reaction:
1. Select an object or a group

2. Choose Interact > Add Reaction > Set Position.

3. Enter a Target position of 0, 0, -5. 
The negative value in the Z coordinate will make it move away. 

4. Turn on Additive. 
Every time the reaction is triggered, it adds the value to the current position.

5. Add a Transition time so that the object moves smoothly from one position to another.

6. Turn on Local.
The reaction appears in the Interaction Editor.

7. Choose Interact > Add Sensor > Keyboard - Arrow Keypad.

8. In the Interaction Editor, link OnKeyPress: Up from under the ArrowKey sensor to the Set 
Position reaction.
Each time you press the UP ARROW key the Robot moves into the distance by the value you 
entered in step 3, until it is out of the field of vision of the WebCam.
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Set Orientation reaction
This reaction rotates an object to a saved orientation, or rotates an object by increments each 
time the reaction is triggered.

To create a Set Orientation reaction:
1. Select an object.

2. Choose Interact > Add Reaction > Set Orientation.

3. Adjust reaction’s parameters in the Parameter Editor.

4. Link the reaction to a sensor in the Interaction Editor.
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Set Orientation reaction parameters

Example: Turning a character
The Set Orientation reaction can add further control to the movement of a character. In the 
following example, make the Robot character turn around its center each time you trigger the 
reaction by pressing the RIGHT ARROW key.

Target orientation Determines the orientation the object rotates to when the reaction is triggered, or the 
values added to an object’s orientation parameters when Additive is turned on.

Transition time Determines the time the reaction takes (in seconds).
Additive If Additive is turned off, the target position parameters replace the position param-

eters when the reaction is triggered. If Additive is turned on, the target position val-
ues will instead be added to the current X Y Z position parameters of the object each 
time the reaction is triggered.

Local If Local is turned off, the reaction uses the global axes if it is turned on, the reaction 
uses the object’s local axes. When Local is turned on, Additive is always turned on.

AXS/Interaction_SetOrientation.htm
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To apply a Set Orientation reaction:
1. Select an object or a group.

2. Choose Interact > Add Reaction > Set Orientation.

3. Enter a Target orientation. In this case, add a negative value for the Y coordinate.

4. Turn on Additive.
Every time the reaction is triggered, it adds the value to the current orientation.
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5. Add a Transition time so that the object rotates smoothly.
The reaction appears in the Interaction Editor.

6. Choose Interact > Add Sensor > Keyboard - Arrow Keypad.

7. In the Interaction Editor, link OnKeyPress: Right from under the ArrowKey sensor to the Set 
Orientation Reaction.
Each time you press the RIGHT ARROW key the Robot character turns further clockwise by 
the value you entered in step 3.
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Set Scale reaction
This reaction scales an object to a saved size, or scales an object in increments each time the 
reaction is triggered.

To create a Set Scale reaction:
1. Select an object.

2. Choose Interact > Add Reaction > Set Scale.

3. Adjust the reaction’s parameters in the Parameter Editor.

4. Link the reaction to a sensor. 
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Set Scale reaction parameters

Example: Enlarging a character
The Set Scale reaction changes the size of a character. In this example, make the robot grow each 
time you trigger the reaction by rolling the cursor over the robot.

To apply a Set Scale reaction:
1. Select an object or a group.

2. Choose Interact > Add Reaction > Set Scale.

3. Enter a Target scale. In this case, add new values, such as 2, 2, 2. 

Target scale Determines the size the object scales to when the reaction is triggered, or the values 
added to an object’s scale parameters when Additive is turned on.

Transition time Determines the time the reaction takes (in seconds).
Additive If Additive is turned off, the target position parameters replace the position param-

eters when the reaction is triggered. If Additive is turned on, the target position val-
ues will instead be added to the current X Y Z position parameters of the object each 
time the reaction is triggered.

AXS/Interaction_SetScaling.htm
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4. Turn on Additive if you want to keep on adding multiplying factors.
The reaction appears in the Interaction Editor.

5. Add a MouseOver trigger to the reaction by first adding a Mouse Sensor to the group. Select 
the group in the Project Manager then choose Interact > Add Sensor > Mouse. 

6. Link OnMouseOver from under the Mouse Sensor to the Set Scale reaction in the Interaction 
Editor.
Each time you roll the cursor over the robot, it grows by the value you entered in step 3.
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Set Pose reaction
This reaction makes an object revert to saved position, orientation and scale values. 

This reaction is useful for resetting an object with a translate, rotate, or scale handle: the Set Pose 
reaction could make the object return to its initial position and size after a surfer manipulates it 
on the web page.

To create a Set Pose reaction:
1. Select an object.

2. Do one of the following:

• In the viewports or in the Parameter Editor, adjust the object’s position, orientation and scale values 
to the state that you want the object to be at the end of the reaction. Choose Interact > Add 
Reaction > Set Pose. The target position, target orientation and target scale of the object in the 
Parameter Editor correspond to the values of the current state of the object.

• Choose Interact > Add Reaction > Set Pose, then set target values for position, orientation 
and scale.

3. Link the reaction to a trigger, for example, an ArrowKey trigger.

4. To test the interaction, move the object, and then switch to Preview in AXEL. When you 
press the ARROW key, the object jumps back to the position you specified.

Set Pose reaction parameters

Target position Determines the X Y Z position the object goes to when the reaction is triggered.

After position, orientation and scale animations transform the biplane, a Set Pose 
reaction linked to a MouseSensor on the text returns it to its initial position.

AXS/Interaction_SetPose.htm
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Target orientation Determines the orientation the object rotates to when the reaction is triggered.
Target scale Determines the size the object scales to when the reaction is triggered.
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Set Parameter reaction
This reaction changes the value of a parameter to a set value. For example, use Set Parameter to 
let surfers change the emission rate of particles.

You can apply this reaction to several parameters at once.

To create a Set Parameter reaction:
1. Select the parameter. 

2. Choose Interact > Add Reaction > Set Parameter.
In the Interaction Editor, a Set Parameter reaction appears for each selected parameter.

3. In the Parameter Editor, enter the value to which the parameter will be set when the reaction 
is triggered.

Tip: You can multi-select parameters to create several Set Parameter reactions at once.
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Set Parameter reaction parameters

Example: Turning a light off

1. Select a light’s Turned on parameter.

2. Choose Interact > Add Reaction > Set Parameter. 

Value The parameter is set to this value when the reaction is triggered.
Transition time Determines the time the reaction takes (in seconds). Allows a smooth transition from 

one value to another. 
Not available for on/off parameters such as Visibility.

Additive If Additive is turned off, Value replaces the parameter value when the reaction is 
triggered. If Additive is turned on, Value is added to the parameter’s value when the 
reaction is triggered. 
This parameter is not relevant for on/off values such as Visibility.

The light is turned off via a Set 
Parameter reaction applied to the 
lights’s Turned on parameter.

AXS/Interaction_SetParameter.htm
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3. Select the reaction in the Interaction Editor, and then set the Value to off in the Parameter 
Editor.

4. Choose Interact > Add Sensor > Keyboard - Arrow Keypad.

5. Expand the ArrowKeySensor and link OnKeyPress: Down to the new reaction. 

6. Switch to Preview in AXEL to test the interaction. When you press the DOWN ARROW key, 
the light goes off.

Toggle Parameter reaction
This reaction toggles a parameter between two values. 

For example, toggle the emission rate of particles between 0 and 100 to stop and start particle 
emission, or toggle a light on and off. In the following illustration, the duck is animated along 
two paths. A Toggle Parameter reaction is applied to the Active parameter of each path 
animation: when you press the red button, the duck jumps from one path to another.

You can apply this reaction to several parameters at once.

Note: The difference between the Set Parameter and Toggle Parameter reactions is that Set 
Parameter sets the parameter to a new value, whereas Toggle Parameter lets you alternate between 
two values.

Note: The Toggle Parameter reaction is similar to the Set Parameter reaction except that Set 
Parameter sets a new value and stays that way, whereas Toggle Parameter lets you alternate 
between two values.
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To create a Toggle Parameter reaction:

1. In the Project Manager, select the parameter(s).

2. Choose Interact > Add Reaction > Toggle Parameter. 
In the Interaction Editor, a Toggle Parameter reaction appears for each selected parameter.

3. Select a ToggleParam reaction.

4. In the Parameter Editor, enter Start and Stop values. 
Each time the reaction is triggered, the parameter value toggles between the Start value and 
the Stop value.

The light is toggled on/off via a Toggle 
Parameter reaction applied to the 
lights’s Turned on parameter.

AXS/Interaction_ToggleParameter.htm
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Toggle Parameter reaction parameters

Example: Turning a light on and off
1. Select a light’s Turned on parameter.

2. Choose Interact > Add Reaction > Toggle Parameter. 

3. In the Interaction Editor, select the reaction.

4. In the Parameter Editor, set the Start value to Yes and the Stop value to No.

5. Choose Interact > Add Sensor > Keyboard - Arrow Keypad.

6. Expand the ArrowKeySensor and link OnKeyPress: Down to the new reaction.

7. Switch to Preview in AXEL to test the interaction. Press the Down ARROW key to toggle the 
light on and off.

Start value The value of the parameter the first time you trigger the reaction.
Stop value The value after the next time you trigger the reaction. 

Yellow link indicates Toggle.
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Tooltip Text reaction
The Tooltip Text reaction creates a text box over an object.

You can also attach a tooltip to the web cursor.

By default, this reaction is linked to a MouseOver trigger. This allows you to display 
information, such as hints and warnings. You can edit the tooltip text and color at any time.

To create a Tooltip Text reaction:
1. Select an object.

2. Choose Interact > Add Reaction > Tooltip Text.

3. Enter text in the Text Entry dialog that appears.

4. When previewing in AXEL, move the cursor over the surface.
The tooltip appears. In the Interaction Editor, a new Tooltip reaction is linked to a new Mouse 
Sensor on the selected object. By default, the MouseOver trigger is used. 

To edit the tooltip text or color:
Select the Tooltip reaction in the Interaction Editor and modify its parameters in the Parameter 
Editor.
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Tooltip text reaction parameters

Hyperlink reaction
This reaction places a hyperlink on the object. For example, by clicking on a character, the surfer 
could go straight to the character’s home page.

You can enter full or relative URLs. A relative URL is relative to where the host web page is 
stored. The host web page is the HTML file containing the AXEL object. 

You can use the following URLs in a Hyperlink reaction:

• ./nextpage.htm or nextpage.htm links to an HTM file in the same directory as the host web page.

• ./nextpage or subdirectory/nextpage.htm links to an HTM file in a subdirectory of the host web page 
directory.

Absolute URLs must start with http:// For example:

http://www.MindAvenue.com

Note: In some cases, it may not be convenient to code hyperlinks in the 3D content. You may prefer 
to manage all the hyperlinks in the HTML page. To do this, you can use the Call JavaScript reaction 
instead of the Hyperlink reaction and set the hyperlink in the JavaScript code (which resides in the 
HTML page). See “Call JavaScript reaction” on page 458.

The Hyperlink reaction supports all types of URL protocols, including:

• http
• JavaScript
• File
• ftp: download/upload files
• Mailto
• News 
• Gopher 
The reaction can be set in three ways: 

• If you create the reaction with nothing selected, it is added to the resource bank, waiting to be linked.

• If you select an object then create the reaction, a sensor is added to the object and the reaction is linked 
to it. The sensor is set to OnLeftClick.

• If you select a trigger then create the reaction, the reaction is linked to the trigger.

Text The text that pops up in the tooltip.
Text color The color of the text. Enter an RGB value or click the color chip and select a 

color.
Background color The color of the box around the tooltip text. Enter an RGB value or click the color 

chip and select a color.
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To add a Hyperlink reaction to an object:
1. Select the object and choose Interact > Add Reaction > Hyperlink.

2. Enter the hyperlink that you want the reaction to open, and click OK. 

3. To test the interaction, publish the host web page. For more information, see “Publishing 3D 
content” on page 556.
When you click the object, the web browser opens the specified link.

To trigger a Hyperlink reaction with any sensor:
1. Click an empty part of the viewport to select nothing, then choose 

Interact > Add Reaction > Hyperlink.

2. Link the reaction to a sensor.

To change the URL:
In the Interaction Editor, select the reaction, then adjust its parameters in the Parameter Editor.

Hyperlink reaction parameters

URL The address to which you want to link.
Open in new 
window

Makes the link open in a second window.
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Download AXEL Stream reaction
This reaction downloads an AXEL stream file. Use this reaction to:

• Replace one stream file with another. For example, play a teaser animation then replace it with a larger 
World that takes longer to download, or create very sophisticated projects with multiple AXEL stream 
files that download only when triggered. 

Note: You can also replace the stream file with itself to refresh the 3D content on a page without 
downloading it again. For more information, see “Refreshing the 3D AXEL content in a web page” 
on page 457.

• Merge one stream file into another, adding information without changing the URL.

• Substitute geometry or texture files in the current stream file with new elements from another stream 
file. For example, to change the hubcaps on a car, click a button to download a stream file with four 
different hubcap textures.

To add a Download AXEL Stream reaction to an object:
1. Select the object, then choose Interact > Add Reaction > Download AXEL Stream.

2. Enter the name of the stream file that you want the reaction to download. 

Each AXEL Stream file includes a 
Download Stream reaction that, 
when triggerd, replaces the current 
content with another.

AXS/Interaction_Download_Stream.htm
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Note: You can only use AXEL stream file with the .axs extension, not AXEL content that has been 
converted to QuickTime movies. However, all your content can still be run through QuickTime. For 
more information, see “Webpages and AXEL content” on page 566

3. In the Interaction Editor, select the reaction, then adjust its parameters in the Parameter 
Editor.

4. To test the interaction, publish the host web page.
When you click the object, the stream file is downloaded.

To link a Download AXEL Stream reaction to a sensor:
1. With nothing selected, choose Interact > Add Reaction > Download AXEL Stream.

2. Enter the name of the stream file that you want the reaction to download.

3. In the Interaction Editor, select the reaction, then adjust its parameters in the Parameter 
Editor.

4. Link the reaction to a sensor.

5. To test the interaction, publish the host web page.
When the reaction is triggered, the stream file is downloaded.

Download AXEL Stream reaction parameters

Creating a teaser animation
Use a teaser to occupy the surfer as the larger World downloads, or to introduce the larger World, 
for example. You add a Download AXEL Stream reaction so that the larger World replaces the 
teaser.

If an object’s streaming is off, AXEL waits for that object to download before displaying the 
World. Since the teaser plays while the larger World is downloading, you may want to turn off 
streaming for all objects, textures and sounds. That way, the larger World interrupts the teaser 
only when everything is downloaded. Publish the larger World to create the larger stream file.

Replace The downloaded World replaces the current World. If the reaction is set to download the 
current World, the stream file is not downloaded again. Instead, it is reloaded, thus 
refreshing the current content.

Merge The downloaded World is added to the current World. This is similar to importing an 
AXEL project in author mode. For more information, see “Importing AXEL projects” on 
page 100

Substitute Downloads a second World, and replaces identically named geometry and textures.
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To create a teaser animation:
1. Create a teaser and a larger World.

2. In the larger World, turn off streaming for all the objects, textures, and sounds that you want 
to see when the larger World is first displayed.

3. In the teaser animation, choose Interact > Download AXEL Stream.

4. In the Download AXEL stream dialog, enter the name of the larger stream file.

5. Select the Download AXEL Stream reaction and set the mode to Replace.

6. Link the Download AXEL Stream reaction to a BrowserSensor / OnFinalDownload trigger.

7. Publish the teaser.
When the surfer downloads the teaser, the Download AXEL Stream reaction is triggered and 
AXEL starts downloading the larger stream file. While the Web Surfer views and interacts 
with the teaser, the larger world is downloading.
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Refreshing the 3D AXEL content in a web page
This reaction refreshes the current World by reloading the .axs that is already on a surfer’s 
computer.

To use Download AXEL Stream to refresh the 3D AXEL content in a web page:
1. Create a Download AXEL Stream reaction that downloads the current World. For example, 

in MyWorld.axel, create a Download AXEL Stream reaction to download MyWorld.axs.

2. Set the reaction parameter to Replace.

3. Link the reaction to a sensor.
When the sensor is triggered, the Download AXEL Stream reaction does not download 
MyWorld.axs again. Instead, it reloads it, thus refreshing the current content.

To use Download AXEL Stream to replace elements of your file:
When you select Replace mode for the Download AXEL Stream reaction, the reaction looks for 
all identical Geometry and Texture names, and replaces the old ones with the ones in the 
downloaded stream file.

1. Create a clown and rename the geometry of its nose object to NoseGeometry.

2. Create another file containing only a different nose object.

3. Rename the geometry of its nose object to NoseGeometry.

4. Publish a stream file named Nose2.axs.

Replace looks at Geometry 
names, not object names.

Replace looks at Texture 
names, not object names.



 Chapter 8 | Interaction | 457

5. In the Clown file, choose Interact > Add Reaction > Download AXEL Stream and type in 
Nose2.axs.

6. Set the reaction parameter to Replace.

7. Link the reaction to a sensor.
When the sensor is triggered, the new nose replaces the old nose.

Call JavaScript reaction
This reaction calls a JavaScript when triggered. To call a JavaScript, the function must be 
defined in the host web page or be a standard one. For example, alert(message) is a standard 
method of a JavaScript window object; as long as myOnClick()is a function defined in your host 
web page, you can type: alert("Hello") or myOnClick()

To create a reaction that runs JavaScript:
1. Choose Interact > Add Reaction > Call JavaScript.

2. Enter the JavaScript that you want to run and click OK.

3. Link the reaction to a sensor.
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4. To test the reaction, publish a host web page. For more information, see “Publishing 3D 
content” on page 556.
When the reaction is triggered, the browser executes the script.

Call JavaScript reaction parameters

Goto Time reaction
This reaction moves the project time forward to a specified time. For example, have the surfer 
click to fast forward to the 100 second mark, where a new animation starts. 

The Go to Time reaction only goes forward so the reaction only occurs if the Go to Time is later 
than the current time.

Function name The JavaScript to run when the reaction is triggered.

Clinking each text moves the path 
animation forward in time.

AXS/Interaction_GoToTime.htm
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To Go to a Time by clicking an object:
1. Use the time controls or drag the playhead to the time where the reaction will start.

2. Select an object, and choose Interact > Add Reaction > Goto Time.

3. To test the interaction, switch to Preview in AXEL and click the object. 
The World goes to the selected time.

To link Go to Time to any trigger:
1. Use the time controls or drag the playhead to the time where the reaction will start.

2. With nothing selected, choose Interact > Add Reaction > Goto Time.

3. Link the reaction to a trigger.

4. To test the interaction, switch to Preview in AXEL and trigger the reaction. 
The World goes forward to the selected time.

To adjust the time: 
In the Interaction Editor, select the GoTo Time reaction, then adjust the Target time in the 
Parameter Editor.
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Go to Time reaction parameters

Control Time reaction
This reaction starts or stops the World’s clock.

Example: Stopping the clock
1. Open a project with animations, and/or sensors spread over time. You can also create a simple 

animation to try out this reaction.

2. Choose Interact > Add Reaction > Control Time.

3. From the Interact menu, add an Arrow Key sensor.

Target time The time the World goes to when the reaction is triggered.

Clicking the screen stops/starts 
time freezing the particles in 
their tracks. A MouseSensor 
on the WebCam is linked to a 
Control Time reaction set to 
Toggle Stop/Start.

AXS/Interaction_ControlTime.htm
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4. In the Interaction Editor, link the ControlTime reaction to the OnKeyPress: Up trigger, then 
select the link that joins them.

5. In the Parameter Editor, set the Trigger mode to Stop or Toggle.

6. Switch to Preview in AXEL to test the interaction. When you press the UP ARROW key, the 
animations stops since time is no longer running. If the Trigger mode is Toggle, then you can 
press again to restart the clock.

Creating custom reactions 

Custom reactions allow you to create more complex reactions that would not necessarily be 
possible with the standard reactions that are provided in AXEL.

For more information on scripting Custom reactions, see “Scripting” on page 517.

To create a custom reaction:
1. Select the parameter that will be set by the Custom reaction.

2. Choose Interact > Add Reaction > Custom. 
The Script dialog appears and a Custom reaction appears in the Interaction Editor.

3. Click in the script section and compose a script as follows:

• To enter a parameter name, select the parameter in the Project Manager, then click Insert 
World Selection. If an object name contains spaces, rename it to remove spaces. See 
“Scripts Syntax” on page 518.

• To enter an operator, click the Operators panel, then double-click the operator, or select the 
Operator and click Insert Operator (Windows). The operator is added to your script at the 
insertion point. When you select an operator an explanation of what it does appears below.
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• To enter a function, click the Functions panel, then double-click the function or select the 
function and click Insert Function (Windows). When you select a function an explanation 
of what it does appears below. To add arguments to the function, place the insertion point 
in the script to the left, select a parameter in the Project Manager, then click Insert World 
Selection.

4. Correct any errors in the script. Errors in the script appear in real time in the status box as you 
are typing the script. 

5. Click Apply to assign the value of the script to the parameter selected in step 1. 

6. To test the script, you can modify parameters in your project while the dialog is open and 
check the value in the script dialog. If the value is what you expected, your script works.

7. Click OK.
In the Project Manager, the Custom Relation appears under the object selected in step 1 and 
under Resources / Reactions. 

To edit the script:
1. In the Project Manager, select the script. It appears under Custom reaction, under the object 

and under Resources / Reactions.

2. Choose Edit > Edit Custom Script or double-click the script in the Project Manager.

3. The Script dialog appears. Edit the script, and then click OK.

Custom relations syntax
You can also type a script directly in the script dialog. See “Scripts Syntax” on page 518.

     Creating sensors and triggers
You use a sensor’s triggers to activate reactions.

Triggers appear under the sensors in the Interaction Editor. Sensors can have several triggers. 
For example, a mouse sensor can trigger a reaction on left click. A time sensor can trigger a 
reaction at a predefined time, for example, at 5 seconds. You expand a sensor to view its triggers.

The Interact menu displays all available sensors. When you choose a sensor, it appears in the 
Interaction Editor.

You can also create complex custom sensors which take multiple parameters into account before 
being triggered. For more information, see “Creating custom sensors” on page 484.
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To expand/collapse a sensor:
Click the arrow at the right end of the sensor in the Interaction Editor.



464 | AXEL V2 | User Guide

Available sensors

Browser sensor
The Browser sensor triggers a reaction either when AXEL content first begins to appear on a 
surfer’s computer, or when the AXEL content is fully downloaded to/streamed into the surfer’s 

Browser Triggers a reaction either when AXEL content first appears on a Web Surfer’s 
screen, or when all the content is fully downloaded. Particularly useful if content is 
streamed. See “Browser sensor” on page 466.

Mouse Triggers a reaction when the surfer moves the mouse over or clicks an object. You 
can also apply a mouse sensor to the WebCam; in this case, clicking the back-
ground triggers the reaction. See “Mouse sensor” on page 469.

Proximity Triggers a reaction when one object gets close to another. See “Proximity sensor” 
on page 473.

Position Triggers a reaction when an object is in a specific position. See “Position sensor” 
on page 475.

Orientation Triggers a reaction when an object is in a specific orientation. See “Orientation sen-
sor” on page 476.

Parameter Change Triggers a reaction when a parameter changes by more than a specified tolerance. 
See “Parameter change sensor” on page 477.

Parameter Range Triggers a reaction when a parameter value enters or exits a given range.
Use this sensor with parameters for which you can specify a range, such as Posi-
tion, Subdivision or Smoothness. For example, a light’s Intensity parameter is 
either on or off, and so would not work. See “Parameter Range sensor” on page 
478.

Time Triggers a reaction at a specific time. When you create animations, they are auto-
matically linked to the Time sensor at the current time. See “Time sensor” on page 
479.

Time Pulse Specifies a frequency at which a reaction will be triggered, as well as a start/end 
time. See “Time pulse sensor” on page 481.

Download Triggers a reaction when an object’s geometry, sound file or texture file download 
is complete. See “Download sensor” on page 482.

Refresh Rate Triggers a reaction when the refresh rate changes to a value above or below a target 
in the refresh rate. See “Refresh rate sensor” on page 483.

Keyboard 
sensors

Triggers a reaction when the surfer presses a key on the keyboard. There are six 
Keyboard groups: Alpha Key, Arrow Key, Number Key, Function Key, Input Key 
and Numeric Keypad. See “Keyboard sensor” on page 483.

Note: Only one sensor of each type can be added. 
Custom 
(!AXELedge 
only)

Triggers a reaction according to the script that you enter. For more information, see 
“Creating custom sensors” on page 484.
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machine. For more information on streaming, see Streaming in the Sequencer and “About 
antialiasing” on page 594.

For example, if you want a sound to play only when the AXEL content is fully downloaded, you 
would link the Play Sound reaction to the OnFinalDownload trigger under the browser sensor. 
OnFinalDownload is similarly useful for triggering PlayMovie reactions. For more information, 
see “To stream a movie inside an .axs file:” on page 320. 

You can preview your project while looking at the streaming view in the Sequencer to gage 
when these reactions will occur on surfer’s machines.

To use the Browser sensor:
Link the Browser sensor to a reaction.
By default the Browser Sensor appears in the Interaction Editor and cannot be deleted. If you 
cannot see the Browser sensor, right-click the Interaction Editor then choose Display all.

To preview when the Browser sensor triggers reactions:
1. With a reaction linked to the Browser sensor, click the Streaming view in the Sequencer.

2. Preview in AXEL (B) and notice your content streaming in as the reactions are triggered.
Reactions linked to OnFinalDownload are triggered when all content has streamed in.

The PlaySound reaction is triggered at this mark.
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Reactions linked to OnInitialDownload are triggered when content first appears. This could 
be useful, for example, if you want background music to start to play while your content is 
streaming in. In this case, remember to turn off streaming for the background music file so it 
is fully downloaded before it is triggered to play. 

The Browser sensor and Download AXEL Stream reactions
The Browser sensor is also particularly useful for Download AXEL Stream reactions.  

If this reactions is linked to OnIntialDownload, the incoming AXEL file begins to replace, 
merge with or substitute the current AXEL content as soon as the current AXEL content appears 
on screen, at the 0 mark. For the OnFinalDownload trigger, the current AXEL content would 
have to be fully downloaded before the second content from the Download Stream reaction 
begins to be downloaded.

The PlaySound reaction is triggered at this mark.
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This process is referred to as creating a teaser animation. For more information, see “Creating a 
teaser animation” on page 455.

Browser sensor parameters

Mouse sensor
The mouse sensor is one of the most intuitive sensors since the surfer is used to clicking objects 
on the screen. A mouse sensor uses the left, middle, or right mouse click, or a mouseover to 
trigger a reaction.

OnFinalDownload Triggers a reaction when AXEL content is completely downloaded to a 
surfer’s computer. For example, if your content is streamed and only want 
the sounds to play when the content is fully downloaded, link the Play 
Sound reaction to this trigger.

OnInitialDownload Triggers a reaction when AXEL content first appears on a surfer’s screen. 

Tip: Test the Browser Sensor’s triggers in the Streaming view in the 
Sequencer when you are previewing.

The second download stream only 
begins to download at this mark.
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You can add a mouse sensor to an object or to the WebCam. When the mouse sensor is on the 
WebCam, the interaction is triggered when the surfer moves the mouse over the background and 
clicks. The mouse sensor on a WebCam is used for navigation handles, such as orbiting and 
panning.

If you add an orbit WebCam handle, for instance, it will appear under the background mouse 
sensor. If you have both a WebCam handle and a Mouse sensor, for instance, surfers will be in 
WebCam Orbit mode until they go over an object with a sensor, at which time the WebCam Orbit 
mode will be temporarily deactivated to enable that object’s own sensor.

You can edit the cursor type of a mouse sensor, changing it to an arrow, a hand, for example to 
better represent the interaction to the surfer.

When surfers move the mouseover the object, the cursor changes to indicate that they can 
interact with that object. You can select which cursor appears.

Mouse buttons
Consider your audience when defining what mouse buttons to use as a trigger. Some surfers do 
not have middle or right buttons on their mouse, depending on the platform they use or the 
primary uses of their computer. Clicking a one-button mouse is equivalent to a left click in 
AXEL. The buttons on a two-button mouse are equivalent to left and right clicks. 

If you are using a one- or two-button mouse to author your project, you can still use all the 
triggers available in AXEL, but you will be unable to properly preview and test your page.

To create a mouse sensor:
1. Select an object.

2. Choose Interact > Add Sensor > Mouse.
A new mouse sensor appears in the Interaction Editor.
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3. To link the sensor to a reaction, expand the sensor and do one of the following:

• Drag from a trigger to a reaction.

• SHIFT-click a trigger and a reaction, then choose Interact > Link Reaction, or press 
CTRL+L (Windows) or COMMAND+L (Macintosh).

4. Switch to Preview in AXEL to test the interaction.
When you click the object, the reaction occurs. You will often want to edit the link between 
the Mouse trigger and the reaction to further refine your interactions. For more information, 
see “Editing Links” on page 495

To change the cursor associated with a mouse sensor:
1. In the Interaction Editor, select the sensor.

2. In the Parameter Editor, select a Cursor type from the list.

3. Switch to Preview in AXEL to test the interaction. Move your cursor over the object with the 
mouse sensor to see the cursor you selected.
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Mouse sensor cursor types
Different cursor types for the Mouse Sensors all applied to red cubes.

Vertical arrow

Cross arrow

Invisible

Question

Round head

Cross

Horizontal arrow

Closed hand

Target

Eyeball

Zoom

Exclamation
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Proximity sensor
A proximity sensor triggers a reaction when one object enters or exits a certain distance from 
another object. For example, when Krazee Bob approaches the Welcome mat, the saloon doors 
open.

To create a proximity sensor:
1. Multi-select two objects, then choose Interact > Add Sensor > Proximity.

2. In the Interaction Editor, expand the proximity sensor and select the trigger you want to use:

3. Drag from the trigger to a reaction to link them.

OnEnterProximity Triggers a reaction when the objects approaching each other come within 
the limit distance. 

OnExitProximity Triggers a reaction when the objects moving apart exit the limit distance. 
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4. With the sensor still selected, set the Limit in the Parameter Editor. 

Note: If a proximity sensor is applied to an object that has a translation handle on it, and the 
surfer moves the object around very quickly, depending on performance on the surfer’s machine, 
the sensor may not be triggered.

Proximity sensor parameters

Limit The distance in units at which the reaction is triggered.
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Position sensor
The position sensor triggers a reaction when an object reaches or leaves a specific position. For 
example, moving a coin into a slot could play a sound. 

To create a position sensor:
1. Select an object then choose Interact > Add Sensor > Position.

In the Interaction Editor, expand the position sensor and select the trigger you want to use:

2. Drag from the trigger to a reaction to link them.

3. Select the position sensor and adjust its parameters in the Parameter Editor. 

4. To test the sensor, add a Translate handle to the object, then switch to Preview in AXEL and 
drag the object into position to trigger the reaction. For more information, see “Using 
handles” on page 486.

Position sensor parameters

OnEnterPos Triggers a reaction when the object arrives at the critical position.
OnExitPos Triggers a reaction when the object leaves the critical position.

Critical position Position at which the object triggers a reaction.
Tolerance The reaction can occur as long as the object is close to the Critical position. The 

Tolerance determines how close the object must be to trigger the reaction. For 
example, if Tolerance is 3 units, the reaction occurs when the object is 3 units from 
the Critical position.
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Orientation sensor
An orientation sensor triggers a reaction when the object is at a specific orientation in degrees. 
For example, a door opening more than 15 degrees could trigger a chime sound.

To create an orientation sensor:
1. Rotate an object into the desired orientation, then choose Interact > Add Sensor > 

Orientation.
An orientation sensor appears in the Interaction Editor.

2. Expand the orientation sensor and select the trigger you want to use:

3. Drag from the trigger to a reaction to link them.

4. Select the orientation sensor and adjust its parameters in the Parameter Editor.

5. To test the sensor, add a Rotate handle to the object, then switch to Preview in AXEL and 
drag the object to trigger the reaction. For more information, see “Using handles” on page 
486.

Orientation sensor parameters

OnEnterOri Triggers a reaction when the objects arrives at the Critical orientation.
OnExitOri Triggers a reaction when the objects leaves the Critical orientation.

Critical 
orientation

Orientation at which the object triggers a reaction.

Tolerance The reaction can occur as long as the object is close to the Critical orientation. The 
Tolerance determines how close the object must be to trigger the reaction. For exam-
ple, if Tolerance is 3 degrees, the reaction occurs when the object is 3 degrees from 
the Critical orientation.
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Parameter change sensor
This sensor triggers a reaction when a parameter changes by more than a certain amount. You 
can apply this sensor to several parameters at once.

Any parameter can be used to trigger a reaction. For instance, create a Parameter change sensor 
so that every time the surfer moves an object more than three units along the floor, a creaking 
sound is triggered.

To create a parameter change sensor:
1. Select the parameter(s) in the Project Manager or the Parameter Editor, then choose Interact 

> Add Sensor > Parameter Change.
A parameter change sensor appears in the Interaction Editor for each selected parameter.

2. Expand the sensor.

3. Drag from OnParamChange to a reaction to link them.

4. Select the parameter change sensor and adjust its parameters in the Parameter Editor.

Parameter change sensor parameters

Tolerance Determines how much the parameter can change before the reaction is triggered.
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Parameter Range sensor
This sensor triggers a reaction when a parameter falls inside or outside a range. You can apply 
this sensor to several parameters at once. For instance, when an objects transparency parameter 
is between 0 and 20 percent, it is detected by a radar and an alarm goes off.

To create a parameter range sensor:
1. Select the parameter(s) in the Project Manager or the Parameter Editor, then choose Interact 

> Add Sensor > Parameter Range.
A parameter range sensor appears in the Interaction Editor for each selected parameter.

2. Expand the sensor and select the trigger you want to use:

3. Drag from the trigger to a reaction to link them.

4. Select the parameter range sensor and adjust its parameters in the Parameter Editor.

Parameter range sensor parameters

OnParamInRange Triggers a reaction when the parameter falls between the Min and Max 
values.

OnParamOutOfRange Triggers a reaction when the parameter falls outside the range specified 
by the Min and Max values.

Min The low end of the range.
Max The high end of the range.
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Time sensor
A time sensor triggers a reaction at a specific time, in seconds. For example, you make 
something move at second 4 to alert the surfer of the possibility of interaction, or start making 
noise at second 8.3.

Anything linked to the Time sensor plays as you scrub the playhead, including movies.

When you create animations, they are automatically linked to the Time sensor at the current 
time. For more information, see “Animations as reactions” on page 364

To apply a time sensor:
1. Stop playback and go to the time at which you want the reaction to occur.

2. Choose Interact > Add Sensor > Time.

3. In the Interaction Editor, expand the time sensor, then drag from a time to a reaction to link 
them.

4. Switch to Preview in AXEL to test the interaction. The reaction occurs after the number of 
seconds you specified. 

To adjust the time at which the reaction occurs:
In the Interaction Editor, select the TimeSensor, then enter a new time in the Parameter Editor.

To delete a time trigger:
In the Interaction Editor, expand the TimeSensor, select the time to remove, and press DELETE.
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To fasten multiple reactions to the same Time trigger:
In the Interaction Editor, link multiple reactions to the same AtTime trigger.

By default, when you add an animation sequence a separate and independent AtTime trigger is 
added to the TimeSensor at the current time, which triggers the reaction. You could have many 
AtTime triggers at time 0, for example. If you instead change the links so that multiple reactions 
are linked to the same AtTime trigger, they are hinged to whatever this time trigger is set to. If 
you edit this AtTime trigger to a new time in the Parameter Editor, both reactions are triggered 
at this new time, and if you try to drag one of the sequences in the Sequencer, all the other 
sequences linked to the same AtTime trigger move in tandem.
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Time pulse sensor
This sensor triggers a reaction at a certain frequency between the start pulse and the end pulse.

For example, play a strange sound in your cemetery every 11 seconds, from time 22.00 to 99.00 
seconds, or trigger a light going on and off every second.

The following triggers are available:

Time pulse sensor parameters

On First Pulse Triggers the reaction once at the Start Pulse time.
On Last Pulse Triggers the reaction once at the End Pulse time.
On Inter Pulse Triggers a reaction at a given frequency between the Start Pulse time 

and the End Pulse time. The reaction does not occur on the Start or 
End Pulse time. For example, if the Start Pulse is 2 seconds, the End 
Pulse is 10 seconds, and the Frequency is 2, the reaction occurs every 
2 seconds from second 4 to second 8.

On Pulse Triggers a reaction at a given frequency from the Start Pulse time to 
the End Pulse time inclusively. For example, if the Start Pulse is 2 sec-
onds, the End Pulse is 10 seconds, and the Frequency is 2, the reaction 
occurs every 2 seconds from second 2 to second 10.

Start The time in seconds of the first pulse. 
End The time in seconds of the last pulse. 
Frequency The interval in seconds between the pulses. For example, to trigger the reaction every 

5 seconds, use an OnPulse trigger and set the frequency to 5. Frequency must be 
greater than 0.

Pulse Skipping Skips a pulse when the reactions cannot keep up with the frequency. When the sensor 
detects that 2 or more reactions should have been triggered since the last pulse time, 
it only triggers one reaction if Pulse Skipping is on. If Pulse Skipping is off, it trig-
gers all the reactions as many times as they should have occurred. Pulse Skipping is 
on by default.
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Download sensor
This sensor triggers a reaction when the download of geometry, a sound file, or an image or 
movie texture is complete. 

For example, if you have a character with a reaction that moves his lips to accompany a sound 
file, you could link the OnDownloadComplete of a .wav file to the reaction that makes the 
character talk.

To apply a download sensor:
1. Unlink the reaction from Time Zero.

2. In the Project Manager, expand Resources / Sounds.

3. Select the .wav file.

4. Choose Interact >Add Sensor > Download.

5. In the Interaction Editor, expand the Download sensor, then link the trigger to both reactions.

6. Switch to Preview in AXEL to test the interaction. The reaction occurs after the number of 
seconds you specified. 

To adjust the time at which the reaction occurs:
In the Interaction Editor, select the TimeSensor, then enter a new time in the Parameter Editor.
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Refresh rate sensor
This sensor triggers a reaction when the refresh rate increases above a target value or decreases 
below a target value. 

For example, if an animation goes from 20 frames per second to 10 frames per second when a 
complex geometry appears in the World, the refresh rate sensor could sense the drop in refresh 
rate and trigger a reaction that hides the complex geometry or even reduce its number of 
subdivisions removing some of its complexity.

Refresh rate sensor parameters

Keyboard sensor
You can use the keys on the keyboard to trigger reactions.

For example, a surfer could press the UP ARROW key to point a spot light at an apple.

Keyboard keys are grouped into six groups, each represented by a sensor: Alpha Key (A-Z); 
Arrow Keypad (LEFT, RIGHT, UP, DOWN); Number Key (0-9); Function Key (F1-F12); Input 
Key (ESC, ENTER, etc.) and Numeric Keypad (0-9 and /,*,+ etc.). 

To create a keyboard sensor:
1. Choose Interact > Add Sensor, and select a keyboard sensor.

2. Expand the keyboard sensor to view its triggers.

3. Drag from a trigger to a reaction to link them.

Target 
Refresh Rate

When the refresh rate changes, if it moves above or below the target, 
the reaction is triggered.
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4. Preview in AXEL ( ) to test the interaction. Press the key you specified to trigger the 
reaction.

Creating custom sensors 

Custom sensors allow you to use more complex triggers that can take into account any number 
of parameters from multiple objects or groups in order to trigger reactions. 

A custom sensor uses a script where the results must be TRUE or FALSE, as the script is a 
boolean equation.

You can link the sensor’s triggers to any reaction and then edit the links, just like any standard 
trigger in AXEL.

The Custom Sensor has 3 triggers:

• when the script value is TRUE

• when the script value is FALSE

• when the script value toggles: the reaction is triggered as the sensor’s value passes from TRUE to 
FALSE, or vice versa.

For more information on scripting Custom sensors, see “Scripting” on page 517.

To create a custom sensor:
1. Choose Interact > Add Sensor > Custom.

The Script dialog appears and a CustomSensor appears in the Interaction Editor.

2. To enter a parameter name, select the parameter in the Project Manager, then click Insert 
Project Selection.

3. Click in the script section and compose a script as follows:
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• To enter a parameter name, select the parameter in the Project Manager, then click Insert 
World Selection. If the object name contains spaces, rename it to remove the spaces. See 
“Scripts Syntax” on page 518.

• To enter an operator, click the Operators panel, then double-click the operator, or select the 
Operator and click Insert Operator (Windows). The operator is added to your script at the 
insertion point. When you select an operator an explanation of what it does appears below.

• To enter a function, click the Functions panel, then double-click the function or select the 
function and click Insert Function (Windows). When you select a function an explanation 
of what it does appears below. To add arguments to the function, place the insertion point 
in the script to the left, select a parameter in the Project Manager, then click Insert World 
Selection.

4. Correct any errors in the script. Errors in the script appear in real time in the status box as you 
are typing the script. 

5. Click Apply to assign the value of the script to the parameter selected in step 1.

6. To test the script, you can modify parameters in your project while the dialog is open and 
check the value in the script dialog. If the value is what you expected, your script works.

7. Click OK.

8. Link the sensor to a reaction. Expand it, then click and drag from one of its triggers to a 
reaction.
The Custom Sensor appears under Resources / Sensors. 

To edit the script:
1. In the Project Manager, select the script under Resources / Sensors.

2. Choose Edit > Edit Custom Script.

3. Edit the script, then click OK.

Custom sensors syntax
You can also type a script directly in the script dialog. See “Scripts Syntax” on page 518.
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     Using handles
You add handles to objects and groups so that surfers can manipulate them interactively. You 
can also add handles to the WebCam so that surfers can navigate around the 3D World. 

When you add a handle to an object or to the WebCam, a reaction and a sensor are automatically 
created and linked.

You can change the cursor type that will appear on an object when you are using handles. To do 
this, you change this on the mouse sensor that is linked to the handles. For more information, 
see“Mouse sensor” on page 469.

About mixing effects and mixing weight
Assume you have a hammer that is pose-constrained to a giant magnet. Its position parameter is 
controlled entirely by that relation. If you add a Position handle to the hammer and try to move 
it, it does not budge!

You can modify this with the handle parameters. If you enable “Override other” while you are 
click and drag the hammer, you are disabling the pose constraint. As soon as you release the 
hammer, it re-activates the pose constraint and the hammer returns on the magnet.

Enabling “Mix with other” allows you to have both the pose constraint and the position handle 
active at the same time. The mixing weight determines the relative weight of each effect on the 
hammer’s position. If you set the handle’s mixing weight to 20, and the pose constraint is at its 
default mixing weight of 100, the pose constraint is more powerful. Clicking and dragging the 
hammer only inches it away from the magnet. If you set the handle to 300, you hardly notice the 
magnet’s effect.

Translate handle
A Translate handle enables surfers to drag an object using the mouse. Adding a Translate handle 
creates a Translate reaction linked to the selected object or group.

To apply a Translate handle to an object: 
1. Select the object.

2. Choose Interact > Add Handle > Translate.
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In the Interaction Editor, a Translate reaction is linked to a MouseSensor. By default, the 
trigger is set to OnLeftClick.

3. Switch to Preview in AXEL (B) to test the interaction. Move the cursor over the object. The 
cursor changes to a hand. Drag the object.

4. To modify the handle:

• Select the Translate reaction and adjust its parameters.

• Select the MouseSensor and adjust its parameters. 

• Select the line that joins them and adjust the trigger parameters.

To remove a Translate handle:
In the Interaction Editor, select the Translate reaction and press DELETE.
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Translate handle parameters

Rotate handle
A Rotate handle enables surfers to turn an object around using the mouse. Adding a Rotate 
handle creates a Rotate reaction linked to the selected object or group.

To apply a Rotate handle to an object: 
1. Select the object.

2. Choose Interact > Add Handle > Rotate.

Type Limits the translation to a specific direction. Select one of the following:
• Horizontal to translate the object from side-to-side vis-à-vis the current 

WebCam.
• Vertical to translate the object up and down vis-à-vis the current WebCam.
• Front/Back to translate the object towards or away from the current WebCam.

Tip: Since Horizontal, Vertical and Front/Back are always referenced from the 
orientation of the WebCam it is added to, changing this WebCam’s orientation alters 
the absolute axis of the translation, keeping it correctly aligned with your WebCam.

• X, Y, or Z to translate on the object’s local X, Y, or Z axis respectively.
• Free to translate on the object’s local X, Y, or Z axis respectively.

Override 
other

The surfer’s action overrides any other forces affecting the object’s translation.

Mix with other Uses the Mixing weight parameter to calculate all forces affecting the object’s posi-
tion while translating.

Mixing weight Determines the weight, in percentage, of the handle in relation to other forces on the 
object.

Invert joints Enables 2D behavior of joint constraints and inverse kinematics. Use with pin or ball 
joints (and inverse kinematics). In the case of an arm, pulling on the handle (a hand) 
causes the shoulder to follow.

Throw object Allows an object to be thrown by the user, by clicking, dragging and releasing the 
object.

Throwing 
resistance

Determines how much the object travels when released.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap unit. When 
the snap unit is 0 (the default value), the object does not snap to a grid.
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In the Interaction Editor, a Rotate reaction is linked to a MouseSensor.

3. Switch to Preview in AXEL (B) to test the interaction.

4. To modify the handle: 

• Select the Rotate reaction and adjust its parameters.

• Select the MouseSensor and adjust its parameters.

• Select the line that joins them and adjust the trigger parameters.

To remove a Rotate handle:
In the Interaction Editor, select the Rotate reaction and press DELETE.

Rotate handle parameters

Type Sets the axis of rotation. Select one of the following:
• Tilt to rotate in the World X axis.
• Turn to rotate in the World Y axis.
• Tilt or Turn to rotate in the World X or World Y axis. 
• X, Y, or Z to rotate around the object’s local X, Y, or Z axis respectively.
• Free to rotate freely around the World X, Y, and Z axes. This is the default type.

Rotation pivot Determines the point around which the object rotates.
Override 
other

The handle overrides other forces affecting the object’s rotation.

Mix with other Uses the Mixing weight parameter to calculate all forces affecting the object’s ori-
entation while rotating.

Mixing weight Determines the weight, in percentage, of the handle in relation to other forces on the 
object.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap unit. When 
the snap unit is 0 (the default value), the object does not snap to a grid.
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Scale handle
A Scale handle enables surfers to scale an object or group. Adding a Scale handle creates a Scale 
reaction linked to the selected object or group.

Scale handle parameters

Type You can edit the scaling to be X, Y, Z, uniform or free (the default).
Preserve scale 
volume

Maintains the object’s volume when you scale it along one or two axes. For example, 
if you shrink a cone along the X axis, it gets taller so that its volume remains the 
same.

Override 
other

Determines how the handle reacts if the object is affected by other forces.

Mix with other Uses the Mixing weight parameter to calculate all forces affecting the object’s size 
while scaling.

Mixing weight Determines the weight, in percentage, of the handle in relation to other forces on the 
object.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap unit. When 
the snap unit is 0 (the default value), the object does not snap to a grid.
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Push handle
This handle allows surfers to push points inwards. It is similar to the Push Surface option in the 
Model menu. However, when the surfer disengages the push, the points return to their original 
position.

Push handle parameters

Contact radius Determines the size of the point of contact. A small contact radius is like 
pushing the surface with your finger tip; a large contact radius is like pushing 
with your fist.

Deformation radius Determines the distance around the contact point that is affected by the 
deformation. Use a small deformation radius to simulate pushing a soft 
material, like soft clay. Use a large deformation radius to simulate a less pli-
able surface, like a well-inflated balloon or a trampoline.

Push depth Determines how much the surface is pushed in.
Push speed In Determines how fast the surface deforms when you drag your cursor. 
Push speed out Determines how fast the surface bounces back to its original shape.

Tip: The object that is being pushed has to be totally restored to its 
original shape before any other actions can take place in the scene. You 
may, therefore, want to keep a high value for this parameter to ensure no 
conflicting actions.

AXS/Interaction_Handles_Push.htm
AXS/Interaction__Handles_Push.htm
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Bend handle
This handle allows surfers to bend a surface. It is similar to the Bend Surface option in the Model 
menu. However, when the surfer stops interacting, the object returns to its previous state.

Bend handle parameters

Orbit WebCam handle
This handle allows surfers to move the WebCam around its interest point. You can set the 
distance of the WebCam’s interest in its parameters, or frame (F)It uses the background mouse 
sensor’s OnLeftClick trigger as a default.

 an object, objects or a group and the WebCam’s interest is automatically set at the center of 
these.

Orbit WebCam handle parameters

Origin The point where the object bends. 
Axis The axis around which the bend takes place. The default 0, 0, 1 makes the surface 

bend around the Z axis.
Angle Angle of the bend, in degrees.
Minimum angle Smallest amount you can bend the surface. 
Maximum angle Largest amount you can bend the surface. 
Bend range The region that bends (in units along the bend axis).
Bend speed in Determines how fast the surface bends when you drag it. 
Bend speed out Determines how fast the surface bends back to its original shape. 

Type Determines how the surfer orbits: horizontal, vertical, horizontal and vertical, or free
Override 
other 

The surfer’s action overrides any animation or constraints affecting the WebCam.

Mix with other Combines the surfer’s action with any animation or constraints affecting the Web-
Cam.

Mixing weight Determines the relative strength of the handle compared to any animation or con-
straints affecting the WebCam.
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Rotate WebCam handle
This handle allows surfers to rotate the WebCam around its local center. It uses the background 
mouse sensor’s OnLeftClick as a default sensor.

Rotate WebCam handle parameters

Translate WebCam handle
This handle allows surfers to pan the WebCam (or to move in or out). It uses the background 
sensor’s OnLeftClick as a default trigger.

Translate WebCam handle parameters

Type Options are Roll (around the WebCam’s Z axis), Tilt (from top to bottom), Turn (left 
to right), Tilt and Turn, and Free.

Override 
other 

The surfer’s action overrides any animation or constraints affecting the WebCam.

Mix with other Combines the surfer’s action with any animation or constraints affecting the Web-
Cam.

Mixing weight Determines the relative strength of the handle compared to any animation or con-
straints affecting the WebCam.

Type The tranlation can be Free, or limited to Horizontal, Vertical or Front/Back.
Override 
other 

The surfer’s action overrides any animation or constraints affecting the WebCam.

Mix with other Combines the surfer’s action with any animation or constraints affecting the Web-
Cam.

Mixing weight Determines the relative strength of the handle compared to any animation or con-
straints affecting the WebCam.
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Zoom WebCam handle
This handle allows surfers to move in or away from the WebCam’s interest. (You are not 
changing the WebCam’s Vertical FOV angle, but its position.) This handle uses the WebCam 
mouse sensor’s OnLeftClick as a default sensor.

Zoom WebCam handle parameters

Override 
other

The surfer’s action overrides any animation or constraints affecting the WebCam.

Mix with other Combines the surfer’s action with any animation or constraints affecting the Web-
Cam.

Mixing weight Determines the relative strength of the handle compared to any animation or con-
straints affecting the WebCam.
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Editing Links
There is a default link for every interaction.  For example, when you link a mouse sensor to an 
animation reaction, by default, the animation starts when you click the mouse. A different event 
could trigger the reaction, for example, to:

• Start the first time you click, then stop on the next click, then continue on the next click and so on

• Freeze when you click

• Start 2 seconds after you click

• Start when you SHIFT-click

• Be triggered only once
If you drag a link to another trigger or reaction, the link retains its parameters unless a parameter 
is not relevant in its new position. For example, dragging a link from a MouseSensor’s trigger 
to the Time sensor hides the Modifier key parameter since the reaction is no longer triggered by 
button combinations, but rather at a specific point in time. All of the link’s other parameters, 
such as Expiry count and Trigger mode, are retained.

To edit a link:
1. In the Interaction Editor, select the link that joins a reaction to a trigger.

2. In the Parameter Editor, adjust the link parameters.
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Link parameters

Trigger on For mouse, keyboard, and arrow key sensors, determines at what point the reac-
tion occurs:
Down: occurs when the surfer clicks the mouse button or key or rolls the cursor 
over the object with a mouseover trigger.
Hold: occurs as long as the surfer holds the mouse button or key or keeps the cur-
sor over the object with a mouseover trigger.
Up: occurs when the surfer releases the mouse button or key or rolls the cursor off 
the object with a mouseover trigger.

Modifier key For mouse, keyboard, and arrow key sensors, the surfer must press SHIFT, CTRL, 
or CTRL+SHIFT with the sensor to trigger the reaction.

Note: While modifier keys work with handles, they may not perform well on all 
systems. Be sure to test your content well in different browsers if you choose to use 
modifier keys with handles.

Expiry count The maximum number of times that a trigger can be set off. For example, if a 
honking sound plays when a surfer clicks a horn, an expiry count of 10 means the 
surfer can honk the horn 10 times.

Time delay The delay in seconds before the reaction occurs after it is triggered. For example 
if the delay is 1, the honking sound plays 1 second after the surfer clicks the horn.

Repeat delay The number of seconds that must pass before the reaction can be triggered again. 
For example, if the repeat delay is 2, the surfer can honk the horn every 2 seconds. 
Even if the surfer clicks repeatedly, the sound plays only if 2 seconds have elapsed 
since the last time it played.
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Trigger mode Determines what happens when the sensor is triggered:

• Start: starts the reaction.

• Stop: ends the reaction.

• Toggle Start/Stop: toggles the reaction on and off.

• Toggle Stop/Start: toggles the reaction off then on.

• Activate: allows the reaction to be triggered by other sensors.

• Deactivate: prevents the reaction from being triggered by other sensors.

• Toggle Activate/Deactivate: toggles between letting the reaction be triggered 
by other sensors and preventing the reaction from being triggered by other 
sensors. See “Using an Activate link to control a reaction” on page 501.

• Toggle Deactivate/Activate: toggles between preventing the reaction from 
being triggered by other sensors and letting the reaction be triggered by other 
sensors.

Tip: Links between sensors and triggers to reactions in the Interaction Editor are 
different colors and styles depending on the trigger mode. For more information, 
see “Trigger modes and link colors/styles for visual cues in the Interaction Editor” 
on page 498.

Start mode For Play Animation reactions, Play Sound and Play Movie reactions, when the 
Trigger mode is set to Start, the Start mode determines how the reaction starts:

• Restart: the animation starts from the beginning.

• Continue: the animation starts where it last stopped.
Stop mode For Play Animation, Play Sound and Play Movie reactions, when the Trigger 

mode is set to Stop, the Stop mode determines what happens when the reaction is 
stopped: 

• Pause: the animation stops and stays in its current state.

• Cancel: the animation also stops, and like Pause it stays in its current state, 
but unlike Pause the reaction is not blocked, but can be acted upon. For 
example, you have a translation handle on an object and this object also has a 
PlayAnim reaction on the Position except that "Cancel" will allow you to use 
your Translation handle, while "Pause" blocks the object in place.

• Go to beginning: the animation stops and is reset to the first key.

• Go to End: the animation goes to the last key.
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Trigger modes and link colors/styles for visual cues in the 
Interaction Editor
The links that connect triggers to reactions in the Interaction Editor have different colors and 
styles, depending on their Trigger mode. For example, a link with a trigger mode of Start is 
green, while a link with a Deactivate trigger mode is both red, and has diamond connecting 
nodes instead of circles. This helps you organize and edit your interactions.

If there is more than on link on a sensor, and this sensor is collapsed the link is black to represent 
multiple links. 

By expanding and collapsing sensors (and group reactions), and using the display options to 
isolate information, in combination with the link colors, you gain a clear picture of how 
interaction is organized in your project.
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Start

Stop

Toggle Stop/Start

Activate

Deactivate

Toggle Acti/Deactivate

Toggle Deact/Activate

Toggle Start/Stop

Links have distinctive colors and styles depending on their Trigger 
mode—that is, in what way they define how a sensor triggers a reaction.
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To see the trigger modes in the Interaction Editor:
1. If a sensor is collapsed, click its expand arrow.

Individual colors are then visible, indicating their trigger mode.

2. If the Interaction Editor is cluttered, you can use the display options to isolate the interactions 
you want to see and edit. Use the context menu to select display options by Right-clicking 
(Windows) or Command-clicking (Macintosh) in the Interaction Editor, or by using the 
display button ( ).
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Using an Activate link to control a reaction
Normally a reaction occurs when the surfer triggers it. For example, a door opens when the 
surfer clicks the handle. You can use an Activate/Deactivate trigger mode to add another 
condition to the reaction occurring. For example, clicking the handle opens the door only if the 
surfer clicks a key first. 

Use the Activate mode to force reactions to occur in a specific sequence. For example, clicking 
an object could trigger different animations, depending on what the surfer did previously.

Example: Use a key to control the reaction of a door opening when clicked:
1. Create an animation of a door opening. 

2. Add a mouse sensor to the doorknob, and link it to the Play Animation reaction.

3. Switch to Preview in AXEL ( ) to test the interaction.
When you click the knob, the door opens.

4. Deactivate the reaction at time 0. Link TimeSensor / AtTime 0.00 to the Play animation 
reaction, then select the link and set the Trigger mode to Deactivate.
In the Interaction Editor, notice the trigger is red to indicate that it deactivates the reaction. 
Also notice the icons are different from other links.

5. Switch to Preview in AXEL ( ) to test the interaction.
When you click the knob, nothing happens because the reaction was deactivated as soon as 
the World opened at time 0.
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6. Now, use a key to activate the Play animation reaction. Create an object to use as a key, and 
add a mouse sensor to it.

7. Link the mouse sensor on the key to the Play animation reaction. Select the link and set the 
Trigger mode to Activate.
Notice the link color and icon indicate that it is in Activate mode.

8. Switch to Preview in AXEL ( ) to test the interaction.
Click the doorknob. Nothing happens because at time 0, the reaction was deactivated. Now 
click the key. This activates the Play animation reaction. Now when you click the doorknob, 
the door opens.
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Grouping reactions
Grouping reactions makes it easier to assign multiple reactions to one or more sensors. 

You can create groups within groups, all with different parameters, including different Link 
parameters. Notice the three reaction groups in the following example:

• The Rocket group has its Reaction order set to All at once; Loud Sounds, Switch Camera1 
and Mayhem are all triggered at the same time.

• The Loud Sounds group has its Reaction order set to Solo: random; every time Rocket is 
triggered, one of the sound files plays randomly.

• The Mayhem group has its Reaction order set to Solo: cycled in order; the first time Rocket 
is triggered, it plays the Call Javascript; the second time, the Set Position reaction; the third 
time, it returns to Call Javascript.

To group reactions:
1. Create two reactions.

2. In the Interaction Editor, CTRL-select (Windows) or COMMAND-select (Macintosh) the 
reactions, then choose Interact > Group Reactions or press CTRL+G (Windows) or 
COMMAND+G (Macintosh).

3. To adjust the order in which the reactions occur, select the group and adjust its trigger order 
in the Parameter Editor. 

4. Link the group to a sensor.

Note: You can also adjust reaction timing using the Sequencer or by editing the Trigger Time 
Delay parameter.

 Loud sounds reactions 
play solo randomly

Mayhem reactions play 
solo, cycled, in order

Rocket reactions 
play all at once
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To rename a group of reactions:
1. Click the group in the Interaction Editor.

2. In the Parameter Editor, type a new name and press ENTER.

To ungroup reactions:
Select the group and press DELETE.

Staggering the time of Group reactions
You can set the individual reactions that make up a Group reaction to be triggered at different 
times. This way, when the Group reaction is triggered with its Reaction order set to All at once, 
it sets off your series of events not necessarily all at once, but rather offset to the times you 
specify.

Example: setting different offset times for the three reactions in a Group reaction:
1. Create a Play Animation reaction, a Play Sound Reaction and a Set Parameter reaction.

2. In the Interaction Editor, multi-select the three reactions.

3. Choose Interact > Group Reactions from the menu bar, or click the Group reactions button 
in the Interaction Editor then choose Group Reactions.

4. In the Interaction Editor, link the Group reaction to any sensor, for this case use a Mouse 
sensor to test this easily.

Now, when you look in the Sequencer, and expand the Group reaction there, you will see your 
PlayAnim, Play Sound and Set Parameter. All of these are at time 0 and so will be triggered 
simultaneously immediately after the sensor is triggered.

5. Drag the Play Sound Animation (using its sequence start time bar) to coincide with the last 
key of the PlayAnim.

6. Drag the Set Parameter reaction a little past where the Play Sound reaction lies in the 
timeline.

7. Click the Group reaction in the Sequencer or Interaction Editor, then in the Parameter Editor 
make sure its Reaction Order is set to All at once.
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Now, when you click you mouse sensor, first the PlayAnim will run through, then the Play 
Sound will be heard, and finally the parameter you set in the final reaction is engaged.

Group reaction parameters

All at once All reactions play at once.
Solo – Random Only one reaction plays every time the group reaction is triggered. The reaction is 

chosen randomly.
Solo – In order: When triggered a first time, the first reaction plays. When triggered a second time, 

the second plays. This goes on until all reactions have played. Any subsequent trig-
gering has no effect.

Solo – Cycled in 
order

When triggered a first time, the first reaction plays. When triggered a second time, 
the second plays. Once all reactions have played, the cycle starts over. 

1 2 3
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 Adding a Rollover reaction
Use a Rollover group reaction to automate the creation of several reactions, with a trigger, in a 
single step. The Rollover group reaction includes a Set Glow Parameter reaction, a Tooltip Text 
reaction and a Play Sound reaction, all linked to the selected object or group. The group reaction 
is triggered upon a MouseOver. 

You can always, then, add to or remove reactions from this group.

To add a Rollover reaction:
1. Click an object in a viewport or in the Project Manager.

2. Choose Interact > Add Rollover.
The Open dialog appears.

3. Select a sound and click Open.
A Glow Parameter reaction, Tooltip Text reaction and a Play Sound reaction are grouped as 
a reaction and linked to a MouseOver trigger on the object. A material is created if the object 
does not already have one.

Note: You can also multi-select a sound and an object, then choose Interact > Add Rollover to 
add a rollover.

4. Adjust the reaction parameters by expanding the RolloverOverGroup, and clicking on it, or 
any of the links or individual reactions, then adjusting the parameters in the Parameter Editor.

Tip: This reaction can also be applied to a group of objects. In that case, no Glow Parameter 
reaction is created.
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Chapter 9
Scripting 

In addition to using AXEL’s own preset relations, 
sensors, and reactions, AXELedge users can script 
their own with AXELedge’s straightforward 
scripting language based on a subset of JavaScript.

You script through a script dialog that helps you 
piece together your script from objects’ parameters, 
then combine them with functions and operators.

Scripts for relations are called Custom relations and 
are applied to objects like constraints. Scripts for 
sensors and reactions are called Custom sensors and 
Custom reactions, appear in the Interaction Editor, 
and can be linked, grouped, and otherwise combined 
with all other AXEL interactions.

In this chapter:

Scripts Syntax ......512 
Scripting parameters with 
multiple fields ......513 
Functions ..............516 
Operators ..............524 
Other Example Scripts ........ 532 
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Scripts Syntax 

The Syntax for AXEL scripts is similar to JavaScript. 

AXELedge scripts are case-sensitive so it is helpful to use the Insert buttons and to double-click 
the functions and operators to assemble your scripts to reduce mistakes. Also, remember when 
you add on axis or rgb extensions to parameters, such as .y or .x that they are in lowercase.

In the expression, empty spaces are ignored, however empty spaces are not valid in the 
parameter name.

To enter a boolean value, type true or false, or 1 for true and 0 for false. If numeric values or 
vectors are used in boolean operations, they are first converted to boolean as described below.

Using different types of values in functions and operators
With most functions and operators, you can use any of the following types of values: 

• Numbers, for example the value of the Subdivisions parameter.

• Vectors, for example the value of a Position parameter.

• Booleans, for example the value of a Visible parameter.
Some functions and operators support only one type of value in which case the type of value is 
specified in the function Syntax and description.

For example, the Syntax of the Add function is: “value1 + value2”. The word “value” indicates 
that you can add any type of value (numbers, vectors, and boolean values).

The Syntax for the Dot product is: “Dot(vector1, vector2)”. This means that you can only use 
vectors with the dot product function.

References to parameters
Parameter names cannot contain spaces. Before applying a custom script to an object, make sure 
its name does not contain spaces or special characters. Rename the object if needed.

Parameter names can contain only the following types of characters:

• Text (a to z and A to Z)

• Numbers (0 to 9)

• Underscore (_)
You can enter parameters in the script dialog using the Insert World Selection button or type the 
parameter name directly in the script dialog, in which case the following Syntax is used:

object.parameter
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• object: the name of the object to which the parameter belongs

• parameter: the name of the parameter as it appears in the Project Manager.
Examples:

• Cube1.Position.x

• CurveCns1.Position_on_curve

• CubeGeometry1.Width

How values are converted to booleans
If numbers, text, or vectors are used in boolean operations, they are first converted to booleans 
according to the following rules:

• 0 is false. All other numbers are true.

• The text string false is false. An empty text string is false. All other text strings are true.

• If all three numbers in a vector are 0, then the vector is false. If any of the numbers is not 0, then the 
vector is true.

Scripting parameters with multiple fields 

If you want one parameter's Y value to correspond to another's X value, for example, you can 
use the [ , , ] operator.  Each space of the operator is filled in with either an X, Y or Z value, in 
that order. For example, to relate the X position value of a cone to the Y scale value of a cube, 
a script would read: Cone1.Position =  [Cube1.Scale.y, 0, 0], where the cone's Y and Z values are 
set at 0, while its X position is constrained to the Y scale value of the cube.  Here, you add on a 
.y operator to the cube's scale value to indicate you only want the Y value of the cube's scale. 
For a color parameter that uses RGB values, each space in the [ , , ] operator corresponds to 
either the R, the G or the B value, in that order. 

Example: constraining a cube's Z position using Custom Relations:
1. To work with a cube's Z position independently in a script, relate the cube's X and Y positions 

to themselves in the script:
a) Create a cube
b) In the Project Manager, select the cube's position.
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c) Choose Relate > Add Custom Relation.

d) In the Script dialog, click the Operators panel, then double-click the [ , , ] operator.

e) Click in the first space of the operator, then in the Project Manager, select the Cube's 
position parameter once again.
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f) Click Insert World Selection. The dialog now contains the following script:  
[Cube1.Position, , ].

g) Add .x to the position parameter so the script reads: [Cube1.Position.x, , ]. Since the cube's 
X position is constrained to its own X position, it is not affected by the script.

h) Repeat the step for the second space, inserting Cube1.Position, only add a .y so the script 
reads Cube1.Position = [Cube1.Position.x, Cube1.Position.y, ].

2. Make the cube's Z position parameter equal to the X position parameter of a sphere:
a) Create a sphere and translate it to the right of the cube:
b) In the Project Manager, select the sphere's position parameter.
c) In the script dialog, click in the last space of the [ , , ] operator, then click Insert World 

Selection.
d) Add .x to the sphere's position parameter so the script reads: Cube1.Position = 

[Cube1.Position.x, Cube1.Position.y, Sphere1.Position.x].
e) Click Apply and close the Script dialog window.
f) To test the Custom relation, translate the sphere.

As you translate the sphere along the X axis, the cube is translated along the Z axis.

3. Make the cube's X position value relate to a cylinder's Y position value, and make the cube's 
Y position value relate to a cylinder's X position value: 
a) Create a cylinder and translate it to the left of the cube.
b) Select the cube's position parameter and choose Relate > Add Custom Relation.
c) In the script dialog that appears, type : [Cylinder1.Position.y, Cylinder1.Position.x, 

Cube1.Position.z]; then click Apply.
If you translate the cylinder along the X axis, the cube is translated along the Y axis. If 
you translate the cylinder along the Y axis, the cube is translated along the X axis.

The cylinder is translated on the Y axis 
which translates the cube along the X axis.
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Functions 

distance( , ) 

Syntax
distance(value1, value2)

Description
Returns the distance from value1 to value 2 as if value1 and value2 are points in space.

Example 
If value1 is [2,2,2] and value2 is [2,5,6] then distance( value1, value2 ) returns 5. 

In the following illustration, Cone1 is at position [2,2,2] and Cube1 is at position [2,5,6]. They 
are related to the Fall off distance parameter of a spotlight in the following script: 
SpotLight1.Fall_off_distance= distance( Cone1.Position , Cube1.Position ) 

The values in the distance function do not have to be positions in 3D space. For example, 
following from above, you could then insert the SpotLight1.Fall_off_distance into another 
distance function as follows:

DirectionLight1.Intensity= distance( SpotLight1.Fall_off_distance , [10,10,10]) 

Because the spotlight’s fall off distance has been set at a value of 5 from the first custom relation, 
the script calculates the distance between [5, 0, 0] to the position [10,10,10], which is entered in 
numbers directly, and returns 8.66.

The distance between the centers of the Cube 
and the Cone is 5.
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getLength( ) 

Syntax
getLength(value1)

Description
Returns the distance from value1 to [0,0,0] as if value1 is a point in space.

Example
If value1 is [3,4,0] then getLength( value1 ) returns 5.

setLength( ) 

Syntax
setLength(value1, number1)

Description
Sets the length of value1 to number1 and returns the resulting value. The length of a text value 
cannot be set using setLength.

Example
If value1 is [75,100,0] and number1 is 5, then setLength( value1, number1) set value1 to [3,4,0] 
and returns [3,4,0].

getVelocity( ) 

Syntax
getVelocity(value1)

Description
Returns the rate of change of value1. The first time it is evaluated, get Velocity returns a null 
value.
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Example
If value of Cube1.Position has changed from [0,0,0] to [6,8,0] over the last 2 seconds then 
getVelocity(Cube1.Position ) equals [3,4,0].

getSpeed( ) 

Syntax
getSpeed(value1)

Description
Returns the vector of the rate of change of value1. The first time it is evaluated, getSpeed returns 
0. Then it always returns a non-negative number.

Example
If the value of Cube1.Position has changed from [0,0,0] to [6,8,0] over the last 2 seconds then 
getSpeed(Cube1.Position ) equals 5.

getPreviousValue( ) 

Syntax
getPreviousValue(value1)

Description
Returns the previous value of value1. 

Just the first time it is evaluated, getPreviousValue returns the current value of value1 because 
there is no previous value to retrieve. All subsequent evaluations returns the previous value.

Example
If Cube1.Visible was true on last script evaluation, then getPreviousValue( Cube1.Visible ) 
equals true whatever is the current value of Cube1.Visible.
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getDeltaValue( ) 

Syntax
getDeltaValue(value1)

Description
Returns the difference between the current and the previous value of value1. The first time it is 
evaluated, getDeltaValue returns a null value.

Example
If CubeGeometry1.Width is currently 15 but was 10 on last script evaluation, then 
getDeltaValue( CubeGeometry1.Width ) equals 5.

In the following example, the getDeltaValue() function is used to simulate gravity working on a 
sphere:

Sphere1.Position =

( [0.0, -9.8, 0.0] * getDeltaValue( time() ) + getVelocity( Sphere1.Position ) ) * 
getDeltaValue( time() ) + Sphere1.Position 

For the previous script to more accurately simulate gravity, it has to continuously re-evaluate the 
sphere’s position relative to where it was at an earlier point in time. Thus, the getDeltaValue() 
function is used, along with the time() function, so that the script continuously recalculates 
where the sphere just was. It is dropped by a value of 9.8 on the negative Y axis—multiplied by 
its velocity—to accelerate the drop.

You can try changing the -9.8 value to a lower value to decrease the pull of gravity, perhaps to 
simulate a trip to the moon, or change the X or Y values to a number other that O in order to 
account for some horizontal momentum.

random( , ) 

Syntax
random(number1,number2)
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Description
Returns a random numeric value between number1 and number2.

Example
If you were creating a game, and wanted an object to randomly be repositioned around a 
specified 3D space, you could use the following script for a custom reaction:

Object1.Position=
[ random( 5, -5), random( 5, -5), random( 5, -5)]

You could then link this reaction to a TimePulse sensor with a frequency of 2 seconds. The result 
would be that every 2 seconds, the object would be repositioned randomly within a 10x10x10 
space around the World origin.

time() 

Syntax
time()

Description
Returns AXEL’s current clock time of the content in seconds.

Example
The following script returns the first condition, [0, 255, 0] which is the rgb value for green, if 
the script is evaluated anytime before 60 seconds on AXEL’s internal time. Otherwise, the script 
returns the value [255, 0, 0], which is the rgb value for red.

Material1.Color=

time() <= 60 ?   [0 , 255, 0]   :  [255, 0, 0] 

systemYear() 
The systemYear() function, like other comparable functions in AXELedge, like sytemDay() and 
systemSecond(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.
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Syntax
systemYear()

Description
Returns the current system year.

Example
At 10:05:29 on March 7, 2001, systemYear() equals 2001.

systemMonth() 
The systemMonth() function, like other comparable functions in AXELedge, like systemDay() 
and systemSecond(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.

Syntax
systemMonth()

Description
Returns the current system month.

Example
At 10:05:29 on March 7, 2001, systemMonth() equals 3.

systemDay() 
The systemDay() function, like other comparable functions in AXELedge, like systemYear() 
and systemSecond(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.

Syntax
systemDay()
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Description
Returns the current system day

Example
At 10:05:29 on March 7, 2001, systemDay() equals 7.

systemHour() 
The systemHour() function, like other comparable functions in AXELedge, like systemDay() 
and systemSecond(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.

Syntax
systemHour()

Description
Returns the current system hour

Example
At 10:05:29 on March 7, 2001, systemHour() equals 10.

systemMinute() 
The systemMinute() function, like other comparable functions in AXELedge, like systemDay() 
and systemSecond(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.

Syntax
systemMinute()
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Description
Returns the current system minute.

Example
At 10:05:29 on March 7, 2001, systemMinute() equals 5.

systemSecond() 
The systemSecond() function, like other comparable functions in AXELedge, like systemDay() 
and systemMinute(), is always a positive integer. 

You can use the function in combination with other values, functions or operators, and it works 
like any other value.

Syntax
systemSecond()

Description
Returns the current system second.

Example
In the following clock example, the systemSecond() function is used to relate the second hand 
of the clock to the ticking seconds of your computer. Since the hands of the clock rotate around 
the Z axis in this example, the other axis remain at 0. Also, the systemSecond function is 
multiplied by 6, giving the proper proportion between seconds, of which there are 60 in a 
minute, and degrees, of which their are 360 around a circle.

Second_hand.Orientation = 
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[0.0, 0.0, -systemSecond() * 6]

dot( , ) 

Syntax
dot(vector1,vector2 )

Description
Returns the mathematical dot product of vector1 and vector2.

Example
If vector1 is [1,2,3] and vector2 is [2,-5,6] then dot(vector1, vector2) returns 10.

cross( , ) 

Syntax
cross(vector1,vector2 )

Description
Returns the mathematical cross product of vector1 and vector2.

Example
If vector1 is [1,2,3] and vector2 is [2,-5,6] then cross(vector1, vector2) returns [27,0,-9].

AXS/Scripts_SysTimes.htm
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Operators 

+ 

Syntax
value1 + value2

Description
Adds value1 and value2, returning their sum.

Example
2 + 3 equals 5, and [0,2,2] + [2,1,1] equals [2,3,3].

- 

Syntax
value1 - value2

Description
Subtracts value2 from value1, returning their difference.

Example
5-3 equals 2, while 3-5 equals -2.

* 

Syntax
value1 * value2

Description
Multiplies value2 from value1, returning their product.
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Example
2*3 equals 6, while [2,3,4] * [2,2,2] equals [4,6,8].

/ 

Syntax
value1 / value2

Description
Divides value2 from value1, returning their quotient.

Example
3/6 equals 0.5 while 6/3 equals 2.

% 

Syntax
number1 % number2

Description
Divides number1 by number2, returning only the remainder of the division. number1 and 
number2 must be numeric.

Example
5%3 equals 2 and 6.5%3 equals 0.5.

+value 

Syntax
+ value1

Description
Converts a boolean or text value type into a numeric value.
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Example
If value1 equals true then +value1 equals 1. If value1 is the test “1.0” then +value1 returns 1, 
but if value1 is the test “cube” it returns 0.

-value 

Syntax
- value1

Description
Returns the negative of value1. value1 is first converted into a number if it is not already one.

Example
If value1 equals 7 then -value1 equals -7.

In the following example, when we relate the Pin Joint angle to another Pin Joint angle, we add 
the - operator in the script. This reverses the value of the angle for the left door since it is hinged 
on the opposite side to the wall than the right door.
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! 

Syntax
!value1

Description
Returns the boolean negation of value1. value1 is first converted into a boolean if it is not 
already one.

Example
(1<2) equals true while !(1<2) equals false.

When you rotate the right door, the left door 
moves on its angle in tandem.
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() 

Syntax
(value1)

Description
Returns value1. Parenthesis are typically used to change the order of evaluation of complex 
expressions.

Example
1+2*3 equals 7, while (1+2)*3 equals 9.

< 

Syntax
value1 < value2

Description
Returns true if value1 is smaller than value2, and returns false otherwise.

Example
1<2 equals true while 3.1<3 equals false.

> 

Syntax
value1 > value2

Description
Returns true if value1 is greater than value2, and returns false otherwise.
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Example
1>2 equals false, while 3.1>3 equals true.

<= 

Syntax
value1 <= value2

Description
Returns true if value1 is smaller or equal to value2, and returns false otherwise.

Example
Both 1<=1 and 1<=2 equals true, while 3.1<=3 equals false.

>= 

Syntax
value1 >= value2

Description
Returns true if value1 is greater or equal to value2, and returns false otherwise.

Example
Both 1>=1 and 2>=1 equals true, while 3>=3.1 equals false.

== 

Syntax
value1 = = value2
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Description
Returns true if value1 and value2 are exactly the same, and returns false otherwise.

Example
Both 2.1= =2.1 and (3>2)= =true equal true, while 2= =2.1 equals false.

!= 

Syntax
value1 != value2

Description
Returns false if value1 and value2 are equal, and returns true otherwise.

Example
Both 2!=2.1 and (3>2)!=false equal true, while 2.1!=2.1 equals false.

|| 

Syntax
value1 || value2

Description
Returns true if value1 if its boolean value is true, or returns value2 otherwise.

Example
Both (1<2)||(3<4) and (4<3)||(1<2) equal true since (1<2) equals true, while (2<1)||(4<3) equals 
false.
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&& 

Syntax
value1 && value2

Description
Returns true if value1 if its boolean value is false, or returns value2 otherwise.

Example
Both (2<1)&&(4<3) and (3<4)&&(2<1) equal false since (2<1) equals false, while 
(1<2&&(3<4) equals false.

?: 

Syntax
condition ? value1 : value2

Description
Returns value1 if condition is true, or returns value2 otherwise. The condition is first converted 
into a boolean if it is not already one.

Example
(1= =1)?3:4 equals 3, while (1= =2)?3:4 equals 4.

[ , , ] 

Syntax
[value1, value2, ...]

Description
Returns a vector of 2, 3 or 4 fields, for which field values are value1, value2, etc. A vector of 3 
fields can store a position, an orientation or a color, etc. 
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Example
[1,2,3] can be used to set the position of an object at x=1, y=2 and z=3.

You can also use this operator to isolate one filed in a script, for example the script:

Cube1.Positon= [5, Cube1.Positon.y, Cube1.Positon.z]
sets the Cube’s X position to 5, while ignoring its other two Position values. The Y and Z 
position values for the cube, then, can be acted upon separately by other constraints or actions.

.x (or .y, .z, .r, .g, .b) 

Syntax
[WorldRef].field

Description
Returns the value of a specific field of the world reference. The field must be x, y or z for 
position, orientation and scale, or it must be r,g or b for color.

Example
Cube1.Position.x returns the value of the x field of Cube1’s position, and Light1.Color.g returns 
the value of the green field of the Light1’s color.

Other Example Scripts 

Collision Detection
There are different ways you can create forms of collision detection, including using AXEL’s 
Bounding constraints added to each object to be avoided, with the Inside parameter on the 
Bounding Box or Bounding Sphere turned off. Another way is given here; Using a custom senor, 
a line of script is written for each obstacle that causes the objects of your scene to be bumped 
backwards.

This collision detection script is linked to a ship on a curve with a reaction that puts it slightly 
back on a curve whenever it gets close to one of the spheres/obstacles.

Trigger when value changes:

distance( ship.Position, Sphere1.Position) <= 2.5 ||
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distance( ship.Position, Sphere2.Position) <= 2.5 ||

distance( ship.Position, Sphere3.Position) <= 2.5 ||

distance( ship.Position, Sphere4.Position) <= 2.5 ||

distance( ship.Position, Sphere5.Position) <= 2.5 ||

distance( ship.Position, Sphere6.Position) <= 2.5 ||

distance( ship.Position, Sphere18.Position) <= 2.5 

Each line in the above script is simply one of a series of conditions, any of which can be true, 
for a reaction to occur. Each line corresponds to a ship getting close to a particular sphere, which 
acts as an obstacle. As with all objects referenced in AXEL, the sphere’s position is defined by 
its center, so to make sure the ship properly avoids the spheres, the less than or equal to operator 
(<=) is used, which covers both the radius of the sphere and the length of the ship’s geometry 
from its center.

Bouncing
The following is an example of how you can make a ball bounce within a cube. You can 
experiment with the actual scripts that will achieve this effect, pictured here is just how this 
example would look in the Project Manager along with the script for the Custom Sensor. Notice, 
for each collision between the sphere and a wall, there is a Custom Sensor to detect. Each 
Custom Sensor is then linked to a Custom Reaction that sends the sphere off in the opposite 
direction.

Custom Sensors 
between each wall 
and the ball.

Linked to reactions.

AXS/Scripts_bouncing.htm
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The following is the script for the Custom Sensor If Ricochet Left Wall:

Trigger when value changes: 

Ball.Position.x < PlaneLeft.Position.x + Ball.Scale.x/2

The sensor is linked to a Group Reaction called Mvt Towards Right, which includes several 
Custom Reactions. These Custom Reactions are triggered as a result of the ball hitting the Left 
Wall, and will make the ball move right with the appropriate speed and angle.

Ball and Chain easing back into position
The following example has a chain link which uses IK to approximate the sway of the heavy 
chain. You can take hold of the ball using a Translate handle, and when you let go, the following 
script drops the ball back to its rest position:

Ball.Position =
( [0.0, -9.8, 0.0] * getDeltaValue( time() ) + 
getVelocity( Ball.Position ) ) * 
getDeltaValue( time() ) + Ball.Position 

Notice how the getDeltaValue function works along with the getVelocity function to mimic the 
deceleration of the ball as it returns to its resting position.

Scoring
The following example shows a simple example of a custom relation on the text parameter of a 
text layer, used for scoring in a simple game of gobbling the fish. This example works because 
AXELedge will compute the text parameter of a text layer or a 3D text surface as a numeric 
value, as long as you subtract 0 from the text like in the following script of a custom reaction:

TextLayer1.Text=

((TextLayer1.Text) - 0 + 10)

AXS/Scripts_ball_and_chain.htm
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The -0 in this script is just a method AXEL uses to turn the text into a numeric—and thus 
computable—value. 

Each time you click a little fish, the big fish 
swallows it up and adds 10 to your score.

AXS/Scripts_Score.htm
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Chapter 10
Publishing

Publishing in AXEL has a specifc meaning, 
differeciating it from exported content.

In that, AXEL publishes its full interactive content to 
the AXELplayer in the AXEL Stream file format 
(.axs), as well as direclty to QuickTime as AXEL 
QuickTime Movies (.mov).

These formats are AXEL’s interactive formats built 
to maximize the interactive abilities inherent in 
AXEL, where you have control over streaming, can 
embed the content and preview directly in Web 
Browsers, and can optimize the content for playback 
using tools such as the Sequencer’s Streaming view.

Remember, you can export, but you can also publish!

In this chapter:

Publishing 3D content ......... 556

Publishing AXEL Streams to the 
AXELplayer ........................ 558

Publishing AXEL QuickTime 
Movies ................................ 563

Publishing AXEL QuickTime 
Movies ................................ 563

Webpages and AXEL content ...
566

Windowless content 
(AXELplayer) ..................... 580

Optimizing .......................... 586

AXEL object <tag> code 
reference .............................. 613
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Publishing 3D content
Publish settings determine how your project is: published and placed on a webpage, published 
to an AXEL projector, or opened in the QuickTime player as an interactive AXEL QuickTime 
Movie. The publishing formats, AXEL Stream files (.axs), AXEL projectors (.exe in Windows) 
and AXEL QuickTime Movies (.mov), include of AXEL’s unique interaction abilities.

There are a couple of differences between publishing and exporting: 

• Publishing can automatically embed the content in a web page.

• Generally, 3D content published to the AXELplayer and QuickTime includes all of AXEL’s 
interactive capabilities, while content exported to the Flash player or as a VRML world is more 
limited in its interactivity. 

You might use exported content because you wanted to combine your 3D AXEL work with other 
content in the Flash author or a VRML editor, or to use as linear movies that can be composited. 
For more information, see “Exporting” on page 111. 

You can also open up .axs files in the AXELplayer Standalone, as well as in QuickTime with the 
QuickTime AXEL component. 

To display the Publish settings in the Parameter Editor:
In the Project Manager, click Publish Settings, then in the Parameter Editor choose AXEL 
Stream, AXEL QuickTime Movie, or AXEL projector.

You can toggle on/off Confirm file overwrite if you want to be warned before overwriting files. 
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You can toggle off Use default filename if you want to type your own names for your published 
files, otherwise they automatically use the same name as the AXEL project file (.axel) with the 
appropriate extension tacked on at the end (.axs, .mov, or .exe).

About published files
When you save an AXEL project file (.axel), you are saving the environment in which you built 
geometry, animation, interactions and materials. You can open this file at any time to preview 
or modify your content.

For Web Surfers to enjoy your AXEL content, you publish or export it in one of a variety of 
ways, either as an AXEL stream file (.axs), an AXEL QuickTime movie or regular QuickTime 
movie (.mov), in still images (.jpeg, .gif, or .png), an AXEL Projector (in Windows it has the .exe 
extension), a Flash Movie file (.swf), or a VRML World (.wrl). 

For more information on exporting and the various export formats, see “Exporting” on page 111.

You can then embed the files in an HTML web page that surfers can view in a web browser. The 
AXEL Projector executable cannot be opened in any authoring software, while the .axs file also 
cannot be opened in other software with the exception of QuickTime authoring software—
where only limited aspects can be edited like the size of the actual content window, graphic 
modes and exported parameters or reaction triggers.

Stream files (.axs) and AXEL QuickTime movies (.mov) contain all the information required by 
the AXELplayer or QuickTime to display your project in a web page. It bundles all the 
geometry, textures, sounds, reactions and animations into one file. AXEL projectors include all 
this information, plus bundle either the Windows AXELplayer or the Macinstosh AXELplayer 
in one excutable file so no other software is necessary for playback. You cannot edit the content 
within these files but you can edit the project used to create it, then publish new files from the 
edited content. Keep in mind that movies that use the Publish as URL parameter are not included 
in the files.

Batch publishing AXEL stream files (Windows)
You can publish a batch of stream files using a text file. This is useful for upgrading a series of 
projects to a new version AXEL.
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To batch publish AXEL stream files:
1. Create a text file containing, one per line, the author file (with its full path) and the name and 

path of the published file. The number sign (#) in front of a line will ignore the line in the 
batch saving.

2. Choose Publish > Batch Publish, and select the text file.

3. If any errors occur, AXEL displays an error message referring you to a .log file listing the 
files that it could not save.

Publishing AXEL Streams to the AXELplayer
To view your 3D content on the web, you publish a host web page in which a stream file is 
embedded. The stream file can invoke either the AXELplayer or the QuickTime player for 
playback. The stream file can also play in a stand-alone QuickTime 5 or 6 player for Windows 
or Mac OS X for which no host web page is necessary, or in the AXELplayer Standalone.

To Generate AXEL Stream:
1. Choose File > Save, and save the project in the directory you want to use for the project file, 

the stream file, and the web page.

2. In the Project Manager, click Publish settings/AXEL Stream.
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3. In the Parameter Editor, adjust the Publish settings.

Note: Do not use spaces in your stream file name as it will not be recognized by JavaScript. You 
can use underscores instead.

4. Adjust your project to the starting position of how it will open on a surfer’s machine. For 
example, you may want to turn on the Loop button ( ) so the your project continues to run 
indefinitely on surfers’ machines, or set the WebCam viewport to a different WebCam as this 
will be the initial WebCam through which your content is viewed.

5. Choose Publish > Generate AXEL Stream.
A stream file and a host web page are created. 

Enter a name for the stream file.

Set the size of the 3D window or, to create 
windowless content, turn on Windowless and 
adjust the windowless settings.

Enter a name for the host web page.

Default host web page design

Embedded stream file

HTML text
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Tip: Remember to save the project. If you want to edit the 3D content of a host web page later 
on, you will need the AXEL project file that was used to create it.

Publish settings/AXEL Stream
For the procedure to publish to the AXELplayer see “Publishing AXEL Streams to the 
AXELplayer” on page 558.

Publish settings/AXEL stream

Stream file The name of the stream file created when you use the Generate AXEL Stream com-
mand. 

Note: Do not use a file name with spaces as it may cause you problems later (i.e., 
it will not be recognized by JavaScript).

Generate stream Generates an AXEL stream file (.axs) when you Generate AXEL Stream.
Host webpage 
file

The name of the web page file (.htm) in which the stream file will be embedded. 
When you publish the content, the HTML file’s AXEL object code and the stream 
file are overwritten, but the rest of the web page is not overwritten.
In Windows, this web page appears in the viewport in Host Web Page view. 

Generate 
webpage

Generates a host web page when you Generate AXEL Stream.

Confirm file 
overwrite

Prompts you to confirm if you want to overwrite existing .axs and/or .htm file(s) 
when you Generate AXEL Stream if the names match.

3D window 
width

Width of the 3D window in the web page. You can enter the number in pixels, or in 
% of web page size.

3D window 
height

Height of the 3D window in the web page. You can enter the number in pixels, or in 
% of web page size.

Hardware accel-
eration

Allows the player to use graphic card hardware acceleration when available on the 
host’s computer to enhance AXEL content.

Windowless The 3D content appears directly on the web page. Its background is transparent. 
Results vary depending on the platform and web browser.

Absolute posi-
tioning

Allows you to set the top and left position of the windowless AXEL content relative 
to the browser window’s edges. Otherwise, the windowless content is relative to the 
other elements in the page.

Top position With Absolute positioning on, determines the distance of the AXEL content from the 
top of the browser window. Otherwise the top position is relative to the previous ele-
ment on the page. The value is in pixels.

Left position With Absolute positioning on, determines the distance of the AXEL content from the 
left edge of the browser window. Otherwise the left position is relative to the previ-
ous element on the page. The value is in pixels.
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Publishing AXEL Projector files
You can publish your AXEL content to an AXEL Projector files, which bundles an AXELplayer 
Standalone with your content. You can post this file for download on the Web or in a CD-ROM, 
for example, and the user does not have to have a browser or other software for playback.

You can generate both Windows and Macintosh executables from within both the Windows 
version of AXEL and the Macintosh version of AXEL. These file can run on Windows machines 
(Win 95 through XP), and Macintosh (OS 9.1, through OX 10.2) respectively.

To export an AXEL Projector:
1. Adjust your AXEL Projector export Settings.

2. Choose File > Export > AXEL Projector.
Depending on your settings, a self-executable file is created for Windows and/or Macintosh 
that includes your current AXEL content .

Z-index Determines the stacking order of the AXEL object on a web page that contains other 
graphics. Z-index is not supported by Internet Explorer on Macintosh.

Alpha (Opacity) Sets the level that foreground 3D objects are opaque (impenetrable to light) in win-
dowless publishing. 

Drop shadow Turns on/off the drop shadow.
Shadow dark-
ness

Varies the shadow from gray to black.

Shadow hori off-
set

Sets the horizontal distance between an object and its shadow.

Shadow vert off-
set

Sets the vertical distance between an object and its shadow.

Double-click the 
executable and 
Snowboarding Santa 
opens in the AXELplayer 
Standalone. Control Santa 
right then and there.
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Publish settings/AXEL Projector (Windows and Macintosh)
For the procedure to create AXEL Projector files, see “Publishing AXEL Projector files” on 
page 561.

Publishing AXEL QuickTime Movies
You can publish interactive QuickTime movies from directly in AXEL that use the QuickTime 
AXEL component to preserve all off AXEL’s interactivity.

Note: Center and right mouse button triggers do not function properly in QuickTime. You can use 
modifier keys instead. Check the MindAvenue Web site for updates on the QuickTime component 
and other importers/exporters.

PC file The name of the PC AXEL Projector executable that is generated. This file can only 
be opened on Windows machines as it includes the Windows-specific AXEL Projec-
tor application. The generated file has the extension .exe

Mac file The name of the Mac AXEL Projector executable that is generated. This file can only 
be opened on Macintosh machines as it includes the Macintosh-specific AXEL Pro-
jector application.

Hardware 
Acceleration

Turn on/off Hardware Acceleration for the default of your published content. Users 
can then toggle on/off Hardware Acceleration on their own machines from the 
AXEL Projector application that plays the content.

Chromeless 
(Windows)

Turn on/off Chromeless, to set the default for the borders and menu of the AXEL 
Projector for your published content. Users can then toggle on/off Chromeless on 
their own machines from the AXEL Projector application to gain access to the menu 
and borders or hide everything but the AXEL content.

Fullscreen Opens the file in fullscreen.
Width The width, in pixels, of the AXEL Projector that opens and plays the AXEL content. 

Users can then stretch their AXEL Projector as they desire. With the chrome border 
enabled, the actual width is squeezed slightly to make room for the borders.

Height The height, in pixels, of the AXEL Projector that opens and plays the AXEL content. 
Users can then stretch the AXEL Projector as they desire. With the chrome border 
enabled, the actual Height is squeezed slightly to make room for the borders and 
menu bar.

Top The position, in pixels, from the top of the screen that the projector opens at.
Left The position, in pixels, from the left of the screen that the projector opens at.
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You can also use other methods to invoke QuickTime to play your AXEL stream files, by 
changing the html code and/or optionally open your .axs file in QuickTime Pro and save it as a 
movie. 

Both these alternative methods cause your AXEL content to invoke and play in QuickTime as 
opposed to the AXELplayer.

For more information, you can visit the relevant page on Apple Computer’s web site, at:

http://www.apple.com/quicktime/authoring/embed.html 

The following are the three methods for your AXEL Stream files (.axs) to play in QuickTime:

To publish content to QuickTime directly from AXEL:

1. Adjust your QuickTime Publish Settings under Publish Settings/AXEL QuickTime Movie.

2. Choose Publish > Generate AXEL QuickTime Movie (F10).
Your interactive AXEL QuickTime Movie file and host webpage are published to the project 
folder.

Alternative Method # 1: To play AXEL content in QuickTime by changing the HTML code:
This follows the standard way of placing QuickTime elements within an html page.

1. Publish your AXEL content to an HTML page initially using the AXELplayer by choosing 
Publish > Generate AXEL Stream. For more information, see Publishing AXEL Streams 
to the AXELplayer.

2. Open the HTML page containing the AXEL stream file in a text editor.

3. Replace the AXELplayer Object and Embed tag code with the QuickTime player Object and 
Embed tags as follows:

<OBJECT CLASSID="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" HEIGHT="300" WIDTH="400"
CODEBASE="http://www.apple.com/qtactivex/qtplug-in.cab">

The name of your AXEL QuickTime Movie. The 
project name is used. To type a different name toggle 
off the Use default filename in the Publish settings.

Dimensions, in pixels, of your AXEL QuickTime movie.

The name of you host web page.

http://www.apple.com/quicktime/authoring/embed.html
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<PARAM name="SRC" VALUE="yourfile.axs">
<PARAM name="AUTOPLAY" VALUE="true">
<PARAM name="CONTROLLER" VALUE="false">
<EMBED QTSRC="yourfile.axs" HEIGHT="300" WIDTH="400"
SRC="Sample.qtif" Type="image/x-quicktime" plug-inSPAGE="http://www.apple.com/quicktime/download">
</EMBED>
</OBJECT>

4. yourfile.axs (or yourfile.mov if you saved your stream file as a QuickTime movie, see below), 
is your .axs file that your generated from AXEL. It will appear in your originally generated 
HTML code so simply insert the proper file name in the appropriate places for both the 
Object and Embed information.
The HEIGHT and WIDTH attributes in the HTML should match the dimensions of the 
movie. The movie will be sized at the width and height set in the AXEL Publish settings.

5. When you upload your files to your server, make sure that the file Sample.qtif is located in 
the same folder as your AXEL QuickTime content. 
The sample.qtif file is supplied with QuickTime. On Windows, it is located at C:\Program 
Files\QuickTime\Sample.qtif. On Macintosh OS X, you will find the file in your QuickTime 
for OS 9 folder; it is located at Applications (Mac OS 9):QuickTime:Sample Image (and 
should be given an extension so the file is named Sample.qtif for use on the web server).

Alternative method # 2: To play AXEL content in QuickTime by opening and saving in 
QuickTime Pro: 
1. With the QuickTime AXEL component installed, open up your .axs file in QuickTime Pro, 

then choose File > Open Movie in New Player, then select an .axs file.

2. Click Convert (Windows) or Open (Macintosh).

3. Choose File > Save as.
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4. In the dialog that open, change the files extension from ".axs" to ".mov", then select Make 
movie self-contained.

5. Click Save.
When you open the movie you will have your interaction right there in the QuickTime 5 or 
6 player. If someone opens this movie on a machine without the AXEL QuickTime 
component they will be prompted to add more software to their QuickTime player as 
described in “To install the AXEL QuickTime component:” Saving your AXEL stream files 
as a movies allows you to put the files remotely on a server where they doe not have to be 
embedded in web pages and add other QuickTime effects.

Note: The type of your .axs files must be correct for QuickTime 5 or 6 to recognize the content as 
AXEL content. The type of your files may change if you move them between PC and Mac 
platforms, you can make sure the type is .axs using Resedit or other Typer applications.

Publish Settings/AXEL QuickTime Movie
 For the procedure to publish AXEL QuickTime Movies see “Publishing AXEL QuickTime 
Movies” on page 563.

Publish settings/AXEL QuickTime Movie

Movie file The name of the AXEL QuickTime Movie. Click the ... button to choose a save loca-
tion.

Generate movie 
file

Generates the AXEL QuickTime Movie (.mov). Toggle this parameter off if you just 
want to generate a host web page without overwriting the .mov file.
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Webpages and AXEL content

Previewing AXEL Streams and AXEL QuickTime movies
There are two ways to preview your content in a web page without exiting AXEL: 

• In a web browser.  

• In Windows, you can also display the host web page inside a viewport.  

Previewing AXEL Streams and AXEL QuickTime movies in a 
web browser
You can preview the current host web page in a compatible web browser or HTML editor 
without exiting AXEL.

To preview the host web page in Internet Explorer or Netscape Navigator:
Choose Publish > Preview in IE or Preview in Netscape.
On the Macintosh, this list can be edited and your choices appear directly in the Publish menu.

To preview in other browsers or in an HTML editor:
In Windows, choose Publish > Preview in, and when the Open dialog appears, navigate to the 
browser executable or HTML editor, then click Open.

On the Macintosh, choose Publish > Preview in, then choose a browser from the list. You can 
edit the browser list in Preferences / Web Browsers from the Edit menu in Mac OS 9, or from 
the AXEL menu in Mac OS X.

HTML file The name of the HTML host web page that embeds your AXEL QuickTime Movie 
embedded.

Generate HTML 
file

Generates the AXEL QuickTime Movie (.mov). Toggle this parameter off if you just 
want to generate AXEL QuickTime Movie (.mov) without the host webpage (and if 
you do not want to overwrite an existing host web page). 

Window width The width, in pixels, of the AXEL QuickTime Movie, whether it is embedded in a 
web page or played in the standalone QuickTime player.

Window height The height, in pixels, of the AXEL QuickTime Movie, whether it is embedded in a 
web page or played in the standalone QuickTime player.
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Note: For the preview to take effect in a browser, the browser has to be installed on your computer 
and have the AXELplayer plug-in.

Previewing in a host web page (Windows)
By default, the host web page is displayed in the upper right viewport. The current 3D World 
appears inside the host web page. 

When you publish in an existing web page, that page appears in host web page view. If you 
modify the World, you can view your changes in context. When you are satisfied with the 3D 
World inside the host web page, you must generate the web content to update the stream file in 
the actual web page.

You can manipulate objects, 
zoom, pan, and orbit inside 
the host web page.
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To show the host web page:
Right-click a viewport and choose Enable Host Web Page.

Note: To hide the host web page, choose Disable Host Web Page.

Adding 3D content to an existing web page
You can add 3D content to an existing 2D web page using AXEL or an HTML editor. To embed 
more than one stream file in a host web page, use an HTML editor.

To add 3D content to an existing web page using AXEL:
1. Choose File > Save As, navigate to the location of your web page, and click Save. 

The AXEL project file is saved, and related textures, sounds, and stream files are also copied 
to the new location.

2. In the Project Manager, click Publish Settings. 

3. In the Parameter Editor, enter the name of the web page file in the Host webpage file field. 
In Windows, you can also open a dialog by clicking the button to the right of the field, and 
selecting the file from the dialog.
Your file becomes the host web page.

4. Turn off Generate stream.

5. Choose Publish > Generate AXEL Stream.

6. When prompted to add the tag to the end of the page, click OK.
A stream file is embedded at the end of the HTML code in your host web page. Your 3D 
content appears at the bottom of the web page. To move it, cut and paste the AXEL object 
code to the desired location on the page.
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To add 3D content to an existing web page using an HTML editor:
1. Publish the project to generate a host web page (.htm) and an AXEL stream file (.axs).

2. Place the AXEL stream file in the same directory as your web page.

3. Cut and paste the AXEL object code from the host web page into your web page.

4. Adjust the window size or windowless properties in the AXEL object code.

Modifying a web page
You can edit the 3D content in AXEL and regenerate the web content.

To modify the 3D content:
1. Open the AXEL project file (.axel) used to create the 3D content.

2. Edit the project. Change the models, colors and interaction, for example.

3. In the Publish Settings, make sure the host web page and stream file names correspond to the 
web page you want to update.

4. Turn on Generate stream and Generate webpage, then choose Publish > Generate AXEL 
Stream.
The stream file is updated. Refresh your web page in your browser to see the result.

5. Choose File > Save to save the updated project.

3D stream file (.axs) 2D Text 2D images (.gif)
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To modify the placement of 3D and 2D elements:
Choose Publish > View Source Host Web Page or open the page in an HTML editor, edit the 
HTML code, and save your changes.

Note: To move the 3D content around the page, simply cut and paste the following AXEL content 
code to the desired location.

<!-- Begin of AXEL content -->
<object id="Furniture_constraints_completed" classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A"
    codebase="http://www.mindavenue.com/Downloads/AXELplayerAX_Win32.cab#version=1,0,800,0"
    width="200" height="200">
   <param name="Src" value="Furniture_constraints_completed.axs">
   <param name="Windowless" value="0">
   <embed src="Furniture_constraints_completed.axs" name="Furniture_constraints_completed"
       plug-inspage="http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm"
       type="application/x-MindAvenueAXELStream"
       width=200 height=200 Windowless=false>
   </embed>
</object>
<!-- End of AXEL content -->
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Example: Copying the 3D content into an HTML table
In this example, the 3D content is resized and then copied and pasted into the images table.

1. Open the HTML file, add a row to the images table, then copy and paste the AXEL content 
into the new row.

2. To make the 3D window smaller, edit the window width and height attributes in the Publish 
settings, or in the HTML code.

AXEL content AXEL content
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<table width="100%" border="0" cellspacing="0" cellpadding="0" bgcolor="#666666" height="40" 
align="center">
    <tr>
      <td><!-- Begin of AXEL content -->
<object id="Furniture_constraints_completed" classid="CLSID:68A2C3BD-7809-11D3-8ACF-
0050046F2F9A"
    codebase="http://www.mindavenue.com/Downloads/AXELplayerAX_Win32.cab#version=1,0,800,0"
    width="200" height="200">
   <param name="Src" value="Furniture_constraints_completed.axs">
   <param name="Windowless" value="0">
   <embed src="Furniture_constraints_completed.axs" name="Furniture_constraints_completed"
       plug-inspage="http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm"
       type="application/x-MindAvenueAXELStream"
       width=200 height=200 Windowless=false>
   </embed>
</object>
<!-- End of AXEL content --></td>

<td><font face="Arial, Helvetica, sans-serif" size="4">Sleeping Beauty night table </font><br><font 
face="Arial, Helvetica, sans-serif" size="2">Available in cherry wood, teak, and natural pine. </
font><br>$439.00* 
<br><br><font face="Arial, Helvetica, sans-serif" size="1">*Does not include shipping and handling.</font></
td>

<td>
<table width="100%" border="0" cellspacing="0" cellpadding="0" bgcolor="#666666" height="40" 
align="center">
    <tr>

<td valign="top"><img src="couches.gif" width="100" height="100"></td></tr>
<tr>
<td valign="top"><img src="beds.gif" width="100" height="100"></td> </tr>

AXEL 
content on 
the left

Images 
table on the 
right

<tr>
<td>
<!-- Begin of AXEL content -->
<object id="Furniture_constraints_completed" classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A"
    codebase="http://www.mindavenue.com/Downloads/AXELplayerAX_Win32.cab#version=1,0,800,0"
    width="100" height="100">
   <param name="Src" value="Furniture_constraints_completed.axs"> <param name="Windowless" value="0">
   <embed src="Furniture_constraints_completed.axs" name="Furniture_constraints_completed"
       plug-inspage="http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm"
       type="application/x-MindAvenueAXELStream"
       width=100 height=100 Windowless=false>
   </embed>
</object>
<!-- End of AXEL content -->
</td></tr>
</table>
</td>
</tr>
<tr>
      <td height="1" bgcolor="#666666" align="center" valign="middle">&nbsp;</td>
    </tr>
</table>

 Copied 
AXEL 
content 

Edited size 
attributes
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Adjusting the window size in a web page (AXELplayer)
The 3D window that contains the AXEL content can be any size. You set the size in the 
Publishing settings in AXEL or in the object code in the HTML file.

To set the size of the 3D window using AXEL:
1. In the Project Manager, select Publish Settings.

2. In the Parameter Editor, make sure Generate web page is turned on.

3. In the 3D window width field, enter the width in pixels or as a percentage of the web page 
width. In the 3D window height field, enter the height in pixels or as a percentage of the web 
page height. Values are in pixels unless they are followed by a % sign. You can have one 
value in pixels and the other as a percentage.
Pixel values are fixed so that the 3D window is the same size on every surfer’s screen. 
Percentage values are a function of the size of the browser window. As a surfer resizes the 

100 x 100  250 x 250 350 x 350
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browser window, the AXEL 3D window scales accordingly. Also, the screen resolution of 
the surfer’s computer plays a part in the absolute size of the 3D window.

When you choose Publish > Generate AXEL Stream, the window size attributes are 
updated in the object code of the published content.

To set the size of the 3D window in the HTML code:
1. Open the host web page in a text editor.

2. Change the width and height attributes in the AXEL object code.

Note: The size attributes are overwritten the next time you publish this host web page. To re-
publish the 3D content without changing the window size, either set the window size in the 
Publish settings, or change the name of the host web page. When you publish, the stream file is 
updated without changing the rest of the htm page.
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External Communication: AXEL to other content, other content 
to AXEL
For communication to the outside from AXEL content, and to the inside of AXEL content, you 
use exported parameters and exported reaction triggers. Exported parameters and reaction 
triggers can be used as simple html buttons or prompts on the web page, or controlled through 
a database, or use the exported parameters to communicate with other formats—perhaps using 
a scripting language such as JavaScript—to Flash or Director content, or to communicate with 
other media types in a QuickTime presentation.

You can also communicate between AXEL windows (or windowless content) using exported 
parameters and reaction triggers.

Look for more specific information and tutorials about communicating between AXEL and 
other content through exported parameters and reaction triggers on the MindAvenue Web site. 
Address specific questions to the User Forum in the support section.

Exporting parameters
You can export AXEL parameters to a button on your web page. Exported parameters are 
manipulated by scripts embedded in the web page. 

In the previous illustration, the spotlight’s color parameter was exported. The surfer can click a 
button to change the spotlight color. The shadow material’s transparency parameter was also 
exported. The surfer can type a value between 0 and 100 to modify the shadow. The changes 
take effect when the surfer moves the cursor into the 3D window.

From the color of an object to the intensity of a light, any parameter can be exposed to the surfer.

Exported parameters
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Note: The Export Parameter feature is not supported by Internet Explorer on Macintosh, which 
does not allow plug-ins scripted with JavaScript.

To export a parameter:
1. In the Project Manager, select the parameter. 

2. Choose Publish > Export Parameter.

3. In the Project Manager, expand Resources / Web Parameters to display the exported 
parameters.

4. Rename the parameter to give it the name that you want to display on the web page. You can 
also edit the parameter name in an HTML editor after you generate the web content.
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5. Generate the web content, then open the web page in a web browser. In Windows, you can 
also right-click a viewport and turn on Host Web Page. 
The web page contains controls to change the parameter. Depending on the parameter, the 
surfer may have to type a number or click a button as shown above.
Parameters can be controlled by other parts of the web page using JavaScript.

Note: The host web page communicates with the AXEL player through the exported web 
parameters. JavaScript finds the AXEL object through the id value in the <object> tag or the name 
value in the <embed> tag. When you modify the host web page htm file, make sure the id value 
name matches the name your JavaScript functions use to call SetWebParam() and GetWebParam().
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Exporting reaction triggers
Exporting reaction triggers creates buttons in the host web page. By clicking the buttons, the 
surfer triggers reaction.

To export a reaction trigger:
1. In the Interaction Editor, select the reaction you want the surfer to trigger from the web page.

2. Choose Publish > Export Reaction Trigger.
The new trigger is listed in the Project Manager, under Resources / Web Parameters. The 
name of the trigger appears on the buttons on the web page. 

3. To rename the trigger, click the name twice in the Project Manager, then type a new name. 

<!--AXELBeginWebParamCode-- NOTE: This sample JavaScript code was automatically generated by AXEL and will be 
overwritten the next time you publish from AXEL. This is an example of how to connect your own JavaScript code to the 
exported parameter(s) of your AXEL content. You can copy and modify the sample code outside of this section which is 
bracketed by "AXELBeginWebParamCode" and "AXELEndWebParamCode" to avoid it being overwritten! -->

<script language="JavaScript">
   function setSpotLight1_Color( i_NewValue )
   {
      document.Untitled.SetWebParam( "SpotLight1_Color", i_NewValue );
   }
   function getSpotLight1_Color( i_NewValue )
   {
      return document.Untitled.GetWebParam( "SpotLight1_Color" );
   }
</script>

<form>
<p>SpotLight1_Color:
   <input type="button" value="Default" OnClick="setSpotLight1_Color( '255  255  255' )">
   <input type="button" value="Red" OnClick="setSpotLight1_Color( '1. 0. 0. 1.' )">
   <input type="button" value="Green" OnClick="setSpotLight1_Color( '0. 1. 0. 1.' )">
   <input type="button" value="Blue" OnClick="setSpotLight1_Color( '0. 0. 1. 1.' )">
   <input type="button" value="Prompt" OnClick="setSpotLight1_Color( prompt( 'Change SpotLight1_Color value:', 
getSpotLight1_Color() ))">
</p>
</form>

<!-- End of AXEL automatically generated code --AXELEndWebParamCode-->

HTML input buttons 
control the generated 
JavaScript 

JavaScript 
controls 
the 
exported 
parameters
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4. To publish the project, choose Publish > Generate AXEL Stream.
The trigger controls appear on the host web page.



580 | AXEL V2 | User Guide

Uploading AXEL content to the web
To upload your content, you publish it, then upload the resulting HTML and stream files to the 
web. 

Note: There are two modes - binary and ascii - that ftp clients use to transfer files, make sure you 
are using the mode that corresponds with your server when uploading your files.

To upload AXEL content:
1. Publish your work. See “Publishing 3D content” on page 556.

2. Upload the following files:

• AXEL stream file (.axs) (or QuickTime file (.mov), or Flash file (.swf), or VRML file (.wrl), 
etc.)

• Host web page (.htm)

• If you are publishing to QuickTime, you also must upload the Sample.qtif file to the same 
folder as your AXEL QuickTime content. 

The sample.qtif file is supplied with QuickTime. On Windows, it is located at C:\Program 
Files\QuickTime\Sample.qtif. On Macintosh OS X, you will find the file in your QuickTime 
for OS 9 folder; it is located at Applications (Mac OS 9):QuickTime:Sample Image (and 
should be given an extension so the file is named Sample.qtif for use on the web server).

• Any other files linked to the host web page (.jpg, .gif, .htm, .mov, scripts, for example.)

3. If you turn on Publish as URL for any movie files used in your project, upload the movie files 
to the location that you specify in their respective URL fields.

Windowless content (AXELplayer)
You can publish windowless content that floats on top of your web page; you can adjust its 
transparency, Z-index, and drop shadows.
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In the following illustration, Krazee Bob is seen first in the AXEL authoring software, walking 
on a black background. Then, when published as windowless content, he walks on top of the 
page. The background is removed, revealing the rest of the web page.

Note: Windowless publishing is processor-intensive. Results vary depending on the web browser. 

To publish windowless content:
1. In the Project Manager, click Publish Settings.

2. In the Parameter Editor, turn on Windowless.
The following Windowless settings are enabled.

6. Choose Publish > Generate AXEL Stream.

3. To set the layering order, adjust the Z-index. 
See “About Z-index (AXELplayer)” on page 
582.

4. To see through objects, increase their Alpha 
(Opacity). See “About transparency in 
windowless content (AXELplayer)” on page 
583.

5. To create drop shadows of the 3D objects, turn 
on Drop shadow and adjust the shadow fields. 
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About Z-index (AXELplayer)
When several layers are superimposed in a web page, the Z-index (“z” is for depth) determines 
their order, from front to back. Increasing the Z-index brings 3D content to the front of other 
layers on the web page.

In the following illustration, Krazee Bob is walking over the text; in the illustration on the left, 
his Z-index is higher than that of the text. On the right, his index was reduced to have him appear 
under the text.

When publishing AXEL content, the default Z-index is 0. You can modify the Z-index in the 
Publish settings before publishing your World. You can also change the Z-index in the HTML 
file after the stream file is published.

Netscape version 4 browsers handle layers differently than later Netscape versions or Internet 
Explorer. Netscape 4 does not respect the Z-index style parameter. Instead, the sequence in 
which the layers appear in the HTML code determines their background-to-foreground order. 
The layer whose element (usually a DIV) is placed first in the HTML code is in the background, 
subsequent layers are closer to the front, and the layer whose element is coded last is in the 
foreground. 

To create layered pages that display correctly in all browsers, it is necessary both to include Z-
index style parameters and to make sure that the layers are coded in sequence from back to front. 

Z-index is not supported with Internet Explorer on Macintosh. Therefore the windowless 
content always appears in front. With Netscape on Macintosh, you can change the sequencing 
within the source to get desired results.
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About transparency in windowless content (AXELplayer)
With windowless content, you can see through the background so the objects appear to float on 
the web page. In addition, you can apply transparency to the 3D objects in the foreground. 

Adjust the transparency of windowless content by setting the Alpha (Opacity) in the Publish 
settings.

Alpha (Opacity) can range from 0 to 100. When Alpha (Opacity) is 100%, the 3D objects are 
opaque. When Alpha (Opacity) is 50%, the 3D objects are semi-transparent.

Drop shadows in windowless content (AXELplayer)
For windowless content, the 3D objects can cast shadows on the rest of the web page.

To create shadows:
1. In the Project Manager, click Publish Settings, then in the Parameter 

Editor, turn on Windowless and Drop shadows.

2. Adjust the shadow fields:

Shadow darkness Varies the shadow from grey to black.
Shadow hori offset Sets the horizontal distance between an object and its shadow.
Shadow vert offset Sets the vertical distance between an object and its shadow.
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3. Choose Publish > Generate AXEL Stream.

Windowless content in different browsers (AXELplayer)
The following codes display AXEL stream files on top of other content. The first sample is the 
default HTML code generated byAXEL. Internet Explorer 4+ reads the layer information but 
not Netscape Navigator 4+. 

The second sample is the same code but with two added lines, the opening and closing layer tags 
at the beginning and end of the code. The style information already included in the AXEL object 
tag (such as positioning and dimensions) can be read only by Internet Explorer 4+. So that 
Netscape Navigator 4+ is also instructed to put the windowless content in a layer, simply add a 
<layer> tag before the AXEL code in an HTML editor. Make sure the width and height values 
in the layer tag match those in the stream file. However, it is better to leave the top and left values 
at 0 because they are added to those within the stream file.

Internet Explorer 4+ ignores the <layer> and goes directly to the AXEL stream file.

For more information on browsers that give the best results, refer to the Support section at 
www.MindAvenue.com.
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Note: Netscape 6 does not support windowless content. Netscape 4+ on the Macintosh may crash 
when displaying windowless content. 

Default Code - IE 4+

<object id="AXELStreamFile" 
classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A" 
codebase="http://www.mindavenue.com/Downloads/
AXELplayerAX_Win32.cab#version=1,0,828,1"
style="position: absolute; left:5px; top:5px; z-index:0"
   width="400" height="300">
<param name="Src" value="AXELStreamFile.axs">
<param name="Windowless" value="1">
<embed src="AXELStreamFile.axs" 
name="AXELStreamFile"  plug-inspage=http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm 
type="application/x-MindAvenueAXELStream"
          width="400" height="300" windowless="true">
</embed> 
</object>

Crossbrowser Code - IE4+ AND NN4+

<layer ID="layer" top="0" left="0" width="400" height="300">
<object id="AXELStreamFile" 
classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A" 
codebase="http://www.mindavenue.com/Downloads/
AXELplayerAX_Win32.cab#version=1,0,828,1"
style="position: absolute; left:5px; top:5px; z-index:0"
   width="400" height="300">
<param name="Src" value="AXELStreamFile.axs">
<param name="Windowless" value="1">
<embed src="AXELStreamFile.axs" 
name="AXELStreamFile"  plug-inspage=http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm 
type="application/x-MindAvenueAXELStream"
          width="400" height="300" windowless="true">
</embed> 
</object>
</layer>

Width and 
height values 
should match. 
Top and left 
values are added 
to those in the 
stream file.
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Optimizing
AXEL includes tools to control and preview how your content will stream to machines with 
different connection speeds, as well as control over antialiasing, hardware acceleration and 
clipping so that you can optimize your content accordingly.

About streaming
You can make surface geometry, textures, and sounds streamable so that the web page can be 
displayed before all the 3D content is downloaded.

In the following illustration, Krazee Bob is in a room, pondering which door to open. Behind 
each door is a closet filled with junk about to fall on him. The surfer does not see this since the 
door has yet to be opened, so valuable time is being wasted by waiting for all this to download.

Without streaming, the 3D window would only appear once all the content (every object, every 
texture, every sound file) was downloaded. It could take some time to download content that is 
not even visible, sounds that may only be triggered a minute later by the surfer, textures on 
objects that you cannot see yet.

In the previous example, the default download behavior is the following:

The initial display time is 20 seconds. AXEL waits until all geometry, interaction, and animation 
is downloaded, and then sends low-resolution versions of texture files. Then the page opens. As 
the surfer is watching or interacting at second 20, sound files and full-resolution texture files 
continue downloading. The download is complete at second 57.

The default may not be satisfactory. For example, you may want the wooden barrel texture on 
Krazee Bob to appear immediately at full resolution, while the car and all the junk behind the 
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door stream in. You can change the default behavior by making specific objects streamable. You 
can also set the streaming priority to control which objects are streamed first.

A low-resolution version of a streamed geometry is inserted at the beginning of the .axs stream. 
When the geometry is displayed in a web page, the low resolution geometry is downloaded first, 
then the real geometry is displayed as soon as it is downloaded.
Image textures and sound files are streamable by default. If you want them to be downloaded 
completely before your project is viewable, turn off Streamable.

Geometry is not streamable by default, nor are movie textures. If you have a large object or 
movie that does not appear immediately, you should turn on its Streamable parameter so that it 
does not hold up the display of your web page.

If you experiment with streaming, you will find that you can sometimes significantly reduce the 
initial display time by streaming parts of your World, especially textures and sounds. You can 
compare the download time estimates in Streaming mode in the Sequencer, as well as the time 
at which they appear to the surfer (remember to choose which connection you are using from 
the Download speed list in the Download Estimates settings).

Streaming in the Sequencer
Streaming governs the download flow of individual items from your AXEL project to a surfer’s 
web page.

The Streaming view in the Sequencer is a time-based display of all the geometries, sounds and 
textures in your project according to their streaming priority. Use the Streaming view to see the 
streaming priorities of items. You can select streamed items in the Sequencer and then adjust 
their streaming priority in the Parameter Editor. For more information, see “About antialiasing” 
on page 594 and “Estimating download time” on page 592.

Compare items’ respective streaming priorities and download times both with each other, and 
by using Interaction view, with animations and reactions. This will help you lend coherence to 
your project through time by allowing you to coordinate all of these events based on when they 
will occur. 

You can set streaming priorities for all the items in your project in the Parameter Editor, or leave 
some as unstreamed so that all their information must be downloaded before they appear in the 
World.You can then compare the priorities in the Sequencer. 

The portion of the Unstreamed Data track that falls before time 0 measures the data that must be 
downloaded before your project begins to appear on a surfer’s computer. This point also 
corresponds to the point where OnInitialDownload trigger of the browser sensor triggers a 
reaction. The other browser sensor trigger, OnFinalDownload, triggers a reaction at the end 
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mark of the Download Stream bar, which marks when the AXEL content is fully downloaded. 
For more information, see “Browser sensor” on page 466.

To view streaming priorities in the Sequencer: 
Click the Streaming view and expand the categories.
The time it takes for the item to download to a web page is represented. 

To refresh streaming priorities:

In the Sequencer’s toolbar, click the Refresh button ( ).

Download time and performance
Download time determines how long a surfer has to wait before your 3D content appears. 
Performance is how the content performs on the surfer's machine once downloaded. 
Performance is not necessarily affected by the same factors that slow down download times. 

Download time
Download time is affected by:

• The connection the surfer has to the Internet.

• The size of the stream file (.axs):
a) The file size is affected partly by the quantity of frozen geometry - that is - from objects 

created from scratch or that are comprised of deformed pre-set surfaces. If you have a lot of 
frozen and complex geometry in you scene with a lot of points, this makes your AXEL 
stream file heavier to download.
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b) Mostly, however, the size of the file is affected by all the texture files and sounds included 
in your scene. This is why it is important to pare down your image and movie textures, as 
well as your sound files, to the smallest acceptable size. Look at the size of the various 
.bmp .mp3 .mpeg .avi .wav .midi and .mov files to get an idea of what is contained in a 
stream file. 

Keep in mind that AXEL compresses sound files and textures to minimize the size of the stream 
file. The amount of reduction in file size depends on the amount of information in your file. For 
example, a picture that is mostly white space with only a few ink blots will be pared down 
significantly. Similarly, a large sound file with only a few brief instances of sound will be 
reduced in size quite a bit. On the other hand, an image that has a lot of detail will remain quite 
large after compression. 

Performance
The performance of your content on the surfer’s machine is not something you can fully control 
since it depends on the processor and graphic card, and it is not necessarily affected by the same 
factors that slow down download times. You can get an idea with the grading of your refresh rate 
in your World (in Windows, press I in a viewport), but it can vary from one machine to another.

The higher the refresh rate, the better the performance. The maximum performance is around 18 
Hz.

Performance is affected by the quantity and complexity of geometry displayed on screen. Very 
complex geometry with large textures significantly lowers refresh rate. Invisible geometry, that 
is, geometries with their visibility parameter turned off are not calculated and so will have no 
affect on performance. However, geometry that is transparent, in other words that has a Material 
with a transparency parameter of, or near, 100, is calculated and slows down performance.

Keep aware of the number of total points in your World in the Project Manager to gage its total 
complexity.

Sound files are heavy to download but they will not affect performance once transferred. 

Multiple lights or large quantities of particles can slow down performance since they require 
more processing power, but are insignificant in terms of download time. 

Grade of refresh 
rate

Refresh rate
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You can turn on Hardware acceleration for your published files so that they will use the graphic 
card on surfers’ computers if one is available. For more information, see “Hardware 
acceleration” on page 594.

You can add a clipbox which reduces the area that AXEL must calculate to define your World. 
The performance gain in using a clip box can be useful if you are publishing windowless content. 
For more information, see “Clipping” on page 596.

Example: How sphere geometry affects download time and performance
A sphere is defined by its radius and is generally quick to download because its shape is pre-
defined. Increasing subdivisions of this sphere has no effect on download time because this just 
alters an attribute of this sphere. However, increasing subdivisions will slow down performance 
because there is more information to calculate on the host computer. 

If you move just one point on this subdivided sphere, performance does not change much 
because visually the sphere is roughly the same, but its download time increases significantly. 
The object can no longer be defined as a sphere by a simple equation; instead its 3542 separate 
points must be downloaded and reconstructed. 

Tip: As you work, keep an eye on the number of points in your whole World and learn how to 
minimize the number of points in your scene.
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.

Download time and 
performance is quick.

Performance is identical to 
the second sphere, yet 
download time significantly 
increases since it is no longer 
a sphere but 3542 points to be 
downloaded. 

Download time is quick but 
performance slows down.

,
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Estimating download time
You can use various techniques to reduce download time. You can use download simulations, as 
well as the Streaming view in the Sequencer, to forecast the download time of your 3D 
content.You can simulate different network connections and see corresponding estimated 
download times.

To view download estimates:
1. In the Project Manager, click Download Estimates. 

Download estimates appear in the Parameter Editor. 

2. Select different connection speeds and notice Time to initial display, as well as Total 
download time.

3. Turn on Autofresh estimates to automatically refresh the time estimates as you transform 
your World. This is off by default so that AXEL does not calculate estimates while you work. 
Alternatively, you can use the refresh button ( ) to calculate estimates when you want.

4. Turn on Show details to see the amount of data that composes each item within every 
streaming priority.

To simulate the download with different connections:
1. In the Project Manager, click Download Estimates.

2. In the Parameter Editor, select the Download speed you want to simulate.

3. Turn on Simulation. 

4. Turn on Autorefresh estimates to automatically refresh download estimates as you transform 
your World. This is off by default so that AXEL does not calculate estimates while you work. 
Alternatively, you can use the refresh button ( ) in the Sequencer’s toolbar to calculate 
estimates when you want.

5. Turn on Show details to see the amount of data that composes each item within every 
streaming priority.
AXEL simulates downloading the stream file to the WebCam view. 
You can set different streaming priorities for your project’s items and simulate how they will 
download by previewing in AXEL.

To view the download stream in the Sequencer:
Click the Streaming button ( ) in the Sequencer.
Expand all the relevant categories. Click the refresh button ( ) to ensure that the Sequencer 
recognizes the latest changes to your project.
Items that are streamable are itemized according to their streaming priority. Groups are 
streamable, but are itemized according to their constituent items.
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To turn on streaming of geometry, textures, or sound files:
1. In the Project Manager, select the element you want to modify.

2. In the Parameter Editor, turn on Streamable. The Streamable parameter is under 
ConeGeometry for a cone, for example.

3. Select the Streaming priority.

To turn on streaming for a group:
1. In the Project Manager or viewports, select the group.

2. In the Parameter Editor, turn on streamable and select a streaming priority.
This overrides the individual streaming priorities of geometries, textures and sounds in the 
group. For example, if you turn off streamable for the group, all items in the group are 
downloaded unstreamed to a surfer’s machine, even if individual items are set to Streamable.

To adjust streaming for all items in the World:
1. In the Project Manager, expand World and click the Streamable icon.

2. In the Parameter Editor, turn on/off Streamable. With streamable enabled you can then select 
a streaming priority.
This overrides the individual streaming priorities of geometries, textures and sounds in the 
World. For example, if you turn off Streamable for the World, all items are downloaded 
unstreamed to a surfer’s machine.

Download Estimates settings

Download speed Sets the download speed used for download simulations when previewing in AXEL. 
It is as if AXEL content was transferred to a host computer via the Internet at this 
speed. Also controls the connection speed used in the Sequencer’s streaming view.

Simulation Turns on a download simulation, which will run when previewing in AXEL.
Autorefresh esti-
mates

Automatically refreshes download estimates as you transform your World.

Time to initial 
display

The time it takes for the first elements of your AXEL project to appear on the surfer’s 
computer.

Total download 
time

The time it takes for all the elements of your AXEL project to be transferred to the 
surfer’s computer.

Total size The size of the AXEL stream file (.axs) in bytes.
Show details Displays the file size, in bytes, of items in your AXEL project listed by streaming 

priority and item type.
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About antialiasing
Antialiasing removes the jaggies that you see on diagonal lines. 

Antialiasing improves the quality of your images but can slow down display rate. Antialiasing 
does not increase the weight of an object but it requires processing power to smooth the jaggies. 
If your audience is viewing your web page on a slow computer, the objects may take a little 
longer to display. If your content contains animation, the antialiasing may slow down the 
playback speed.

To turn on antialiasing for all objects: 
1. In the Project Manager, select the WebCam. 

2. In the Parameter Editor, set Antialiasing to On. 
All objects are rendered with antialiasing. 

To turn on antialiasing only for certain objects: 
1. For each object that you want antialiased, select the object and turn on Antialiasing in the 

Parameter Editor. 

2. Select the WebCam and set Antialiasing to Per object. 
Only the objects whose Antialiasing parameter is on are rendered with antialisasing. 

Hardware acceleration
Hardware acceleration uses a system’s graphic card to improve graphic performance, producing 
smoother animations and interactions. It is especially efficient when using lots of textures, and 
for creating large 3D viewports. 

AXEL uses software rendering by default, but you can choose to use the hardware acceleration 
available on your system to improve its performance as you work. As well, you can enable 

Without 
Antialiasing

With
Antialiasing



 Chapter 10 | Publishing | 595

hardware acceleration on the surfer’s computer to enhance the AXEL content that their player 
displays. 

When Hardware acceleration is turned on for published content, the player uses the graphic card 
hardware acceleration on the surfer’s computer, if it is available. When Hardware acceleration 
is off, the player does not use hardware acceleration even if it is available. 

In Windows, you can change the default behavior so that AXEL uses Hardware acceleration for 
all new projects. 

To turn on/off hardware acceleration for the current project while authoring: 
1. In the Project Manager, select Author Settings / Visualize.

2. Turn on/off Hardware acceleration in the Parameter Editor.

Note: Hardware acceleration is not available if it is not supported by your system's graphics 
card, even if it is turned on in AXEL. 

To turn on/off hardware acceleration for published content:
1. In the Project Manager, select Publish Settings.

2. Turn on/off Hardware acceleration in the Parameter Editor.

Note: Do not use hardware acceleration for published content unless the target audience of your 
web page is expected to have graphic cards with good 3D acceleration support. Hardware 
acceleration is not available on all graphic cards, and it may result in some visual differences, 
depending on the graphic card support of OpenGL. 

To know if AXEL is using hardware acceleration for the current project: 
In Windows, right-click the WebCam viewport, and choose Display > Stats or press I.
On the Macintosh, check the right corner of a viewports status bar.

SW means software rendering; HW means hardware accelerated rendering. 

To use hardware acceleration for all new projects (Windows): 
1. Right-click the AXEL shortcut icon and choose Properties.

2. Click the Shortcut tab, then in the Target field, add /hw after the quotation marks.

To force using software rendering for all projects (Windows):
1. Right-click the AXEL shortcut icon and choose Properties.

2. Click the Shortcut tab, then in the Target field, add /sw after the quotation marks.
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Clipping
Under normal circumstances, AXEL must look for and calculate anything within the WebCam’s 
viewing frustum. This can be a large amount of information. Clipping is the process through 
which AXEL calculates only a certain part of the 3D space, as defined by a clip box, thus 
improving performance. 

If you publish windowless content, for instance, a 3D car driving over HTML text, a clip box 
attached to that car enhances performance since AXEL only calculates what is inside it. 

The clip box parameters are animatable, so you can use it for wipes or other effects. You can use 
only one clip box in a World.

By adding a pose constraint between the clip box and object(s) or group, you ensure that the clip 
box moves with the object or group.

The following illustrations show Krazee Bob walking on a plane, with a clip box attached to 
him. The illustration on the left shows how, without clipping, AXEL must calculate the whole 
WebCam view. The illustration on the right shows clipping enabled, with AXEL only displaying 
the contents of the 3D clip box.

To create a clip box:
1. Choose Visualize > Add ClipBox.

The clip box appears in the Project Manager and in the viewports. By default, the clip box is 
a 1-unit cube. You can edit, animate and constrain the clip box like any other object. 

2. To show/hide the clip box, choose View > Active Viewport/All Viewports > Show/Hide 
ClipBox.

3. Translate, rotate, and scale the clip box so that it frames the portion of the World that you 
want to publish. You can manipulate the clip box the same way you manipulate a cube.

4. Adjust the clip box parameters.

5. To preview the result, click the WebCam view and choose View > Active Viewport > 
Enable Clipping.
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ClipBox Parameters

AXEL Players
To view AXEL 3D interactive content, you need the AXELplayer, QuickTime 5 or 6 with the 
AXEL QuickTime component, or the AXELplayer Standalone. 

Note: For the various export formats, you need corresponding players or browsers. For more 
information see “Exporting” on page 111.

In Windows, the AXELplayer is automatically installed on your system when you install the 
AXEL authoring software. On the Macintosh, the player comes with the authoring software and 
is easy to install. Web Surfers also need either the AXELplayer or the QuickTime AXEL 
component to view your content.

When surfers first open a web page containing AXEL content published to the AXELplayer, 
they are prompted to download the player from the MindAvenue web site. When surfers first 
open a web page containing AXEL content published to QuickTime, they are prompted to add 
the AXEL QuickTime component via Apple Computer’s web site. 

Once the AXELplayer is installed, it periodically checks the MindAvenue web site for newer 
versions and asks surfers if they want to download an updated version. Similarly, if surfers come 
across AXEL content created with a newer version of the AXELedge or AXELcore authoring 
software, they are prompted to update their player. In this case, downloading a new player is 
required to view the content.

QuickTime also checks for component updates and prompts users when new software is 
available.

Windows AXELplayer Standalone

Position The X, Y, Z position of the clip box.
Orientation The orientation of the clip box in degrees along the X, Y, and Z axis.
Scale The size of the clip box in reference to its original size.
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Besides creating AXEL projectors for Windows through the AXEL Projector’s Export settings, 
and opening AXEL Stream files (.axs) directly into the Standalone player, in Windows you can 
use a command line prompt to input your published AXEL Stream files to the AXELplayer 
Standalone. This is a useful method for playing many files on a CD-ROM for example, which 
you can combine with an auto-start for effective and quick 3D presentations or games, for 
instance.

Use the chromeless function in the Windows Standalone to make your AXEL content appear 
without a border or menu.

To open an AXEL stream file in the AXELplayer Standalone:
In the AXELplayer Standalone (AXELplayerSA_win.exe), choose File > Open, then select an 
AXEL file with the .axs extension to open.

To turn on chromeless: 
Choose View > Chromeless.

The Standalone is installed in Program Files/Common Files/MindAvenue, and 
is available from the Windows Start menu via Programs > MindAvenue.
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The AXEL content is displayed without a border. It cannot be dragged or resized.

To turn off chromeless:
Press ESC.

Borders and a menu wrap around the AXEL content. The window can be dragged and resized.

To toggle between Half Size and Normal Size: 
Choose View > Half Size (Ctrl+0) or View > Normal Size (Ctrl+1)

Chromeless AXEL content in the Standalone player shifts total focus to the interactive content and can 
fill the screen. Combine the fullscreen and chromeless settings when exporting for maximum effect.
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To manually resize content in the AXELplayer Standalone:
Drag the border of the AXELplayer Standalone. If the Player is in chromeless mode, first press 
Esc to show the borders. 

The dimensions of your AXEL content, whether set in the AXEL Stream file Publish settings/ 
AXEL Projector Export settings, or through the DOS command line, refer to the content in a 
chromeless AXELplayer Standalone. The chrome slightly squeezes the width and height of the 
content to account for borders and the menu.

To stop/start the content:
Choose Play > Stop/Start (Ctrl+P). 

When you stop content, all reactions are paused.

To restart the content:
Choose Play > Restart (Ctrl+R).

Press Ctrl+P and even particles are frozen in their tracks.
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To turn on/off looping:
Choose Play > Loop.

This overrides the loop setting from the AXEL author and the command line. 

Hardware acceleration:
Whether Hardware acceleration is enabled can only be controlled either via the Publish settings 
in the AXEL author, or from a command line, not from within the AXELplayer Standalone. 

The status of Hardware Acceleration is displayed under the View menu in the AXELplayer 
Standalone. For more information, see command line procedures below.

Limitations:
• Exported parameters and reaction triggers are not supported.

• When a Call JavaScript or Hyperlink reaction is triggered from the AXELplayer Standalone, a new 
Internet browser page loads and the JavaScript command or URL protocol is inserted into its URL 
field.

AXELplayer Standalone Menu Items

Preparing AXEL content for CD-ROM Playback 
You can use DOS commands to open .axs files in the AXELplayer Standalone with specified 
settings. You can do this with a series of .axs files dedicated for playback from a CD-ROM.

For CD-ROM playback of AXEL content, you need the following files:

• AXELplayerSA_win.exe 

Menu Options Shortcut
File Open CTRL+O

Exit CTRL+X
View Half Size CTRL+0

Normal Size CTRL+1
Loop
Chromeless (ESC to exit)
Hardware Acceleration

Play Stop/Start CTRL+P
Restart CTRL+R

Help About
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• Your published AXEL stream files (.axs)

• Optionally, a batch file (.bat) or autorun file (.inf) to input the stream files into the 
AXELplayer Standalone 

To control the AXELplayer Standalone from a DOS command line:
Type AXELplayerSA_win.exe, followed by the name of the .axs file (spaces in the filename are 
not supported from a command line) followed by each desired setting, each of which is preceded 
by a dash and followed by the value.

For example, to play "mycontent.axs" in a 640 x 480 window using hardware acceleration, type:

AXELPlayerWin mycontent.axs -width 640 -height 480 -hw on 

You can set paths for the AXELplayer Standalone and the AXEL Stream files. For example, if 
the AXELplayer Standalone is in d:\standalone, and mycontent.axs is in c:\AXEL\content, you 
would type the following:

d:\standalone\AXELplayerSA_win c:\AXEL\content\mycontent.axs -width 640 -height 480 -hw on 

Relevant Publish settings set by the AXEL author are used unless they are overridden in a 
command line. If nothing is specified for standalone-specific settings such as top and left 
positioning of the AXELplayer Standalone window, defaults are used as indicated in the syntax 
table at the end of this document.

To use an autorun file to automatically open AXEL content from a CD-ROM:
1. Use a text editor to create an autorun file:

c) Name the file autorun.inf
d) Use the following syntax in the file:

[ autorun ]

OPEN = AXELplayerSA_win.exe mycontent.axs 

You use the same syntax in the autorun file as you would if you were manually inputting .axs 
files into the AXELplayer Standalone. For example, if you want "mycontent.axs” to open 
automatically when you insert a CD-ROM, in chromeless mode with a fullscreen, and using 
hardware acceleration, your autorun.inf text file would read:

[ autorun ]

OPEN = AXELPlayerWin.exe mycontent.axs -fullscreen on -chrome off -hw on

2. Place the autorun.inf  file, along with AXELplayerSA_win.exe and the .axs stream files in 
the root directory of the CD-ROM.

When you insert the CD-ROM into a machine, the AXEL content opens automatically with the 
settings you specified in the autorun file. 
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Note: This autorun code and procedure was tested on Windows 2000 and Windows 98. For other 
Windows operating systems, see Microsoft's autorun documentation at:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/Shell/
programmersguide/shell_basics/shell_basics_extending/autorun/autoplay_intro.asp

The AXELplayer Standalone supports the following command-line syntax:

Macintosh AXELplayer Standalone

Besides creating AXEL projectors for Macintosh through the AXEL Projector’s Export settings, 
and opening AXEL Stream files (.axs) directly into the Standalone player, on Macintosh you can 
use AppleScript to input your stream files to the AXELplayer Standalone. This is a useful 
method for playing many files on a CD-ROM for example, for effective and quick 3D 
presentations or games, for instance.

The AXELplayer Standalone for the Macintosh takes advantage of the latest Mac OS 
technology for speedy and crisp playback. 

AXELplayerSA_win.ex
e [<filename>.axs]

Loads file

-help Shows usage information
-fullscreen [on|off] Sets fullscreen mode on or off (default is off)
-hw [on|off] Sets hardware acceleration on or off (default is off)
-chrome [on|off] Sets window chrome on or off (default is on)
-loop [on|off] Sets looping on or off (default is taken from <filename>.axs)
-left <x> Sets left position of window (if not given, system default is used)
-top <y> Sets top position of window (if not given, system default is used)
-width <w> Sets width of window (if not given, system default is used)
-height <h> Sets height of window (if not given, system default is used)

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/Shell/programmersguide/shell_basics/shell_basics_extending/autorun/autoplay_intro.asp
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To open an AXEL stream file in the AXELplayer Standalone:
In the AXELplayer Standalone, choose File > Open, then select an AXEL Stream file.

To manually resize content in the AXELplayer Standalone:

Drag the size box at the lower right corner of the AXELplayer Standalone. For OS X, the size 
box is not visible, so just drag from the lower right corner of the content.

To stop/start the content:
Choose Play > Stop/Start (COMMAND+S/COMMAND+P). 

© Copyright FCMM 2002
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When you stop content, all reactions are paused.

To restart the content:
Choose Play > Restart (Command+R).

To turn on/off looping:
Choose Play > Loop.

This overrides the loop setting from the AXEL author and any script you use.

© Copyright FCMM 2002
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To Zoom the AXELplayer Standalone window:
Choose Window > Zoom Window.

This toggles between the window's default size and fullscreen.

Hardware acceleration:
Hardware acceleration is on by default and can only be disabled from a command line, not from 
within the AXELplayer Standalone. For almost all cases, Hardware acceleration works well on 
Macintosh-this is why it is on by default regardless of your Publish Settings in AXEL.

For more information, see Sample AppleScript for the AXELplayer Standalone, below.

Current Limitations
• Exported parameters, reaction triggers, and Call JavaScript reactions, are not supported.

• When a Hyperlink reaction is triggered from the AXELplayer Standalone, a new Internet browser 
page loads and the URL protocol is inserted into its URL field. 

AXELplayer Standalone Controls Summary

Menu Options Shortcut
AXELplayer 
(OS X)

Quit (OS X) Command+Q

File Open Command+O
Close Command+W

© Copyright FCMM 2002
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Using AppleScript to Control the AXELplayer
You can use AppleScript to control the AXELplayer. Use AppleScript to input files, control the 
settings your Stream files open with, arrange multiple AXELplayer Standalone windows, etc.

SampleAppleScript commands for the AXELplayer Standalone:
tell application "AXELplayer"

run with properties {acceleration:true, zoomed:true, name:"superaxel"}
-- that's how to override options for embedded content.
-- If there's no embedded content, the run command will return an error
(use open file instead).

reopen
-- if there is embedded content and all windows have been closed, the
embedded content will be reopened. Also brings the app to the front.

open file "Tesla:Desktop Folder:AXS files:AXELMobile.axs" with
properties {acceleration:true, zoomed:true, name:"superaxel"}
-- that's how to open a file and set options

set looping of window 1 to true
set zoomed of window 1 to false
set playing of window named "superaxel" to false
-- examples of changing properties on the fly.
-- each window has a number: its current layering position (1 frontmost)
-- window can be referred to by name: window named "superaxel"

properties of window 1
-- list of all properties of a window

close window named "AXELMobile.axs"
-- close a window by name

close window 1
-- close a window by number

set wins to every window
repeat with win in wins
if ID of win is not 2 then
close win
end if

Quit (OS 9) Command+Q
Play Stop/Start Command+P

Restart Command+R
Loop

Window Zoom Window
Collapse/Minimize Win-
dow

Command+M

Arrange in Front/Bring All 
to Front
(List of open files)
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end repeat
-- example of looping over windows to examine a property and take an action

quit
-- quit the application, closing all windows
end tell

Projector files in the AXELplayer Standalone
When you export AXEL Projector files, you create an executable (in Windows .exe ) combining 
your content with the AXELplayer Standalone that does not need a browser, nor any other 
application to run. You can also open up regular .axs stream files in the AXELplayer Standalone.

There are separate AXELplayer Standalones for Windows and Macintosh, although they both 
play .axs content generated from both Windows and Macintosh versions of AXEL, and you can 
create Windows and Mac Projectors on each platform as well. 

AXELplayer Standalones for both Windows and Macintosh are installed on your system when 
you install AXELcore or AXELedge.

Depending on the nature of your project, you may either want to use an AXEL Projector file, for 
example if you have only a single AXEL project to showcase from a CD-ROM, or the 
AXELplayer Standalone in conjunction with many .axs files that you input via a DOS command 
line (Windows) or via AppleScript (Macintosh).

You can open regular .axs stream files in the AXELplayer Standalone with their interactive 
capabilities intact. The AXEL Publish settings, for example, Width and Height, determine how 
the files are displayed in the AXELplayer Standalone. Publish settings are accessed in the AXEL 
author's Project Manager. After publishing .axs files, settings can be changed either before you 
load the .axs file in a command line, or, for certain settings, within the AXELplayer Standalone 
itself. 

When you publish AXEL Projector files, however, you cannot use a command line to open up 
the file so therefore, you must set the AXEL Projector Export settings beforehand in the AXEL 
author. Once the Projector file is open in an AXELplayer Standalone, the user has the same 
control as if a regular .axs file was opened in the AXELplayer Standalone, as explained below.

AXEL and QuickTime
Publishing an AXEL QuickTime movie creates a .mov file that plays in QuickTime 5 or 6 with 
the (freely downloadable) QuickTime AXEL component. This interactive .mov includes all of 
AXEL’s interactive abilities, similar to an .axs file, only dedicated for playback in QuickTime. 
Once in the QuickTime format, you can combine your AXEL tracks with other AXEL tracks or 
QuickTime media for even more dynamic and interactive possibilities.
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You can also play .axs files directly that were published as AXEL Streams in the QuickTime 5 
or 6 player, with all AXEL interactive capabilities intact. 

The first time a Web Surfer comes across AXEL content published to QuickTime they are 
prompted to add additional software to their QuickTime 5 or 6 player, just like any other 
QuickTime component; and after the short download the AXEL content will play right in their 
QuickTime player. 

For information on how to publish your to AXEL QuickTime movies, see “Publishing AXEL 
QuickTime Movies” on page 563.

You can also export linear QuickTime movies in the QuickTime JPEG or PNG format, which 
only exports time contingent animation, such as animations linked to the TimeSensor, or 
triggered by a Proximity sensor. For more information, see “Exporting linear Movies” on page 
130.

Note: Currently, the AXEL QuickTime Component is available for Mac OS X and Windows.

To install the AXEL QuickTime component:
1. Open a page containing content published to QuickTime from AXEL.

A dialog prompts you to download additional QuickTime software, "AXEL."

2. Click Do It Now as the dialog requests. 
The AXEL QuickTime Component is added to your QuickTime 5 or 6 player via Apple's web 
site. You will need to refresh your browser page to view the content correctly.

Note: If QuickTime 5 or 6 is not installed on your system you are also taken through this process. 

To open up an .axs file in QuickTime:
1. Once the AXEL QuickTime Component is installed (see above) in the QuickTime 5 or 6 

Player, choose File > Open Movie in New Player, then select an .axs file.
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2. Click Convert (Windows) or Open (Macintosh).

How AXEL’s relates to other tracks in QuickTime
 With the advent of the QuickTime AXEL component, AXEL QuickTime Movies and AXEL 
stream files are now recognized by many QuickTime (or compatible) authoring programs. 
Therefore, you can now combine your interactive AXEL content with other media types, such 
as MPEG-4 video, audio tracks that stream in from a remote location, image masks, etc.

For this, the time of AXEL tracks becomes a consideration, as it does not map precisely onto 
some other linear tracks that you might combine with AXEL. For example, when you open up 
an AXEL track (.axs) file in QuickTime Pro, it has a duration of just 1/20th of a second. This 
does not pose a problem if you are combining your .axs file with a picture that is discrete in time.  
You would just copy both contents and paste them into a QuickTime movie using the Edit > 
Add Scaled command in QuickTime Pro.  

However, while combining audio tracks, movies or Flash tracks that have a duration is also 
easily done, there is a slightly different process—similar to combining QuickTime VR tracks 
which like AXEL, are not linear, with other more traditional time-based QuickTime elements. 

This process, then, is to always make sure that the tracks with the appropriate duration, whether 
a sound or a linear movie, are always the base tracks that you add AXEL tracks to, again using 
the Edit > Add Scaled command.

The following example illustrates a typical procedure for this.
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Example: Adding multiple AXEL tracks to a Flash track in QuickTime Pro:
1. In QuickTime Pro, open up a Flash track that has a duration.

2. Again in QT Pro, open up a new player with  an .axs stream file.

3. Click in the QuickTime window that contains the .axs stream and choose Edit > Copy.

4. Click in the QuickTime window with the Flash file and choose Edit > Add Scaled.

5. The AXEL content is pasted on top of and in front of the Flash track. It is also scaled in time 
to match the time of the Flash track.

6. Now, through QuickTime Pro's Movie Properties dialog you can rearrange the layer order, 
resize the individual track windows, and use other QuickTime Pro functions.

AXEL in QuickTime Pro and other QuickTime software
With the AXEL QuickTime component your .axs files are recognized as QuickTime files and 
open up in most software that read the QuickTime format.

Flash track

AXEL tracks
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A couple of examples of what you can do with AXEL tracks in QuickTime Pro:

Two AXEL tracks side-by-side in a single movie. Both play and function independently.

An interactive AXEL file playing in 
a skinned QuickTime Player.

An image mask over an AXEL track. 
You can only drag the cube when your 
cursor is not blocked by the mask.
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AXEL object <tag> code reference
The following AXEL object code is generated automatically when you publish a stream file 
using the Publish > Generate AXEL Stream, destined for the AXELplayer. 

Notice, the same information is presented in two tags:

• In HTML 4.0 for Internet Explorer on Windows, an Object tag is used. See “Object tag reference” on 
page 614.

• For Netscape and for Internet Explorer on Macintosh, an Embed tag is used. See “Embed tag 
reference” on page 615.

Tip: There may be some occasions when, after previewing in different browsers, you decide to 
publish separate AXEL stream files optimized for each browser, Internet Explorer and Netscape. 
In this case, you just manually type the name of the .axs stream file dedicated for Internet Explorer 
in the Object tag, and similarly include the name of the .axs stream file dedicated for Netscape in 
the Embed tag.

<!-- Begin AXEL object -->

<object id="Fish_stream" classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A"
    codebase="http://www.mindavenue.com/Downloads/AXELplayerAX_Win32.cab#version=1,0,793,0"
    style="position:absolute; left:5; top:100; z-index:1; filter:alpha(opacity=100)"
    width="700" height="500">
   <param name="Src" value="Fish_stream.axs">

<param name="Windowless" value="1">
   <embed src="Fish_stream.axs" name="Fish_stream"
       plug-inspage="http://www.mindavenue.com/Downloads/AXELplayerNPInstall.htm"
       type="application/x-MindAvenueAxelStream"
       style="position:absolute; left:5; top:100; z-index:1;"
       width=700 height=500 Windowless=true>
   </embed>
</object>

<!-- End AXEL object -->
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Object tag reference
The Object tag is used by Internet Explorer on Windows to identify the AXEL object.

Attributes:
id: name used to locate the object in the HTML file. It must be unique in the file. The JavaScript 
created when you export parameters uses this name to find the object.

classid: tells the browser what registered application to use to process the object. This is a 
universally unique identifier for the AXEL player.

codebase: tells the browser to download the AXEL player from the MindAvenue web site if it 
cannot find it on the system.

style: this is the in-line Cascading Style Sheet (CSS). The properties are:

• position: affects the Top and Left properties. Position can be Absolute or Relative.

• top: distance from the top in pixels or percentage.

• left: distance from the left of the page in pixels or percentage.

• z-index: determines the layering order of the object. Increasing the index values brings the 
object to the front of other layers. 

• filter: creates transparency and shadows. You can use other DHTML filter functions in this 
tag.

width: the width of the AXEL window in pixels or percentage.

height: the height of the AXEL window in pixels or percentage.

param defines parameters used by the object: 

• The src parameter has a value giving the AXEL stream file name. 

• The windowless parameter has a value of 1 if the content is windowless, or 0 if the content 
is not windowless.
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Embed tag reference
The Embed tag is used by Netscape and Internet Explorer on Macintosh to identify the AXEL 
object.

Attributes
src: AXEL stream file name.

name: unique name used by JavaScript to find the object inside the HTML file.

plug-inspage: if the browser cannot find the AXEL player on the system, it links to the 
MindAvenue Downloads page where the player can be found.

type: tells the browser what type of data the object contains, using a MIME (Multimedia Internet 
Mail Extensions) type. This allows the browser to select the AXEL player plug-in.

style: the in-line CSS. Its properties are:

• position: affects the Top and Left properties. Position can be Absolute or Relative.

• left: distance from the left of the page in pixels or percentage.

• top: distance from the top in pixels or percentage.

• z-index: determines the layering order of the object; this property is not supported inside 
the embed tag in Netscape.

width: the width of the AXEL window in pixels or percentage.

height: the height of the AXEL window in pixels or percentage.

windowless: displays the content on a transparent overlay. The value is True or False.

QuickTime tag reference
Object: Works with Internet Explorer 4 and later on Windows.

Class ID: specifies the QuickTime ActiveX control.

Codebase: Tells Explorer where to find the ActiveX control if it is not installed.

Param with name=“src”: Has the URL of your AXEL file as its value.

Embed: Works with all other Windows browsers and all Mac browsers including Internet 
Explorer for Mac.

SRC: is set to a file whose MIME type is used exclusively by QuickTime, such as .qtif (image/
x-quicktime). This file must exist and is downloaded by the browser, but it is not displayed. The 
browser uses the QuickTime plug-in to handle any file of this mime type.
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plug-inSPAGE: tells the browser where to find the QuickTime plug-in if it is not installed. 

QTRSRC: holds the url of your AXEL .axs or .mov file, and this is what QuickTime plays.
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Index

Symbols
.axel files

batch saving (Windows) 558
saving 556

.axs files
generating 556

.png textures 331

Numerics
1-bone limbs 231
2-bone limbs 234
2D Position parameter, text layers 252
3D content

adding to an existing web page 571
download time 593
importing 3ds max 109
importing VRML 103
modifying in a web page 573
modifying in AXELedge 572
previewing in a host web page 

(Windows) 569
previewing in a web browser 569
publishing 559
uploading to the web 583
viewing with AXEL player 603

3D space, overview 152
3D window height, Publish settings 561
3D window in web page

publishing windowless content 584

sizing 576
3D window width, Publish settings 561
3ds max, importing through 

AXELpublisher 109

A
Absolute positioning, Publish settings 561
Active parameter

bends 227
constraints 274
particles 404
texture projectors 336
waves 410

Add Animation Sequence command 376
Add Ball Joint command 293
Add Clip Box command 602
Add Color Material commands 303
Add Curve commands

Arc 187
Circle 187
Rectangle 185

Add Cylindrical Projector command 335
Add Image Texture command 320
Add Light command 344
Add Limb command

1 Bone 231
2 Bones 234

Add Movie Texture command 321
Add Particles command 401
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Add Pin Joint command 290
Add Planar Projector command 335
Add Point command 195
Add Slider Joint command 295
Add Snap command 282
Add Spring command 285
Add Surface command 205
Add Text Layer command 250
Add to Group command 259
Add WebCam command 350
Additive parameter

animation 387
Set Orientation reaction 440
Set Parameter reaction 449
Set Position reaction 437
Set Scale reaction 444

Advanced Color Models, materials 313
Aligning 67
All at once parameter, Group reactions 514
Alpha (Opacity)

Publish settings 561
See also Image format parameter

alpha, transparency in .png images 331
Ambient Color parameter

Advanced Color Models 313
lights 345

Angle limit, example for a skeleton 236
Angle parameter

Bend reaction 500
bends 227
curves 184
revolutions 212

Animate on Path command 408
animation

adding keys 394
additive animation 397
animating parameters 376
animation tools 45
changing speed 388
copying keys 395
creating particles 401
creating path animation 408
creating waves 410
curve editor 371
deleting animation sequence 395
deleting keys 395
duplicating through import 100
editing keys 392
editing parameters 385
framing 369

introduction 26
looping 366
moving between keys 366
offsetting 372
parameters 386
playback tools 43
previewing 366
recording 376
scrubbing 370
selecting 383
Sequencer, using 367
shape,animating geometry 411
stopping the clock 464
viewing interactions 368
viewing stream properties 368, 593

Animation cylcing, Movie Export settings 135
Anti-aliasing parameter

curves 183
surfaces 202
text 248
WebCams 600

AppleScript
using with AXELplayer Standalone 613

AppleScript menu (Macintosh) 88
arc, adding 187
Author mode 43, 55
auto-keyframing, see animating 

parameters 376
Autorefresh Estimates setting, Download 

Estimates 598
Avatar height, VRML Export settings 149
Avatar knee height, VRML Export 

settings 149
Avatar radius, VRML Export settings 149
Avatar speed, VRML Export settings 149
AXEL player 603
AXELedge content

object code reference 620
previewing in web browser 569

AXEL-generated HTML code
Embed tag 622
Object tag 621

AXELplayer Standalone
publishing projectors 562

AXELpublisher 109
axes

changing orientation of object 173
global/local 152
manipulating in global 167
manipulating in local 167
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rotating in local 172
scaling along 175
translating in local 170

Axis parameter
ball joint constraints 294
Bend reaction 500
bends 227
pin joint constraints 292
slider joint constraints 296

B
Background color parameter

Tooltip text reaction 454
WebCams 350

backups, creating 98
Ball joint home angles parameter

limb 1 232
limb 2 234

ball joints 293
batch saving 558
Bend handle 500
Bend range parameter

Bend reaction 500
bends 227

Bend speed out parameter
Bend reaction 500

Bend speed parameter
Bend reaction 500

Bend Surface command 226
blending texture and material 329
BMP, texture formats 339
Browser sensor 459
browsers

previewing in 569
windowless content in 588

C
Call JavaScript reaction 462
camera, see WebCams
capping

cylinders 208
extrusions 215
revolutions 212

Cartoon rendering style, materials 308
CD-ROM playback

on Macintosh 613
on Windows 607

CD-ROM Playback, AXELplayer Standalone 
for Windows 607, 613

center

moving, groups 259
moving, objects 173
selecting 163

Chromeless
Windows AXELplayer Standalone 

setting 605
Chromeless (Windows)

AXEL Projector Export setting 563
circle, adding 187
classid, object tag attribute 621
clicking objects to launch reactions 474
clip boxes 602

displaying 54
enabling 54

Closed parameter
curves 184

closing
curves 184, 198
projects 96
surfaces see, capping

codebase, object tag attribute 621
collision detection

and Bounding box constraint 289
color

adding 303
background in viewports 60
blending with texture 329
changing 314
editing on selected points and faces 316
introduction 24

Color limit, Flash Export settings 127
Color parameter

Advanced Color Models 313
cartoon materials 312
lights 345
shaded materials 310
wireframe 312

Color usage per object, Flash Export 
settings 127

Coloring parameter
surfaces 203
text 248, 252

common surface parameters 202
cones, adding 205
Confirm file overwrite, Publish settings 561
connecting sensors and reactions 504
Constrain Direction command 277

and the WebCursor 272
Constrain Distance command 275
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Constrain Orientation parameter, pose 
constraints 274

Constrain Pose command 274
Constrain Position parameter, pose 

constraints 274
Constrain Scale parameter, pose 

constraints 274
Constrain to Bounding Box command 287
Constrain to Bounding Sphere command 289
Constrain to Curve command 279
Constrained Axis parameter, ball joint 

constraints 294
Constrained Direction parameter, direction 

constraints 278
Constrained Position parameter, snap 

constraints 283
Constraint axis parameter

pin joint constraints 292
slider joint constraints 296

constraints
adding to groups 261
adding to objects 265
adjusting offset 268
and centers 262
ball joint 293
bounding box 287
bounding sphere 289
curve 279
direction 277
displaying 53
distance 275
duplicating though import 100
follower 23
introduction 21
leader 23
locking 270
pin joints 290
pose 274
showing 267
slider joint 295
snap 282
spring 285
unlocking 268

construction views 47
Contact radius parameter, Push reaction 499
Contact radius setting, surface pushing 228
context menu

Host Web Page in preview mode 62
when previewing in AXEL 55

Control Time Reaction 464

coordinate systems 152
copying

keys 395
parameters 68
objects, see Duplicate command

Crease angle parameter
surfaces 203
text 248

Crease control parameter
surfaces 203
text 248

Critical orientation parameter, orientation 
sensor 480

CriticalPos parameter, Position sensors 479
cubes, adding 205
cursor

constraining objects to 272
types in published content 476

Cursor depth factor parameter, direction 
constraints 278

cursor, changing sensor cursor 475
curve editor, in animation 371
curves

adding points 195
closing 198
common parameters 183
converting from text 253
creating a rectangle 185
creating an arc or circle 187
creating surfaces from 209
deleting points 195
drawing 188
Extrusion along Curve 216
Extrusion from Curve 214
importing EPS files 103
in path animation 408
increasing/decreasing steps 196
inverting 199
moving points 195
rationalizing position 200
rationalizing scale 200
Revolution from Curve 210
simplifying 197
sketching 191
smoothness 194
subdividing 196

Custom command
relations 297
sensors 490

custom reactions 466
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Custom Wireframe rendering style, 
materials 309

cut and paste, see Duplicate command
cylinders, adding 205

D
default material 314
Deform depth setting, surface pushing 228
Deform radius setting, surface pushing 228
Deformation radius parameter, Push 

reaction 499
depth

Z axis 152
Depth parameter, cubes 206
DHTML 621
Direction parameter, distance constraints 278
Disable Wireframe command 58
displaying

animation curves in Timeline 371
grid 56
toolbars 45
windows 39

Distance parameter, distance constraints 276
Distance sampling setting, curves 192
Distance tolerance parameter, spring 

constraints 281
download

estimates, settings 598
estimates, viewing 597
time 593

Download AXEL stream reaction 457
Download sensor 487
Download Speed setting, Download 

Estimates 598
dragging in 3D content see handles
Draw Curve command 188
Draw Surface command 209
Drop shadow, Publish settings 561
drop shadows, creating for windowless 

content 587
Duplicate command 180, 260
Duplicating

animations, constraints, interactions 101
Duration parameter

movie textures 325
dynamic, see spring constraint

E
Edit Background Color, viewports 54
Edit Point Color command 316

embed tag, in AXEL-generated HTML 
code 622

embedding fonts, see Publish outline parameter
Emission Rate parameter, particles 404
Enable Angle Limits parameter, pin joint 

constraints 292
Enable Clipping command 602
Enable Clipping, viewports 54
Enable Joint Limits parameter, ball joint 

constraints 294
Enable selection only

Flash Export settings 125
Enable slider limits parameter, slider joint 

constraints 296
Enable Snap to Grid command 57
Enable tangency parameter, spring 

constraints 281
Enable Wireframe command 54, 58
End Capping

cylinders 208
extrusions 215
revolutions 212

End parameter, Time Pulse sensors 486
End time

Movie Export settings 134
End time, Flash Export settings 124
environment map, creating 338
Environment mapping setting, textures 328
EPS,importing 103
Examine, VRML Export settings 149
Expiry count parameter, links 505
Export

images 129
VRML files 140

Export interaction, VRML Export settings 149
Export invisible objects, VRML Export 

settings 149
Export mode

Flash Export settings 124
Image Export settings 131
Movie Export settings 134

Export Parameter command 579
Export Reaction Trigger command 582
export settings

Movie 134
Export time, Image Export settings 131
Exporting

Flash movies (.swf) 116
exporting

introduction 34
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overview 112
Extrapolation parameter, animation 387
Extrude parameter, text 249
Extrusion along Curve command 216
Extrusion depth parameter, text 249
Extrusion from Curve command 214

F
faces, subdividing 221
Fall-off distance parameter, lights 345
Fall-off parameter, lights 345
Far plane distance parameter, WebCams 351
Field of View parameter, WebCam 353
File parameter

image textures 320
movie textures 325

Filtering parameter, textures 328
Flash

AXEL content and 118
export techniques and visuals 118
exporting Flash movies (.swf) 116

Fly, VRML Export settings 149
Font parameters, text 248, 252
fonts, embeddingsee Publish outline parameter
Format

image Export settings 131
Movie Export settings 135

formats supported
3ds max, importing 109
EPS, importing 103
movie 320
sounds 428
textures 339
VRML, importing 103

forward kinematics 230
Frame rate

Flash Export settings 124
Movie Export settings 134

framing
animation 369
viewports 53
WebCams 357

Free joint angle parameter
ball joint constraints 294
pin joint constraints 292

Free position parameter, spring constraints 281
Frequency parameter, Time Pulse sensors 486
Frozen parameter

curves 183, 184
surfaces 203

text 248
Fullscreen

AXEL Projector Export setting 563

G
Generate stream, Publish settings 561
Generate Web Content command 559
Generate webpage, Publish settings 561
Geometry constrained parameter

bounding box constraints 288
bounding sphere constraints 290

GIF, texture formats 339
global/local axes 152
Glow Color parameter, Advanced Color 

Models 313
Glow parameter

cartoon materials 312
shaded materials 310

Go To Home State command, limbs 241
Go to Time reaction 463
graphics cards, using 600
Gravity parameter, particles 405
grid, displaying 56
Group command 257
groups

adding and removing objects 259
adding constraints 261, 265
creating 257
duplicating 260
manipulating 259
moving the center 259
reactions 512
renaming 258
selecting 162, 258
selecting in viewports 258
selecting objects in 258
showing/hiding 168, 259
ungrouping 259

H
handles 492
hardware acceleration 600
Hardware acceleration, Publish settings 561
Headlight, VRML Export settings 149
Height parameter

cones 207
cubes 206
curves 183
cylinders 208
waves 410

hiding
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clip boxes 54
constraints 53
grid 54
groups 168, 259
host web page 61, 570
objects 168
stats 53
toolbars 45
WebCams 358
windows 39

Highlight Color parameter, Advanced Color 
Models 313

Highlight parameter, lights 345
Home State mode, limbs 241
Horizontal subdivisions parameter, 

cylinders 208
Horizontal tiling setting, textures 328
host web page

displaying 61, 570
previewing in 569

Host webpage file, Publish settings 561
hotkeys, editing (Macintosh) 74
Hyperlink reaction 454

I
id, object tag attribute 621
Image format parameter

image textures 320
image textures

adding 320
supported formats 339

Image width and height parameter, image 
textures 320

Images
export 129

Import AXEL project command 101
importing

3ds max 109
EPS files 103
VRML 103

Inside parameter
bounding box constraints 288
bounding sphere constraints 289

Instance command 180
Intensity parameter, lights 345
Interaction Editor

filtering display 420
using 417

Interaction view, Sequencer 368
interactions

controlling reactions 510
creating handles 492
creating reactions 425
creating sensors and triggers 467
custom sensors 490
introduction 29

interactive, making objects 474
Interest distance parameter, WebCams 351
Interlacing

image Export settings 131
Interpolation parameter

animation 386
inverse kinematics 230
Invert command

curves 199
surfaces 223

Invert joints parameter, Translate reaction 494

J
Joint Angle parameter

ball joint constraints 294
pin joint constraints 292

JPEG, texture formats 339

K
Keyboard sensor 488
Keyboard Shortcuts editor (Macintosh) 74
keyframing, see animating parameters 376
keys

adding, removing, copying 395
dragging in the curve editor 371
editing 392
moving between 366

Keys parameter, animation 388
kinematics 230

L
Layering parameter, text 252
layers

text 250
layers, see Z-index
Left

AXEL Projector Export setting 563
left 47
Left position, Publish settings 561
Length parameter

extrusions 215
waves 410

lights
adding 344
fall-off 346
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overview 340
show/hide 345
turning on/off 345

LightWave,importing 104
limbs

adding 1 bone 231
adding 2 bones 234
going to home state 241
parameters, 2 limbs 234
parameters, limb 1 232
setting home state 241
working with 235

Limit parameter, Proximity sensors 478
Line color parameter. cartoon materials 312
Line placement parameter, cartoon 

materials 312
Line width parameter

cartoon materials 312
wireframe 313

lines see curves
Link Material command 304
Link Particle Obstacle command 406
Link Reaction command 419
Link Texture command 326
linking

material to objects 304
sensors, triggers and reactions 417
textures to objects and materials 326

Links
colors and styles for visual cues 507

links
editing 504
parameters 419
unlinking 420

Local parameter
Set Orientation reaction 440
Set Position reaction 437

local/global axes 152
locking constraints 270
look 47
Loop parameter

Play Movie reaction 325
Play Sound reaction 430

loop playback 366

M
Mac file

AXEL Projector Export setting 563
manipulating

groups 259

objects 166
manipulation

introduction 16
manipulation tools 44
material

adding 303
applying an Advanced Color Model 313
blending with texture 329
changing color 314
changing rendering style 307
changing the default material 314
coloring selected points and faces 316
introduction 24
linking to objects 304
linking to textures 326
parameters 310
removing 304
renaming 305
selecting 305
See also textures

Max parameter, Parameter Range sensors 483
Maximum Age parameter, particles 404
Maximum Angle parameter

Bend reaction 500
bends 227
pin joint constraints 292

Maximum limit angle parameter, ball joint 
constraints 294

Maximum position limit parameter, slider joint 
constraints 296

Maximum speed parameter, particles 404
menus

AppleScript (Macintosh) 88
AXELedge (Macintosh OSX) 77
Visualize 83

Merge parameter, Download AXEL Stream 
reaction 458

merging projects, see Import AXEL Project 
command 101

MIDI, sound formats 428
Min parameter, Parameter Range sensors 483
Minimum age parameter, particles 404
Minimum angle parameter, Bend reaction 500
Minimum Angle parameter, bends 227
Minimum angle parameter, pin joint 

constraints 292
Minimum Position Limit parameter, slider joint 

constraints 296
Minimum Speed parameter, particles 404
Mix Shape command 225
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Mix with other parameter
Orbit WebCam reaction 501
Rotate reaction 496
Rotate WebCam reaction 502
Scale reaction 496
Translate reaction 494
Translate WebCam reaction 502
Zoom WebCam reaction 503

Mixing weight parameter
Orbit WebCam reaction 501
Rotate reaction 496
Rotate WebCam reaction 502
Scale reaction 496
Translate reaction 494
Translate WebCam reaction 502
Zoom WebCam reaction 503

Mode parameter
limb 1 232
limb 2 234

modeling
introduction 16

modeling tools
manipulation 44
selection 44

Modifier key parameter, links 505
morphing 225
Mouse sensor 474
Movie

export Linear (QuickTime,Animated 
GIF,MPEG-4) 132

movie textures
adding 321
playing from a remote location 323

Movie width and height parameter, movie 
textures 325

moving
objects, see Translate tool
WebCams 356

MP3 sound formats 428
MPEG/MPG sound formats 428
MPEG-4

exporting 132
Multiple-parameter selecting 67

N
Near plane distance parameter, WebCams 351
Near plane height parameter, WebCams 351
Non keyable parameter

animation 386
nudge 167

Number of cycles, Movie Export settings 135
Number of frames

Flash Export settings 124
Movie Export settings 134

Number of points parameter
curves 183
surfaces 202
text 248

O
Object tag, AXEL-generated HTML code 621
objects

adding color 303
attaching to a WebCam 356
bending 226
changing color 314
changing rotation center 173
constraining 265
duplicating 180
importing AXEL projects 101
importing in 3ds max format 109
importing in EPS format 103
importing in VRML format 103
instancing 180
making them interactive 425, 474
manipulating 166
mixing shapes 225
parameters, copying 68
renaming 64
rotating 172
scaling 174
selecting 160
selecting in a group 258
showing/hiding 168
translating 170
weight 155
 See also curves, lights, surfaces, text and 

WebCams
obstacles

adding to particles 406
removing from particles 407

offset
animation 372

Open in new window parameter
Hyperlink reaction 455

opening
Apple Scripts 88
projects 96

Optimize file size, Flash Export settings 128
Orbit WebCam handle 500
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orbiting
in viewports 49
in WebCam view 355

Orientation offset parameter
pose constraints 274

Orientation parameter
ball joint constraints 294
clip boxes 603
curves 183
lights 345
surfaces 202
text 248
texture projectors 336
textures 328
WebCams 350

Orientation sensor 480
Origin parameter

Bend reaction 500
revolutions 212

Origin, Bend parameter 227
Orthogonal projection parameter

WebCams 351
orthogonal views 47
overhead 47
Override other parameter

Orbit WebCam reaction 501
Rotate reaction 495
Rotate WebCam reaction 502
Scale reaction 496
Translate reaction 494
Translate WebCam reaction 502
Zoom WebCam reaction 503

P
Pan parameter

Play Sound reaction 430
panning

in viewports 49
in WebCam view 355

param, object tag attribute 621
Parameter Change sensor 482
Parameter Editor, using 65
Parameter Range sensor 483
parameters

animating 376
animating multiple 379
copying 68
editing 65
exporting 579

parent, see groups and constraints

Particle Shape parameter, particles 405
Particle Size parameter, particles 404
particles

adding obstacles to 406
creating and using 401
parameters 404
removing obstacles from 407

path animation
creating 408
modifying 409

PC file
AXEL Projector Export setting 563

Percentage setting, simplifying surfaces 221
perspective 47
Pin joint home angles parameter, limb 2 234
pin joints 290
planar texture mapping 334
planes, adding 205
Play Animation reaction 427
Play Movie reaction 430
Play Sound reaction 428
playback tools 43
player, viewing AXEL content on the web 603
playhead

navigating the Sequencer 365
scrubbing 370

point
colors for published content 316

point of view 47
Point positions parameter

curves 183
surfaces 202

points
adjusting spacing of points 192
color 316
colors for visual cues 163
described 155
editing on curves 195
first and last on curve 163
manipulating multiple 219
selecting 162
shape animation 411

polygons 9
polygons, see surfaces 209
Position Offset parameter, pose constraints 274
Position on slider parameter, slider joint 

constraints 296
Position parameter

ball joint constraints 294
clip boxes 603



 Index | 665

curves 183
lights 345
pin joint constraints 292
slider joint constraints 296
spring constraints 281
surfaces 202
text 248
texture projectors 336
textures 328
WebCams 350

Position sensor 479
Position type parameter, curve constraints 281
pov 47
Precision parameter, text 249
Preserve scale volume parameter, Scale 

reaction 496
preset surfaces 10
Preview in AXEL command 55, 366
Preview In commands 569
Preview mode tool 43
previewing

context menu 55
export dialog 115
exported files 115
in a host web page (Windows) 569
in a web browser 569

primitives 10
primitives, see surfaces
project directory 96
Project Manager, using 63
Projected parameter, text 252
Projector

bundling AXELplayer Standalone 614
CD-ROM playback on Macintosh 613
CD-ROM playback on Windows 607, 613
Macintosh AXELplayer Standalone 609
overview 562
Windows AXELplayer Standalone 604

projects
backups 98
directory 96
importing 101
moving 97
opening, saving and closing 96
saving automatically (Macintosh) 99

Protect from import, Flash Export settings 129
Proximity sensor 476
Publish as URL parameter, movie textures 325
Publish outline parameter, text 249
Publish Settings 559, 560

publishing
introduction 34

Pulse Skipping parameter, Time Pulse 
sensors 486

Push depth parameter, Push reaction 499
Push handle 498
Push speed In parameter, Push reaction 499
Push speed out parameter, Push reaction 499
Push Surface command 228
Push Surface settings 228

Q
Quality

Movie Export settings 135
Quality, Image Export settings 131
QuickTime

exporting linear 132
QuickTime, movie textures 320

R
Radius parameter

curves 184
spheres 205

Rationalize Pose command
curves 200
surfaces 223

Rationalize Scale command
curves 200
surfaces 223

rationalizing textures 332
reactions

changing the sensor cursor 475
controlling 510
creating 425
custom 466
displaying in Sequence Editor 422
editing triggers 417
editing, Play Animation 422
exporting triggers 582
grouping 512
previewing 425
removing 418

rectangle, adding 185
Refresh Rate sensor 488
Relative to Group parameter, animation 388
Remove from Group command 259
renaming objects 64
Rendering Style parameter, WebCams 350
Repeat delay parameter, links 505
repeating animation playback 366
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Replace parameter, Download AXEL Stream 
reaction 458

Reset Home State command, limbs 241
Reset Viewpoint, viewports 53
Resistance parameter, spring constraints 285
Rest length parameter, spring constraints 285
Revolution around parameter, revolutions 212
Revolution axis parameter, revolutions 212
Revolution from Curve command 210
Roll Angle parameter, extrusions 215
Rollover reaction 515
Rotate handle 494
Rotate tool 171
Rotate WebCam handle 502
Rotation pivot parameter, Rotate reaction 495

S
saving projects 96
saving projects automatically (Macintosh) 99
Scale

handle 496
tool 174

Scale parameter
clip boxes 603
curves 183
lights 345
surfaces 202
text 248
texture projectors 336
textures 328
WebCams 350

Scaling offset parameter, pose constraints 274
Scaling parameter, extrusions 215
scripts

custom relations 297
custom sensors 490
in reactions 466
syntax 518

scrubbing, animation 370
Select tool 156
selecting

all 162
animation sequences 383
center 163
groups 162, 258
materials 305
multi-selecting 160
objects 160
objects in a group 258
points 162

unselecting 161
Selecting multiple parameters 67
Selection Only display

viewports 54
selection tools 44
sensors

browser 459
creating 467
custom 490

Sequencer
navigating 365
offsetting in 372
using 367
zooming the timescale 369

Set Grid Size
viewports 54

Set Orientation reaction 439
Set Parameter reaction 448
Set Pose reaction 446
Set Position reaction 436
Set Scale reaction 443
Set Webcam reaction 431
Shaded fill option, Flash Export settings 126
Shaded rendering style, materials 308
Shadow angle parameter, cartoon 

materials 312
Shadow darkness

drop shadows 587
Publish settings 561

Shadow hori offset
drop shadows 587
Publish settings 561

Shadow vert offset
drop shadows 587
Publish settings 561

shape animation 411
shapes

mixing 225
See also surfaces

Shininess parameter
cartoon materials 312
shaded materials 310

shortcuts, editing (Macintosh) 74
Show Constraints command 267
Show details setting, Download Estimates 599
showing

clip boxes 54
constraints 53
grid 54
host web page 61, 570
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stats 53
toolbars 45
WebCams 358
windows 39

Simplify command
curves 197
surfaces 221

Simulation setting, Download Estimates 598
Single sided parameter, text 248
Single-sided parameter, surfaces 202
sizing, 3D window in web page 576
skeleton, creating 235
Sketch Curve command 191
Sketch curve settings 192
Skin command 242
Skinning

example with limbs 235
example with shape modifiers 242

slider joints 295
Smoothness parameter

surfaces 203
text 248

smoothness, curves 194
snap constraint 282
Snap to Grid command 167
Snap unit parameter

Rotate reaction 496
Scale reaction 496
Translate reaction 494

Solo - Cycled in order parameter, Group 
reactions 514

Solo - In order parameter, Group reactions 514
Solo - Random parameter, Group 

reactions 514
Sound radius, VRML Export settings 149
sound, adding 428
sounds, file location 96
Speed Inheritance Factor parameter, 

particles 404
Speed parameter, waves 410
spheres, adding 205
Spin Rate parameter, particles 404
splines, see curves curves
Spot Angles parameter, lights 345
Spot concentration parameter, lights 345
Spread Angle parameter, particles 404
spring constraint 285
Springiness parameter, spring constraints 285
Standalone Player

CD-ROM playback (Macinstosh) 613

CD-ROM playback (Windows) 607
start animation sequence 372
Start mode parameter, links 506
Start parameter, Time Pulse sensors 486
Start time

Flash Export settings 124
Start time, Movie Export settings 134
Start value parameter, Toggle Parameter 

reaction 452
starting projects 96
Stats display

viewports 53
Steps parameter, curves 183
stills 129
Stop mode parameter, links 506
Stop value parameter, Toggle Parameter 

reaction 452
stream file, Download AXEL stream 

reaction 457
Stream file, Publish settings 560
Streamable parameter

image textures 320
movie textures 325
surfaces 202
text 249

streaming
batch saving files (Windows) 558
objects 590

Streaming priority parameter
image textures 320
movie textures 325
surfaces 202
text 249

Streaming view, Sequencer 368, 593
style, object tag attribute 621
Subdivide command

curves 196
faces 221
surfaces 221

Subdivisions parameter
cones 207
curves 184
extrusions 215
planes 207
revolutions 212
spheres 205

Substitute parameter, Download AXEL stream 
reaction 458

Surface closing parameter, revolutions 212
Surface from Curve command 209
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surfaces
bending 226
capping 208
creating by extrusion 214
creating by extrusion along a curve 216
creating by revolution 210
creating common shapes 205
creating from a curve 209
deleting points 218
drawing 209
inverting 223
manipulating points 219
pushing 228
rationalizing position 223
rationalizing scale 223
simplifying 221
skin 242
subdividing 221
subdividing faces 221
text 246

Switch Geometry reaction 435
Switch Material reaction 432
syntax, scripts 518

T
Tangency axis parameter, curve 

constraints 281
Target orientation parameter

Set Orientation reaction 440
Set Pose reaction 447
snap constraints 283

Target position parameter
Set Pose reaction 447
Set Position reaction 437
snap constraints 283

Target Refresh Rate parameter, Refresh Rate 
sensors 488

Target scale parameter
Set Pose reaction 447
Set Scale reaction 444

Target time parameter, Go to Time 
reaction 464

text
adjusting thickness of 246
converting to curves 253
creating 246
creating layers 250
fonts 254
manipulating 247
positioning text overlay 250

publishing as an outline 254
Text color parameter, Tooltip text reaction 454
Text command 246
Text parameter

text 248, 252
Tooltip text reaction 454

Texture enabled parameter, shaded 
materials 311

textures
adding image textures 320
adding movie textures 321
adjusting projection 335
blending with material color 329
directory paths 96
environment mapping 338
introduction 24
linking to materials and objects 326
playing movies from a remote location 323
rationalizing 332
supported image formats 339
tiling 333

Texturing Mode setting 329
Throw object parameter, Translate 

reaction 494
Throwing resistance parameter, Translate 

reaction 494
Time delay parameter, links 372, 505
Time field, navigating the Sequencer 365
Time Pulse sensor 486
Time sensor 484
Time to initial display setting, Download 

Estimates 599
Timescale parameter, animation 388
Toggle Parameter reaction 450
Tolerance parameter

orientation sensor 480
Parameter Change sensor 482
Position sensors 479

toolbars
moving 45
showing/hiding 45

Tooltip Text reaction 453
Top

AXEL Projector Export setting 563
Top Capping parameter

cylinders 208
extrusions 215
revolutions 212

Top position, Publish settings 561
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Total download time setting, Download 
Estimates 599

Total size setting, Download Estimates 599
transforms, see manipulating objects
Transition Period parameter

snap constraints 283
Transition time parameter

Set Orientation reaction 440
Set Parameter reaction 449
Set Position reaction 437
Set Scale reaction 444

Translate handle 493
Translate tool 169
Translate WebCam handle 502
transparency

in .png images 331
publishing settings 586

Transparency parameter
cartoon materials 312
shaded materials 311
wireframe 313

Trigger mode parameter, links 506
Trigger on parameter, links 505
triggers

Activate/Deactivate 510
creating 467
editing 417
exporting 582

Turned On parameter, lights 345
Type parameter

Orbit WebCam reaction 501
Rotate reaction 495
Rotate WebCam reaction 502
Scale reaction 496
Translate reaction 494
Translate WebCam reaction 502

U
Ungroup command 259
unhiding

groups 168
objects 168

Unlink Particle Obstacle command 407
unlocking constraints 268
uploading

AXELedge content 583
URL parameter

Call JavaScript reaction 463
Hyperlink reaction 455
movie textures 325

User Interface 38
creating your own using constrained 

WebCam 358
creating your own, text 250

UV Scale parameter
texture projectors 337

V
Value parameter, Set Parameter reaction 449
Vertical FOV angle parameter, WebCams 351
Vertical subdivisions parameter, cylinders 208
Vertical tiling setting, textures 328
video, see movie textures 321
view 47

introduction 13
View Source Host Web Page command 573
viewing download estimates 597
viewports

background color 60
changing view in 51
changing view in all viewports 52
displaying and sizing a grid 56
introduction 10
options 53
overview 47

Visibility limit, VRML Export settings 149
Visible parameter

curves 183
groups 259
lights 345
surfaces 202
text 248, 252
texture projectors 336
WebCams 350

visualize
introduction 24

Visualize menu 83
Volume parameter

Play Movie reaction 325
Play Sound reaction 430

VRML
export example, .wrl as text file 145
export example, collision detection and 

interaction 142
export example, viewpoints 140

VRML, importing 103

W
Walk, VRML Export settings 149
WAV sound formats 428
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wave animation 410
web page

adding 3D content to 571
download time 593
generating 3D content for 559
host web page 569
modifying placement of 3D/2D 

elements 573
streaming 590
viewing with AXEL player 603
window sizing 576
windowless content 584

WebCam
moving 356
orbiting 355
panning 355

WebCam view, described 47
WebCams

adding 350
adjusting field of view 353
attaching to an object 356
background color 60
frustum 353
pointing 357
rotating 356
showing/hiding 358
switching 354
zooming 355

weight of objects 155
Weight parameter

animation 388
Weight parameter, constraints 274
Width parameter

cones 207
cubes 205
curves 183
cylinders 208

windowless content
creating drop shadows 587
in different browsers 588
publishing 584

Windowless, Publish settings 561
windows

moving 39
showing/hiding 39

Wireframe options, Flash Export settings 128
wireframe, enabling 54, 58
workflow 14
workspace 14

Z
Z axis, described 152
Z-index, layers in web page 585
Z-index, Publish settings 561
zoom

in Sequencer 369
in viewports 49
in WebCam view 355

Zoom WebCam handle 503
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